]> git.pld-linux.org Git - packages/qt-gstreamer.git/blob - qt-gstreamer.spec
- dropped repeated %description
[packages/qt-gstreamer.git] / qt-gstreamer.spec
1 Summary:        QtGStreamer - libraries integrating Qt with GStreamer
2 Summary(pl.UTF-8):      QtGStreamer - biblioteki integrujące Qt z GStreamerem
3 Name:           qt-gstreamer
4 Version:        0.10.1
5 Release:        1
6 License:        LGPL v2+
7 Group:          Libraries
8 Source0:        http://gstreamer.freedesktop.org/src/qt-gstreamer/%{name}-%{version}.tar.bz2
9 # Source0-md5:  d2507a8084973fa9956d792c20013977
10 URL:            http://gstreamer.net/
11 BuildRequires:  QtCore-devel >= 4.5
12 BuildRequires:  QtGui-devel >= 4.5
13 BuildRequires:  QtTest-devel >= 4.5
14 BuildRequires:  automoc4 >= 0.9.88
15 BuildRequires:  bison
16 BuildRequires:  boost-devel >= 1.39
17 BuildRequires:  cmake >= 2.8
18 BuildRequires:  flex
19 BuildRequires:  gstreamer-devel >= 0.10.31
20 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.31
21 BuildRequires:  libstdc++-devel >= 6:4.5
22 BuildRequires:  pkgconfig
23 BuildRequires:  qt4-qmake >= 4.5
24 Requires:       QtCore >= 4.5
25 Requires:       QtGui >= 4.5
26 Requires:       gstreamer >= 0.10.31
27 Requires:       gstreamer-plugins-base >= 0.10.31
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 QtGStreamer is a set of libraries and plugins providing C++ bindings
32 for GStreamer with a Qt-style API plus some helper classes for
33 integrating GStreamer better in Qt applications.
34
35 Currently, it consists of the following parts:
36  * QtGLib - library providing C++/Qt bindings for parts of the GLib
37    and GObject APIs, a base on which QtGStreamer is built.
38  * QtGStreamer - library providing C++/Qt bindings for GStreamer
39  * QtGStreamerUi - library providing integration with QtGui;
40    currently, it only provides a video widget that embeds GStreamer's
41    video sinks.
42  * QtGStreamerUtils - library providing some high level utility
43    classes.
44
45 In addition, it provides a "qwidgetvideosink" GStreamer element, an
46 video sink element that can draw directly on QWidgets using QPainter.
47
48 %description -l pl.UTF-8
49 QtGStreamer to zestaw bibliotek i wtyczek z wiązaniami C++ do
50 GStreamera o API w stylu Qt oraz klasami pomocniczymi dla lepszej
51 integracji GStreamera w aplikacjach Qt.
52
53 Obecnie zawiera następujące części:
54  - QtGLib - biblioteka z wiązaniami C++/Qt dla części API bibliotek
55    GLib i GObject; w oparciu o nią zbudowany jest QtGStreamer
56  - QtGStreamer - biblioteka z wiązaniami C++/Qt do GStreamera
57  - QtGStreamerUi - biblioteka integrująca z QtGui; obecnie zawiera
58    tylko widget wideo osadzający wyjście obrazu (videosink) GStremera.
59  - QtGStreamerUtils - biblioteka udostępniająca klasy narzędziowe
60    wysokiego poziomu.
61
62 Ponadto pakiet udostępnia element GStreamera "qwidgetvideosink" -
63 element wyjściowy obrazu rysujący bezpośrednio na QWidgetach przy
64 użyciu QPaintera.
65
66 %package devel
67 Summary:        Header files for QtGStreamer libraries
68 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek QtGStreamer
69 Group:          Development/Libraries
70 Requires:       %{name} = %{version}-%{release}
71 Requires:       QtCore-devel >= 4.5
72 Requires:       QtGui-devel >= 4.5
73 Requires:       gstreamer-devel >= 0.10.31
74 Requires:       gstreamer-plugins-base-devel >= 0.10.31
75
76 %description devel
77 Header files for QtGStreamer libraries.
78
79 %description devel -l pl.UTF-8
80 Pliki nagłówkowe bibliotek QtGStreamer.
81
82 %prep
83 %setup -q
84
85 %build
86 install -d build
87 cd build
88 %cmake .. \
89         -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
90         -DQTGSTREAMER_EXAMPLES=OFF \
91         -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4
92
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} -C build install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %files
108 %defattr(644,root,root,755)
109 %doc README
110 %attr(755,root,root) %{_libdir}/libQtGLib-2.0.so.*.*.*
111 %attr(755,root,root) %ghost %{_libdir}/libQtGLib-2.0.so.0
112 %attr(755,root,root) %{_libdir}/libQtGStreamer-0.10.so.*.*.*
113 %attr(755,root,root) %ghost %{_libdir}/libQtGStreamer-0.10.so.0
114 %attr(755,root,root) %{_libdir}/libQtGStreamerUi-0.10.so.*.*.*
115 %attr(755,root,root) %ghost %{_libdir}/libQtGStreamerUi-0.10.so.0
116 %attr(755,root,root) %{_libdir}/libQtGStreamerUtils-0.10.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libQtGStreamerUtils-0.10.so.0
118 %attr(755,root,root) %{_libdir}/gstreamer-0.10/libgstqwidgetvideosink.so
119
120 %files devel
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_libdir}/libQtGLib-2.0.so
123 %attr(755,root,root) %{_libdir}/libQtGStreamer-0.10.so
124 %attr(755,root,root) %{_libdir}/libQtGStreamerUi-0.10.so
125 %attr(755,root,root) %{_libdir}/libQtGStreamerUtils-0.10.so
126 %{_includedir}/QtGStreamer
127 %{_pkgconfigdir}/QtGLib-2.0.pc
128 %{_pkgconfigdir}/QtGStreamer-0.10.pc
129 %{_pkgconfigdir}/QtGStreamerUi-0.10.pc
130 %{_pkgconfigdir}/QtGStreamerUtils-0.10.pc
131 %dir %{_libdir}/QtGStreamer
132 %{_libdir}/QtGStreamer/QtGStreamer*.cmake
This page took 0.084911 seconds and 4 git commands to generate.