]> git.pld-linux.org Git - packages/qt-gstreamer.git/blob - qt-gstreamer.spec
- updated to 0.10.3
[packages/qt-gstreamer.git] / qt-gstreamer.spec
1 # NOTE: copy package to qt-gstreamer0.10 before updating to 1.0.x (when available)
2 # TODO: Qt5 packages
3 Summary:        QtGStreamer - libraries integrating Qt with GStreamer
4 Summary(pl.UTF-8):      QtGStreamer - biblioteki integrujące Qt z GStreamerem
5 Name:           qt-gstreamer
6 Version:        0.10.3
7 Release:        1
8 License:        LGPL v2+
9 Group:          Libraries
10 Source0:        http://gstreamer.freedesktop.org/src/qt-gstreamer/%{name}-%{version}.tar.bz2
11 # Source0-md5:  1dfbca4ffa924b0896dadb42221600e2
12 URL:            http://gstreamer.net/
13 BuildRequires:  OpenGL-devel
14 BuildRequires:  QtCore-devel >= 4.7
15 BuildRequires:  QtDeclarative-devel >= 4.7
16 BuildRequires:  QtGui-devel >= 4.7
17 BuildRequires:  QtOpenGL-devel >= 4.7
18 BuildRequires:  QtTest-devel >= 4.7
19 BuildRequires:  bison
20 BuildRequires:  boost-devel >= 1.39
21 BuildRequires:  cmake >= 2.8.9
22 BuildRequires:  flex
23 BuildRequires:  glib2-devel >= 2.0
24 BuildRequires:  gstreamer0.10-devel >= 0.10.33
25 BuildRequires:  gstreamer0.10-plugins-base-devel >= 0.10.33
26 BuildRequires:  libstdc++-devel >= 6:4.5
27 BuildRequires:  pkgconfig
28 BuildRequires:  qt4-qmake >= 4.7
29 Requires:       QtCore >= 4.7
30 Requires:       QtGui >= 4.7
31 Requires:       QtOpenGL >= 4.7
32 Requires:       gstreamer0.10 >= 0.10.33
33 Requires:       gstreamer0.10-plugins-base >= 0.10.33
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 QtGStreamer is a set of libraries and plugins providing C++ bindings
38 for GStreamer with a Qt-style API plus some helper classes for
39 integrating GStreamer better in Qt applications.
40
41 Currently, it consists of the following parts:
42  * QtGLib - library providing C++/Qt bindings for parts of the GLib
43    and GObject APIs, a base on which QtGStreamer is built.
44  * QtGStreamer - library providing C++/Qt bindings for GStreamer
45  * QtGStreamerUi - library providing integration with QtGui;
46    currently, it only provides a video widget that embeds GStreamer's
47    video sinks.
48  * QtGStreamerUtils - library providing some high level utility
49    classes.
50
51 In addition, it provides a "qwidgetvideosink" GStreamer element, an
52 video sink element that can draw directly on QWidgets using QPainter.
53
54 %description -l pl.UTF-8
55 QtGStreamer to zestaw bibliotek i wtyczek z wiązaniami C++ do
56 GStreamera o API w stylu Qt oraz klasami pomocniczymi dla lepszej
57 integracji GStreamera w aplikacjach Qt.
58
59 Obecnie zawiera następujące części:
60  - QtGLib - biblioteka z wiązaniami C++/Qt dla części API bibliotek
61    GLib i GObject; w oparciu o nią zbudowany jest QtGStreamer
62  - QtGStreamer - biblioteka z wiązaniami C++/Qt do GStreamera
63  - QtGStreamerUi - biblioteka integrująca z QtGui; obecnie zawiera
64    tylko widget wideo osadzający wyjście obrazu (videosink) GStremera.
65  - QtGStreamerUtils - biblioteka udostępniająca klasy narzędziowe
66    wysokiego poziomu.
67
68 Ponadto pakiet udostępnia element GStreamera "qwidgetvideosink" -
69 element wyjściowy obrazu rysujący bezpośrednio na QWidgetach przy
70 użyciu QPaintera.
71
72 %package devel
73 Summary:        Header files for QtGStreamer libraries
74 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek QtGStreamer
75 Group:          Development/Libraries
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       QtCore-devel >= 4.7
78 Requires:       QtGui-devel >= 4.7
79 Requires:       gstreamer0.10-devel >= 0.10.33
80 Requires:       gstreamer0.10-plugins-base-devel >= 0.10.33
81
82 %description devel
83 Header files for QtGStreamer libraries.
84
85 %description devel -l pl.UTF-8
86 Pliki nagłówkowe bibliotek QtGStreamer.
87
88 %package -n QtDeclarative-plugin-gstreamer
89 Summary:        Qt GStreamer plugin for QtDeclarative
90 Summary(pl.UTF-8):      Wtyczka Qt GStreamer dla QtDeclarative
91 Group:          Libraries
92 Requires:       %{name} = %{version}-%{release}
93 Requires:       QtDeclarative >= 4.7
94
95 %description -n QtDeclarative-plugin-gstreamer
96 Qt GStreamer plugin for QtDeclarative.
97
98 %description -n QtDeclarative-plugin-gstreamer -l pl.UTF-8
99 Wtyczka Qt GStreamer dla QtDeclarative.
100
101 %prep
102 %setup -q
103
104 %build
105 install -d build
106 cd build
107 %cmake .. \
108         -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
109         -DQTGSTREAMER_EXAMPLES=OFF \
110         -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4
111
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} -C build install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   -p /sbin/ldconfig
124 %postun -p /sbin/ldconfig
125
126 %files
127 %defattr(644,root,root,755)
128 %doc NEWS README
129 %attr(755,root,root) %{_libdir}/libQtGLib-2.0.so.*.*.*
130 %attr(755,root,root) %ghost %{_libdir}/libQtGLib-2.0.so.0
131 %attr(755,root,root) %{_libdir}/libQtGStreamer-0.10.so.*.*.*
132 %attr(755,root,root) %ghost %{_libdir}/libQtGStreamer-0.10.so.0
133 %attr(755,root,root) %{_libdir}/libQtGStreamerUi-0.10.so.*.*.*
134 %attr(755,root,root) %ghost %{_libdir}/libQtGStreamerUi-0.10.so.0
135 %attr(755,root,root) %{_libdir}/libQtGStreamerUtils-0.10.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/libQtGStreamerUtils-0.10.so.0
137 %attr(755,root,root) %{_libdir}/gstreamer-0.10/libgstqtvideosink.so
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/libQtGLib-2.0.so
142 %attr(755,root,root) %{_libdir}/libQtGStreamer-0.10.so
143 %attr(755,root,root) %{_libdir}/libQtGStreamerUi-0.10.so
144 %attr(755,root,root) %{_libdir}/libQtGStreamerUtils-0.10.so
145 %{_includedir}/QtGStreamer
146 %{_pkgconfigdir}/QtGLib-2.0.pc
147 %{_pkgconfigdir}/QtGStreamer-0.10.pc
148 %{_pkgconfigdir}/QtGStreamerUi-0.10.pc
149 %{_pkgconfigdir}/QtGStreamerUtils-0.10.pc
150 %{_libdir}/cmake/QtGStreamer
151
152 %files -n QtDeclarative-plugin-gstreamer
153 %defattr(644,root,root,755)
154 %dir %{_libdir}/qt4/imports/QtGStreamer
155 %attr(755,root,root) %{_libdir}/qt4/imports/QtGStreamer/libQtGStreamerQuick1.so
156 %{_libdir}/qt4/imports/QtGStreamer/qmldir
This page took 0.049568 seconds and 3 git commands to generate.