]> git.pld-linux.org Git - packages/qt-gstreamer.git/blob - qt-gstreamer.spec
525d8a33e0d1fe3b20b6496df1a0f5e145b70cd2
[packages/qt-gstreamer.git] / qt-gstreamer.spec
1 Summary:        QtGStreamer - libraries integrating Qt with GStreamer
2 Summary(pl.UTF-8):      QtGStreamer - biblioteki integrujące Qt z GStreamerem
3 Name:           qt-gstreamer
4 Version:        0.10.2
5 Release:        1
6 License:        LGPL v2+
7 Group:          Libraries
8 Source0:        http://gstreamer.freedesktop.org/src/qt-gstreamer/%{name}-%{version}.tar.bz2
9 # Source0-md5:  6fd5be25e51b4dbf5a2cc8943be92703
10 URL:            http://gstreamer.net/
11 BuildRequires:  OpenGL-devel
12 BuildRequires:  QtCore-devel >= 4.7
13 BuildRequires:  QtDeclarative-devel >= 4.7
14 BuildRequires:  QtGui-devel >= 4.7
15 BuildRequires:  QtOpenGL-devel >= 4.7
16 BuildRequires:  QtTest-devel >= 4.7
17 BuildRequires:  bison
18 BuildRequires:  boost-devel >= 1.39
19 BuildRequires:  cmake >= 2.8.6
20 BuildRequires:  flex
21 BuildRequires:  glib2-devel >= 2.0
22 BuildRequires:  gstreamer-devel >= 0.10.33
23 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.33
24 BuildRequires:  libstdc++-devel >= 6:4.5
25 BuildRequires:  pkgconfig
26 BuildRequires:  qt4-qmake >= 4.7
27 Requires:       QtCore >= 4.7
28 Requires:       QtGui >= 4.7
29 Requires:       QtOpenGL >= 4.7
30 Requires:       gstreamer >= 0.10.33
31 Requires:       gstreamer-plugins-base >= 0.10.33
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 QtGStreamer is a set of libraries and plugins providing C++ bindings
36 for GStreamer with a Qt-style API plus some helper classes for
37 integrating GStreamer better in Qt applications.
38
39 Currently, it consists of the following parts:
40  * QtGLib - library providing C++/Qt bindings for parts of the GLib
41    and GObject APIs, a base on which QtGStreamer is built.
42  * QtGStreamer - library providing C++/Qt bindings for GStreamer
43  * QtGStreamerUi - library providing integration with QtGui;
44    currently, it only provides a video widget that embeds GStreamer's
45    video sinks.
46  * QtGStreamerUtils - library providing some high level utility
47    classes.
48
49 In addition, it provides a "qwidgetvideosink" GStreamer element, an
50 video sink element that can draw directly on QWidgets using QPainter.
51
52 %description -l pl.UTF-8
53 QtGStreamer to zestaw bibliotek i wtyczek z wiązaniami C++ do
54 GStreamera o API w stylu Qt oraz klasami pomocniczymi dla lepszej
55 integracji GStreamera w aplikacjach Qt.
56
57 Obecnie zawiera następujące części:
58  - QtGLib - biblioteka z wiązaniami C++/Qt dla części API bibliotek
59    GLib i GObject; w oparciu o nią zbudowany jest QtGStreamer
60  - QtGStreamer - biblioteka z wiązaniami C++/Qt do GStreamera
61  - QtGStreamerUi - biblioteka integrująca z QtGui; obecnie zawiera
62    tylko widget wideo osadzający wyjście obrazu (videosink) GStremera.
63  - QtGStreamerUtils - biblioteka udostępniająca klasy narzędziowe
64    wysokiego poziomu.
65
66 Ponadto pakiet udostępnia element GStreamera "qwidgetvideosink" -
67 element wyjściowy obrazu rysujący bezpośrednio na QWidgetach przy
68 użyciu QPaintera.
69
70 %package devel
71 Summary:        Header files for QtGStreamer libraries
72 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek QtGStreamer
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       QtCore-devel >= 4.7
76 Requires:       QtGui-devel >= 4.7
77 Requires:       gstreamer-devel >= 0.10.33
78 Requires:       gstreamer-plugins-base-devel >= 0.10.33
79
80 %description devel
81 Header files for QtGStreamer libraries.
82
83 %description devel -l pl.UTF-8
84 Pliki nagłówkowe bibliotek QtGStreamer.
85
86 %package -n QtDeclarative-plugin-gstreamer
87 Summary:        Qt GStreamer plugin for QtDeclarative
88 Summary(pl.UTF-8):      Wtyczka Qt GStreamer dla QtDeclarative
89 Group:          Libraries
90 Requires:       %{name} = %{version}-%{release}
91 Requires:       QtDeclarative >= 4.7
92
93 %description -n QtDeclarative-plugin-gstreamer
94 Qt GStreamer plugin for QtDeclarative.
95
96 %description -n QtDeclarative-plugin-gstreamer -l pl.UTF-8
97 Wtyczka Qt GStreamer dla QtDeclarative.
98
99 %prep
100 %setup -q
101
102 %build
103 install -d build
104 cd build
105 %cmake .. \
106         -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
107         -DQTGSTREAMER_EXAMPLES=OFF \
108         -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4
109
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} -C build install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   -p /sbin/ldconfig
122 %postun -p /sbin/ldconfig
123
124 %files
125 %defattr(644,root,root,755)
126 %doc NEWS README
127 %attr(755,root,root) %{_libdir}/libQtGLib-2.0.so.*.*.*
128 %attr(755,root,root) %ghost %{_libdir}/libQtGLib-2.0.so.0
129 %attr(755,root,root) %{_libdir}/libQtGStreamer-0.10.so.*.*.*
130 %attr(755,root,root) %ghost %{_libdir}/libQtGStreamer-0.10.so.0
131 %attr(755,root,root) %{_libdir}/libQtGStreamerUi-0.10.so.*.*.*
132 %attr(755,root,root) %ghost %{_libdir}/libQtGStreamerUi-0.10.so.0
133 %attr(755,root,root) %{_libdir}/libQtGStreamerUtils-0.10.so.*.*.*
134 %attr(755,root,root) %ghost %{_libdir}/libQtGStreamerUtils-0.10.so.0
135 %attr(755,root,root) %{_libdir}/gstreamer-0.10/libgstqtvideosink.so
136
137 %files devel
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/libQtGLib-2.0.so
140 %attr(755,root,root) %{_libdir}/libQtGStreamer-0.10.so
141 %attr(755,root,root) %{_libdir}/libQtGStreamerUi-0.10.so
142 %attr(755,root,root) %{_libdir}/libQtGStreamerUtils-0.10.so
143 %{_includedir}/QtGStreamer
144 %{_pkgconfigdir}/QtGLib-2.0.pc
145 %{_pkgconfigdir}/QtGStreamer-0.10.pc
146 %{_pkgconfigdir}/QtGStreamerUi-0.10.pc
147 %{_pkgconfigdir}/QtGStreamerUtils-0.10.pc
148 %dir %{_libdir}/QtGStreamer
149 %{_libdir}/QtGStreamer/QtGStreamer*.cmake
150
151 %files -n QtDeclarative-plugin-gstreamer
152 %defattr(644,root,root,755)
153 %dir %{_libdir}/qt4/imports/QtGStreamer
154 %attr(755,root,root) %{_libdir}/qt4/imports/QtGStreamer/libQtGStreamerQML.so
155 %{_libdir}/qt4/imports/QtGStreamer/qmldir
This page took 0.256511 seconds and 2 git commands to generate.