]> git.pld-linux.org Git - packages/qt-gstreamer.git/blame - qt-gstreamer.spec
- added Qt5Declarative plugin
[packages/qt-gstreamer.git] / qt-gstreamer.spec
CommitLineData
40f731f5 1# NOTE: copy package to qt-gstreamer0.10 before updating to 1.0.x (when available)
ba518b99
JB
2#
3# Conditional build:
4%bcond_without qt4 # Qt 4 libraries
5%bcond_without qt5 # Qt 5 libraries
6#
7Summary: QtGStreamer - libraries integrating Qt 4 with GStreamer
8Summary(pl.UTF-8): QtGStreamer - biblioteki integrujące Qt 4 z GStreamerem
3b311080 9Name: qt-gstreamer
40f731f5 10Version: 0.10.3
3b311080
JB
11Release: 1
12License: LGPL v2+
13Group: Libraries
f6eae54a 14Source0: http://gstreamer.freedesktop.org/src/qt-gstreamer/%{name}-%{version}.tar.bz2
40f731f5 15# Source0-md5: 1dfbca4ffa924b0896dadb42221600e2
3b311080 16URL: http://gstreamer.net/
a8f475c6 17BuildRequires: OpenGL-devel
3b311080 18BuildRequires: bison
f6eae54a 19BuildRequires: boost-devel >= 1.39
40f731f5 20BuildRequires: cmake >= 2.8.9
3b311080 21BuildRequires: flex
a8f475c6 22BuildRequires: glib2-devel >= 2.0
40f731f5
JB
23BuildRequires: gstreamer0.10-devel >= 0.10.33
24BuildRequires: gstreamer0.10-plugins-base-devel >= 0.10.33
3b311080
JB
25BuildRequires: libstdc++-devel >= 6:4.5
26BuildRequires: pkgconfig
ba518b99
JB
27%if %{with qt4}
28BuildRequires: QtCore-devel >= 4.7
29BuildRequires: QtDeclarative-devel >= 4.7
30BuildRequires: QtGui-devel >= 4.7
31BuildRequires: QtOpenGL-devel >= 4.7
32BuildRequires: QtTest-devel >= 4.7
a8f475c6 33BuildRequires: qt4-qmake >= 4.7
ba518b99
JB
34%endif
35%if %{with qt5}
36BuildRequires: Qt5Core-devel >= 5.0.0
d431bec6 37BuildRequires: Qt5Declarative-devel >= 5.0.0
ba518b99
JB
38BuildRequires: Qt5Gui-devel >= 5.0.0
39BuildRequires: Qt5OpenGL-devel >= 5.0.0
40BuildRequires: Qt5Widgets-devel >= 5.0.0
41BuildRequires: Qt5Test-devel >= 5.0.0
42BuildRequires: qt5-qmake >= 5.0.0
43%endif
a8f475c6
JB
44Requires: QtCore >= 4.7
45Requires: QtGui >= 4.7
46Requires: QtOpenGL >= 4.7
40f731f5
JB
47Requires: gstreamer0.10 >= 0.10.33
48Requires: gstreamer0.10-plugins-base >= 0.10.33
3b311080
JB
49BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51%description
52QtGStreamer is a set of libraries and plugins providing C++ bindings
53for GStreamer with a Qt-style API plus some helper classes for
ba518b99 54integrating GStreamer better in Qt 4 applications.
3b311080
JB
55
56Currently, it consists of the following parts:
ba518b99 57 * QtGLib - library providing C++/Qt 4 bindings for parts of the GLib
3b311080 58 and GObject APIs, a base on which QtGStreamer is built.
ba518b99 59 * QtGStreamer - library providing C++/Qt 4 bindings for GStreamer
3b311080
JB
60 * QtGStreamerUi - library providing integration with QtGui;
61 currently, it only provides a video widget that embeds GStreamer's
62 video sinks.
f6eae54a
JB
63 * QtGStreamerUtils - library providing some high level utility
64 classes.
3b311080
JB
65
66In addition, it provides a "qwidgetvideosink" GStreamer element, an
67video sink element that can draw directly on QWidgets using QPainter.
68
69%description -l pl.UTF-8
70QtGStreamer to zestaw bibliotek i wtyczek z wiązaniami C++ do
71GStreamera o API w stylu Qt oraz klasami pomocniczymi dla lepszej
ba518b99 72integracji GStreamera w aplikacjach Qt 4.
3b311080
JB
73
74Obecnie zawiera następujące części:
ba518b99 75 - QtGLib - biblioteka z wiązaniami C++/Qt 4 dla części API bibliotek
3b311080 76 GLib i GObject; w oparciu o nią zbudowany jest QtGStreamer
ba518b99 77 - QtGStreamer - biblioteka z wiązaniami C++/Qt 4 do GStreamera
3b311080
JB
78 - QtGStreamerUi - biblioteka integrująca z QtGui; obecnie zawiera
79 tylko widget wideo osadzający wyjście obrazu (videosink) GStremera.
f6eae54a
JB
80 - QtGStreamerUtils - biblioteka udostępniająca klasy narzędziowe
81 wysokiego poziomu.
3b311080
JB
82
83Ponadto pakiet udostępnia element GStreamera "qwidgetvideosink" -
84element wyjściowy obrazu rysujący bezpośrednio na QWidgetach przy
85użyciu QPaintera.
86
3b311080
JB
87%package devel
88Summary: Header files for QtGStreamer libraries
89Summary(pl.UTF-8): Pliki nagłówkowe bibliotek QtGStreamer
90Group: Development/Libraries
91Requires: %{name} = %{version}-%{release}
a8f475c6
JB
92Requires: QtCore-devel >= 4.7
93Requires: QtGui-devel >= 4.7
40f731f5
JB
94Requires: gstreamer0.10-devel >= 0.10.33
95Requires: gstreamer0.10-plugins-base-devel >= 0.10.33
3b311080
JB
96
97%description devel
98Header files for QtGStreamer libraries.
99
100%description devel -l pl.UTF-8
101Pliki nagłówkowe bibliotek QtGStreamer.
102
a8f475c6
JB
103%package -n QtDeclarative-plugin-gstreamer
104Summary: Qt GStreamer plugin for QtDeclarative
105Summary(pl.UTF-8): Wtyczka Qt GStreamer dla QtDeclarative
106Group: Libraries
107Requires: %{name} = %{version}-%{release}
108Requires: QtDeclarative >= 4.7
109
110%description -n QtDeclarative-plugin-gstreamer
111Qt GStreamer plugin for QtDeclarative.
112
113%description -n QtDeclarative-plugin-gstreamer -l pl.UTF-8
114Wtyczka Qt GStreamer dla QtDeclarative.
115
ba518b99
JB
116%package -n qt5-gstreamer
117Summary: Qt5GStreamer - libraries integrating Qt 5 with GStreamer
118Summary(pl.UTF-8): Qt5GStreamer - biblioteki integrujące Qt 5 z GStreamerem
119Group: Libraries
120Requires: Qt5Core >= 5.0.0
121Requires: Qt5Gui >= 5.0.0
122Requires: Qt5OpenGL >= 5.0.0
123Requires: gstreamer0.10 >= 0.10.33
124Requires: gstreamer0.10-plugins-base >= 0.10.33
125
126%description -n qt5-gstreamer
127Qt5GStreamer is a set of libraries and plugins providing C++ bindings
128for GStreamer with a Qt-style API plus some helper classes for
129integrating GStreamer better in Qt 5 applications.
130
131Currently, it consists of the following parts:
132 * Qt5GLib - library providing C++/Qt 5 bindings for parts of the GLib
133 and GObject APIs, a base on which Qt5GStreamer is built.
134 * Qt5GStreamer - library providing C++/Qt 5 bindings for GStreamer
135 * Qt5GStreamerUi - library providing integration with Qt5Gui;
136 currently, it only provides a video widget that embeds GStreamer's
137 video sinks.
138 * Qt5GStreamerUtils - library providing some high level utility
139 classes.
140
141In addition, it provides a "qwidgetvideosink" GStreamer element, an
142video sink element that can draw directly on QWidgets using QPainter.
143
144%description -n qt5-gstreamer -l pl.UTF-8
145Qt5GStreamer to zestaw bibliotek i wtyczek z wiązaniami C++ do
146GStreamera o API w stylu Qt oraz klasami pomocniczymi dla lepszej
147integracji GStreamera w aplikacjach Qt 5.
148
149Obecnie zawiera następujące części:
150 - Qt5GLib - biblioteka z wiązaniami C++/Qt 5 dla części API bibliotek
151 GLib i GObject; w oparciu o nią zbudowany jest QtGStreamer
152 - Qt5GStreamer - biblioteka z wiązaniami C++/Qt 5 do GStreamera
153 - Qt5GStreamerUi - biblioteka integrująca z Qt5Gui; obecnie zawiera
154 tylko widget wideo osadzający wyjście obrazu (videosink) GStremera.
155 - QtGStreamerUtils - biblioteka udostępniająca klasy narzędziowe
156 wysokiego poziomu.
157
158Ponadto pakiet udostępnia element GStreamera "qwidgetvideosink" -
159element wyjściowy obrazu rysujący bezpośrednio na QWidgetach przy
160użyciu QPaintera.
161
162%package -n qt5-gstreamer-devel
163Summary: Header files for Qt5GStreamer libraries
164Summary(pl.UTF-8): Pliki nagłówkowe bibliotek QtGStreamer
165Group: Development/Libraries
166Requires: %{name} = %{version}-%{release}
167Requires: Qt5Core-devel >= 5.0.0
168Requires: Qt5Gui-devel >= 5.0.0
169Requires: gstreamer0.10-devel >= 0.10.33
170Requires: gstreamer0.10-plugins-base-devel >= 0.10.33
171
172%description -n qt5-gstreamer-devel
173Header files for Qt5GStreamer libraries.
174
175%description -n qt5-gstreamer-devel -l pl.UTF-8
176Pliki nagłówkowe bibliotek Qt5GStreamer.
177
d431bec6
JB
178%package -n Qt5Declarative-plugin-gstreamer
179Summary: Qt GStreamer plugin for Qt5Declarative
180Summary(pl.UTF-8): Wtyczka Qt GStreamer dla Qt5Declarative
181Group: Libraries
182Requires: %{name} = %{version}-%{release}
183Requires: Qt5Declarative >= 5.0.0
184
185%description -n Qt5Declarative-plugin-gstreamer
186Qt GStreamer plugin for Qt5Declarative.
187
188%description -n Qt5Declarative-plugin-gstreamer -l pl.UTF-8
189Wtyczka Qt GStreamer dla Qt5Declarative.
190
3b311080
JB
191%prep
192%setup -q
193
194%build
ba518b99
JB
195%if %{with qt4}
196install -d build-qt4
197cd build-qt4
3b311080
JB
198%cmake .. \
199 -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
200 -DQTGSTREAMER_EXAMPLES=OFF \
201 -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4
ba518b99
JB
202%{__make}
203cd ..
204%endif
3b311080 205
ba518b99
JB
206%if %{with qt5}
207install -d build-qt5
208cd build-qt5
209%cmake .. \
210 -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
211 -DQTGSTREAMER_EXAMPLES=OFF \
212 -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt5 \
213 -DQT_VERSION=5
3b311080 214%{__make}
ba518b99
JB
215cd ..
216%endif
3b311080
JB
217
218%install
219rm -rf $RPM_BUILD_ROOT
220
ba518b99
JB
221%if %{with qt4}
222%{__make} -C build-qt4 install \
223 DESTDIR=$RPM_BUILD_ROOT
224%endif
225
226%if %{with qt5}
227%{__make} -C build-qt5 install \
3b311080 228 DESTDIR=$RPM_BUILD_ROOT
ba518b99 229%endif
3b311080
JB
230
231%clean
232rm -rf $RPM_BUILD_ROOT
233
234%post -p /sbin/ldconfig
235%postun -p /sbin/ldconfig
236
ba518b99
JB
237%post -n qt5-gstreamer -p /sbin/ldconfig
238%postun -n qt5-gstreamer -p /sbin/ldconfig
239
240%if %{with qt4}
3b311080
JB
241%files
242%defattr(644,root,root,755)
a8f475c6 243%doc NEWS README
3b311080
JB
244%attr(755,root,root) %{_libdir}/libQtGLib-2.0.so.*.*.*
245%attr(755,root,root) %ghost %{_libdir}/libQtGLib-2.0.so.0
246%attr(755,root,root) %{_libdir}/libQtGStreamer-0.10.so.*.*.*
247%attr(755,root,root) %ghost %{_libdir}/libQtGStreamer-0.10.so.0
248%attr(755,root,root) %{_libdir}/libQtGStreamerUi-0.10.so.*.*.*
249%attr(755,root,root) %ghost %{_libdir}/libQtGStreamerUi-0.10.so.0
f6eae54a
JB
250%attr(755,root,root) %{_libdir}/libQtGStreamerUtils-0.10.so.*.*.*
251%attr(755,root,root) %ghost %{_libdir}/libQtGStreamerUtils-0.10.so.0
a8f475c6 252%attr(755,root,root) %{_libdir}/gstreamer-0.10/libgstqtvideosink.so
3b311080
JB
253
254%files devel
255%defattr(644,root,root,755)
256%attr(755,root,root) %{_libdir}/libQtGLib-2.0.so
257%attr(755,root,root) %{_libdir}/libQtGStreamer-0.10.so
258%attr(755,root,root) %{_libdir}/libQtGStreamerUi-0.10.so
f6eae54a 259%attr(755,root,root) %{_libdir}/libQtGStreamerUtils-0.10.so
3b311080
JB
260%{_includedir}/QtGStreamer
261%{_pkgconfigdir}/QtGLib-2.0.pc
262%{_pkgconfigdir}/QtGStreamer-0.10.pc
263%{_pkgconfigdir}/QtGStreamerUi-0.10.pc
f6eae54a 264%{_pkgconfigdir}/QtGStreamerUtils-0.10.pc
40f731f5 265%{_libdir}/cmake/QtGStreamer
a8f475c6
JB
266
267%files -n QtDeclarative-plugin-gstreamer
268%defattr(644,root,root,755)
269%dir %{_libdir}/qt4/imports/QtGStreamer
40f731f5 270%attr(755,root,root) %{_libdir}/qt4/imports/QtGStreamer/libQtGStreamerQuick1.so
a8f475c6 271%{_libdir}/qt4/imports/QtGStreamer/qmldir
ba518b99
JB
272%endif
273
274%if %{with qt5}
275%files -n qt5-gstreamer
276%defattr(644,root,root,755)
277%doc NEWS README
278%attr(755,root,root) %{_libdir}/libQt5GLib-2.0.so.*.*.*
279%attr(755,root,root) %ghost %{_libdir}/libQt5GLib-2.0.so.0
280%attr(755,root,root) %{_libdir}/libQt5GStreamer-0.10.so.*.*.*
281%attr(755,root,root) %ghost %{_libdir}/libQt5GStreamer-0.10.so.0
282%attr(755,root,root) %{_libdir}/libQt5GStreamerUi-0.10.so.*.*.*
283%attr(755,root,root) %ghost %{_libdir}/libQt5GStreamerUi-0.10.so.0
284%attr(755,root,root) %{_libdir}/libQt5GStreamerUtils-0.10.so.*.*.*
285%attr(755,root,root) %ghost %{_libdir}/libQt5GStreamerUtils-0.10.so.0
286%attr(755,root,root) %{_libdir}/gstreamer-0.10/libgstqt5videosink.so
287
288%files -n qt5-gstreamer-devel
289%defattr(644,root,root,755)
290%attr(755,root,root) %{_libdir}/libQt5GLib-2.0.so
291%attr(755,root,root) %{_libdir}/libQt5GStreamer-0.10.so
292%attr(755,root,root) %{_libdir}/libQt5GStreamerUi-0.10.so
293%attr(755,root,root) %{_libdir}/libQt5GStreamerUtils-0.10.so
294%{_includedir}/Qt5GStreamer
295%{_pkgconfigdir}/Qt5GLib-2.0.pc
296%{_pkgconfigdir}/Qt5GStreamer-0.10.pc
297%{_pkgconfigdir}/Qt5GStreamerUi-0.10.pc
298%{_pkgconfigdir}/Qt5GStreamerUtils-0.10.pc
299%{_libdir}/cmake/Qt5GStreamer
d431bec6
JB
300
301%files -n Qt5Declarative-plugin-gstreamer
302%defattr(644,root,root,755)
303%dir %{_libdir}/qt5/imports/QtGStreamer
304%attr(755,root,root) %{_libdir}/qt5/imports/QtGStreamer/libQtGStreamerQuick1.so
305%{_libdir}/qt5/imports/QtGStreamer/qmldir
ba518b99 306%endif
This page took 0.106162 seconds and 4 git commands to generate.