]> git.pld-linux.org Git - packages/qt-gstreamer.git/blame - qt-gstreamer.spec
- added Qt5 support
[packages/qt-gstreamer.git] / qt-gstreamer.spec
CommitLineData
40f731f5 1# NOTE: copy package to qt-gstreamer0.10 before updating to 1.0.x (when available)
ba518b99
JB
2# TODO: finish Qt5 packages (Quick1/QtDeclarative?)
3#
4# Conditional build:
5%bcond_without qt4 # Qt 4 libraries
6%bcond_without qt5 # Qt 5 libraries
7#
8Summary: QtGStreamer - libraries integrating Qt 4 with GStreamer
9Summary(pl.UTF-8): QtGStreamer - biblioteki integrujące Qt 4 z GStreamerem
3b311080 10Name: qt-gstreamer
40f731f5 11Version: 0.10.3
3b311080
JB
12Release: 1
13License: LGPL v2+
14Group: Libraries
f6eae54a 15Source0: http://gstreamer.freedesktop.org/src/qt-gstreamer/%{name}-%{version}.tar.bz2
40f731f5 16# Source0-md5: 1dfbca4ffa924b0896dadb42221600e2
3b311080 17URL: http://gstreamer.net/
a8f475c6 18BuildRequires: OpenGL-devel
3b311080 19BuildRequires: bison
f6eae54a 20BuildRequires: boost-devel >= 1.39
40f731f5 21BuildRequires: cmake >= 2.8.9
3b311080 22BuildRequires: flex
a8f475c6 23BuildRequires: glib2-devel >= 2.0
40f731f5
JB
24BuildRequires: gstreamer0.10-devel >= 0.10.33
25BuildRequires: gstreamer0.10-plugins-base-devel >= 0.10.33
3b311080
JB
26BuildRequires: libstdc++-devel >= 6:4.5
27BuildRequires: pkgconfig
ba518b99
JB
28%if %{with qt4}
29BuildRequires: QtCore-devel >= 4.7
30BuildRequires: QtDeclarative-devel >= 4.7
31BuildRequires: QtGui-devel >= 4.7
32BuildRequires: QtOpenGL-devel >= 4.7
33BuildRequires: QtTest-devel >= 4.7
a8f475c6 34BuildRequires: qt4-qmake >= 4.7
ba518b99
JB
35%endif
36%if %{with qt5}
37BuildRequires: Qt5Core-devel >= 5.0.0
38# ?
39#BuildRequires: Qt5Declarative-devel >= 5.0.0
40#BuildRequires: Qt5Quick1-devel >= 5.0.0
41BuildRequires: Qt5Gui-devel >= 5.0.0
42BuildRequires: Qt5OpenGL-devel >= 5.0.0
43BuildRequires: Qt5Widgets-devel >= 5.0.0
44BuildRequires: Qt5Test-devel >= 5.0.0
45BuildRequires: qt5-qmake >= 5.0.0
46%endif
a8f475c6
JB
47Requires: QtCore >= 4.7
48Requires: QtGui >= 4.7
49Requires: QtOpenGL >= 4.7
40f731f5
JB
50Requires: gstreamer0.10 >= 0.10.33
51Requires: gstreamer0.10-plugins-base >= 0.10.33
3b311080
JB
52BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54%description
55QtGStreamer is a set of libraries and plugins providing C++ bindings
56for GStreamer with a Qt-style API plus some helper classes for
ba518b99 57integrating GStreamer better in Qt 4 applications.
3b311080
JB
58
59Currently, it consists of the following parts:
ba518b99 60 * QtGLib - library providing C++/Qt 4 bindings for parts of the GLib
3b311080 61 and GObject APIs, a base on which QtGStreamer is built.
ba518b99 62 * QtGStreamer - library providing C++/Qt 4 bindings for GStreamer
3b311080
JB
63 * QtGStreamerUi - library providing integration with QtGui;
64 currently, it only provides a video widget that embeds GStreamer's
65 video sinks.
f6eae54a
JB
66 * QtGStreamerUtils - library providing some high level utility
67 classes.
3b311080
JB
68
69In addition, it provides a "qwidgetvideosink" GStreamer element, an
70video sink element that can draw directly on QWidgets using QPainter.
71
72%description -l pl.UTF-8
73QtGStreamer to zestaw bibliotek i wtyczek z wiązaniami C++ do
74GStreamera o API w stylu Qt oraz klasami pomocniczymi dla lepszej
ba518b99 75integracji GStreamera w aplikacjach Qt 4.
3b311080
JB
76
77Obecnie zawiera następujące części:
ba518b99 78 - QtGLib - biblioteka z wiązaniami C++/Qt 4 dla części API bibliotek
3b311080 79 GLib i GObject; w oparciu o nią zbudowany jest QtGStreamer
ba518b99 80 - QtGStreamer - biblioteka z wiązaniami C++/Qt 4 do GStreamera
3b311080
JB
81 - QtGStreamerUi - biblioteka integrująca z QtGui; obecnie zawiera
82 tylko widget wideo osadzający wyjście obrazu (videosink) GStremera.
f6eae54a
JB
83 - QtGStreamerUtils - biblioteka udostępniająca klasy narzędziowe
84 wysokiego poziomu.
3b311080
JB
85
86Ponadto pakiet udostępnia element GStreamera "qwidgetvideosink" -
87element wyjściowy obrazu rysujący bezpośrednio na QWidgetach przy
88użyciu QPaintera.
89
3b311080
JB
90%package devel
91Summary: Header files for QtGStreamer libraries
92Summary(pl.UTF-8): Pliki nagłówkowe bibliotek QtGStreamer
93Group: Development/Libraries
94Requires: %{name} = %{version}-%{release}
a8f475c6
JB
95Requires: QtCore-devel >= 4.7
96Requires: QtGui-devel >= 4.7
40f731f5
JB
97Requires: gstreamer0.10-devel >= 0.10.33
98Requires: gstreamer0.10-plugins-base-devel >= 0.10.33
3b311080
JB
99
100%description devel
101Header files for QtGStreamer libraries.
102
103%description devel -l pl.UTF-8
104Pliki nagłówkowe bibliotek QtGStreamer.
105
a8f475c6
JB
106%package -n QtDeclarative-plugin-gstreamer
107Summary: Qt GStreamer plugin for QtDeclarative
108Summary(pl.UTF-8): Wtyczka Qt GStreamer dla QtDeclarative
109Group: Libraries
110Requires: %{name} = %{version}-%{release}
111Requires: QtDeclarative >= 4.7
112
113%description -n QtDeclarative-plugin-gstreamer
114Qt GStreamer plugin for QtDeclarative.
115
116%description -n QtDeclarative-plugin-gstreamer -l pl.UTF-8
117Wtyczka Qt GStreamer dla QtDeclarative.
118
ba518b99
JB
119%package -n qt5-gstreamer
120Summary: Qt5GStreamer - libraries integrating Qt 5 with GStreamer
121Summary(pl.UTF-8): Qt5GStreamer - biblioteki integrujące Qt 5 z GStreamerem
122Group: Libraries
123Requires: Qt5Core >= 5.0.0
124Requires: Qt5Gui >= 5.0.0
125Requires: Qt5OpenGL >= 5.0.0
126Requires: gstreamer0.10 >= 0.10.33
127Requires: gstreamer0.10-plugins-base >= 0.10.33
128
129%description -n qt5-gstreamer
130Qt5GStreamer is a set of libraries and plugins providing C++ bindings
131for GStreamer with a Qt-style API plus some helper classes for
132integrating GStreamer better in Qt 5 applications.
133
134Currently, it consists of the following parts:
135 * Qt5GLib - library providing C++/Qt 5 bindings for parts of the GLib
136 and GObject APIs, a base on which Qt5GStreamer is built.
137 * Qt5GStreamer - library providing C++/Qt 5 bindings for GStreamer
138 * Qt5GStreamerUi - library providing integration with Qt5Gui;
139 currently, it only provides a video widget that embeds GStreamer's
140 video sinks.
141 * Qt5GStreamerUtils - library providing some high level utility
142 classes.
143
144In addition, it provides a "qwidgetvideosink" GStreamer element, an
145video sink element that can draw directly on QWidgets using QPainter.
146
147%description -n qt5-gstreamer -l pl.UTF-8
148Qt5GStreamer to zestaw bibliotek i wtyczek z wiązaniami C++ do
149GStreamera o API w stylu Qt oraz klasami pomocniczymi dla lepszej
150integracji GStreamera w aplikacjach Qt 5.
151
152Obecnie zawiera następujące części:
153 - Qt5GLib - biblioteka z wiązaniami C++/Qt 5 dla części API bibliotek
154 GLib i GObject; w oparciu o nią zbudowany jest QtGStreamer
155 - Qt5GStreamer - biblioteka z wiązaniami C++/Qt 5 do GStreamera
156 - Qt5GStreamerUi - biblioteka integrująca z Qt5Gui; obecnie zawiera
157 tylko widget wideo osadzający wyjście obrazu (videosink) GStremera.
158 - QtGStreamerUtils - biblioteka udostępniająca klasy narzędziowe
159 wysokiego poziomu.
160
161Ponadto pakiet udostępnia element GStreamera "qwidgetvideosink" -
162element wyjściowy obrazu rysujący bezpośrednio na QWidgetach przy
163użyciu QPaintera.
164
165%package -n qt5-gstreamer-devel
166Summary: Header files for Qt5GStreamer libraries
167Summary(pl.UTF-8): Pliki nagłówkowe bibliotek QtGStreamer
168Group: Development/Libraries
169Requires: %{name} = %{version}-%{release}
170Requires: Qt5Core-devel >= 5.0.0
171Requires: Qt5Gui-devel >= 5.0.0
172Requires: gstreamer0.10-devel >= 0.10.33
173Requires: gstreamer0.10-plugins-base-devel >= 0.10.33
174
175%description -n qt5-gstreamer-devel
176Header files for Qt5GStreamer libraries.
177
178%description -n qt5-gstreamer-devel -l pl.UTF-8
179Pliki nagłówkowe bibliotek Qt5GStreamer.
180
3b311080
JB
181%prep
182%setup -q
183
184%build
ba518b99
JB
185%if %{with qt4}
186install -d build-qt4
187cd build-qt4
3b311080
JB
188%cmake .. \
189 -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
190 -DQTGSTREAMER_EXAMPLES=OFF \
191 -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4
ba518b99
JB
192%{__make}
193cd ..
194%endif
3b311080 195
ba518b99
JB
196%if %{with qt5}
197install -d build-qt5
198cd build-qt5
199%cmake .. \
200 -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
201 -DQTGSTREAMER_EXAMPLES=OFF \
202 -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt5 \
203 -DQT_VERSION=5
3b311080 204%{__make}
ba518b99
JB
205cd ..
206%endif
3b311080
JB
207
208%install
209rm -rf $RPM_BUILD_ROOT
210
ba518b99
JB
211%if %{with qt4}
212%{__make} -C build-qt4 install \
213 DESTDIR=$RPM_BUILD_ROOT
214%endif
215
216%if %{with qt5}
217%{__make} -C build-qt5 install \
3b311080 218 DESTDIR=$RPM_BUILD_ROOT
ba518b99 219%endif
3b311080
JB
220
221%clean
222rm -rf $RPM_BUILD_ROOT
223
224%post -p /sbin/ldconfig
225%postun -p /sbin/ldconfig
226
ba518b99
JB
227%post -n qt5-gstreamer -p /sbin/ldconfig
228%postun -n qt5-gstreamer -p /sbin/ldconfig
229
230%if %{with qt4}
3b311080
JB
231%files
232%defattr(644,root,root,755)
a8f475c6 233%doc NEWS README
3b311080
JB
234%attr(755,root,root) %{_libdir}/libQtGLib-2.0.so.*.*.*
235%attr(755,root,root) %ghost %{_libdir}/libQtGLib-2.0.so.0
236%attr(755,root,root) %{_libdir}/libQtGStreamer-0.10.so.*.*.*
237%attr(755,root,root) %ghost %{_libdir}/libQtGStreamer-0.10.so.0
238%attr(755,root,root) %{_libdir}/libQtGStreamerUi-0.10.so.*.*.*
239%attr(755,root,root) %ghost %{_libdir}/libQtGStreamerUi-0.10.so.0
f6eae54a
JB
240%attr(755,root,root) %{_libdir}/libQtGStreamerUtils-0.10.so.*.*.*
241%attr(755,root,root) %ghost %{_libdir}/libQtGStreamerUtils-0.10.so.0
a8f475c6 242%attr(755,root,root) %{_libdir}/gstreamer-0.10/libgstqtvideosink.so
3b311080
JB
243
244%files devel
245%defattr(644,root,root,755)
246%attr(755,root,root) %{_libdir}/libQtGLib-2.0.so
247%attr(755,root,root) %{_libdir}/libQtGStreamer-0.10.so
248%attr(755,root,root) %{_libdir}/libQtGStreamerUi-0.10.so
f6eae54a 249%attr(755,root,root) %{_libdir}/libQtGStreamerUtils-0.10.so
3b311080
JB
250%{_includedir}/QtGStreamer
251%{_pkgconfigdir}/QtGLib-2.0.pc
252%{_pkgconfigdir}/QtGStreamer-0.10.pc
253%{_pkgconfigdir}/QtGStreamerUi-0.10.pc
f6eae54a 254%{_pkgconfigdir}/QtGStreamerUtils-0.10.pc
40f731f5 255%{_libdir}/cmake/QtGStreamer
a8f475c6
JB
256
257%files -n QtDeclarative-plugin-gstreamer
258%defattr(644,root,root,755)
259%dir %{_libdir}/qt4/imports/QtGStreamer
40f731f5 260%attr(755,root,root) %{_libdir}/qt4/imports/QtGStreamer/libQtGStreamerQuick1.so
a8f475c6 261%{_libdir}/qt4/imports/QtGStreamer/qmldir
ba518b99
JB
262%endif
263
264%if %{with qt5}
265%files -n qt5-gstreamer
266%defattr(644,root,root,755)
267%doc NEWS README
268%attr(755,root,root) %{_libdir}/libQt5GLib-2.0.so.*.*.*
269%attr(755,root,root) %ghost %{_libdir}/libQt5GLib-2.0.so.0
270%attr(755,root,root) %{_libdir}/libQt5GStreamer-0.10.so.*.*.*
271%attr(755,root,root) %ghost %{_libdir}/libQt5GStreamer-0.10.so.0
272%attr(755,root,root) %{_libdir}/libQt5GStreamerUi-0.10.so.*.*.*
273%attr(755,root,root) %ghost %{_libdir}/libQt5GStreamerUi-0.10.so.0
274%attr(755,root,root) %{_libdir}/libQt5GStreamerUtils-0.10.so.*.*.*
275%attr(755,root,root) %ghost %{_libdir}/libQt5GStreamerUtils-0.10.so.0
276%attr(755,root,root) %{_libdir}/gstreamer-0.10/libgstqt5videosink.so
277
278%files -n qt5-gstreamer-devel
279%defattr(644,root,root,755)
280%attr(755,root,root) %{_libdir}/libQt5GLib-2.0.so
281%attr(755,root,root) %{_libdir}/libQt5GStreamer-0.10.so
282%attr(755,root,root) %{_libdir}/libQt5GStreamerUi-0.10.so
283%attr(755,root,root) %{_libdir}/libQt5GStreamerUtils-0.10.so
284%{_includedir}/Qt5GStreamer
285%{_pkgconfigdir}/Qt5GLib-2.0.pc
286%{_pkgconfigdir}/Qt5GStreamer-0.10.pc
287%{_pkgconfigdir}/Qt5GStreamerUi-0.10.pc
288%{_pkgconfigdir}/Qt5GStreamerUtils-0.10.pc
289%{_libdir}/cmake/Qt5GStreamer
290%endif
This page took 0.722267 seconds and 4 git commands to generate.