]> git.pld-linux.org Git - packages/qpid-cpp.git/commitdiff
- added qmf-broker patch (export one more header)
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 2 Sep 2012 15:29:56 +0000 (17:29 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 2 Sep 2012 15:29:56 +0000 (17:29 +0200)
qpid-cpp-qmf-broker.patch [new file with mode: 0644]
qpid-cpp.spec

diff --git a/qpid-cpp-qmf-broker.patch b/qpid-cpp-qmf-broker.patch
new file mode 100644 (file)
index 0000000..2612d1b
--- /dev/null
@@ -0,0 +1,129 @@
+Index: qpid/cpp/include/qmf/BrokerImportExport.h
+===================================================================
+--- qpid/cpp/include/qmf/BrokerImportExport.h  (revision 0)
++++ qpid/cpp/include/qmf/BrokerImportExport.h  (revision 0)
+@@ -0,0 +1,42 @@
++#ifndef QPID_BROKER_IMPORT_EXPORT_H
++#define QPID_BROKER_IMPORT_EXPORT_H
++
++/*
++ * Licensed to the Apache Software Foundation (ASF) under one
++ * or more contributor license agreements.  See the NOTICE file
++ * distributed with this work for additional information
++ * regarding copyright ownership.  The ASF licenses this file
++ * to you under the Apache License, Version 2.0 (the
++ * "License"); you may not use this file except in compliance
++ * with the License.  You may obtain a copy of the License at
++ *
++ *   http://www.apache.org/licenses/LICENSE-2.0
++ *
++ * Unless required by applicable law or agreed to in writing,
++ * software distributed under the License is distributed on an
++ * "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
++ * KIND, either express or implied.  See the License for the
++ * specific language governing permissions and limitations
++ * under the License.
++ */
++
++#if defined(WIN32) && !defined(QPID_DECLARE_STATIC)
++#  if defined(BROKER_EXPORT) || defined (qpidbroker_EXPORTS)
++#    define QPID_BROKER_EXTERN __declspec(dllexport)
++#  else
++#    define QPID_BROKER_EXTERN __declspec(dllimport)
++#  endif
++#  ifdef _MSC_VER
++#    define QPID_BROKER_CLASS_EXTERN
++#    define QPID_BROKER_INLINE_EXTERN QPID_BROKER_EXTERN
++#  else
++#    define QPID_BROKER_CLASS_EXTERN QPID_BROKER_EXTERN
++#    define QPID_BROKER_INLINE_EXTERN
++#  endif
++#else
++#  define QPID_BROKER_EXTERN
++#  define QPID_BROKER_CLASS_EXTERN
++#  define QPID_BROKER_INLINE_EXTERN
++#endif
++
++#endif
+Index: qpid/cpp/src/CMakeLists.txt
+===================================================================
+--- qpid/cpp/src/CMakeLists.txt        (revision 1352588)
++++ qpid/cpp/src/CMakeLists.txt        (working copy)
+@@ -1224,6 +1224,7 @@ set (qmf_SOURCES
+ set (qmf_HEADERS
+   ../include/qpid/agent/ManagementAgent.h
+   ../include/qpid/agent/QmfAgentImportExport.h
++  ../include/qmf/BrokerImportExport.h
+     )
+ add_msvc_version (qmf library dll)
+Index: qpid/cpp/src/qmf.mk
+===================================================================
+--- qpid/cpp/src/qmf.mk        (revision 1352588)
++++ qpid/cpp/src/qmf.mk        (working copy)
+@@ -30,7 +30,8 @@ lib_LTLIBRARIES +=   \
+ #
+ QMF_API =                                     \
+   ../include/qpid/agent/ManagementAgent.h     \
+-  ../include/qpid/agent/QmfAgentImportExport.h
++  ../include/qpid/agent/QmfAgentImportExport.h        \
++  ../include/qmf/BrokerImportExport.h
+ #
+ # Public headers for the QMF2 API
+@@ -96,7 +97,6 @@ libqmf2_la_SOURCES =                 \
+   qmf/AgentSessionImpl.h      \
+   qmf/AgentSubscription.cpp   \
+   qmf/AgentSubscription.h     \
+-  qmf/BrokerImportExport.h    \
+   qmf/ConsoleEvent.cpp                \
+   qmf/ConsoleEventImpl.h      \
+   qmf/ConsoleSession.cpp      \
+Index: qpid/cpp/src/qmf/BrokerImportExport.h
+===================================================================
+deleted file mode 100644
+--- qpid/cpp/src/qmf/BrokerImportExport.h      (revision 1352588)
++++ /dev/null  (working copy)
+@@ -1,42 +0,0 @@
+-#ifndef QPID_BROKER_IMPORT_EXPORT_H
+-#define QPID_BROKER_IMPORT_EXPORT_H
+-
+-/*
+- * Licensed to the Apache Software Foundation (ASF) under one
+- * or more contributor license agreements.  See the NOTICE file
+- * distributed with this work for additional information
+- * regarding copyright ownership.  The ASF licenses this file
+- * to you under the Apache License, Version 2.0 (the
+- * "License"); you may not use this file except in compliance
+- * with the License.  You may obtain a copy of the License at
+- *
+- *   http://www.apache.org/licenses/LICENSE-2.0
+- *
+- * Unless required by applicable law or agreed to in writing,
+- * software distributed under the License is distributed on an
+- * "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+- * KIND, either express or implied.  See the License for the
+- * specific language governing permissions and limitations
+- * under the License.
+- */
+-
+-#if defined(WIN32) && !defined(QPID_DECLARE_STATIC)
+-#  if defined(BROKER_EXPORT) || defined (qpidbroker_EXPORTS)
+-#    define QPID_BROKER_EXTERN __declspec(dllexport)
+-#  else
+-#    define QPID_BROKER_EXTERN __declspec(dllimport)
+-#  endif
+-#  ifdef _MSC_VER
+-#    define QPID_BROKER_CLASS_EXTERN
+-#    define QPID_BROKER_INLINE_EXTERN QPID_BROKER_EXTERN
+-#  else
+-#    define QPID_BROKER_CLASS_EXTERN QPID_BROKER_EXTERN
+-#    define QPID_BROKER_INLINE_EXTERN
+-#  endif
+-#else
+-#  define QPID_BROKER_EXTERN
+-#  define QPID_BROKER_CLASS_EXTERN
+-#  define QPID_BROKER_INLINE_EXTERN
+-#endif
+-
+-#endif
index a57fe1b4fd2228b225727d05c473295093c3202e..0b0db3b4d913e4732e3721795f84599efbd1d898 100644 (file)
@@ -23,6 +23,8 @@ Source0:      http://www.us.apache.org/dist/qpid/%{version}/%{name}-%{version}.tar.gz
 Patch0:                %{name}-boost.patch
 Patch1:                %{name}-link.patch
 Patch2:                %{name}-perl.patch
+# https://reviews.apache.org/r/5593/
+Patch3:                %{name}-qmf-broker.patch
 URL:           http://qpid.apache.org/
 BuildRequires: acl-devel
 BuildRequires: autoconf >= 2.59
@@ -185,6 +187,7 @@ Wiązania języka Ruby do bibliotek Qpid/C++.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p2
 
 %build
 %{__libtoolize}
This page took 0.040787 seconds and 4 git commands to generate.