]> git.pld-linux.org Git - packages/qemu.git/commitdiff
- updated x32 patch with more fixes
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 26 Mar 2015 19:26:15 +0000 (20:26 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Thu, 26 Mar 2015 19:26:15 +0000 (20:26 +0100)
- require bcc that works on x32

kvm-on-x32.patch [deleted file]
qemu.spec
x32.patch [new file with mode: 0644]

diff --git a/kvm-on-x32.patch b/kvm-on-x32.patch
deleted file mode 100644 (file)
index 434338a..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
---- qemu-2.1+dfsg.orig/configure
-+++ qemu-2.1+dfsg/configure
-@@ -5080,7 +5080,9 @@ case "$target_name" in
-       \( "$target_name" = "ppcemb" -a "$cpu" = "ppc64" \) -o \
-       \( "$target_name" = "mipsel" -a "$cpu" = "mips" \) -o \
-       \( "$target_name" = "x86_64" -a "$cpu" = "i386"   \) -o \
--      \( "$target_name" = "i386"   -a "$cpu" = "x86_64" \) \) ; then
-+      \( "$target_name" = "i386"   -a "$cpu" = "x86_64" \) -o \
-+      \( "$target_name" = "x86_64" -a "$cpu" = "x32"   \) -o \
-+      \( "$target_name" = "i386"   -a "$cpu" = "x32" \) \) ; then
-       echo "CONFIG_KVM=y" >> $config_target_mak
-       if test "$vhost_net" = "yes" ; then
-         echo "CONFIG_VHOST_NET=y" >> $config_target_mak
index a783b29259c8633efdc85f13535b9c67d660d279..4c71a1494d5282ba23285e46ddf13fa2d445dd4e 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -62,14 +62,14 @@ Patch2:             %{name}-whitelist.patch
 Patch3:                %{name}-system-libcacard.patch
 Patch4:                %{name}-xattr.patch
 Patch5:                libjpeg-boolean.patch
-Patch6:                kvm-on-x32.patch
+Patch6:                x32.patch
 # Proof of concept, for reference, do not remove
 Patch400:      %{name}-kde_virtual_workspaces_hack.patch
 URL:           http://www.qemu-project.org/
 %{?with_opengl:BuildRequires:  OpenGL-GLX-devel}
 %{?with_sdl:BuildRequires:     SDL2-devel >= 2.0}
 BuildRequires: alsa-lib-devel
-BuildRequires: bcc
+BuildRequires: bcc >= 0.16.21-2
 %{?with_bluetooth:BuildRequires:       bluez-libs-devel}
 %{?with_brlapi:BuildRequires:  brlapi-devel}
 %{?with_ceph:BuildRequires:    ceph-devel}
diff --git a/x32.patch b/x32.patch
new file mode 100644 (file)
index 0000000..d8a60c9
--- /dev/null
+++ b/x32.patch
@@ -0,0 +1,40 @@
+--- qemu-2.2.0/configure~      2015-03-26 19:52:14.000000000 +0100
++++ qemu-2.2.0/configure       2015-03-26 19:56:34.255072716 +0100
+@@ -1819,7 +1819,7 @@
+ # libseccomp check
+ if test "$seccomp" != "no" ; then
+-    if test "$cpu" = "i386" || test "$cpu" = "x86_64" &&
++    if test "$cpu" = "i386" || test "$cpu" = "x86_64" || test "$cpu" = "x32" &&
+         $pkg_config --atleast-version=2.1.1 libseccomp; then
+         libs_softmmu="$libs_softmmu `$pkg_config --libs libseccomp`"
+         QEMU_CFLAGS="$QEMU_CFLAGS `$pkg_config --cflags libseccomp`"
+@@ -2932,7 +2932,7 @@
+ ##########################################
+ # TPM passthrough is only on x86 Linux
+-if test "$targetos" = Linux && test "$cpu" = i386 -o "$cpu" = x86_64; then
++if test "$targetos" = Linux && test "$cpu" = i386 -o "$cpu" = x86_64 -o "$cpu" = x32; then
+   tpm_passthrough=$tpm
+ else
+   tpm_passthrough=no
+@@ -4161,7 +4161,7 @@
+ # Mac OS X ships with a broken assembler
+ roms=
+-if test \( "$cpu" = "i386" -o "$cpu" = "x86_64" \) -a \
++if test \( "$cpu" = "i386" -o "$cpu" = "x86_64" -o "$cpu" = "x32" \) -a \
+         "$targetos" != "Darwin" -a "$targetos" != "SunOS" -a \
+         "$softmmu" = yes ; then
+   roms="optionrom"
+@@ -5080,7 +5080,9 @@ case "$target_name" in
+       \( "$target_name" = "ppcemb" -a "$cpu" = "ppc64" \) -o \
+       \( "$target_name" = "mipsel" -a "$cpu" = "mips" \) -o \
+       \( "$target_name" = "x86_64" -a "$cpu" = "i386"   \) -o \
+-      \( "$target_name" = "i386"   -a "$cpu" = "x86_64" \) \) ; then
++      \( "$target_name" = "i386"   -a "$cpu" = "x86_64" \) -o \
++      \( "$target_name" = "x86_64" -a "$cpu" = "x32"   \) -o \
++      \( "$target_name" = "i386"   -a "$cpu" = "x32" \) \) ; then
+       echo "CONFIG_KVM=y" >> $config_target_mak
+       if test "$vhost_net" = "yes" ; then
+         echo "CONFIG_VHOST_NET=y" >> $config_target_mak
This page took 0.045996 seconds and 4 git commands to generate.