]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
add BR bcc
[packages/qemu.git] / qemu.spec
1 # TODO:
2 # - --enable-glusterfs when glusterfs 3.4 is out
3 # - qemu-system-ppc -hda ac-ppc.img says:
4 #   qemu: could not open disk image ac-ppc.img: error "Success"
5 #   qemu-0.12.2-2.x86_64.rpm - broken
6 #   qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
7 #   qemu-0.15.0-2.x86_64.rpm - qemu-system-sparc/ppc booting with -kernel, -initrd options stalls in openbios prompt
8 #   qemu-0.11.1-*.x86_64.rpm - OK
9 #
10 # Conditional build:
11 %bcond_without  sdl             # SDL UI and audio support
12 %bcond_without  opengl          # OpenGL support
13 %bcond_without  ceph            # Ceph/RBD support
14 %bcond_with     glusterfs       # GlusterFS backend
15 %bcond_without  spice           # SPICE support
16 %bcond_with     esd             # EsounD audio support
17 %bcond_without  oss             # OSS audio support
18 %bcond_without  pulseaudio      # PulseAudio audio support
19 %bcond_without  xen             # Xen backend driver support
20
21 Summary:        QEMU CPU Emulator
22 Summary(pl.UTF-8):      QEMU - emulator procesora
23 Name:           qemu
24 Version:        1.3.0
25 Release:        0.1
26 License:        GPL v2+
27 Group:          Applications/Emulators
28 Source0:        http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
29 # Source0-md5:  a4030ddd2ba324152a97d65d3c0b247d
30 Patch0:         %{name}-cflags.patch
31 Patch1:         vgabios-widescreens.patch
32 Patch2:         %{name}-whitelist.patch
33 Patch3:         %{name}-system-libcacard.patch
34 # Proof of concept, for reference, do not remove
35 Patch4:         %{name}-kde_virtual_workspaces_hack.patch
36 URL:            http://www.qemu-project.org/
37 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
38 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
39 BuildRequires:  alsa-lib-devel
40 BuildRequires:  bcc
41 BuildRequires:  bluez-libs-devel
42 BuildRequires:  brlapi-devel
43 %{?with_ceph:BuildRequires:     ceph-devel}
44 BuildRequires:  curl-devel
45 BuildRequires:  cyrus-sasl-devel >= 2
46 %{?with_esd:BuildRequires:      esound-devel}
47 BuildRequires:  glib2-devel >= 1:2.12
48 %{?with_glusterfs:BuildRequires:        glusterfs-devel >= 3.4}
49 BuildRequires:  gnutls-devel
50 BuildRequires:  libaio-devel
51 BuildRequires:  libcacard-devel
52 BuildRequires:  libcap-devel
53 BuildRequires:  libcap-ng-devel
54 BuildRequires:  libfdt-devel
55 BuildRequires:  libiscsi-devel
56 BuildRequires:  libjpeg-devel
57 BuildRequires:  libpng-devel
58 BuildRequires:  libseccomp-devel
59 BuildRequires:  libuuid-devel
60 BuildRequires:  ncurses-devel
61 BuildRequires:  nss-devel >= 3.12.8
62 BuildRequires:  perl-Encode
63 BuildRequires:  perl-tools-pod
64 BuildRequires:  pkgconfig
65 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
66 BuildRequires:  sed >= 4.0
67 %if %{with spice}
68 BuildRequires:  spice-protocol >= 0.12.0
69 BuildRequires:  spice-server-devel >= 0.12.0
70 %endif
71 BuildRequires:  texi2html
72 BuildRequires:  texinfo
73 BuildRequires:  usbredir-devel >= 0.5.3
74 BuildRequires:  vde2-devel
75 BuildRequires:  which
76 %{?with_xen:BuildRequires:      xen-devel >= 3.4}
77 BuildRequires:  xfsprogs-devel
78 BuildRequires:  xorg-lib-libX11-devel
79 BuildRequires:  zlib-devel
80 Requires:       %{name}-img = %{version}-%{release}
81 Requires:       %{name}-system-alpha = %{version}-%{release}
82 Requires:       %{name}-system-arm = %{version}-%{release}
83 Requires:       %{name}-system-cris = %{version}-%{release}
84 Requires:       %{name}-system-lm32 = %{version}-%{release}
85 Requires:       %{name}-system-m68k = %{version}-%{release}
86 Requires:       %{name}-system-microblaze = %{version}-%{release}
87 Requires:       %{name}-system-mips = %{version}-%{release}
88 Requires:       %{name}-system-or32 = %{version}-%{release}
89 Requires:       %{name}-system-ppc = %{version}-%{release}
90 Requires:       %{name}-system-s390x = %{version}-%{release}
91 Requires:       %{name}-system-sh4 = %{version}-%{release}
92 Requires:       %{name}-system-sparc = %{version}-%{release}
93 Requires:       %{name}-system-unicore32 = %{version}-%{release}
94 Requires:       %{name}-system-x86 = %{version}-%{release}
95 Requires:       %{name}-system-xtensa = %{version}-%{release}
96 Requires:       %{name}-user = %{version}-%{release}
97 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
98
99 %define systempkg_req \
100 Requires:       SDL >= 1.2.1 \
101 Requires:       usbredir >= 0.5.3
102
103 # some PPC/SPARC boot image in ELF format
104 %define         _noautostrip    .*%{_datadir}/qemu/.*-.*
105
106 %description
107 QEMU is a FAST! processor emulator. By using dynamic translation it
108 achieves a reasonnable speed while being easy to port on new host
109 CPUs. QEMU has two operating modes:
110
111 - User mode emulation. In this mode, QEMU can launch Linux processes
112   compiled for one CPU on another CPU. Linux system calls are converted
113   because of endianness and 32/64 bit mismatches. Wine (Windows
114   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
115
116 - Full system emulation. In this mode, QEMU emulates a full system,
117   including a processor and various peripherials. It can also be used to
118   provide virtual hosting of several virtual PC on a single server.
119
120 %description -l pl.UTF-8
121 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
122 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
123 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
124
125 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
126   procesy linuksowe skompilowane dla jednego procesora na innym
127   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
128   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
129   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
130   cele QEMU.
131
132 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
133   włączając w to procesor i różne urządzenia peryferyjne. Może być także
134   używane do wirtualnego hostowania kilku wirtualnych pecetów na
135   pojedynczym serwerze.
136
137 %package common
138 Summary:        QEMU common files needed by all QEMU targets
139 Summary(pl.UTF-8):      Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
140 Group:          Development/Tools
141 Requires:       glib2 >= 1:2.12
142 Conflicts:      qemu < 1.0-2
143
144 %description common
145 QEMU is a generic and open source processor emulator which achieves a
146 good emulation speed by using dynamic translation.
147
148 This package provides the common files needed by all QEMU targets.
149
150 %description common -l pl.UTF-8
151 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
152 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
153
154 Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
155 środowiska QEMU.
156
157 %package img
158 Summary:        QEMU command line tool for manipulating disk images
159 Summary(pl.UTF-8):      Narzędzie QEMU do operacji na obrazach dysków
160 Group:          Development/Tools
161 Conflicts:      qemu < 1.0-2
162
163 %description img
164 This package provides a command line tool for manipulating disk
165 images.
166
167 %description img -l pl.UTF-8
168 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
169 na obrazach dysków.
170
171 %package user
172 Summary:        QEMU user mode emulation of qemu targets
173 Summary(pl.UTF-8):      QEMU - emulacja trybu użytkownika środowisk qemu
174 Group:          Development/Tools
175 Requires:       %{name}-common = %{version}-%{release}
176
177 %description user
178 QEMU is a generic and open source processor emulator which achieves a
179 good emulation speed by using dynamic translation.
180
181 This package provides the user mode emulation of QEMU targets.
182
183 %description user -l pl.UTF-8
184 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
185 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
186
187 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
188
189 %package system-alpha
190 Summary:        QEMU system emulator for Alpha
191 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Alpha
192 Group:          Development/Tools
193 Requires:       %{name}-common = %{version}-%{release}
194 %systempkg_req
195
196 %description system-alpha
197 QEMU is a generic and open source processor emulator which achieves a
198 good emulation speed by using dynamic translation.
199
200 This package provides the system emulator with Alpha CPU.
201
202 %description system-alpha -l pl.UTF-8
203 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
204 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
205
206 Ten pakiet zawiera emulator systemu z procesorem Alpha.
207
208 %package system-arm
209 Summary:        QEMU system emulator for ARM
210 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem ARM
211 Group:          Development/Tools
212 Requires:       %{name}-common = %{version}-%{release}
213 %systempkg_req
214
215 %description system-arm
216 QEMU is a generic and open source processor emulator which achieves a
217 good emulation speed by using dynamic translation.
218
219 This package provides the system emulator for ARM.
220
221 %description system-arm -l pl.UTF-8
222 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
223 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
224
225 Ten pakiet zawiera emulator systemu z procesorem ARM.
226
227 %package system-cris
228 Summary:        QEMU system emulator for CRIS
229 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem CRIS
230 Group:          Development/Tools
231 Requires:       %{name}-common = %{version}-%{release}
232 %systempkg_req
233
234 %description system-cris
235 QEMU is a generic and open source processor emulator which achieves a
236 good emulation speed by using dynamic translation.
237
238 This package provides the system emulator with CRIS CPU.
239
240 %description system-cris -l pl.UTF-8
241 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
242 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
243
244 Ten pakiet zawiera emulator systemu z procesorem CRIS.
245
246 %package system-lm32
247 Summary:        QEMU system emulator for LM32
248 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem LM32
249 Group:          Development/Tools
250 Requires:       %{name}-common = %{version}-%{release}
251 %systempkg_req
252
253 %description system-lm32
254 QEMU is a generic and open source processor emulator which achieves a
255 good emulation speed by using dynamic translation.
256
257 This package provides the system emulator with LM32 CPU.
258
259 %description system-lm32 -l pl.UTF-8
260 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
261 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
262
263 Ten pakiet zawiera emulator systemu z procesorem LM32.
264
265 %package system-m68k
266 Summary:        QEMU system emulator for m68k
267 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem m68k
268 Group:          Development/Tools
269 Requires:       %{name}-common = %{version}-%{release}
270 %systempkg_req
271
272 %description system-m68k
273 QEMU is a generic and open source processor emulator which achieves a
274 good emulation speed by using dynamic translation.
275
276 This package provides the system emulator with m68k CPU.
277
278 %description system-m68k -l pl.UTF-8
279 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
280 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
281
282 Ten pakiet zawiera emulator systemu z procesorem m68k.
283
284 %package system-microblaze
285 Summary:        QEMU system emulator for MicroBlaze
286 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MicroBlaze
287 Group:          Development/Tools
288 Requires:       %{name}-common = %{version}-%{release}
289 %systempkg_req
290
291 %description system-microblaze
292 QEMU is a generic and open source processor emulator which achieves a
293 good emulation speed by using dynamic translation.
294
295 This package provides the system emulator with MicroBlaze CPU.
296
297 %description system-microblaze -l pl.UTF-8
298 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
299 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
300
301 Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
302
303 %package system-mips
304 Summary:        QEMU system emulator for MIPS
305 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MIPS
306 Group:          Development/Tools
307 Requires:       %{name}-common = %{version}-%{release}
308 %systempkg_req
309
310 %description system-mips
311 QEMU is a generic and open source processor emulator which achieves a
312 good emulation speed by using dynamic translation.
313
314 This package provides the system emulator with MIPS CPU.
315
316 %description system-mips -l pl.UTF-8
317 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
318 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
319
320 Ten pakiet zawiera emulator systemu z procesorem MIPS.
321
322 %package system-or32
323 Summary:        QEMU system emulator for OpenRISC
324 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem OpenRISC
325 Group:          Development/Tools
326 Requires:       %{name}-common = %{version}-%{release}
327 %systempkg_req
328
329 %description system-or32
330 QEMU is a generic and open source processor emulator which achieves a
331 good emulation speed by using dynamic translation.
332
333 This package provides the system emulator with OpenRISC CPU.
334
335 %description system-or32 -l pl.UTF-8
336 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
337 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
338
339 Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
340
341 %package system-ppc
342 Summary:        QEMU system emulator for PowerPC
343 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem PowerPC
344 Group:          Development/Tools
345 Requires:       %{name}-common = %{version}-%{release}
346 %systempkg_req
347
348 %description system-ppc
349 QEMU is a generic and open source processor emulator which achieves a
350 good emulation speed by using dynamic translation.
351
352 This package provides the system emulator with PowerPC CPU.
353
354 %description system-ppc -l pl.UTF-8
355 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
356 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
357
358 Ten pakiet zawiera emulator systemu z procesorem PowerPC.
359
360 %package system-s390x
361 Summary:        QEMU system emulator for S390
362 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem S390
363 Group:          Development/Tools
364 Requires:       %{name}-common = %{version}-%{release}
365 %systempkg_req
366
367 %description system-s390x
368 QEMU is a generic and open source processor emulator which achieves a
369 good emulation speed by using dynamic translation.
370
371 This package provides the system emulator with S390 CPU.
372
373 %description system-s390x -l pl.UTF-8
374 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
375 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
376
377 Ten pakiet zawiera emulator systemu z procesorem S390.
378
379 %package system-sh4
380 Summary:        QEMU system emulator for SH4
381 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SH4
382 Group:          Development/Tools
383 Requires:       %{name}-common = %{version}-%{release}
384 %systempkg_req
385
386 %description system-sh4
387 QEMU is a generic and open source processor emulator which achieves a
388 good emulation speed by using dynamic translation.
389
390 This package provides the system emulator with SH4 CPU.
391
392 %description system-sh4 -l pl.UTF-8
393 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
394 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
395
396 Ten pakiet zawiera emulator systemu z procesorem SH4.
397
398 %package system-sparc
399 Summary:        QEMU system emulator for SPARC
400 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SPARC
401 Group:          Development/Tools
402 Requires:       %{name}-common = %{version}-%{release}
403 %systempkg_req
404
405 %description system-sparc
406 QEMU is a generic and open source processor emulator which achieves a
407 good emulation speed by using dynamic translation.
408
409 This package provides the system emulator with SPARC/SPARC64 CPU.
410
411 %description system-sparc -l pl.UTF-8
412 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
413 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
414
415 Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
416
417 %package system-unicore32
418 Summary:        QEMU system emulator for UniCore32
419 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem UniCore32
420 Group:          Development/Tools
421 Requires:       %{name}-common = %{version}-%{release}
422 %systempkg_req
423
424 %description system-unicore32
425 QEMU is a generic and open source processor emulator which achieves a
426 good emulation speed by using dynamic translation.
427
428 This package provides the system emulator with UniCore32 CPU.
429
430 %description system-unicore32 -l pl.UTF-8
431 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
432 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
433
434 Ten pakiet zawiera emulator systemu z procesorem UniCore32.
435
436 %package system-x86
437 Summary:        QEMU system emulator for x86
438 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem x86
439 Group:          Development/Tools
440 Requires:       %{name}-common = %{version}-%{release}
441 %systempkg_req
442
443 %description system-x86
444 QEMU is a generic and open source processor emulator which achieves a
445 good emulation speed by using dynamic translation.
446
447 %description system-x86 -l pl.UTF-8
448 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
449 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
450
451 %package system-xtensa
452 Summary:        QEMU system emulator for Xtensa
453 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Xtensa
454 Group:          Development/Tools
455 Requires:       %{name}-common = %{version}-%{release}
456 %systempkg_req
457
458 %description system-xtensa
459 QEMU is a generic and open source processor emulator which achieves a
460 good emulation speed by using dynamic translation.
461
462 This package provides the system emulator with Xtensa CPU.
463
464 %description system-xtensa -l pl.UTF-8
465 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
466 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
467
468 Ten pakiet zawiera emulator systemu z procesorem Xtensa.
469
470 %prep
471 %setup -q
472 %patch0 -p1
473 %patch1 -p1
474 %patch2 -p0
475 %patch3 -p1
476
477 %{__mv} libcacard libcacard-use-system-lib
478
479 # workaround for conflict with alsa/error.h
480 ln -s ../error.h qapi/error.h
481
482 %build
483 ./configure \
484         --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
485         --extra-ldflags="%{rpmldflags}" \
486         --prefix=%{_prefix} \
487         --sysconfdir=%{_sysconfdir} \
488         --cc="%{__cc}" \
489         --host-cc="%{__cc}" \
490         --disable-strip \
491         --enable-attr \
492         --enable-bluez \
493         --enable-brlapi \
494         --enable-cap-ng \
495         --enable-curl \
496         --enable-curses \
497         --enable-docs \
498         --enable-fdt \
499         %{__enable_disable glusterfs} \
500         --enable-libiscsi \
501         --enable-mixemu \
502         %{__enable_disable opengl} \
503         %{__enable_disable ceph rbd} \
504         %{__enable_disable sdl} \
505         --enable-seccomp \
506         %{__enable_disable spice} \
507         --enable-smartcard \
508         --enable-smartcard-nss \
509         --enable-usb-redir \
510         --enable-uuid \
511         --enable-vde \
512         --enable-virtfs \
513         --enable-vnc-jpeg \
514         --enable-vnc-png \
515         --enable-vnc-sasl \
516         --enable-vnc-tls \
517         %{__enable_disable xen} \
518         --audio-card-list="ac97,es1370,sb16,cs4231a,adlib,gus,hda" \
519         --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
520         --interp-prefix=%{_libdir}/qemu/lib-%%M
521 # note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
522 # --libexecdir in configure is nop
523 %{__make} \
524         V=1 \
525         CONFIG_QEMU_HELPERDIR="%{_libdir}"
526
527 # rebuild patched vesa tables with additional widescreen modes.
528 %{__make} -C roms/vgabios stdvga-bios
529
530 %install
531 rm -rf $RPM_BUILD_ROOT
532
533 %{__make} install \
534         DESTDIR=$RPM_BUILD_ROOT \
535         libexecdir=%{_libdir}
536
537 install -d $RPM_BUILD_ROOT%{_sysconfdir}
538 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
539 #!/bin/sh
540
541 EOF
542
543 # already packaged
544 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
545 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
546
547 # install patched vesa tables with additional widescreen modes.
548 cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
549
550 %clean
551 rm -rf $RPM_BUILD_ROOT
552
553 %files
554 %defattr(644,root,root,755)
555
556 %files common
557 %defattr(644,root,root,755)
558 %doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
559 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
560 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
561 %dir %{_sysconfdir}/qemu
562 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
563 %attr(755,root,root) %{_bindir}/qemu-nbd
564 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
565 %{_mandir}/man1/qemu.1*
566 %{_mandir}/man1/virtfs-proxy-helper.1*
567 %{_mandir}/man8/qemu-nbd.8*
568
569 %dir %{_datadir}/qemu
570 %{_datadir}/%{name}/keymaps
571 %{_datadir}/%{name}/qemu-icon.bmp
572 # various bios images
573 %{_datadir}/%{name}/*.bin
574 %{_datadir}/%{name}/*.rom
575 %{_datadir}/%{name}/*.dtb
576 %{_datadir}/%{name}/openbios-ppc
577 %{_datadir}/%{name}/openbios-sparc*
578 %{_datadir}/%{name}/palcode-clipper
579
580 %files img
581 %defattr(644,root,root,755)
582 %attr(755,root,root) %{_bindir}/qemu-img
583 %{_mandir}/man1/qemu-img.1*
584
585 %files user
586 %defattr(644,root,root,755)
587 %attr(755,root,root) %{_bindir}/qemu-alpha
588 %attr(755,root,root) %{_bindir}/qemu-arm
589 %attr(755,root,root) %{_bindir}/qemu-armeb
590 %attr(755,root,root) %{_bindir}/qemu-cris
591 %attr(755,root,root) %{_bindir}/qemu-ga
592 %attr(755,root,root) %{_bindir}/qemu-i386
593 %attr(755,root,root) %{_bindir}/qemu-io
594 %attr(755,root,root) %{_bindir}/qemu-m68k
595 %attr(755,root,root) %{_bindir}/qemu-microblaze
596 %attr(755,root,root) %{_bindir}/qemu-microblazeel
597 %attr(755,root,root) %{_bindir}/qemu-mips
598 %attr(755,root,root) %{_bindir}/qemu-mipsel
599 %attr(755,root,root) %{_bindir}/qemu-or32
600 %attr(755,root,root) %{_bindir}/qemu-ppc
601 %attr(755,root,root) %{_bindir}/qemu-ppc64
602 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
603 %attr(755,root,root) %{_bindir}/qemu-s390x
604 %attr(755,root,root) %{_bindir}/qemu-sh4
605 %attr(755,root,root) %{_bindir}/qemu-sh4eb
606 %attr(755,root,root) %{_bindir}/qemu-sparc
607 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
608 %attr(755,root,root) %{_bindir}/qemu-sparc64
609 %attr(755,root,root) %{_bindir}/qemu-unicore32
610 %attr(755,root,root) %{_bindir}/qemu-x86_64
611
612 %files system-alpha
613 %defattr(644,root,root,755)
614 %attr(755,root,root) %{_bindir}/qemu-system-alpha
615
616 %files system-arm
617 %defattr(644,root,root,755)
618 %attr(755,root,root) %{_bindir}/qemu-system-arm
619
620 %files system-cris
621 %defattr(644,root,root,755)
622 %attr(755,root,root) %{_bindir}/qemu-system-cris
623
624 %files system-lm32
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{_bindir}/qemu-system-lm32
627
628 %files system-m68k
629 %defattr(644,root,root,755)
630 %attr(755,root,root) %{_bindir}/qemu-system-m68k
631
632 %files system-microblaze
633 %defattr(644,root,root,755)
634 %attr(755,root,root) %{_bindir}/qemu-system-microblaze
635 %attr(755,root,root) %{_bindir}/qemu-system-microblazeel
636
637 %files system-mips
638 %defattr(644,root,root,755)
639 %attr(755,root,root) %{_bindir}/qemu-system-mips
640 %attr(755,root,root) %{_bindir}/qemu-system-mipsel
641 %attr(755,root,root) %{_bindir}/qemu-system-mips64
642 %attr(755,root,root) %{_bindir}/qemu-system-mips64el
643
644 %files system-or32
645 %defattr(644,root,root,755)
646 %attr(755,root,root) %{_bindir}/qemu-system-or32
647
648 %files system-ppc
649 %defattr(644,root,root,755)
650 %attr(755,root,root) %{_bindir}/qemu-system-ppc
651 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
652 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
653
654 %files system-s390x
655 %defattr(644,root,root,755)
656 %attr(755,root,root) %{_bindir}/qemu-system-s390x
657
658 %files system-sh4
659 %defattr(644,root,root,755)
660 %attr(755,root,root) %{_bindir}/qemu-system-sh4
661 %attr(755,root,root) %{_bindir}/qemu-system-sh4eb
662
663 %files system-sparc
664 %defattr(644,root,root,755)
665 %attr(755,root,root) %{_bindir}/qemu-system-sparc
666 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
667
668 %files system-unicore32
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_bindir}/qemu-system-unicore32
671
672 %files system-x86
673 %defattr(644,root,root,755)
674 %attr(755,root,root) %{_bindir}/qemu-system-i386
675 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
676
677 %files system-xtensa
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{_bindir}/qemu-system-xtensa
680 %attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
This page took 0.080055 seconds and 4 git commands to generate.