]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- package KSM support files
[packages/qemu.git] / qemu.spec
1 # TODO:
2 # - merge missing bits from qemu-kvm
3 #
4 # Conditional build:
5 %bcond_without  sdl             # SDL UI and audio support
6 %bcond_without  glx             # OpenGL/GLX support
7 %bcond_without  ceph            # Ceph/RBD support
8 %bcond_without  glusterfs       # GlusterFS backend
9 %bcond_without  rdma            # RDMA-based migration support
10 %bcond_with     gtk2            # GTK+ 2.x instead of 3.x
11 %bcond_without  spice           # SPICE support
12 %bcond_with     esd             # EsounD audio support
13 %bcond_without  oss             # OSS audio support
14 %bcond_without  pulseaudio      # PulseAudio audio support
15 %bcond_without  xen             # Xen backend driver support
16
17 Summary:        QEMU CPU Emulator
18 Summary(pl.UTF-8):      QEMU - emulator procesora
19 Name:           qemu
20 Version:        1.6.1
21 Release:        3
22 License:        GPL v2+
23 Group:          Applications/Emulators
24 Source0:        http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
25 # Source0-md5:  3a897d722457c5a895cd6ac79a28fda0
26 # KSM control scripts
27 Source5:        ksm.service
28 Source6:        ksm.sysconfig
29 Source7:        ksmctl.c
30 Source8:        ksmtuned.service
31 Source9:        ksmtuned
32 Source10:       ksmtuned.conf
33 Source11:       qemu-guest-agent.service
34 Source12:       99-qemu-guest-agent.rules
35 Patch0:         %{name}-cflags.patch
36 Patch1:         vgabios-widescreens.patch
37 Patch2:         %{name}-whitelist.patch
38 Patch3:         %{name}-system-libcacard.patch
39 # Proof of concept, for reference, do not remove
40 Patch4:         %{name}-kde_virtual_workspaces_hack.patch
41 URL:            http://www.qemu-project.org/
42 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
43 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
44 BuildRequires:  alsa-lib-devel
45 BuildRequires:  bcc
46 BuildRequires:  bluez-libs-devel
47 BuildRequires:  brlapi-devel
48 %{?with_ceph:BuildRequires:     ceph-devel}
49 BuildRequires:  curl-devel
50 BuildRequires:  cyrus-sasl-devel >= 2
51 %{?with_esd:BuildRequires:      esound-devel}
52 BuildRequires:  glib2-devel >= 1:2.12
53 %{?with_glusterfs:BuildRequires:        glusterfs-devel >= 3.4}
54 BuildRequires:  gnutls-devel
55 BuildRequires:  libaio-devel
56 BuildRequires:  libcacard-devel
57 BuildRequires:  libcap-devel
58 BuildRequires:  libcap-ng-devel
59 BuildRequires:  libfdt-devel
60 %{?with_rdma:BuildRequires:     libibverbs-devel}
61 BuildRequires:  libiscsi-devel
62 BuildRequires:  libjpeg-devel
63 BuildRequires:  libpng-devel
64 %{?with_rdma:BuildRequires:     librdmacm-devel}
65 BuildRequires:  libseccomp-devel
66 BuildRequires:  libssh2-devel >= 1.2.8
67 # for usb passthrough, when available
68 #BuildRequires: libusb-devel >= 1.0.13
69 BuildRequires:  libuuid-devel
70 BuildRequires:  ncurses-devel
71 BuildRequires:  nss-devel >= 3.12.8
72 BuildRequires:  perl-Encode
73 BuildRequires:  perl-tools-pod
74 BuildRequires:  pkgconfig
75 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
76 BuildRequires:  rpmbuild(macros) >= 1.202
77 BuildRequires:  sed >= 4.0
78 %if %{with spice}
79 BuildRequires:  spice-protocol >= 0.12.0
80 BuildRequires:  spice-server-devel >= 0.12.0
81 %endif
82 BuildRequires:  texi2html
83 BuildRequires:  texinfo
84 BuildRequires:  usbredir-devel >= 0.6
85 BuildRequires:  vde2-devel
86 BuildRequires:  which
87 %{?with_xen:BuildRequires:      xen-devel >= 3.4}
88 BuildRequires:  xfsprogs-devel
89 BuildRequires:  xorg-lib-libX11-devel
90 BuildRequires:  zlib-devel
91 %if %{with gtk2}
92 BuildRequires:  gtk+2-devel >= 2:2.18.0
93 BuildRequires:  vte0-devel >= 0.24.0
94 %else
95 BuildRequires:  gtk+3-devel >= 3.0.0
96 BuildRequires:  vte-devel >= 0.32.0
97 %endif
98 Requires:       %{name}-img = %{version}-%{release}
99 Requires:       %{name}-system-alpha = %{version}-%{release}
100 Requires:       %{name}-system-arm = %{version}-%{release}
101 Requires:       %{name}-system-cris = %{version}-%{release}
102 Requires:       %{name}-system-lm32 = %{version}-%{release}
103 Requires:       %{name}-system-m68k = %{version}-%{release}
104 Requires:       %{name}-system-microblaze = %{version}-%{release}
105 Requires:       %{name}-system-mips = %{version}-%{release}
106 Requires:       %{name}-system-moxie = %{version}-%{release}
107 Requires:       %{name}-system-or32 = %{version}-%{release}
108 Requires:       %{name}-system-ppc = %{version}-%{release}
109 Requires:       %{name}-system-s390x = %{version}-%{release}
110 Requires:       %{name}-system-sh4 = %{version}-%{release}
111 Requires:       %{name}-system-sparc = %{version}-%{release}
112 Requires:       %{name}-system-unicore32 = %{version}-%{release}
113 Requires:       %{name}-system-x86 = %{version}-%{release}
114 Requires:       %{name}-system-xtensa = %{version}-%{release}
115 Requires:       %{name}-user = %{version}-%{release}
116 Obsoletes:      qemu-kvm
117 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
118
119 %define systempkg_req \
120 Requires:       SDL >= 1.2.1 \
121 Requires:       usbredir >= 0.6 \
122 %if %{with gtk2} \
123 Requires:       gtk+2 >= 2:2.18.0 \
124 Requires:       vte0 >= 0.24.0 \
125 %else \
126 Requires:       gtk+3 >= 3.0.0 \
127 Requires:       vte >= 0.32.0 \
128 %endif
129
130 # some PPC/SPARC boot image in ELF format
131 %define         _noautostrip    .*%{_datadir}/qemu/.*-.*
132
133 %description
134 QEMU is a FAST! processor emulator. By using dynamic translation it
135 achieves a reasonnable speed while being easy to port on new host
136 CPUs. QEMU has two operating modes:
137
138 - User mode emulation. In this mode, QEMU can launch Linux processes
139   compiled for one CPU on another CPU. Linux system calls are converted
140   because of endianness and 32/64 bit mismatches. Wine (Windows
141   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
142
143 - Full system emulation. In this mode, QEMU emulates a full system,
144   including a processor and various peripherials. It can also be used to
145   provide virtual hosting of several virtual PC on a single server.
146
147 %description -l pl.UTF-8
148 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
149 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
150 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
151
152 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
153   procesy linuksowe skompilowane dla jednego procesora na innym
154   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
155   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
156   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
157   cele QEMU.
158
159 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
160   włączając w to procesor i różne urządzenia peryferyjne. Może być także
161   używane do wirtualnego hostowania kilku wirtualnych pecetów na
162   pojedynczym serwerze.
163
164 %package common
165 Summary:        QEMU common files needed by all QEMU targets
166 Summary(pl.UTF-8):      Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
167 Group:          Development/Tools
168 Requires(post,preun,postun):    systemd-units >= 38
169 Requires(postun):       /usr/sbin/groupdel
170 Requires(postun):       /usr/sbin/userdel
171 Requires(pre):  /bin/id
172 Requires(pre):  /usr/bin/getgid
173 Requires(pre):  /usr/sbin/groupadd
174 Requires(pre):  /usr/sbin/useradd
175 Requires:       glib2 >= 1:2.12
176 Requires:       libssh2 >= 1.2.8
177 Requires:       systemd-units >= 38
178 Provides:       group(qemu)
179 Provides:       user(qemu)
180 Obsoletes:      qemu-kvm-common
181 Conflicts:      qemu < 1.0-2
182
183 %description common
184 QEMU is a generic and open source processor emulator which achieves a
185 good emulation speed by using dynamic translation.
186
187 This package provides the common files needed by all QEMU targets.
188
189 %description common -l pl.UTF-8
190 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
191 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
192
193 Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
194 środowiska QEMU.
195
196 %package img
197 Summary:        QEMU command line tool for manipulating disk images
198 Summary(pl.UTF-8):      Narzędzie QEMU do operacji na obrazach dysków
199 Group:          Development/Tools
200 Conflicts:      qemu < 1.0-2
201 Obsoletes:      qemu-kvm-img
202
203 %description img
204 This package provides a command line tool for manipulating disk
205 images.
206
207 %description img -l pl.UTF-8
208 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
209 na obrazach dysków.
210
211 %package user
212 Summary:        QEMU user mode emulation of qemu targets
213 Summary(pl.UTF-8):      QEMU - emulacja trybu użytkownika środowisk qemu
214 Group:          Development/Tools
215 Requires:       %{name}-common = %{version}-%{release}
216 Obsoletes:      qemu-kvm-user
217
218 %description user
219 QEMU is a generic and open source processor emulator which achieves a
220 good emulation speed by using dynamic translation.
221
222 This package provides the user mode emulation of QEMU targets.
223
224 %description user -l pl.UTF-8
225 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
226 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
227
228 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
229
230 %package system-alpha
231 Summary:        QEMU system emulator for Alpha
232 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Alpha
233 Group:          Development/Tools
234 Requires:       %{name}-common = %{version}-%{release}
235 %systempkg_req
236 Obsoletes:      qemu-kvm-system-alpha
237
238 %description system-alpha
239 QEMU is a generic and open source processor emulator which achieves a
240 good emulation speed by using dynamic translation.
241
242 This package provides the system emulator with Alpha CPU.
243
244 %description system-alpha -l pl.UTF-8
245 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
246 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
247
248 Ten pakiet zawiera emulator systemu z procesorem Alpha.
249
250 %package system-arm
251 Summary:        QEMU system emulator for ARM
252 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem ARM
253 Group:          Development/Tools
254 Requires:       %{name}-common = %{version}-%{release}
255 %systempkg_req
256 Obsoletes:      qemu-kvm-system-arm
257
258 %description system-arm
259 QEMU is a generic and open source processor emulator which achieves a
260 good emulation speed by using dynamic translation.
261
262 This package provides the system emulator for ARM.
263
264 %description system-arm -l pl.UTF-8
265 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
266 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
267
268 Ten pakiet zawiera emulator systemu z procesorem ARM.
269
270 %package system-cris
271 Summary:        QEMU system emulator for CRIS
272 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem CRIS
273 Group:          Development/Tools
274 Requires:       %{name}-common = %{version}-%{release}
275 %systempkg_req
276 Obsoletes:      qemu-kvm-system-cris
277
278 %description system-cris
279 QEMU is a generic and open source processor emulator which achieves a
280 good emulation speed by using dynamic translation.
281
282 This package provides the system emulator with CRIS CPU.
283
284 %description system-cris -l pl.UTF-8
285 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
286 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
287
288 Ten pakiet zawiera emulator systemu z procesorem CRIS.
289
290 %package system-lm32
291 Summary:        QEMU system emulator for LM32
292 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem LM32
293 Group:          Development/Tools
294 Requires:       %{name}-common = %{version}-%{release}
295 %systempkg_req
296 Obsoletes:      qemu-kvm-system-lm32
297
298 %description system-lm32
299 QEMU is a generic and open source processor emulator which achieves a
300 good emulation speed by using dynamic translation.
301
302 This package provides the system emulator with LM32 CPU.
303
304 %description system-lm32 -l pl.UTF-8
305 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
306 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
307
308 Ten pakiet zawiera emulator systemu z procesorem LM32.
309
310 %package system-m68k
311 Summary:        QEMU system emulator for m68k
312 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem m68k
313 Group:          Development/Tools
314 Requires:       %{name}-common = %{version}-%{release}
315 %systempkg_req
316 Obsoletes:      qemu-kvm-system-m68k
317
318 %description system-m68k
319 QEMU is a generic and open source processor emulator which achieves a
320 good emulation speed by using dynamic translation.
321
322 This package provides the system emulator with m68k CPU.
323
324 %description system-m68k -l pl.UTF-8
325 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
326 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
327
328 Ten pakiet zawiera emulator systemu z procesorem m68k.
329
330 %package system-microblaze
331 Summary:        QEMU system emulator for MicroBlaze
332 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MicroBlaze
333 Group:          Development/Tools
334 Requires:       %{name}-common = %{version}-%{release}
335 %systempkg_req
336 Obsoletes:      qemu-kvm-system-microblaze
337
338 %description system-microblaze
339 QEMU is a generic and open source processor emulator which achieves a
340 good emulation speed by using dynamic translation.
341
342 This package provides the system emulator with MicroBlaze CPU.
343
344 %description system-microblaze -l pl.UTF-8
345 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
346 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
347
348 Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
349
350 %package system-mips
351 Summary:        QEMU system emulator for MIPS
352 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MIPS
353 Group:          Development/Tools
354 Requires:       %{name}-common = %{version}-%{release}
355 %systempkg_req
356 Obsoletes:      qemu-kvm-system-mips
357
358 %description system-mips
359 QEMU is a generic and open source processor emulator which achieves a
360 good emulation speed by using dynamic translation.
361
362 This package provides the system emulator with MIPS CPU.
363
364 %description system-mips -l pl.UTF-8
365 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
366 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
367
368 Ten pakiet zawiera emulator systemu z procesorem MIPS.
369
370 %package system-moxie
371 Summary:        QEMU system emulator for Moxie
372 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Moxie
373 Group:          Development/Tools
374 Requires:       %{name}-common = %{version}-%{release}
375 %systempkg_req
376
377 %description system-moxie
378 QEMU is a generic and open source processor emulator which achieves a
379 good emulation speed by using dynamic translation.
380
381 This package provides the system emulator with Moxie CPU.
382
383 %description system-moxie -l pl.UTF-8
384 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
385 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
386
387 Ten pakiet zawiera emulator systemu z procesorem Moxie.
388
389 %package system-or32
390 Summary:        QEMU system emulator for OpenRISC
391 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem OpenRISC
392 Group:          Development/Tools
393 Requires:       %{name}-common = %{version}-%{release}
394 %systempkg_req
395 Obsoletes:      qemu-kvm-system-or32
396
397 %description system-or32
398 QEMU is a generic and open source processor emulator which achieves a
399 good emulation speed by using dynamic translation.
400
401 This package provides the system emulator with OpenRISC CPU.
402
403 %description system-or32 -l pl.UTF-8
404 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
405 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
406
407 Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
408
409 %package system-ppc
410 Summary:        QEMU system emulator for PowerPC
411 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem PowerPC
412 Group:          Development/Tools
413 Requires:       %{name}-common = %{version}-%{release}
414 %systempkg_req
415 Obsoletes:      qemu-kvm-system-ppc
416
417 %description system-ppc
418 QEMU is a generic and open source processor emulator which achieves a
419 good emulation speed by using dynamic translation.
420
421 This package provides the system emulator with PowerPC CPU.
422
423 %description system-ppc -l pl.UTF-8
424 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
425 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
426
427 Ten pakiet zawiera emulator systemu z procesorem PowerPC.
428
429 %package system-s390x
430 Summary:        QEMU system emulator for S390
431 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem S390
432 Group:          Development/Tools
433 Requires:       %{name}-common = %{version}-%{release}
434 %systempkg_req
435 Obsoletes:      qemu-kvm-system-s390x
436
437 %description system-s390x
438 QEMU is a generic and open source processor emulator which achieves a
439 good emulation speed by using dynamic translation.
440
441 This package provides the system emulator with S390 CPU.
442
443 %description system-s390x -l pl.UTF-8
444 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
445 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
446
447 Ten pakiet zawiera emulator systemu z procesorem S390.
448
449 %package system-sh4
450 Summary:        QEMU system emulator for SH4
451 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SH4
452 Group:          Development/Tools
453 Requires:       %{name}-common = %{version}-%{release}
454 %systempkg_req
455 Obsoletes:      qemu-kvm-system-sh4
456
457 %description system-sh4
458 QEMU is a generic and open source processor emulator which achieves a
459 good emulation speed by using dynamic translation.
460
461 This package provides the system emulator with SH4 CPU.
462
463 %description system-sh4 -l pl.UTF-8
464 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
465 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
466
467 Ten pakiet zawiera emulator systemu z procesorem SH4.
468
469 %package system-sparc
470 Summary:        QEMU system emulator for SPARC
471 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SPARC
472 Group:          Development/Tools
473 Requires:       %{name}-common = %{version}-%{release}
474 %systempkg_req
475 Obsoletes:      qemu-kvm-system-sparc
476
477 %description system-sparc
478 QEMU is a generic and open source processor emulator which achieves a
479 good emulation speed by using dynamic translation.
480
481 This package provides the system emulator with SPARC/SPARC64 CPU.
482
483 %description system-sparc -l pl.UTF-8
484 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
485 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
486
487 Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
488
489 %package system-unicore32
490 Summary:        QEMU system emulator for UniCore32
491 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem UniCore32
492 Group:          Development/Tools
493 Requires:       %{name}-common = %{version}-%{release}
494 %systempkg_req
495 Obsoletes:      qemu-kvm-system-unicore32
496
497 %description system-unicore32
498 QEMU is a generic and open source processor emulator which achieves a
499 good emulation speed by using dynamic translation.
500
501 This package provides the system emulator with UniCore32 CPU.
502
503 %description system-unicore32 -l pl.UTF-8
504 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
505 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
506
507 Ten pakiet zawiera emulator systemu z procesorem UniCore32.
508
509 %package system-x86
510 Summary:        QEMU system emulator for x86
511 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem x86
512 Group:          Development/Tools
513 Requires:       %{name}-common = %{version}-%{release}
514 %systempkg_req
515 Obsoletes:      qemu-kvm-system-x86
516
517 %description system-x86
518 QEMU is a generic and open source processor emulator which achieves a
519 good emulation speed by using dynamic translation.
520
521 %description system-x86 -l pl.UTF-8
522 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
523 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
524
525 %package system-xtensa
526 Summary:        QEMU system emulator for Xtensa
527 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Xtensa
528 Group:          Development/Tools
529 Requires:       %{name}-common = %{version}-%{release}
530 %systempkg_req
531 Obsoletes:      qemu-kvm-system-xtensa
532
533 %description system-xtensa
534 QEMU is a generic and open source processor emulator which achieves a
535 good emulation speed by using dynamic translation.
536
537 This package provides the system emulator with Xtensa CPU.
538
539 %description system-xtensa -l pl.UTF-8
540 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
541 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
542
543 Ten pakiet zawiera emulator systemu z procesorem Xtensa.
544
545 %package guest-agent
546 Summary:        QEMU guest agent
547 Summary(pl.UTF-8):      Agent gościa QEMU
548 Group:          Daemons
549 Requires(post,preun,postun):    systemd-units >= 38
550 Requires:       glib2 >= 1:2.12
551 Requires:       systemd-units >= 38
552 Obsoletes:      qemu-kvm-guest-agent
553
554 %description guest-agent
555 QEMU is a generic and open source processor emulator which achieves
556 a good emulation speed by using dynamic translation.
557
558 This package provides an agent to run inside guests, which
559 communicates with the host over a virtio-serial channel named
560 "org.qemu.guest_agent.0".
561
562 This package does not need to be installed on the host OS.
563
564 %description guest-agent -l pl.UTF-8
565 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
566 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
567
568 Ten pakiet udostępnia agenta przeznaczonego do uruchomienia w
569 systemach-gościach, komunikującego się kanałem virtio-serial o nazwie
570 "org.qemu.guest_agent.0".
571
572 Ten pakiet nie musi być zainstalowany w systemie hosta.
573
574 %prep
575 %setup -q
576 %patch0 -p1
577 %patch1 -p1
578 %patch2 -p0
579 %patch3 -p1
580
581 %{__mv} libcacard libcacard-use-system-lib
582
583 # workaround for conflict with alsa/error.h
584 ln -s ../error.h qapi/error.h
585
586 %build
587 ./configure \
588         --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
589         --extra-ldflags="%{rpmldflags}" \
590         --prefix=%{_prefix} \
591         --sysconfdir=%{_sysconfdir} \
592         --cc="%{__cc}" \
593         --host-cc="%{__cc}" \
594         --disable-strip \
595         --enable-attr \
596         --enable-bluez \
597         --enable-brlapi \
598         --enable-cap-ng \
599         --enable-curl \
600         --enable-curses \
601         --enable-docs \
602         --enable-fdt \
603         %{__enable_disable glusterfs} \
604         --enable-libiscsi \
605         --enable-mixemu \
606         %{__enable_disable glx} \
607         %{__enable_disable ceph rbd} \
608         %{__enable_disable rdma} \
609         %{__enable_disable sdl} \
610         --enable-seccomp \
611         %{__enable_disable spice} \
612         --enable-smartcard-nss \
613         --enable-tpm \
614         --enable-usb-redir \
615         --enable-uuid \
616         --enable-vde \
617         --enable-virtfs \
618         --enable-vnc-jpeg \
619         --enable-vnc-png \
620         --enable-vnc-sasl \
621         --enable-vnc-tls \
622         --enable-kvm \
623         %{__enable_disable xen} \
624         --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
625         --interp-prefix=%{_libdir}/qemu/lib-%%M \
626         --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
627
628 # note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
629 # --libexecdir in configure is nop
630 %{__make} \
631         V=1 \
632         CONFIG_QEMU_HELPERDIR="%{_libdir}"
633
634 # rebuild patched vesa tables with additional widescreen modes.
635 %{__make} -C roms/vgabios stdvga-bios
636
637 %{__cc} %{SOURCE7} %{rpmcflags} -o ksmctl
638
639 %install
640 rm -rf $RPM_BUILD_ROOT
641 install -d $RPM_BUILD_ROOT{%{systemdunitdir},/usr/lib/binfmt.d} \
642         $RPM_BUILD_ROOT/etc/{sysconfig,udev/rules.d,modules-load.d} \
643         $RPM_BUILD_ROOT{%{_sysconfdir}/sasl,%{_sbindir}}
644
645 %{__make} install \
646         DESTDIR=$RPM_BUILD_ROOT \
647         libexecdir=%{_libdir}
648
649 install -d $RPM_BUILD_ROOT%{_sysconfdir}
650 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
651 #!/bin/sh
652
653 EOF
654
655 install -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/ksm.service
656 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/ksm
657 install -p ksmctl $RPM_BUILD_ROOT%{_sbindir}
658
659 install -p %{SOURCE8} $RPM_BUILD_ROOT%{systemdunitdir}/ksmtuned.service
660 install -p %{SOURCE9} $RPM_BUILD_ROOT%{_sbindir}/ksmtuned
661 install -p %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/ksmtuned.conf
662
663 # For the qemu-guest-agent subpackage install the systemd
664 # service and udev rules.
665 install -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
666 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
667
668 # already packaged
669 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
670 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
671
672 # install patched vesa tables with additional widescreen modes.
673 cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
674
675 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{de_DE,de}
676 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{fr_FR,fr}
677 %find_lang %{name}
678
679 %clean
680 rm -rf $RPM_BUILD_ROOT
681
682 %pre common
683 %groupadd -g 276 qemu
684 %useradd -u 276 -g qemu -c "QEMU User" qemu
685
686 %post common
687 %systemd_post ksm.service
688 %systemd_post ksmtuned.service
689
690 %preun common
691 %systemd_preun ksm.service
692 %systemd_preun ksmtuned.service
693
694 %postun common
695 if [ "$1" = "0" ]; then
696         %userremove qemu
697         %groupremove qemu
698 fi
699 %systemd_reload
700
701 %triggerpostun common -- qemu-common < 1.6.1-4
702 %systemd_trigger ksm.service
703 %systemd_trigger ksmtuned.service
704
705 %post guest-agent
706 %systemd_reload
707
708 %preun guest-agent
709 %systemd_preun qemu-guest-agent.service
710
711 %postun guest-agent
712 %systemd_reload
713
714 %files
715 %defattr(644,root,root,755)
716
717 %files common -f %{name}.lang
718 %defattr(644,root,root,755)
719 %doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
720 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
721 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
722 %config(noreplace) %verify(not md5 mtime size) /etc/ksmtuned.conf
723 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ksm
724 %{systemdunitdir}/ksm.service
725 %{systemdunitdir}/ksmtuned.service
726 %dir %{_sysconfdir}/qemu
727 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
728 %attr(755,root,root) %{_bindir}/qemu-nbd
729 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
730 %attr(755,root,root) %{_sbindir}/ksmctl
731 %attr(755,root,root) %{_sbindir}/ksmtuned
732 %{_mandir}/man1/qemu.1*
733 %{_mandir}/man1/virtfs-proxy-helper.1*
734 %{_mandir}/man8/qemu-nbd.8*
735
736 %dir %{_datadir}/qemu
737 %{_datadir}/%{name}/keymaps
738 %{_datadir}/%{name}/qemu-icon.bmp
739 # various bios images
740 %{_datadir}/%{name}/*.aml
741 %{_datadir}/%{name}/*.bin
742 %{_datadir}/%{name}/*.rom
743 %{_datadir}/%{name}/*.dtb
744 %{_datadir}/%{name}/qemu_logo_no_text.svg
745 %{_datadir}/%{name}/openbios-ppc
746 %{_datadir}/%{name}/openbios-sparc*
747 %{_datadir}/%{name}/palcode-clipper
748 %{_datadir}/%{name}/s390-ccw.img
749
750 %files img
751 %defattr(644,root,root,755)
752 %attr(755,root,root) %{_bindir}/qemu-img
753 %{_mandir}/man1/qemu-img.1*
754
755 %files user
756 %defattr(644,root,root,755)
757 %attr(755,root,root) %{_bindir}/qemu-alpha
758 %attr(755,root,root) %{_bindir}/qemu-arm
759 %attr(755,root,root) %{_bindir}/qemu-armeb
760 %attr(755,root,root) %{_bindir}/qemu-cris
761 %attr(755,root,root) %{_bindir}/qemu-i386
762 %attr(755,root,root) %{_bindir}/qemu-io
763 %attr(755,root,root) %{_bindir}/qemu-m68k
764 %attr(755,root,root) %{_bindir}/qemu-microblaze
765 %attr(755,root,root) %{_bindir}/qemu-microblazeel
766 %attr(755,root,root) %{_bindir}/qemu-mips
767 %attr(755,root,root) %{_bindir}/qemu-mipsel
768 %attr(755,root,root) %{_bindir}/qemu-mips64
769 %attr(755,root,root) %{_bindir}/qemu-mips64el
770 %attr(755,root,root) %{_bindir}/qemu-mipsn32
771 %attr(755,root,root) %{_bindir}/qemu-mipsn32el
772 %attr(755,root,root) %{_bindir}/qemu-or32
773 %attr(755,root,root) %{_bindir}/qemu-ppc
774 %attr(755,root,root) %{_bindir}/qemu-ppc64
775 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
776 %attr(755,root,root) %{_bindir}/qemu-s390x
777 %attr(755,root,root) %{_bindir}/qemu-sh4
778 %attr(755,root,root) %{_bindir}/qemu-sh4eb
779 %attr(755,root,root) %{_bindir}/qemu-sparc
780 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
781 %attr(755,root,root) %{_bindir}/qemu-sparc64
782 %attr(755,root,root) %{_bindir}/qemu-unicore32
783 %attr(755,root,root) %{_bindir}/qemu-x86_64
784
785 %files system-alpha
786 %defattr(644,root,root,755)
787 %attr(755,root,root) %{_bindir}/qemu-system-alpha
788
789 %files system-arm
790 %defattr(644,root,root,755)
791 %attr(755,root,root) %{_bindir}/qemu-system-arm
792
793 %files system-cris
794 %defattr(644,root,root,755)
795 %attr(755,root,root) %{_bindir}/qemu-system-cris
796
797 %files system-lm32
798 %defattr(644,root,root,755)
799 %attr(755,root,root) %{_bindir}/qemu-system-lm32
800
801 %files system-m68k
802 %defattr(644,root,root,755)
803 %attr(755,root,root) %{_bindir}/qemu-system-m68k
804
805 %files system-microblaze
806 %defattr(644,root,root,755)
807 %attr(755,root,root) %{_bindir}/qemu-system-microblaze
808 %attr(755,root,root) %{_bindir}/qemu-system-microblazeel
809
810 %files system-mips
811 %defattr(644,root,root,755)
812 %attr(755,root,root) %{_bindir}/qemu-system-mips
813 %attr(755,root,root) %{_bindir}/qemu-system-mipsel
814 %attr(755,root,root) %{_bindir}/qemu-system-mips64
815 %attr(755,root,root) %{_bindir}/qemu-system-mips64el
816
817 %files system-moxie
818 %defattr(644,root,root,755)
819 %attr(755,root,root) %{_bindir}/qemu-system-moxie
820
821 %files system-or32
822 %defattr(644,root,root,755)
823 %attr(755,root,root) %{_bindir}/qemu-system-or32
824
825 %files system-ppc
826 %defattr(644,root,root,755)
827 %attr(755,root,root) %{_bindir}/qemu-system-ppc
828 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
829 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
830
831 %files system-s390x
832 %defattr(644,root,root,755)
833 %attr(755,root,root) %{_bindir}/qemu-system-s390x
834
835 %files system-sh4
836 %defattr(644,root,root,755)
837 %attr(755,root,root) %{_bindir}/qemu-system-sh4
838 %attr(755,root,root) %{_bindir}/qemu-system-sh4eb
839
840 %files system-sparc
841 %defattr(644,root,root,755)
842 %attr(755,root,root) %{_bindir}/qemu-system-sparc
843 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
844
845 %files system-unicore32
846 %defattr(644,root,root,755)
847 %attr(755,root,root) %{_bindir}/qemu-system-unicore32
848
849 %files system-x86
850 %defattr(644,root,root,755)
851 %attr(755,root,root) %{_bindir}/qemu-system-i386
852 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
853
854 %files system-xtensa
855 %defattr(644,root,root,755)
856 %attr(755,root,root) %{_bindir}/qemu-system-xtensa
857 %attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
858
859 %files guest-agent
860 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/99-qemu-guest-agent.rules
861 %{systemdunitdir}/qemu-guest-agent.service
862 %attr(755,root,root) %{_bindir}/qemu-ga
This page took 0.11975 seconds and 4 git commands to generate.