]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- create qemu user in post
[packages/qemu.git] / qemu.spec
1 # TODO:
2 # - merge missing bits from qemu-kvm
3 # - --enable-glusterfs when glusterfs 3.4 is out
4 # - qemu-system-ppc -hda ac-ppc.img says:
5 #   qemu: could not open disk image ac-ppc.img: error "Success"
6 #   qemu-0.12.2-2.x86_64.rpm - broken
7 #   qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
8 #   qemu-0.15.0-2.x86_64.rpm - qemu-system-sparc/ppc booting with -kernel, -initrd options stalls in openbios prompt
9 #   qemu-0.11.1-*.x86_64.rpm - OK
10 #
11 # Conditional build:
12 %bcond_without  sdl             # SDL UI and audio support
13 %bcond_without  opengl          # OpenGL support
14 %bcond_without  ceph            # Ceph/RBD support
15 %bcond_with     glusterfs       # GlusterFS backend
16 %bcond_without  spice           # SPICE support
17 %bcond_with     esd             # EsounD audio support
18 %bcond_without  oss             # OSS audio support
19 %bcond_without  pulseaudio      # PulseAudio audio support
20 %bcond_without  xen             # Xen backend driver support
21
22 Summary:        QEMU CPU Emulator
23 Summary(pl.UTF-8):      QEMU - emulator procesora
24 Name:           qemu
25 Version:        1.3.0
26 Release:        0.1
27 License:        GPL v2+
28 Group:          Applications/Emulators
29 Source0:        http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
30 # Source0-md5:  a4030ddd2ba324152a97d65d3c0b247d
31 Patch0:         %{name}-cflags.patch
32 Patch1:         vgabios-widescreens.patch
33 Patch2:         %{name}-whitelist.patch
34 Patch3:         %{name}-system-libcacard.patch
35 # Proof of concept, for reference, do not remove
36 Patch4:         %{name}-kde_virtual_workspaces_hack.patch
37 URL:            http://www.qemu-project.org/
38 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
39 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
40 BuildRequires:  alsa-lib-devel
41 BuildRequires:  bcc
42 BuildRequires:  bluez-libs-devel
43 BuildRequires:  brlapi-devel
44 %{?with_ceph:BuildRequires:     ceph-devel}
45 BuildRequires:  curl-devel
46 BuildRequires:  cyrus-sasl-devel >= 2
47 %{?with_esd:BuildRequires:      esound-devel}
48 BuildRequires:  glib2-devel >= 1:2.12
49 %{?with_glusterfs:BuildRequires:        glusterfs-devel >= 3.4}
50 BuildRequires:  gnutls-devel
51 BuildRequires:  libaio-devel
52 BuildRequires:  libcacard-devel
53 BuildRequires:  libcap-devel
54 BuildRequires:  libcap-ng-devel
55 BuildRequires:  libfdt-devel
56 BuildRequires:  libiscsi-devel
57 BuildRequires:  libjpeg-devel
58 BuildRequires:  libpng-devel
59 BuildRequires:  libseccomp-devel
60 BuildRequires:  libuuid-devel
61 BuildRequires:  ncurses-devel
62 BuildRequires:  nss-devel >= 3.12.8
63 BuildRequires:  perl-Encode
64 BuildRequires:  perl-tools-pod
65 BuildRequires:  pkgconfig
66 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
67 BuildRequires:  sed >= 4.0
68 %if %{with spice}
69 BuildRequires:  spice-protocol >= 0.12.0
70 BuildRequires:  spice-server-devel >= 0.12.0
71 %endif
72 BuildRequires:  texi2html
73 BuildRequires:  texinfo
74 BuildRequires:  usbredir-devel >= 0.5.3
75 BuildRequires:  vde2-devel
76 BuildRequires:  which
77 %{?with_xen:BuildRequires:      xen-devel >= 3.4}
78 BuildRequires:  xfsprogs-devel
79 BuildRequires:  xorg-lib-libX11-devel
80 BuildRequires:  zlib-devel
81 Requires:       %{name}-img = %{version}-%{release}
82 Requires:       %{name}-system-alpha = %{version}-%{release}
83 Requires:       %{name}-system-arm = %{version}-%{release}
84 Requires:       %{name}-system-cris = %{version}-%{release}
85 Requires:       %{name}-system-lm32 = %{version}-%{release}
86 Requires:       %{name}-system-m68k = %{version}-%{release}
87 Requires:       %{name}-system-microblaze = %{version}-%{release}
88 Requires:       %{name}-system-mips = %{version}-%{release}
89 Requires:       %{name}-system-or32 = %{version}-%{release}
90 Requires:       %{name}-system-ppc = %{version}-%{release}
91 Requires:       %{name}-system-s390x = %{version}-%{release}
92 Requires:       %{name}-system-sh4 = %{version}-%{release}
93 Requires:       %{name}-system-sparc = %{version}-%{release}
94 Requires:       %{name}-system-unicore32 = %{version}-%{release}
95 Requires:       %{name}-system-x86 = %{version}-%{release}
96 Requires:       %{name}-system-xtensa = %{version}-%{release}
97 Requires:       %{name}-user = %{version}-%{release}
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %define systempkg_req \
101 Requires:       SDL >= 1.2.1 \
102 Requires:       usbredir >= 0.5.3
103
104 # some PPC/SPARC boot image in ELF format
105 %define         _noautostrip    .*%{_datadir}/qemu/.*-.*
106
107 %description
108 QEMU is a FAST! processor emulator. By using dynamic translation it
109 achieves a reasonnable speed while being easy to port on new host
110 CPUs. QEMU has two operating modes:
111
112 - User mode emulation. In this mode, QEMU can launch Linux processes
113   compiled for one CPU on another CPU. Linux system calls are converted
114   because of endianness and 32/64 bit mismatches. Wine (Windows
115   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
116
117 - Full system emulation. In this mode, QEMU emulates a full system,
118   including a processor and various peripherials. It can also be used to
119   provide virtual hosting of several virtual PC on a single server.
120
121 %description -l pl.UTF-8
122 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
123 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
124 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
125
126 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
127   procesy linuksowe skompilowane dla jednego procesora na innym
128   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
129   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
130   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
131   cele QEMU.
132
133 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
134   włączając w to procesor i różne urządzenia peryferyjne. Może być także
135   używane do wirtualnego hostowania kilku wirtualnych pecetów na
136   pojedynczym serwerze.
137
138 %package common
139 Summary:        QEMU common files needed by all QEMU targets
140 Summary(pl.UTF-8):      Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
141 Group:          Development/Tools
142 Requires:       glib2 >= 1:2.12
143 Conflicts:      qemu < 1.0-2
144
145 %description common
146 QEMU is a generic and open source processor emulator which achieves a
147 good emulation speed by using dynamic translation.
148
149 This package provides the common files needed by all QEMU targets.
150
151 %description common -l pl.UTF-8
152 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
153 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
154
155 Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
156 środowiska QEMU.
157
158 %package img
159 Summary:        QEMU command line tool for manipulating disk images
160 Summary(pl.UTF-8):      Narzędzie QEMU do operacji na obrazach dysków
161 Group:          Development/Tools
162 Conflicts:      qemu < 1.0-2
163
164 %description img
165 This package provides a command line tool for manipulating disk
166 images.
167
168 %description img -l pl.UTF-8
169 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
170 na obrazach dysków.
171
172 %package user
173 Summary:        QEMU user mode emulation of qemu targets
174 Summary(pl.UTF-8):      QEMU - emulacja trybu użytkownika środowisk qemu
175 Group:          Development/Tools
176 Requires:       %{name}-common = %{version}-%{release}
177
178 %description user
179 QEMU is a generic and open source processor emulator which achieves a
180 good emulation speed by using dynamic translation.
181
182 This package provides the user mode emulation of QEMU targets.
183
184 %description user -l pl.UTF-8
185 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
186 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
187
188 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
189
190 %package system-alpha
191 Summary:        QEMU system emulator for Alpha
192 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Alpha
193 Group:          Development/Tools
194 Requires:       %{name}-common = %{version}-%{release}
195 %systempkg_req
196
197 %description system-alpha
198 QEMU is a generic and open source processor emulator which achieves a
199 good emulation speed by using dynamic translation.
200
201 This package provides the system emulator with Alpha CPU.
202
203 %description system-alpha -l pl.UTF-8
204 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
205 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
206
207 Ten pakiet zawiera emulator systemu z procesorem Alpha.
208
209 %package system-arm
210 Summary:        QEMU system emulator for ARM
211 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem ARM
212 Group:          Development/Tools
213 Requires:       %{name}-common = %{version}-%{release}
214 %systempkg_req
215
216 %description system-arm
217 QEMU is a generic and open source processor emulator which achieves a
218 good emulation speed by using dynamic translation.
219
220 This package provides the system emulator for ARM.
221
222 %description system-arm -l pl.UTF-8
223 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
224 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
225
226 Ten pakiet zawiera emulator systemu z procesorem ARM.
227
228 %package system-cris
229 Summary:        QEMU system emulator for CRIS
230 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem CRIS
231 Group:          Development/Tools
232 Requires:       %{name}-common = %{version}-%{release}
233 %systempkg_req
234
235 %description system-cris
236 QEMU is a generic and open source processor emulator which achieves a
237 good emulation speed by using dynamic translation.
238
239 This package provides the system emulator with CRIS CPU.
240
241 %description system-cris -l pl.UTF-8
242 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
243 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
244
245 Ten pakiet zawiera emulator systemu z procesorem CRIS.
246
247 %package system-lm32
248 Summary:        QEMU system emulator for LM32
249 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem LM32
250 Group:          Development/Tools
251 Requires:       %{name}-common = %{version}-%{release}
252 %systempkg_req
253
254 %description system-lm32
255 QEMU is a generic and open source processor emulator which achieves a
256 good emulation speed by using dynamic translation.
257
258 This package provides the system emulator with LM32 CPU.
259
260 %description system-lm32 -l pl.UTF-8
261 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
262 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
263
264 Ten pakiet zawiera emulator systemu z procesorem LM32.
265
266 %package system-m68k
267 Summary:        QEMU system emulator for m68k
268 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem m68k
269 Group:          Development/Tools
270 Requires:       %{name}-common = %{version}-%{release}
271 %systempkg_req
272
273 %description system-m68k
274 QEMU is a generic and open source processor emulator which achieves a
275 good emulation speed by using dynamic translation.
276
277 This package provides the system emulator with m68k CPU.
278
279 %description system-m68k -l pl.UTF-8
280 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
281 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
282
283 Ten pakiet zawiera emulator systemu z procesorem m68k.
284
285 %package system-microblaze
286 Summary:        QEMU system emulator for MicroBlaze
287 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MicroBlaze
288 Group:          Development/Tools
289 Requires:       %{name}-common = %{version}-%{release}
290 %systempkg_req
291
292 %description system-microblaze
293 QEMU is a generic and open source processor emulator which achieves a
294 good emulation speed by using dynamic translation.
295
296 This package provides the system emulator with MicroBlaze CPU.
297
298 %description system-microblaze -l pl.UTF-8
299 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
300 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
301
302 Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
303
304 %package system-mips
305 Summary:        QEMU system emulator for MIPS
306 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MIPS
307 Group:          Development/Tools
308 Requires:       %{name}-common = %{version}-%{release}
309 %systempkg_req
310
311 %description system-mips
312 QEMU is a generic and open source processor emulator which achieves a
313 good emulation speed by using dynamic translation.
314
315 This package provides the system emulator with MIPS CPU.
316
317 %description system-mips -l pl.UTF-8
318 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
319 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
320
321 Ten pakiet zawiera emulator systemu z procesorem MIPS.
322
323 %package system-or32
324 Summary:        QEMU system emulator for OpenRISC
325 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem OpenRISC
326 Group:          Development/Tools
327 Requires:       %{name}-common = %{version}-%{release}
328 %systempkg_req
329
330 %description system-or32
331 QEMU is a generic and open source processor emulator which achieves a
332 good emulation speed by using dynamic translation.
333
334 This package provides the system emulator with OpenRISC CPU.
335
336 %description system-or32 -l pl.UTF-8
337 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
338 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
339
340 Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
341
342 %package system-ppc
343 Summary:        QEMU system emulator for PowerPC
344 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem PowerPC
345 Group:          Development/Tools
346 Requires:       %{name}-common = %{version}-%{release}
347 %systempkg_req
348
349 %description system-ppc
350 QEMU is a generic and open source processor emulator which achieves a
351 good emulation speed by using dynamic translation.
352
353 This package provides the system emulator with PowerPC CPU.
354
355 %description system-ppc -l pl.UTF-8
356 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
357 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
358
359 Ten pakiet zawiera emulator systemu z procesorem PowerPC.
360
361 %package system-s390x
362 Summary:        QEMU system emulator for S390
363 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem S390
364 Group:          Development/Tools
365 Requires:       %{name}-common = %{version}-%{release}
366 %systempkg_req
367
368 %description system-s390x
369 QEMU is a generic and open source processor emulator which achieves a
370 good emulation speed by using dynamic translation.
371
372 This package provides the system emulator with S390 CPU.
373
374 %description system-s390x -l pl.UTF-8
375 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
376 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
377
378 Ten pakiet zawiera emulator systemu z procesorem S390.
379
380 %package system-sh4
381 Summary:        QEMU system emulator for SH4
382 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SH4
383 Group:          Development/Tools
384 Requires:       %{name}-common = %{version}-%{release}
385 %systempkg_req
386
387 %description system-sh4
388 QEMU is a generic and open source processor emulator which achieves a
389 good emulation speed by using dynamic translation.
390
391 This package provides the system emulator with SH4 CPU.
392
393 %description system-sh4 -l pl.UTF-8
394 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
395 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
396
397 Ten pakiet zawiera emulator systemu z procesorem SH4.
398
399 %package system-sparc
400 Summary:        QEMU system emulator for SPARC
401 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SPARC
402 Group:          Development/Tools
403 Requires:       %{name}-common = %{version}-%{release}
404 %systempkg_req
405
406 %description system-sparc
407 QEMU is a generic and open source processor emulator which achieves a
408 good emulation speed by using dynamic translation.
409
410 This package provides the system emulator with SPARC/SPARC64 CPU.
411
412 %description system-sparc -l pl.UTF-8
413 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
414 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
415
416 Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
417
418 %package system-unicore32
419 Summary:        QEMU system emulator for UniCore32
420 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem UniCore32
421 Group:          Development/Tools
422 Requires:       %{name}-common = %{version}-%{release}
423 %systempkg_req
424
425 %description system-unicore32
426 QEMU is a generic and open source processor emulator which achieves a
427 good emulation speed by using dynamic translation.
428
429 This package provides the system emulator with UniCore32 CPU.
430
431 %description system-unicore32 -l pl.UTF-8
432 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
433 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
434
435 Ten pakiet zawiera emulator systemu z procesorem UniCore32.
436
437 %package system-x86
438 Summary:        QEMU system emulator for x86
439 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem x86
440 Group:          Development/Tools
441 Requires:       %{name}-common = %{version}-%{release}
442 %systempkg_req
443
444 %description system-x86
445 QEMU is a generic and open source processor emulator which achieves a
446 good emulation speed by using dynamic translation.
447
448 %description system-x86 -l pl.UTF-8
449 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
450 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
451
452 %package system-xtensa
453 Summary:        QEMU system emulator for Xtensa
454 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Xtensa
455 Group:          Development/Tools
456 Requires:       %{name}-common = %{version}-%{release}
457 %systempkg_req
458
459 %description system-xtensa
460 QEMU is a generic and open source processor emulator which achieves a
461 good emulation speed by using dynamic translation.
462
463 This package provides the system emulator with Xtensa CPU.
464
465 %description system-xtensa -l pl.UTF-8
466 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
467 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
468
469 Ten pakiet zawiera emulator systemu z procesorem Xtensa.
470
471 %prep
472 %setup -q
473 %patch0 -p1
474 %patch1 -p1
475 %patch2 -p0
476 %patch3 -p1
477
478 %{__mv} libcacard libcacard-use-system-lib
479
480 # workaround for conflict with alsa/error.h
481 ln -s ../error.h qapi/error.h
482
483 %build
484 ./configure \
485         --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
486         --extra-ldflags="%{rpmldflags}" \
487         --prefix=%{_prefix} \
488         --sysconfdir=%{_sysconfdir} \
489         --cc="%{__cc}" \
490         --host-cc="%{__cc}" \
491         --disable-strip \
492         --enable-attr \
493         --enable-bluez \
494         --enable-brlapi \
495         --enable-cap-ng \
496         --enable-curl \
497         --enable-curses \
498         --enable-docs \
499         --enable-fdt \
500         %{__enable_disable glusterfs} \
501         --enable-libiscsi \
502         --enable-mixemu \
503         %{__enable_disable opengl} \
504         %{__enable_disable ceph rbd} \
505         %{__enable_disable sdl} \
506         --enable-seccomp \
507         %{__enable_disable spice} \
508         --enable-smartcard \
509         --enable-smartcard-nss \
510         --enable-usb-redir \
511         --enable-uuid \
512         --enable-vde \
513         --enable-virtfs \
514         --enable-vnc-jpeg \
515         --enable-vnc-png \
516         --enable-vnc-sasl \
517         --enable-vnc-tls \
518         %{__enable_disable xen} \
519         --audio-card-list="ac97,es1370,sb16,cs4231a,adlib,gus,hda" \
520         --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
521         --interp-prefix=%{_libdir}/qemu/lib-%%M
522 # note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
523 # --libexecdir in configure is nop
524 %{__make} \
525         V=1 \
526         CONFIG_QEMU_HELPERDIR="%{_libdir}"
527
528 # rebuild patched vesa tables with additional widescreen modes.
529 %{__make} -C roms/vgabios stdvga-bios
530
531 %install
532 rm -rf $RPM_BUILD_ROOT
533
534 %{__make} install \
535         DESTDIR=$RPM_BUILD_ROOT \
536         libexecdir=%{_libdir}
537
538 install -d $RPM_BUILD_ROOT%{_sysconfdir}
539 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
540 #!/bin/sh
541
542 EOF
543
544 # already packaged
545 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
546 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
547
548 # install patched vesa tables with additional widescreen modes.
549 cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
550
551 %clean
552 rm -rf $RPM_BUILD_ROOT
553
554 %pre common
555 %groupadd -g 276 qemu
556 %useradd -u 276 -g qemu -c "QEMU User" qemu
557
558 %postun common
559 if [ "$1" = "0" ]; then
560         %userremove qemu
561         %groupremove qemu
562 fi
563
564 %files
565 %defattr(644,root,root,755)
566
567 %files common
568 %defattr(644,root,root,755)
569 %doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
570 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
571 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
572 %dir %{_sysconfdir}/qemu
573 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
574 %attr(755,root,root) %{_bindir}/qemu-nbd
575 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
576 %{_mandir}/man1/qemu.1*
577 %{_mandir}/man1/virtfs-proxy-helper.1*
578 %{_mandir}/man8/qemu-nbd.8*
579
580 %dir %{_datadir}/qemu
581 %{_datadir}/%{name}/keymaps
582 %{_datadir}/%{name}/qemu-icon.bmp
583 # various bios images
584 %{_datadir}/%{name}/*.bin
585 %{_datadir}/%{name}/*.rom
586 %{_datadir}/%{name}/*.dtb
587 %{_datadir}/%{name}/openbios-ppc
588 %{_datadir}/%{name}/openbios-sparc*
589 %{_datadir}/%{name}/palcode-clipper
590
591 %files img
592 %defattr(644,root,root,755)
593 %attr(755,root,root) %{_bindir}/qemu-img
594 %{_mandir}/man1/qemu-img.1*
595
596 %files user
597 %defattr(644,root,root,755)
598 %attr(755,root,root) %{_bindir}/qemu-alpha
599 %attr(755,root,root) %{_bindir}/qemu-arm
600 %attr(755,root,root) %{_bindir}/qemu-armeb
601 %attr(755,root,root) %{_bindir}/qemu-cris
602 %attr(755,root,root) %{_bindir}/qemu-ga
603 %attr(755,root,root) %{_bindir}/qemu-i386
604 %attr(755,root,root) %{_bindir}/qemu-io
605 %attr(755,root,root) %{_bindir}/qemu-m68k
606 %attr(755,root,root) %{_bindir}/qemu-microblaze
607 %attr(755,root,root) %{_bindir}/qemu-microblazeel
608 %attr(755,root,root) %{_bindir}/qemu-mips
609 %attr(755,root,root) %{_bindir}/qemu-mipsel
610 %attr(755,root,root) %{_bindir}/qemu-or32
611 %attr(755,root,root) %{_bindir}/qemu-ppc
612 %attr(755,root,root) %{_bindir}/qemu-ppc64
613 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
614 %attr(755,root,root) %{_bindir}/qemu-s390x
615 %attr(755,root,root) %{_bindir}/qemu-sh4
616 %attr(755,root,root) %{_bindir}/qemu-sh4eb
617 %attr(755,root,root) %{_bindir}/qemu-sparc
618 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
619 %attr(755,root,root) %{_bindir}/qemu-sparc64
620 %attr(755,root,root) %{_bindir}/qemu-unicore32
621 %attr(755,root,root) %{_bindir}/qemu-x86_64
622
623 %files system-alpha
624 %defattr(644,root,root,755)
625 %attr(755,root,root) %{_bindir}/qemu-system-alpha
626
627 %files system-arm
628 %defattr(644,root,root,755)
629 %attr(755,root,root) %{_bindir}/qemu-system-arm
630
631 %files system-cris
632 %defattr(644,root,root,755)
633 %attr(755,root,root) %{_bindir}/qemu-system-cris
634
635 %files system-lm32
636 %defattr(644,root,root,755)
637 %attr(755,root,root) %{_bindir}/qemu-system-lm32
638
639 %files system-m68k
640 %defattr(644,root,root,755)
641 %attr(755,root,root) %{_bindir}/qemu-system-m68k
642
643 %files system-microblaze
644 %defattr(644,root,root,755)
645 %attr(755,root,root) %{_bindir}/qemu-system-microblaze
646 %attr(755,root,root) %{_bindir}/qemu-system-microblazeel
647
648 %files system-mips
649 %defattr(644,root,root,755)
650 %attr(755,root,root) %{_bindir}/qemu-system-mips
651 %attr(755,root,root) %{_bindir}/qemu-system-mipsel
652 %attr(755,root,root) %{_bindir}/qemu-system-mips64
653 %attr(755,root,root) %{_bindir}/qemu-system-mips64el
654
655 %files system-or32
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_bindir}/qemu-system-or32
658
659 %files system-ppc
660 %defattr(644,root,root,755)
661 %attr(755,root,root) %{_bindir}/qemu-system-ppc
662 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
663 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
664
665 %files system-s390x
666 %defattr(644,root,root,755)
667 %attr(755,root,root) %{_bindir}/qemu-system-s390x
668
669 %files system-sh4
670 %defattr(644,root,root,755)
671 %attr(755,root,root) %{_bindir}/qemu-system-sh4
672 %attr(755,root,root) %{_bindir}/qemu-system-sh4eb
673
674 %files system-sparc
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_bindir}/qemu-system-sparc
677 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
678
679 %files system-unicore32
680 %defattr(644,root,root,755)
681 %attr(755,root,root) %{_bindir}/qemu-system-unicore32
682
683 %files system-x86
684 %defattr(644,root,root,755)
685 %attr(755,root,root) %{_bindir}/qemu-system-i386
686 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
687
688 %files system-xtensa
689 %defattr(644,root,root,755)
690 %attr(755,root,root) %{_bindir}/qemu-system-xtensa
691 %attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
This page took 0.094127 seconds and 4 git commands to generate.