]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- binfmt definitions for foreign qemu-lated binaries (from qemu-kvm package)
[packages/qemu.git] / qemu.spec
1 # TODO:
2 # - merge missing bits from qemu-kvm
3 #
4 # Conditional build:
5 %bcond_without  sdl             # SDL UI and audio support
6 %bcond_without  glx             # OpenGL/GLX support
7 %bcond_without  ceph            # Ceph/RBD support
8 %bcond_without  glusterfs       # GlusterFS backend
9 %bcond_without  rdma            # RDMA-based migration support
10 %bcond_with     gtk2            # GTK+ 2.x instead of 3.x
11 %bcond_without  spice           # SPICE support
12 %bcond_with     esd             # EsounD audio support
13 %bcond_without  oss             # OSS audio support
14 %bcond_without  pulseaudio      # PulseAudio audio support
15 %bcond_without  xen             # Xen backend driver support
16
17 Summary:        QEMU CPU Emulator
18 Summary(pl.UTF-8):      QEMU - emulator procesora
19 Name:           qemu
20 Version:        1.6.1
21 Release:        3
22 License:        GPL v2+
23 Group:          Applications/Emulators
24 Source0:        http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
25 # Source0-md5:  3a897d722457c5a895cd6ac79a28fda0
26 Source2:        qemu.binfmt
27 # Loads kvm kernel modules at boot
28 Source3:        kvm-modules-load.conf
29 # Creates /dev/kvm
30 Source4:        80-kvm.rules
31 # KSM control scripts
32 Source5:        ksm.service
33 Source6:        ksm.sysconfig
34 Source7:        ksmctl.c
35 Source8:        ksmtuned.service
36 Source9:        ksmtuned
37 Source10:       ksmtuned.conf
38 Source11:       qemu-guest-agent.service
39 Source12:       99-qemu-guest-agent.rules
40 Patch0:         %{name}-cflags.patch
41 Patch1:         vgabios-widescreens.patch
42 Patch2:         %{name}-whitelist.patch
43 Patch3:         %{name}-system-libcacard.patch
44 # Proof of concept, for reference, do not remove
45 Patch4:         %{name}-kde_virtual_workspaces_hack.patch
46 URL:            http://www.qemu-project.org/
47 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
48 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
49 BuildRequires:  alsa-lib-devel
50 BuildRequires:  bcc
51 BuildRequires:  bluez-libs-devel
52 BuildRequires:  brlapi-devel
53 %{?with_ceph:BuildRequires:     ceph-devel}
54 BuildRequires:  curl-devel
55 BuildRequires:  cyrus-sasl-devel >= 2
56 %{?with_esd:BuildRequires:      esound-devel}
57 BuildRequires:  glib2-devel >= 1:2.12
58 %{?with_glusterfs:BuildRequires:        glusterfs-devel >= 3.4}
59 BuildRequires:  gnutls-devel
60 BuildRequires:  libaio-devel
61 BuildRequires:  libcacard-devel
62 BuildRequires:  libcap-devel
63 BuildRequires:  libcap-ng-devel
64 BuildRequires:  libfdt-devel
65 %{?with_rdma:BuildRequires:     libibverbs-devel}
66 BuildRequires:  libiscsi-devel
67 BuildRequires:  libjpeg-devel
68 BuildRequires:  libpng-devel
69 %{?with_rdma:BuildRequires:     librdmacm-devel}
70 BuildRequires:  libseccomp-devel
71 BuildRequires:  libssh2-devel >= 1.2.8
72 # for usb passthrough, when available
73 #BuildRequires: libusb-devel >= 1.0.13
74 BuildRequires:  libuuid-devel
75 BuildRequires:  ncurses-devel
76 BuildRequires:  nss-devel >= 3.12.8
77 BuildRequires:  perl-Encode
78 BuildRequires:  perl-tools-pod
79 BuildRequires:  pkgconfig
80 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
81 BuildRequires:  rpmbuild(macros) >= 1.202
82 BuildRequires:  sed >= 4.0
83 %if %{with spice}
84 BuildRequires:  spice-protocol >= 0.12.0
85 BuildRequires:  spice-server-devel >= 0.12.0
86 %endif
87 BuildRequires:  texi2html
88 BuildRequires:  texinfo
89 BuildRequires:  usbredir-devel >= 0.6
90 BuildRequires:  vde2-devel
91 BuildRequires:  which
92 %{?with_xen:BuildRequires:      xen-devel >= 3.4}
93 BuildRequires:  xfsprogs-devel
94 BuildRequires:  xorg-lib-libX11-devel
95 BuildRequires:  zlib-devel
96 %if %{with gtk2}
97 BuildRequires:  gtk+2-devel >= 2:2.18.0
98 BuildRequires:  vte0-devel >= 0.24.0
99 %else
100 BuildRequires:  gtk+3-devel >= 3.0.0
101 BuildRequires:  vte-devel >= 0.32.0
102 %endif
103 Requires:       %{name}-img = %{version}-%{release}
104 Requires:       %{name}-system-alpha = %{version}-%{release}
105 Requires:       %{name}-system-arm = %{version}-%{release}
106 Requires:       %{name}-system-cris = %{version}-%{release}
107 Requires:       %{name}-system-lm32 = %{version}-%{release}
108 Requires:       %{name}-system-m68k = %{version}-%{release}
109 Requires:       %{name}-system-microblaze = %{version}-%{release}
110 Requires:       %{name}-system-mips = %{version}-%{release}
111 Requires:       %{name}-system-moxie = %{version}-%{release}
112 Requires:       %{name}-system-or32 = %{version}-%{release}
113 Requires:       %{name}-system-ppc = %{version}-%{release}
114 Requires:       %{name}-system-s390x = %{version}-%{release}
115 Requires:       %{name}-system-sh4 = %{version}-%{release}
116 Requires:       %{name}-system-sparc = %{version}-%{release}
117 Requires:       %{name}-system-unicore32 = %{version}-%{release}
118 Requires:       %{name}-system-x86 = %{version}-%{release}
119 Requires:       %{name}-system-xtensa = %{version}-%{release}
120 Requires:       %{name}-user = %{version}-%{release}
121 Obsoletes:      qemu-kvm
122 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
123
124 %define systempkg_req \
125 Requires:       SDL >= 1.2.1 \
126 Requires:       usbredir >= 0.6 \
127 %if %{with gtk2} \
128 Requires:       gtk+2 >= 2:2.18.0 \
129 Requires:       vte0 >= 0.24.0 \
130 %else \
131 Requires:       gtk+3 >= 3.0.0 \
132 Requires:       vte >= 0.32.0 \
133 %endif
134
135 # some PPC/SPARC boot image in ELF format
136 %define         _noautostrip    .*%{_datadir}/qemu/.*-.*
137
138 %description
139 QEMU is a FAST! processor emulator. By using dynamic translation it
140 achieves a reasonnable speed while being easy to port on new host
141 CPUs. QEMU has two operating modes:
142
143 - User mode emulation. In this mode, QEMU can launch Linux processes
144   compiled for one CPU on another CPU. Linux system calls are converted
145   because of endianness and 32/64 bit mismatches. Wine (Windows
146   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
147
148 - Full system emulation. In this mode, QEMU emulates a full system,
149   including a processor and various peripherials. It can also be used to
150   provide virtual hosting of several virtual PC on a single server.
151
152 %description -l pl.UTF-8
153 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
154 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
155 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
156
157 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
158   procesy linuksowe skompilowane dla jednego procesora na innym
159   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
160   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
161   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
162   cele QEMU.
163
164 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
165   włączając w to procesor i różne urządzenia peryferyjne. Może być także
166   używane do wirtualnego hostowania kilku wirtualnych pecetów na
167   pojedynczym serwerze.
168
169 %package common
170 Summary:        QEMU common files needed by all QEMU targets
171 Summary(pl.UTF-8):      Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
172 Group:          Development/Tools
173 Requires(post,preun,postun):    systemd-units >= 38
174 Requires(postun):       /usr/sbin/groupdel
175 Requires(postun):       /usr/sbin/userdel
176 Requires(pre):  /bin/id
177 Requires(pre):  /usr/bin/getgid
178 Requires(pre):  /usr/sbin/groupadd
179 Requires(pre):  /usr/sbin/useradd
180 Requires:       glib2 >= 1:2.12
181 Requires:       libssh2 >= 1.2.8
182 Requires:       systemd-units >= 38
183 Provides:       group(qemu)
184 Provides:       user(qemu)
185 Obsoletes:      qemu-kvm-common
186 Conflicts:      qemu < 1.0-2
187
188 %description common
189 QEMU is a generic and open source processor emulator which achieves a
190 good emulation speed by using dynamic translation.
191
192 This package provides the common files needed by all QEMU targets.
193
194 %description common -l pl.UTF-8
195 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
196 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
197
198 Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
199 środowiska QEMU.
200
201 %package img
202 Summary:        QEMU command line tool for manipulating disk images
203 Summary(pl.UTF-8):      Narzędzie QEMU do operacji na obrazach dysków
204 Group:          Development/Tools
205 Conflicts:      qemu < 1.0-2
206 Obsoletes:      qemu-kvm-img
207
208 %description img
209 This package provides a command line tool for manipulating disk
210 images.
211
212 %description img -l pl.UTF-8
213 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
214 na obrazach dysków.
215
216 %package user
217 Summary:        QEMU user mode emulation of qemu targets
218 Summary(pl.UTF-8):      QEMU - emulacja trybu użytkownika środowisk qemu
219 Group:          Development/Tools
220 Requires:       %{name}-common = %{version}-%{release}
221 Obsoletes:      qemu-kvm-user
222
223 %description user
224 QEMU is a generic and open source processor emulator which achieves a
225 good emulation speed by using dynamic translation.
226
227 This package provides the user mode emulation of QEMU targets.
228
229 %description user -l pl.UTF-8
230 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
231 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
232
233 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
234
235 %package system-alpha
236 Summary:        QEMU system emulator for Alpha
237 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Alpha
238 Group:          Development/Tools
239 Requires:       %{name}-common = %{version}-%{release}
240 %systempkg_req
241 Obsoletes:      qemu-kvm-system-alpha
242
243 %description system-alpha
244 QEMU is a generic and open source processor emulator which achieves a
245 good emulation speed by using dynamic translation.
246
247 This package provides the system emulator with Alpha CPU.
248
249 %description system-alpha -l pl.UTF-8
250 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
251 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
252
253 Ten pakiet zawiera emulator systemu z procesorem Alpha.
254
255 %package system-arm
256 Summary:        QEMU system emulator for ARM
257 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem ARM
258 Group:          Development/Tools
259 Requires:       %{name}-common = %{version}-%{release}
260 %systempkg_req
261 Obsoletes:      qemu-kvm-system-arm
262
263 %description system-arm
264 QEMU is a generic and open source processor emulator which achieves a
265 good emulation speed by using dynamic translation.
266
267 This package provides the system emulator for ARM.
268
269 %description system-arm -l pl.UTF-8
270 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
271 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
272
273 Ten pakiet zawiera emulator systemu z procesorem ARM.
274
275 %package system-cris
276 Summary:        QEMU system emulator for CRIS
277 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem CRIS
278 Group:          Development/Tools
279 Requires:       %{name}-common = %{version}-%{release}
280 %systempkg_req
281 Obsoletes:      qemu-kvm-system-cris
282
283 %description system-cris
284 QEMU is a generic and open source processor emulator which achieves a
285 good emulation speed by using dynamic translation.
286
287 This package provides the system emulator with CRIS CPU.
288
289 %description system-cris -l pl.UTF-8
290 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
291 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
292
293 Ten pakiet zawiera emulator systemu z procesorem CRIS.
294
295 %package system-lm32
296 Summary:        QEMU system emulator for LM32
297 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem LM32
298 Group:          Development/Tools
299 Requires:       %{name}-common = %{version}-%{release}
300 %systempkg_req
301 Obsoletes:      qemu-kvm-system-lm32
302
303 %description system-lm32
304 QEMU is a generic and open source processor emulator which achieves a
305 good emulation speed by using dynamic translation.
306
307 This package provides the system emulator with LM32 CPU.
308
309 %description system-lm32 -l pl.UTF-8
310 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
311 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
312
313 Ten pakiet zawiera emulator systemu z procesorem LM32.
314
315 %package system-m68k
316 Summary:        QEMU system emulator for m68k
317 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem m68k
318 Group:          Development/Tools
319 Requires:       %{name}-common = %{version}-%{release}
320 %systempkg_req
321 Obsoletes:      qemu-kvm-system-m68k
322
323 %description system-m68k
324 QEMU is a generic and open source processor emulator which achieves a
325 good emulation speed by using dynamic translation.
326
327 This package provides the system emulator with m68k CPU.
328
329 %description system-m68k -l pl.UTF-8
330 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
331 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
332
333 Ten pakiet zawiera emulator systemu z procesorem m68k.
334
335 %package system-microblaze
336 Summary:        QEMU system emulator for MicroBlaze
337 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MicroBlaze
338 Group:          Development/Tools
339 Requires:       %{name}-common = %{version}-%{release}
340 %systempkg_req
341 Obsoletes:      qemu-kvm-system-microblaze
342
343 %description system-microblaze
344 QEMU is a generic and open source processor emulator which achieves a
345 good emulation speed by using dynamic translation.
346
347 This package provides the system emulator with MicroBlaze CPU.
348
349 %description system-microblaze -l pl.UTF-8
350 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
351 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
352
353 Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
354
355 %package system-mips
356 Summary:        QEMU system emulator for MIPS
357 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MIPS
358 Group:          Development/Tools
359 Requires:       %{name}-common = %{version}-%{release}
360 %systempkg_req
361 Obsoletes:      qemu-kvm-system-mips
362
363 %description system-mips
364 QEMU is a generic and open source processor emulator which achieves a
365 good emulation speed by using dynamic translation.
366
367 This package provides the system emulator with MIPS CPU.
368
369 %description system-mips -l pl.UTF-8
370 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
371 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
372
373 Ten pakiet zawiera emulator systemu z procesorem MIPS.
374
375 %package system-moxie
376 Summary:        QEMU system emulator for Moxie
377 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Moxie
378 Group:          Development/Tools
379 Requires:       %{name}-common = %{version}-%{release}
380 %systempkg_req
381
382 %description system-moxie
383 QEMU is a generic and open source processor emulator which achieves a
384 good emulation speed by using dynamic translation.
385
386 This package provides the system emulator with Moxie CPU.
387
388 %description system-moxie -l pl.UTF-8
389 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
390 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
391
392 Ten pakiet zawiera emulator systemu z procesorem Moxie.
393
394 %package system-or32
395 Summary:        QEMU system emulator for OpenRISC
396 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem OpenRISC
397 Group:          Development/Tools
398 Requires:       %{name}-common = %{version}-%{release}
399 %systempkg_req
400 Obsoletes:      qemu-kvm-system-or32
401
402 %description system-or32
403 QEMU is a generic and open source processor emulator which achieves a
404 good emulation speed by using dynamic translation.
405
406 This package provides the system emulator with OpenRISC CPU.
407
408 %description system-or32 -l pl.UTF-8
409 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
410 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
411
412 Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
413
414 %package system-ppc
415 Summary:        QEMU system emulator for PowerPC
416 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem PowerPC
417 Group:          Development/Tools
418 Requires:       %{name}-common = %{version}-%{release}
419 %systempkg_req
420 Obsoletes:      qemu-kvm-system-ppc
421
422 %description system-ppc
423 QEMU is a generic and open source processor emulator which achieves a
424 good emulation speed by using dynamic translation.
425
426 This package provides the system emulator with PowerPC CPU.
427
428 %description system-ppc -l pl.UTF-8
429 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
430 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
431
432 Ten pakiet zawiera emulator systemu z procesorem PowerPC.
433
434 %package system-s390x
435 Summary:        QEMU system emulator for S390
436 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem S390
437 Group:          Development/Tools
438 Requires:       %{name}-common = %{version}-%{release}
439 %systempkg_req
440 Obsoletes:      qemu-kvm-system-s390x
441
442 %description system-s390x
443 QEMU is a generic and open source processor emulator which achieves a
444 good emulation speed by using dynamic translation.
445
446 This package provides the system emulator with S390 CPU.
447
448 %description system-s390x -l pl.UTF-8
449 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
450 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
451
452 Ten pakiet zawiera emulator systemu z procesorem S390.
453
454 %package system-sh4
455 Summary:        QEMU system emulator for SH4
456 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SH4
457 Group:          Development/Tools
458 Requires:       %{name}-common = %{version}-%{release}
459 %systempkg_req
460 Obsoletes:      qemu-kvm-system-sh4
461
462 %description system-sh4
463 QEMU is a generic and open source processor emulator which achieves a
464 good emulation speed by using dynamic translation.
465
466 This package provides the system emulator with SH4 CPU.
467
468 %description system-sh4 -l pl.UTF-8
469 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
470 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
471
472 Ten pakiet zawiera emulator systemu z procesorem SH4.
473
474 %package system-sparc
475 Summary:        QEMU system emulator for SPARC
476 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SPARC
477 Group:          Development/Tools
478 Requires:       %{name}-common = %{version}-%{release}
479 %systempkg_req
480 Obsoletes:      qemu-kvm-system-sparc
481
482 %description system-sparc
483 QEMU is a generic and open source processor emulator which achieves a
484 good emulation speed by using dynamic translation.
485
486 This package provides the system emulator with SPARC/SPARC64 CPU.
487
488 %description system-sparc -l pl.UTF-8
489 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
490 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
491
492 Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
493
494 %package system-unicore32
495 Summary:        QEMU system emulator for UniCore32
496 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem UniCore32
497 Group:          Development/Tools
498 Requires:       %{name}-common = %{version}-%{release}
499 %systempkg_req
500 Obsoletes:      qemu-kvm-system-unicore32
501
502 %description system-unicore32
503 QEMU is a generic and open source processor emulator which achieves a
504 good emulation speed by using dynamic translation.
505
506 This package provides the system emulator with UniCore32 CPU.
507
508 %description system-unicore32 -l pl.UTF-8
509 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
510 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
511
512 Ten pakiet zawiera emulator systemu z procesorem UniCore32.
513
514 %package system-x86
515 Summary:        QEMU system emulator for x86
516 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem x86
517 Group:          Development/Tools
518 Requires:       %{name}-common = %{version}-%{release}
519 %systempkg_req
520 Obsoletes:      qemu-kvm-system-x86
521
522 %description system-x86
523 QEMU is a generic and open source processor emulator which achieves a
524 good emulation speed by using dynamic translation.
525
526 %description system-x86 -l pl.UTF-8
527 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
528 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
529
530 %package system-xtensa
531 Summary:        QEMU system emulator for Xtensa
532 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Xtensa
533 Group:          Development/Tools
534 Requires:       %{name}-common = %{version}-%{release}
535 %systempkg_req
536 Obsoletes:      qemu-kvm-system-xtensa
537
538 %description system-xtensa
539 QEMU is a generic and open source processor emulator which achieves a
540 good emulation speed by using dynamic translation.
541
542 This package provides the system emulator with Xtensa CPU.
543
544 %description system-xtensa -l pl.UTF-8
545 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
546 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
547
548 Ten pakiet zawiera emulator systemu z procesorem Xtensa.
549
550 %package guest-agent
551 Summary:        QEMU guest agent
552 Summary(pl.UTF-8):      Agent gościa QEMU
553 Group:          Daemons
554 Requires(post,preun,postun):    systemd-units >= 38
555 Requires:       glib2 >= 1:2.12
556 Requires:       systemd-units >= 38
557 Obsoletes:      qemu-kvm-guest-agent
558
559 %description guest-agent
560 QEMU is a generic and open source processor emulator which achieves
561 a good emulation speed by using dynamic translation.
562
563 This package provides an agent to run inside guests, which
564 communicates with the host over a virtio-serial channel named
565 "org.qemu.guest_agent.0".
566
567 This package does not need to be installed on the host OS.
568
569 %description guest-agent -l pl.UTF-8
570 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
571 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
572
573 Ten pakiet udostępnia agenta przeznaczonego do uruchomienia w
574 systemach-gościach, komunikującego się kanałem virtio-serial o nazwie
575 "org.qemu.guest_agent.0".
576
577 Ten pakiet nie musi być zainstalowany w systemie hosta.
578
579 %prep
580 %setup -q
581 %patch0 -p1
582 %patch1 -p1
583 %patch2 -p0
584 %patch3 -p1
585
586 %{__mv} libcacard libcacard-use-system-lib
587
588 # workaround for conflict with alsa/error.h
589 ln -s ../error.h qapi/error.h
590
591 %build
592 ./configure \
593         --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
594         --extra-ldflags="%{rpmldflags}" \
595         --prefix=%{_prefix} \
596         --sysconfdir=%{_sysconfdir} \
597         --cc="%{__cc}" \
598         --host-cc="%{__cc}" \
599         --disable-strip \
600         --enable-attr \
601         --enable-bluez \
602         --enable-brlapi \
603         --enable-cap-ng \
604         --enable-curl \
605         --enable-curses \
606         --enable-docs \
607         --enable-fdt \
608         %{__enable_disable glusterfs} \
609         --enable-libiscsi \
610         --enable-mixemu \
611         %{__enable_disable glx} \
612         %{__enable_disable ceph rbd} \
613         %{__enable_disable rdma} \
614         %{__enable_disable sdl} \
615         --enable-seccomp \
616         %{__enable_disable spice} \
617         --enable-smartcard-nss \
618         --enable-tpm \
619         --enable-usb-redir \
620         --enable-uuid \
621         --enable-vde \
622         --enable-virtfs \
623         --enable-vnc-jpeg \
624         --enable-vnc-png \
625         --enable-vnc-sasl \
626         --enable-vnc-tls \
627         --enable-kvm \
628         %{__enable_disable xen} \
629         --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
630         --interp-prefix=%{_libdir}/qemu/lib-%%M \
631         --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
632
633 # note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
634 # --libexecdir in configure is nop
635 %{__make} \
636         V=1 \
637         CONFIG_QEMU_HELPERDIR="%{_libdir}"
638
639 # rebuild patched vesa tables with additional widescreen modes.
640 %{__make} -C roms/vgabios stdvga-bios
641
642 %{__cc} %{SOURCE7} %{rpmcflags} -o ksmctl
643
644 %install
645 rm -rf $RPM_BUILD_ROOT
646 install -d $RPM_BUILD_ROOT{%{systemdunitdir},/usr/lib/binfmt.d} \
647         $RPM_BUILD_ROOT/etc/{sysconfig,udev/rules.d,modules-load.d} \
648         $RPM_BUILD_ROOT{%{_sysconfdir}/sasl,%{_sbindir}}
649
650 %{__make} install \
651         DESTDIR=$RPM_BUILD_ROOT \
652         libexecdir=%{_libdir}
653
654 install -d $RPM_BUILD_ROOT%{_sysconfdir}
655 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
656 #!/bin/sh
657
658 EOF
659
660 %ifarch %{ix86} %{x8664}
661 install scripts/kvm/kvm_stat $RPM_BUILD_ROOT%{_bindir}
662 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/modules-load.d/kvm.conf
663 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
664 %endif
665
666 install -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/ksm.service
667 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/ksm
668 install -p ksmctl $RPM_BUILD_ROOT%{_sbindir}
669
670 install -p %{SOURCE8} $RPM_BUILD_ROOT%{systemdunitdir}/ksmtuned.service
671 install -p %{SOURCE9} $RPM_BUILD_ROOT%{_sbindir}/ksmtuned
672 install -p %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/ksmtuned.conf
673
674 # For the qemu-guest-agent subpackage install the systemd
675 # service and udev rules.
676 install -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
677 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
678
679 for i in dummy \
680 %ifnarch %{ix86} %{x8664}
681     qemu-i386 \
682 %endif
683 %ifnarch arm
684     qemu-arm \
685 %endif
686 %ifnarch ppc ppc64
687     qemu-ppc \
688 %endif
689 %ifnarch sparc sparc64
690     qemu-sparc \
691 %endif
692 %ifnarch sh4
693     qemu-sh4 \
694 %endif
695 ; do
696         test $i = dummy && continue
697         grep /$i:\$ %{SOURCE2} > $RPM_BUILD_ROOT/usr/lib/binfmt.d/$i.conf
698 done < %{SOURCE2}
699
700 # already packaged
701 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
702 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
703
704 # install patched vesa tables with additional widescreen modes.
705 cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
706
707 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{de_DE,de}
708 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{fr_FR,fr}
709 %find_lang %{name}
710
711 %clean
712 rm -rf $RPM_BUILD_ROOT
713
714 %pre common
715 %groupadd -g 276 qemu
716 %useradd -u 276 -g qemu -c "QEMU User" qemu
717
718 %post common
719 %systemd_post ksm.service
720 %systemd_post ksmtuned.service
721
722 %preun common
723 %systemd_preun ksm.service
724 %systemd_preun ksmtuned.service
725
726 %postun common
727 if [ "$1" = "0" ]; then
728         %userremove qemu
729         %groupremove qemu
730 fi
731 %systemd_reload
732
733 %triggerpostun common -- qemu-common < 1.6.1-4
734 %systemd_trigger ksm.service
735 %systemd_trigger ksmtuned.service
736
737 %post user
738 %systemd_service_restart systemd-binfmt.service
739
740 %postun user
741 %systemd_service_restart systemd-binfmt.service
742
743 %post guest-agent
744 %systemd_reload
745
746 %preun guest-agent
747 %systemd_preun qemu-guest-agent.service
748
749 %postun guest-agent
750 %systemd_reload
751
752 %files
753 %defattr(644,root,root,755)
754
755 %files common -f %{name}.lang
756 %defattr(644,root,root,755)
757 %doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
758 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
759 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
760 %config(noreplace) %verify(not md5 mtime size) /etc/ksmtuned.conf
761 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ksm
762 %{systemdunitdir}/ksm.service
763 %{systemdunitdir}/ksmtuned.service
764 %dir %{_sysconfdir}/qemu
765 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
766 %attr(755,root,root) %{_bindir}/qemu-nbd
767 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
768 %attr(755,root,root) %{_sbindir}/ksmctl
769 %attr(755,root,root) %{_sbindir}/ksmtuned
770 %{_mandir}/man1/qemu.1*
771 %{_mandir}/man1/virtfs-proxy-helper.1*
772 %{_mandir}/man8/qemu-nbd.8*
773
774 %dir %{_datadir}/qemu
775 %{_datadir}/%{name}/keymaps
776 %{_datadir}/%{name}/qemu-icon.bmp
777 # various bios images
778 %{_datadir}/%{name}/*.aml
779 %{_datadir}/%{name}/*.bin
780 %{_datadir}/%{name}/*.rom
781 %{_datadir}/%{name}/*.dtb
782 %{_datadir}/%{name}/qemu_logo_no_text.svg
783 %{_datadir}/%{name}/openbios-ppc
784 %{_datadir}/%{name}/openbios-sparc*
785 %{_datadir}/%{name}/palcode-clipper
786 %{_datadir}/%{name}/s390-ccw.img
787
788 %files img
789 %defattr(644,root,root,755)
790 %attr(755,root,root) %{_bindir}/qemu-img
791 %{_mandir}/man1/qemu-img.1*
792
793 %files user
794 %defattr(644,root,root,755)
795 /usr/lib/binfmt.d/qemu-*.conf
796 %attr(755,root,root) %{_bindir}/qemu-alpha
797 %attr(755,root,root) %{_bindir}/qemu-arm
798 %attr(755,root,root) %{_bindir}/qemu-armeb
799 %attr(755,root,root) %{_bindir}/qemu-cris
800 %attr(755,root,root) %{_bindir}/qemu-i386
801 %attr(755,root,root) %{_bindir}/qemu-io
802 %attr(755,root,root) %{_bindir}/qemu-m68k
803 %attr(755,root,root) %{_bindir}/qemu-microblaze
804 %attr(755,root,root) %{_bindir}/qemu-microblazeel
805 %attr(755,root,root) %{_bindir}/qemu-mips
806 %attr(755,root,root) %{_bindir}/qemu-mipsel
807 %attr(755,root,root) %{_bindir}/qemu-mips64
808 %attr(755,root,root) %{_bindir}/qemu-mips64el
809 %attr(755,root,root) %{_bindir}/qemu-mipsn32
810 %attr(755,root,root) %{_bindir}/qemu-mipsn32el
811 %attr(755,root,root) %{_bindir}/qemu-or32
812 %attr(755,root,root) %{_bindir}/qemu-ppc
813 %attr(755,root,root) %{_bindir}/qemu-ppc64
814 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
815 %attr(755,root,root) %{_bindir}/qemu-s390x
816 %attr(755,root,root) %{_bindir}/qemu-sh4
817 %attr(755,root,root) %{_bindir}/qemu-sh4eb
818 %attr(755,root,root) %{_bindir}/qemu-sparc
819 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
820 %attr(755,root,root) %{_bindir}/qemu-sparc64
821 %attr(755,root,root) %{_bindir}/qemu-unicore32
822 %attr(755,root,root) %{_bindir}/qemu-x86_64
823
824 %files system-alpha
825 %defattr(644,root,root,755)
826 %attr(755,root,root) %{_bindir}/qemu-system-alpha
827
828 %files system-arm
829 %defattr(644,root,root,755)
830 %attr(755,root,root) %{_bindir}/qemu-system-arm
831
832 %files system-cris
833 %defattr(644,root,root,755)
834 %attr(755,root,root) %{_bindir}/qemu-system-cris
835
836 %files system-lm32
837 %defattr(644,root,root,755)
838 %attr(755,root,root) %{_bindir}/qemu-system-lm32
839
840 %files system-m68k
841 %defattr(644,root,root,755)
842 %attr(755,root,root) %{_bindir}/qemu-system-m68k
843
844 %files system-microblaze
845 %defattr(644,root,root,755)
846 %attr(755,root,root) %{_bindir}/qemu-system-microblaze
847 %attr(755,root,root) %{_bindir}/qemu-system-microblazeel
848
849 %files system-mips
850 %defattr(644,root,root,755)
851 %attr(755,root,root) %{_bindir}/qemu-system-mips
852 %attr(755,root,root) %{_bindir}/qemu-system-mipsel
853 %attr(755,root,root) %{_bindir}/qemu-system-mips64
854 %attr(755,root,root) %{_bindir}/qemu-system-mips64el
855
856 %files system-moxie
857 %defattr(644,root,root,755)
858 %attr(755,root,root) %{_bindir}/qemu-system-moxie
859
860 %files system-or32
861 %defattr(644,root,root,755)
862 %attr(755,root,root) %{_bindir}/qemu-system-or32
863
864 %files system-ppc
865 %defattr(644,root,root,755)
866 %attr(755,root,root) %{_bindir}/qemu-system-ppc
867 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
868 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
869
870 %files system-s390x
871 %defattr(644,root,root,755)
872 %attr(755,root,root) %{_bindir}/qemu-system-s390x
873
874 %files system-sh4
875 %defattr(644,root,root,755)
876 %attr(755,root,root) %{_bindir}/qemu-system-sh4
877 %attr(755,root,root) %{_bindir}/qemu-system-sh4eb
878
879 %files system-sparc
880 %defattr(644,root,root,755)
881 %attr(755,root,root) %{_bindir}/qemu-system-sparc
882 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
883
884 %files system-unicore32
885 %defattr(644,root,root,755)
886 %attr(755,root,root) %{_bindir}/qemu-system-unicore32
887
888 %files system-x86
889 %defattr(644,root,root,755)
890 %attr(755,root,root) %{_bindir}/qemu-system-i386
891 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
892 %ifarch %{ix86} %{x8664}
893 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/kvm.conf
894 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/80-kvm.rules
895 %attr(755,root,root) %{_bindir}/kvm_stat
896 %endif
897
898 %files system-xtensa
899 %defattr(644,root,root,755)
900 %attr(755,root,root) %{_bindir}/qemu-system-xtensa
901 %attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
902
903 %files guest-agent
904 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/99-qemu-guest-agent.rules
905 %{systemdunitdir}/qemu-guest-agent.service
906 %attr(755,root,root) %{_bindir}/qemu-ga
This page took 0.086301 seconds and 4 git commands to generate.