]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- added Kernel Samepage Merging support from qemu-kvm
[packages/qemu.git] / qemu.spec
1 # TODO:
2 # - merge missing bits from qemu-kvm
3 #
4 # Conditional build:
5 %bcond_without  sdl             # SDL UI and audio support
6 %bcond_without  glx             # OpenGL/GLX support
7 %bcond_without  ceph            # Ceph/RBD support
8 %bcond_without  glusterfs       # GlusterFS backend
9 %bcond_without  rdma            # RDMA-based migration support
10 %bcond_with     gtk2            # GTK+ 2.x instead of 3.x
11 %bcond_without  spice           # SPICE support
12 %bcond_with     esd             # EsounD audio support
13 %bcond_without  oss             # OSS audio support
14 %bcond_without  pulseaudio      # PulseAudio audio support
15 %bcond_without  xen             # Xen backend driver support
16
17 Summary:        QEMU CPU Emulator
18 Summary(pl.UTF-8):      QEMU - emulator procesora
19 Name:           qemu
20 Version:        1.6.1
21 Release:        3
22 License:        GPL v2+
23 Group:          Applications/Emulators
24 Source0:        http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
25 # Source0-md5:  3a897d722457c5a895cd6ac79a28fda0
26 # KSM control scripts
27 Source5:        ksm.service
28 Source6:        ksm.sysconfig
29 Source7:        ksmctl.c
30 Source8:        ksmtuned.service
31 Source9:        ksmtuned
32 Source10:       ksmtuned.conf
33 Source11:       qemu-guest-agent.service
34 Source12:       99-qemu-guest-agent.rules
35 Patch0:         %{name}-cflags.patch
36 Patch1:         vgabios-widescreens.patch
37 Patch2:         %{name}-whitelist.patch
38 Patch3:         %{name}-system-libcacard.patch
39 # Proof of concept, for reference, do not remove
40 Patch4:         %{name}-kde_virtual_workspaces_hack.patch
41 URL:            http://www.qemu-project.org/
42 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
43 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
44 BuildRequires:  alsa-lib-devel
45 BuildRequires:  bcc
46 BuildRequires:  bluez-libs-devel
47 BuildRequires:  brlapi-devel
48 %{?with_ceph:BuildRequires:     ceph-devel}
49 BuildRequires:  curl-devel
50 BuildRequires:  cyrus-sasl-devel >= 2
51 %{?with_esd:BuildRequires:      esound-devel}
52 BuildRequires:  glib2-devel >= 1:2.12
53 %{?with_glusterfs:BuildRequires:        glusterfs-devel >= 3.4}
54 BuildRequires:  gnutls-devel
55 BuildRequires:  libaio-devel
56 BuildRequires:  libcacard-devel
57 BuildRequires:  libcap-devel
58 BuildRequires:  libcap-ng-devel
59 BuildRequires:  libfdt-devel
60 %{?with_rdma:BuildRequires:     libibverbs-devel}
61 BuildRequires:  libiscsi-devel
62 BuildRequires:  libjpeg-devel
63 BuildRequires:  libpng-devel
64 %{?with_rdma:BuildRequires:     librdmacm-devel}
65 BuildRequires:  libseccomp-devel
66 BuildRequires:  libssh2-devel >= 1.2.8
67 # for usb passthrough, when available
68 #BuildRequires: libusb-devel >= 1.0.13
69 BuildRequires:  libuuid-devel
70 BuildRequires:  ncurses-devel
71 BuildRequires:  nss-devel >= 3.12.8
72 BuildRequires:  perl-Encode
73 BuildRequires:  perl-tools-pod
74 BuildRequires:  pkgconfig
75 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
76 BuildRequires:  rpmbuild(macros) >= 1.202
77 BuildRequires:  sed >= 4.0
78 %if %{with spice}
79 BuildRequires:  spice-protocol >= 0.12.0
80 BuildRequires:  spice-server-devel >= 0.12.0
81 %endif
82 BuildRequires:  texi2html
83 BuildRequires:  texinfo
84 BuildRequires:  usbredir-devel >= 0.6
85 BuildRequires:  vde2-devel
86 BuildRequires:  which
87 %{?with_xen:BuildRequires:      xen-devel >= 3.4}
88 BuildRequires:  xfsprogs-devel
89 BuildRequires:  xorg-lib-libX11-devel
90 BuildRequires:  zlib-devel
91 %if %{with gtk2}
92 BuildRequires:  gtk+2-devel >= 2:2.18.0
93 BuildRequires:  vte0-devel >= 0.24.0
94 %else
95 BuildRequires:  gtk+3-devel >= 3.0.0
96 BuildRequires:  vte-devel >= 0.32.0
97 %endif
98 Requires:       %{name}-img = %{version}-%{release}
99 Requires:       %{name}-system-alpha = %{version}-%{release}
100 Requires:       %{name}-system-arm = %{version}-%{release}
101 Requires:       %{name}-system-cris = %{version}-%{release}
102 Requires:       %{name}-system-lm32 = %{version}-%{release}
103 Requires:       %{name}-system-m68k = %{version}-%{release}
104 Requires:       %{name}-system-microblaze = %{version}-%{release}
105 Requires:       %{name}-system-mips = %{version}-%{release}
106 Requires:       %{name}-system-moxie = %{version}-%{release}
107 Requires:       %{name}-system-or32 = %{version}-%{release}
108 Requires:       %{name}-system-ppc = %{version}-%{release}
109 Requires:       %{name}-system-s390x = %{version}-%{release}
110 Requires:       %{name}-system-sh4 = %{version}-%{release}
111 Requires:       %{name}-system-sparc = %{version}-%{release}
112 Requires:       %{name}-system-unicore32 = %{version}-%{release}
113 Requires:       %{name}-system-x86 = %{version}-%{release}
114 Requires:       %{name}-system-xtensa = %{version}-%{release}
115 Requires:       %{name}-user = %{version}-%{release}
116 Obsoletes:      qemu-kvm
117 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
118
119 %define systempkg_req \
120 Requires:       SDL >= 1.2.1 \
121 Requires:       usbredir >= 0.6 \
122 %if %{with gtk2} \
123 Requires:       gtk+2 >= 2:2.18.0 \
124 Requires:       vte0 >= 0.24.0 \
125 %else \
126 Requires:       gtk+3 >= 3.0.0 \
127 Requires:       vte >= 0.32.0 \
128 %endif
129
130 # some PPC/SPARC boot image in ELF format
131 %define         _noautostrip    .*%{_datadir}/qemu/.*-.*
132
133 %description
134 QEMU is a FAST! processor emulator. By using dynamic translation it
135 achieves a reasonnable speed while being easy to port on new host
136 CPUs. QEMU has two operating modes:
137
138 - User mode emulation. In this mode, QEMU can launch Linux processes
139   compiled for one CPU on another CPU. Linux system calls are converted
140   because of endianness and 32/64 bit mismatches. Wine (Windows
141   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
142
143 - Full system emulation. In this mode, QEMU emulates a full system,
144   including a processor and various peripherials. It can also be used to
145   provide virtual hosting of several virtual PC on a single server.
146
147 %description -l pl.UTF-8
148 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
149 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
150 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
151
152 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
153   procesy linuksowe skompilowane dla jednego procesora na innym
154   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
155   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
156   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
157   cele QEMU.
158
159 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
160   włączając w to procesor i różne urządzenia peryferyjne. Może być także
161   używane do wirtualnego hostowania kilku wirtualnych pecetów na
162   pojedynczym serwerze.
163
164 %package common
165 Summary:        QEMU common files needed by all QEMU targets
166 Summary(pl.UTF-8):      Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
167 Group:          Development/Tools
168 Requires(postun):       /usr/sbin/groupdel
169 Requires(postun):       /usr/sbin/userdel
170 Requires(pre):  /bin/id
171 Requires(pre):  /usr/bin/getgid
172 Requires(pre):  /usr/sbin/groupadd
173 Requires(pre):  /usr/sbin/useradd
174 Requires:       glib2 >= 1:2.12
175 Requires:       libssh2 >= 1.2.8
176 Provides:       group(qemu)
177 Provides:       user(qemu)
178 Obsoletes:      qemu-kvm-common
179 Conflicts:      qemu < 1.0-2
180
181 %description common
182 QEMU is a generic and open source processor emulator which achieves a
183 good emulation speed by using dynamic translation.
184
185 This package provides the common files needed by all QEMU targets.
186
187 %description common -l pl.UTF-8
188 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
189 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
190
191 Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
192 środowiska QEMU.
193
194 %package img
195 Summary:        QEMU command line tool for manipulating disk images
196 Summary(pl.UTF-8):      Narzędzie QEMU do operacji na obrazach dysków
197 Group:          Development/Tools
198 Conflicts:      qemu < 1.0-2
199 Obsoletes:      qemu-kvm-img
200
201 %description img
202 This package provides a command line tool for manipulating disk
203 images.
204
205 %description img -l pl.UTF-8
206 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
207 na obrazach dysków.
208
209 %package user
210 Summary:        QEMU user mode emulation of qemu targets
211 Summary(pl.UTF-8):      QEMU - emulacja trybu użytkownika środowisk qemu
212 Group:          Development/Tools
213 Requires:       %{name}-common = %{version}-%{release}
214 Obsoletes:      qemu-kvm-user
215
216 %description user
217 QEMU is a generic and open source processor emulator which achieves a
218 good emulation speed by using dynamic translation.
219
220 This package provides the user mode emulation of QEMU targets.
221
222 %description user -l pl.UTF-8
223 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
224 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
225
226 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
227
228 %package system-alpha
229 Summary:        QEMU system emulator for Alpha
230 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Alpha
231 Group:          Development/Tools
232 Requires:       %{name}-common = %{version}-%{release}
233 %systempkg_req
234 Obsoletes:      qemu-kvm-system-alpha
235
236 %description system-alpha
237 QEMU is a generic and open source processor emulator which achieves a
238 good emulation speed by using dynamic translation.
239
240 This package provides the system emulator with Alpha CPU.
241
242 %description system-alpha -l pl.UTF-8
243 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
244 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
245
246 Ten pakiet zawiera emulator systemu z procesorem Alpha.
247
248 %package system-arm
249 Summary:        QEMU system emulator for ARM
250 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem ARM
251 Group:          Development/Tools
252 Requires:       %{name}-common = %{version}-%{release}
253 %systempkg_req
254 Obsoletes:      qemu-kvm-system-arm
255
256 %description system-arm
257 QEMU is a generic and open source processor emulator which achieves a
258 good emulation speed by using dynamic translation.
259
260 This package provides the system emulator for ARM.
261
262 %description system-arm -l pl.UTF-8
263 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
264 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
265
266 Ten pakiet zawiera emulator systemu z procesorem ARM.
267
268 %package system-cris
269 Summary:        QEMU system emulator for CRIS
270 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem CRIS
271 Group:          Development/Tools
272 Requires:       %{name}-common = %{version}-%{release}
273 %systempkg_req
274 Obsoletes:      qemu-kvm-system-cris
275
276 %description system-cris
277 QEMU is a generic and open source processor emulator which achieves a
278 good emulation speed by using dynamic translation.
279
280 This package provides the system emulator with CRIS CPU.
281
282 %description system-cris -l pl.UTF-8
283 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
284 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
285
286 Ten pakiet zawiera emulator systemu z procesorem CRIS.
287
288 %package system-lm32
289 Summary:        QEMU system emulator for LM32
290 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem LM32
291 Group:          Development/Tools
292 Requires:       %{name}-common = %{version}-%{release}
293 %systempkg_req
294 Obsoletes:      qemu-kvm-system-lm32
295
296 %description system-lm32
297 QEMU is a generic and open source processor emulator which achieves a
298 good emulation speed by using dynamic translation.
299
300 This package provides the system emulator with LM32 CPU.
301
302 %description system-lm32 -l pl.UTF-8
303 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
304 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
305
306 Ten pakiet zawiera emulator systemu z procesorem LM32.
307
308 %package system-m68k
309 Summary:        QEMU system emulator for m68k
310 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem m68k
311 Group:          Development/Tools
312 Requires:       %{name}-common = %{version}-%{release}
313 %systempkg_req
314 Obsoletes:      qemu-kvm-system-m68k
315
316 %description system-m68k
317 QEMU is a generic and open source processor emulator which achieves a
318 good emulation speed by using dynamic translation.
319
320 This package provides the system emulator with m68k CPU.
321
322 %description system-m68k -l pl.UTF-8
323 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
324 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
325
326 Ten pakiet zawiera emulator systemu z procesorem m68k.
327
328 %package system-microblaze
329 Summary:        QEMU system emulator for MicroBlaze
330 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MicroBlaze
331 Group:          Development/Tools
332 Requires:       %{name}-common = %{version}-%{release}
333 %systempkg_req
334 Obsoletes:      qemu-kvm-system-microblaze
335
336 %description system-microblaze
337 QEMU is a generic and open source processor emulator which achieves a
338 good emulation speed by using dynamic translation.
339
340 This package provides the system emulator with MicroBlaze CPU.
341
342 %description system-microblaze -l pl.UTF-8
343 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
344 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
345
346 Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
347
348 %package system-mips
349 Summary:        QEMU system emulator for MIPS
350 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MIPS
351 Group:          Development/Tools
352 Requires:       %{name}-common = %{version}-%{release}
353 %systempkg_req
354 Obsoletes:      qemu-kvm-system-mips
355
356 %description system-mips
357 QEMU is a generic and open source processor emulator which achieves a
358 good emulation speed by using dynamic translation.
359
360 This package provides the system emulator with MIPS CPU.
361
362 %description system-mips -l pl.UTF-8
363 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
364 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
365
366 Ten pakiet zawiera emulator systemu z procesorem MIPS.
367
368 %package system-moxie
369 Summary:        QEMU system emulator for Moxie
370 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Moxie
371 Group:          Development/Tools
372 Requires:       %{name}-common = %{version}-%{release}
373 %systempkg_req
374
375 %description system-moxie
376 QEMU is a generic and open source processor emulator which achieves a
377 good emulation speed by using dynamic translation.
378
379 This package provides the system emulator with Moxie CPU.
380
381 %description system-moxie -l pl.UTF-8
382 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
383 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
384
385 Ten pakiet zawiera emulator systemu z procesorem Moxie.
386
387 %package system-or32
388 Summary:        QEMU system emulator for OpenRISC
389 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem OpenRISC
390 Group:          Development/Tools
391 Requires:       %{name}-common = %{version}-%{release}
392 %systempkg_req
393 Obsoletes:      qemu-kvm-system-or32
394
395 %description system-or32
396 QEMU is a generic and open source processor emulator which achieves a
397 good emulation speed by using dynamic translation.
398
399 This package provides the system emulator with OpenRISC CPU.
400
401 %description system-or32 -l pl.UTF-8
402 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
403 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
404
405 Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
406
407 %package system-ppc
408 Summary:        QEMU system emulator for PowerPC
409 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem PowerPC
410 Group:          Development/Tools
411 Requires:       %{name}-common = %{version}-%{release}
412 %systempkg_req
413 Obsoletes:      qemu-kvm-system-ppc
414
415 %description system-ppc
416 QEMU is a generic and open source processor emulator which achieves a
417 good emulation speed by using dynamic translation.
418
419 This package provides the system emulator with PowerPC CPU.
420
421 %description system-ppc -l pl.UTF-8
422 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
423 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
424
425 Ten pakiet zawiera emulator systemu z procesorem PowerPC.
426
427 %package system-s390x
428 Summary:        QEMU system emulator for S390
429 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem S390
430 Group:          Development/Tools
431 Requires:       %{name}-common = %{version}-%{release}
432 %systempkg_req
433 Obsoletes:      qemu-kvm-system-s390x
434
435 %description system-s390x
436 QEMU is a generic and open source processor emulator which achieves a
437 good emulation speed by using dynamic translation.
438
439 This package provides the system emulator with S390 CPU.
440
441 %description system-s390x -l pl.UTF-8
442 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
443 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
444
445 Ten pakiet zawiera emulator systemu z procesorem S390.
446
447 %package system-sh4
448 Summary:        QEMU system emulator for SH4
449 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SH4
450 Group:          Development/Tools
451 Requires:       %{name}-common = %{version}-%{release}
452 %systempkg_req
453 Obsoletes:      qemu-kvm-system-sh4
454
455 %description system-sh4
456 QEMU is a generic and open source processor emulator which achieves a
457 good emulation speed by using dynamic translation.
458
459 This package provides the system emulator with SH4 CPU.
460
461 %description system-sh4 -l pl.UTF-8
462 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
463 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
464
465 Ten pakiet zawiera emulator systemu z procesorem SH4.
466
467 %package system-sparc
468 Summary:        QEMU system emulator for SPARC
469 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SPARC
470 Group:          Development/Tools
471 Requires:       %{name}-common = %{version}-%{release}
472 %systempkg_req
473 Obsoletes:      qemu-kvm-system-sparc
474
475 %description system-sparc
476 QEMU is a generic and open source processor emulator which achieves a
477 good emulation speed by using dynamic translation.
478
479 This package provides the system emulator with SPARC/SPARC64 CPU.
480
481 %description system-sparc -l pl.UTF-8
482 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
483 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
484
485 Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
486
487 %package system-unicore32
488 Summary:        QEMU system emulator for UniCore32
489 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem UniCore32
490 Group:          Development/Tools
491 Requires:       %{name}-common = %{version}-%{release}
492 %systempkg_req
493 Obsoletes:      qemu-kvm-system-unicore32
494
495 %description system-unicore32
496 QEMU is a generic and open source processor emulator which achieves a
497 good emulation speed by using dynamic translation.
498
499 This package provides the system emulator with UniCore32 CPU.
500
501 %description system-unicore32 -l pl.UTF-8
502 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
503 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
504
505 Ten pakiet zawiera emulator systemu z procesorem UniCore32.
506
507 %package system-x86
508 Summary:        QEMU system emulator for x86
509 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem x86
510 Group:          Development/Tools
511 Requires:       %{name}-common = %{version}-%{release}
512 %systempkg_req
513 Obsoletes:      qemu-kvm-system-x86
514
515 %description system-x86
516 QEMU is a generic and open source processor emulator which achieves a
517 good emulation speed by using dynamic translation.
518
519 %description system-x86 -l pl.UTF-8
520 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
521 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
522
523 %package system-xtensa
524 Summary:        QEMU system emulator for Xtensa
525 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Xtensa
526 Group:          Development/Tools
527 Requires:       %{name}-common = %{version}-%{release}
528 %systempkg_req
529 Obsoletes:      qemu-kvm-system-xtensa
530
531 %description system-xtensa
532 QEMU is a generic and open source processor emulator which achieves a
533 good emulation speed by using dynamic translation.
534
535 This package provides the system emulator with Xtensa CPU.
536
537 %description system-xtensa -l pl.UTF-8
538 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
539 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
540
541 Ten pakiet zawiera emulator systemu z procesorem Xtensa.
542
543 %package guest-agent
544 Summary:        QEMU guest agent
545 Summary(pl.UTF-8):      Agent gościa QEMU
546 Group:          Daemons
547 Requires(post,preun,postun):    systemd-units >= 38
548 Requires:       glib2 >= 1:2.12
549 Requires:       systemd-units >= 38
550 Obsoletes:      qemu-kvm-guest-agent
551
552 %description guest-agent
553 QEMU is a generic and open source processor emulator which achieves
554 a good emulation speed by using dynamic translation.
555
556 This package provides an agent to run inside guests, which
557 communicates with the host over a virtio-serial channel named
558 "org.qemu.guest_agent.0".
559
560 This package does not need to be installed on the host OS.
561
562 %description guest-agent -l pl.UTF-8
563 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
564 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
565
566 Ten pakiet udostępnia agenta przeznaczonego do uruchomienia w
567 systemach-gościach, komunikującego się kanałem virtio-serial o nazwie
568 "org.qemu.guest_agent.0".
569
570 Ten pakiet nie musi być zainstalowany w systemie hosta.
571
572 %prep
573 %setup -q
574 %patch0 -p1
575 %patch1 -p1
576 %patch2 -p0
577 %patch3 -p1
578
579 %{__mv} libcacard libcacard-use-system-lib
580
581 # workaround for conflict with alsa/error.h
582 ln -s ../error.h qapi/error.h
583
584 %build
585 ./configure \
586         --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
587         --extra-ldflags="%{rpmldflags}" \
588         --prefix=%{_prefix} \
589         --sysconfdir=%{_sysconfdir} \
590         --cc="%{__cc}" \
591         --host-cc="%{__cc}" \
592         --disable-strip \
593         --enable-attr \
594         --enable-bluez \
595         --enable-brlapi \
596         --enable-cap-ng \
597         --enable-curl \
598         --enable-curses \
599         --enable-docs \
600         --enable-fdt \
601         %{__enable_disable glusterfs} \
602         --enable-libiscsi \
603         --enable-mixemu \
604         %{__enable_disable glx} \
605         %{__enable_disable ceph rbd} \
606         %{__enable_disable rdma} \
607         %{__enable_disable sdl} \
608         --enable-seccomp \
609         %{__enable_disable spice} \
610         --enable-smartcard-nss \
611         --enable-tpm \
612         --enable-usb-redir \
613         --enable-uuid \
614         --enable-vde \
615         --enable-virtfs \
616         --enable-vnc-jpeg \
617         --enable-vnc-png \
618         --enable-vnc-sasl \
619         --enable-vnc-tls \
620         --enable-kvm \
621         %{__enable_disable xen} \
622         --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
623         --interp-prefix=%{_libdir}/qemu/lib-%%M \
624         --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
625
626 # note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
627 # --libexecdir in configure is nop
628 %{__make} \
629         V=1 \
630         CONFIG_QEMU_HELPERDIR="%{_libdir}"
631
632 # rebuild patched vesa tables with additional widescreen modes.
633 %{__make} -C roms/vgabios stdvga-bios
634
635 %{__cc} %{SOURCE7} %{rpmcflags} -o ksmctl
636
637 %install
638 rm -rf $RPM_BUILD_ROOT
639 install -d $RPM_BUILD_ROOT{%{systemdunitdir},/usr/lib/binfmt.d} \
640         $RPM_BUILD_ROOT/etc/{sysconfig,udev/rules.d,modules-load.d} \
641         $RPM_BUILD_ROOT{%{_sysconfdir}/sasl,%{_sbindir}}
642
643 %{__make} install \
644         DESTDIR=$RPM_BUILD_ROOT \
645         libexecdir=%{_libdir}
646
647 install -d $RPM_BUILD_ROOT%{_sysconfdir}
648 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
649 #!/bin/sh
650
651 EOF
652
653 install -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/ksm.service
654 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/ksm
655 install -p ksmctl $RPM_BUILD_ROOT%{_sbindir}
656
657 install -p %{SOURCE8} $RPM_BUILD_ROOT%{systemdunitdir}/ksmtuned.service
658 install -p %{SOURCE9} $RPM_BUILD_ROOT%{_sbindir}/ksmtuned
659 install -p %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/ksmtuned.conf
660
661 # For the qemu-guest-agent subpackage install the systemd
662 # service and udev rules.
663 install -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
664 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
665
666 # already packaged
667 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
668 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
669
670 # install patched vesa tables with additional widescreen modes.
671 cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
672
673 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{de_DE,de}
674 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{fr_FR,fr}
675 %find_lang %{name}
676
677 %clean
678 rm -rf $RPM_BUILD_ROOT
679
680 %pre common
681 %groupadd -g 276 qemu
682 %useradd -u 276 -g qemu -c "QEMU User" qemu
683
684 %post common
685 %systemd_post ksm.service
686 %systemd_post ksmtuned.service
687
688 %preun common
689 %systemd_preun ksm.service
690 %systemd_preun ksmtuned.service
691
692 %postun common
693 if [ "$1" = "0" ]; then
694         %userremove qemu
695         %groupremove qemu
696 fi
697 %systemd_reload
698
699 %triggerpostun common -- qemu-common < 1.6.1-4
700 %systemd_trigger ksm.service
701 %systemd_trigger ksmtuned.service
702
703 %post guest-agent
704 %systemd_reload
705
706 %preun guest-agent
707 %systemd_preun qemu-guest-agent.service
708
709 %postun guest-agent
710 %systemd_reload
711
712 %files
713 %defattr(644,root,root,755)
714
715 %files common -f %{name}.lang
716 %defattr(644,root,root,755)
717 %doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
718 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
719 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
720 %dir %{_sysconfdir}/qemu
721 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
722 %attr(755,root,root) %{_bindir}/qemu-nbd
723 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
724 %{_mandir}/man1/qemu.1*
725 %{_mandir}/man1/virtfs-proxy-helper.1*
726 %{_mandir}/man8/qemu-nbd.8*
727
728 %dir %{_datadir}/qemu
729 %{_datadir}/%{name}/keymaps
730 %{_datadir}/%{name}/qemu-icon.bmp
731 # various bios images
732 %{_datadir}/%{name}/*.aml
733 %{_datadir}/%{name}/*.bin
734 %{_datadir}/%{name}/*.rom
735 %{_datadir}/%{name}/*.dtb
736 %{_datadir}/%{name}/qemu_logo_no_text.svg
737 %{_datadir}/%{name}/openbios-ppc
738 %{_datadir}/%{name}/openbios-sparc*
739 %{_datadir}/%{name}/palcode-clipper
740 %{_datadir}/%{name}/s390-ccw.img
741
742 %files img
743 %defattr(644,root,root,755)
744 %attr(755,root,root) %{_bindir}/qemu-img
745 %{_mandir}/man1/qemu-img.1*
746
747 %files user
748 %defattr(644,root,root,755)
749 %attr(755,root,root) %{_bindir}/qemu-alpha
750 %attr(755,root,root) %{_bindir}/qemu-arm
751 %attr(755,root,root) %{_bindir}/qemu-armeb
752 %attr(755,root,root) %{_bindir}/qemu-cris
753 %attr(755,root,root) %{_bindir}/qemu-i386
754 %attr(755,root,root) %{_bindir}/qemu-io
755 %attr(755,root,root) %{_bindir}/qemu-m68k
756 %attr(755,root,root) %{_bindir}/qemu-microblaze
757 %attr(755,root,root) %{_bindir}/qemu-microblazeel
758 %attr(755,root,root) %{_bindir}/qemu-mips
759 %attr(755,root,root) %{_bindir}/qemu-mipsel
760 %attr(755,root,root) %{_bindir}/qemu-mips64
761 %attr(755,root,root) %{_bindir}/qemu-mips64el
762 %attr(755,root,root) %{_bindir}/qemu-mipsn32
763 %attr(755,root,root) %{_bindir}/qemu-mipsn32el
764 %attr(755,root,root) %{_bindir}/qemu-or32
765 %attr(755,root,root) %{_bindir}/qemu-ppc
766 %attr(755,root,root) %{_bindir}/qemu-ppc64
767 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
768 %attr(755,root,root) %{_bindir}/qemu-s390x
769 %attr(755,root,root) %{_bindir}/qemu-sh4
770 %attr(755,root,root) %{_bindir}/qemu-sh4eb
771 %attr(755,root,root) %{_bindir}/qemu-sparc
772 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
773 %attr(755,root,root) %{_bindir}/qemu-sparc64
774 %attr(755,root,root) %{_bindir}/qemu-unicore32
775 %attr(755,root,root) %{_bindir}/qemu-x86_64
776
777 %files system-alpha
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{_bindir}/qemu-system-alpha
780
781 %files system-arm
782 %defattr(644,root,root,755)
783 %attr(755,root,root) %{_bindir}/qemu-system-arm
784
785 %files system-cris
786 %defattr(644,root,root,755)
787 %attr(755,root,root) %{_bindir}/qemu-system-cris
788
789 %files system-lm32
790 %defattr(644,root,root,755)
791 %attr(755,root,root) %{_bindir}/qemu-system-lm32
792
793 %files system-m68k
794 %defattr(644,root,root,755)
795 %attr(755,root,root) %{_bindir}/qemu-system-m68k
796
797 %files system-microblaze
798 %defattr(644,root,root,755)
799 %attr(755,root,root) %{_bindir}/qemu-system-microblaze
800 %attr(755,root,root) %{_bindir}/qemu-system-microblazeel
801
802 %files system-mips
803 %defattr(644,root,root,755)
804 %attr(755,root,root) %{_bindir}/qemu-system-mips
805 %attr(755,root,root) %{_bindir}/qemu-system-mipsel
806 %attr(755,root,root) %{_bindir}/qemu-system-mips64
807 %attr(755,root,root) %{_bindir}/qemu-system-mips64el
808
809 %files system-moxie
810 %defattr(644,root,root,755)
811 %attr(755,root,root) %{_bindir}/qemu-system-moxie
812
813 %files system-or32
814 %defattr(644,root,root,755)
815 %attr(755,root,root) %{_bindir}/qemu-system-or32
816
817 %files system-ppc
818 %defattr(644,root,root,755)
819 %attr(755,root,root) %{_bindir}/qemu-system-ppc
820 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
821 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
822
823 %files system-s390x
824 %defattr(644,root,root,755)
825 %attr(755,root,root) %{_bindir}/qemu-system-s390x
826
827 %files system-sh4
828 %defattr(644,root,root,755)
829 %attr(755,root,root) %{_bindir}/qemu-system-sh4
830 %attr(755,root,root) %{_bindir}/qemu-system-sh4eb
831
832 %files system-sparc
833 %defattr(644,root,root,755)
834 %attr(755,root,root) %{_bindir}/qemu-system-sparc
835 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
836
837 %files system-unicore32
838 %defattr(644,root,root,755)
839 %attr(755,root,root) %{_bindir}/qemu-system-unicore32
840
841 %files system-x86
842 %defattr(644,root,root,755)
843 %attr(755,root,root) %{_bindir}/qemu-system-i386
844 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
845
846 %files system-xtensa
847 %defattr(644,root,root,755)
848 %attr(755,root,root) %{_bindir}/qemu-system-xtensa
849 %attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
850
851 %files guest-agent
852 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/99-qemu-guest-agent.rules
853 %{systemdunitdir}/qemu-guest-agent.service
854 %attr(755,root,root) %{_bindir}/qemu-ga
This page took 0.090865 seconds and 4 git commands to generate.