]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- added guest-agent package from qemu-kvm
[packages/qemu.git] / qemu.spec
1 # TODO:
2 # - merge missing bits from qemu-kvm
3 # - qemu-system-ppc -hda ac-ppc.img says:
4 #   qemu: could not open disk image ac-ppc.img: error "Success"
5 #   qemu-0.12.2-2.x86_64.rpm - broken
6 #   qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
7 #   qemu-0.15.0-2.x86_64.rpm - qemu-system-sparc/ppc booting with -kernel, -initrd options stalls in openbios prompt
8 #   qemu-0.11.1-*.x86_64.rpm - OK
9 #
10 # Conditional build:
11 %bcond_without  sdl             # SDL UI and audio support
12 %bcond_without  glx             # OpenGL/GLX support
13 %bcond_without  ceph            # Ceph/RBD support
14 %bcond_without  glusterfs       # GlusterFS backend
15 %bcond_without  rdma            # RDMA-based migration support
16 %bcond_with     gtk2            # GTK+ 2.x instead of 3.x
17 %bcond_without  spice           # SPICE support
18 %bcond_with     esd             # EsounD audio support
19 %bcond_without  oss             # OSS audio support
20 %bcond_without  pulseaudio      # PulseAudio audio support
21 %bcond_without  xen             # Xen backend driver support
22
23 Summary:        QEMU CPU Emulator
24 Summary(pl.UTF-8):      QEMU - emulator procesora
25 Name:           qemu
26 Version:        1.6.1
27 Release:        3
28 License:        GPL v2+
29 Group:          Applications/Emulators
30 Source0:        http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
31 # Source0-md5:  3a897d722457c5a895cd6ac79a28fda0
32 Source11:       qemu-guest-agent.service
33 Source12:       99-qemu-guest-agent.rules
34 Patch0:         %{name}-cflags.patch
35 Patch1:         vgabios-widescreens.patch
36 Patch2:         %{name}-whitelist.patch
37 Patch3:         %{name}-system-libcacard.patch
38 # Proof of concept, for reference, do not remove
39 Patch4:         %{name}-kde_virtual_workspaces_hack.patch
40 URL:            http://www.qemu-project.org/
41 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
42 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
43 BuildRequires:  alsa-lib-devel
44 BuildRequires:  bcc
45 BuildRequires:  bluez-libs-devel
46 BuildRequires:  brlapi-devel
47 %{?with_ceph:BuildRequires:     ceph-devel}
48 BuildRequires:  curl-devel
49 BuildRequires:  cyrus-sasl-devel >= 2
50 %{?with_esd:BuildRequires:      esound-devel}
51 BuildRequires:  glib2-devel >= 1:2.12
52 %{?with_glusterfs:BuildRequires:        glusterfs-devel >= 3.4}
53 BuildRequires:  gnutls-devel
54 BuildRequires:  libaio-devel
55 BuildRequires:  libcacard-devel
56 BuildRequires:  libcap-devel
57 BuildRequires:  libcap-ng-devel
58 BuildRequires:  libfdt-devel
59 %{?with_rdma:BuildRequires:     libibverbs-devel}
60 BuildRequires:  libiscsi-devel
61 BuildRequires:  libjpeg-devel
62 BuildRequires:  libpng-devel
63 %{?with_rdma:BuildRequires:     librdmacm-devel}
64 BuildRequires:  libseccomp-devel
65 BuildRequires:  libssh2-devel >= 1.2.8
66 # for usb passthrough, when available
67 #BuildRequires: libusb-devel >= 1.0.13
68 BuildRequires:  libuuid-devel
69 BuildRequires:  ncurses-devel
70 BuildRequires:  nss-devel >= 3.12.8
71 BuildRequires:  perl-Encode
72 BuildRequires:  perl-tools-pod
73 BuildRequires:  pkgconfig
74 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
75 BuildRequires:  rpmbuild(macros) >= 1.202
76 BuildRequires:  sed >= 4.0
77 %if %{with spice}
78 BuildRequires:  spice-protocol >= 0.12.0
79 BuildRequires:  spice-server-devel >= 0.12.0
80 %endif
81 BuildRequires:  texi2html
82 BuildRequires:  texinfo
83 BuildRequires:  usbredir-devel >= 0.6
84 BuildRequires:  vde2-devel
85 BuildRequires:  which
86 %{?with_xen:BuildRequires:      xen-devel >= 3.4}
87 BuildRequires:  xfsprogs-devel
88 BuildRequires:  xorg-lib-libX11-devel
89 BuildRequires:  zlib-devel
90 %if %{with gtk2}
91 BuildRequires:  gtk+2-devel >= 2:2.18.0
92 BuildRequires:  vte0-devel >= 0.24.0
93 %else
94 BuildRequires:  gtk+3-devel >= 3.0.0
95 BuildRequires:  vte-devel >= 0.32.0
96 %endif
97 Requires:       %{name}-img = %{version}-%{release}
98 Requires:       %{name}-system-alpha = %{version}-%{release}
99 Requires:       %{name}-system-arm = %{version}-%{release}
100 Requires:       %{name}-system-cris = %{version}-%{release}
101 Requires:       %{name}-system-lm32 = %{version}-%{release}
102 Requires:       %{name}-system-m68k = %{version}-%{release}
103 Requires:       %{name}-system-microblaze = %{version}-%{release}
104 Requires:       %{name}-system-mips = %{version}-%{release}
105 Requires:       %{name}-system-moxie = %{version}-%{release}
106 Requires:       %{name}-system-or32 = %{version}-%{release}
107 Requires:       %{name}-system-ppc = %{version}-%{release}
108 Requires:       %{name}-system-s390x = %{version}-%{release}
109 Requires:       %{name}-system-sh4 = %{version}-%{release}
110 Requires:       %{name}-system-sparc = %{version}-%{release}
111 Requires:       %{name}-system-unicore32 = %{version}-%{release}
112 Requires:       %{name}-system-x86 = %{version}-%{release}
113 Requires:       %{name}-system-xtensa = %{version}-%{release}
114 Requires:       %{name}-user = %{version}-%{release}
115 Obsoletes:      qemu-kvm
116 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
117
118 %define systempkg_req \
119 Requires:       SDL >= 1.2.1 \
120 Requires:       usbredir >= 0.6 \
121 %if %{with gtk2} \
122 Requires:       gtk+2 >= 2:2.18.0 \
123 Requires:       vte0 >= 0.24.0 \
124 %else \
125 Requires:       gtk+3 >= 3.0.0 \
126 Requires:       vte >= 0.32.0 \
127 %endif
128
129 # some PPC/SPARC boot image in ELF format
130 %define         _noautostrip    .*%{_datadir}/qemu/.*-.*
131
132 %description
133 QEMU is a FAST! processor emulator. By using dynamic translation it
134 achieves a reasonnable speed while being easy to port on new host
135 CPUs. QEMU has two operating modes:
136
137 - User mode emulation. In this mode, QEMU can launch Linux processes
138   compiled for one CPU on another CPU. Linux system calls are converted
139   because of endianness and 32/64 bit mismatches. Wine (Windows
140   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
141
142 - Full system emulation. In this mode, QEMU emulates a full system,
143   including a processor and various peripherials. It can also be used to
144   provide virtual hosting of several virtual PC on a single server.
145
146 %description -l pl.UTF-8
147 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
148 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
149 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
150
151 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
152   procesy linuksowe skompilowane dla jednego procesora na innym
153   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
154   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
155   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
156   cele QEMU.
157
158 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
159   włączając w to procesor i różne urządzenia peryferyjne. Może być także
160   używane do wirtualnego hostowania kilku wirtualnych pecetów na
161   pojedynczym serwerze.
162
163 %package common
164 Summary:        QEMU common files needed by all QEMU targets
165 Summary(pl.UTF-8):      Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
166 Group:          Development/Tools
167 Requires(postun):       /usr/sbin/groupdel
168 Requires(postun):       /usr/sbin/userdel
169 Requires(pre):  /bin/id
170 Requires(pre):  /usr/bin/getgid
171 Requires(pre):  /usr/sbin/groupadd
172 Requires(pre):  /usr/sbin/useradd
173 Requires:       glib2 >= 1:2.12
174 Requires:       libssh2 >= 1.2.8
175 Provides:       group(qemu)
176 Provides:       user(qemu)
177 Obsoletes:      qemu-kvm-common
178 Conflicts:      qemu < 1.0-2
179
180 %description common
181 QEMU is a generic and open source processor emulator which achieves a
182 good emulation speed by using dynamic translation.
183
184 This package provides the common files needed by all QEMU targets.
185
186 %description common -l pl.UTF-8
187 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
188 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
189
190 Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
191 środowiska QEMU.
192
193 %package img
194 Summary:        QEMU command line tool for manipulating disk images
195 Summary(pl.UTF-8):      Narzędzie QEMU do operacji na obrazach dysków
196 Group:          Development/Tools
197 Conflicts:      qemu < 1.0-2
198 Obsoletes:      qemu-kvm-img
199
200 %description img
201 This package provides a command line tool for manipulating disk
202 images.
203
204 %description img -l pl.UTF-8
205 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
206 na obrazach dysków.
207
208 %package user
209 Summary:        QEMU user mode emulation of qemu targets
210 Summary(pl.UTF-8):      QEMU - emulacja trybu użytkownika środowisk qemu
211 Group:          Development/Tools
212 Requires:       %{name}-common = %{version}-%{release}
213 Obsoletes:      qemu-kvm-user
214
215 %description user
216 QEMU is a generic and open source processor emulator which achieves a
217 good emulation speed by using dynamic translation.
218
219 This package provides the user mode emulation of QEMU targets.
220
221 %description user -l pl.UTF-8
222 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
223 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
224
225 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
226
227 %package system-alpha
228 Summary:        QEMU system emulator for Alpha
229 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Alpha
230 Group:          Development/Tools
231 Requires:       %{name}-common = %{version}-%{release}
232 %systempkg_req
233 Obsoletes:      qemu-kvm-system-alpha
234
235 %description system-alpha
236 QEMU is a generic and open source processor emulator which achieves a
237 good emulation speed by using dynamic translation.
238
239 This package provides the system emulator with Alpha CPU.
240
241 %description system-alpha -l pl.UTF-8
242 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
243 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
244
245 Ten pakiet zawiera emulator systemu z procesorem Alpha.
246
247 %package system-arm
248 Summary:        QEMU system emulator for ARM
249 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem ARM
250 Group:          Development/Tools
251 Requires:       %{name}-common = %{version}-%{release}
252 %systempkg_req
253 Obsoletes:      qemu-kvm-system-arm
254
255 %description system-arm
256 QEMU is a generic and open source processor emulator which achieves a
257 good emulation speed by using dynamic translation.
258
259 This package provides the system emulator for ARM.
260
261 %description system-arm -l pl.UTF-8
262 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
263 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
264
265 Ten pakiet zawiera emulator systemu z procesorem ARM.
266
267 %package system-cris
268 Summary:        QEMU system emulator for CRIS
269 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem CRIS
270 Group:          Development/Tools
271 Requires:       %{name}-common = %{version}-%{release}
272 %systempkg_req
273 Obsoletes:      qemu-kvm-system-cris
274
275 %description system-cris
276 QEMU is a generic and open source processor emulator which achieves a
277 good emulation speed by using dynamic translation.
278
279 This package provides the system emulator with CRIS CPU.
280
281 %description system-cris -l pl.UTF-8
282 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
283 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
284
285 Ten pakiet zawiera emulator systemu z procesorem CRIS.
286
287 %package system-lm32
288 Summary:        QEMU system emulator for LM32
289 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem LM32
290 Group:          Development/Tools
291 Requires:       %{name}-common = %{version}-%{release}
292 %systempkg_req
293 Obsoletes:      qemu-kvm-system-lm32
294
295 %description system-lm32
296 QEMU is a generic and open source processor emulator which achieves a
297 good emulation speed by using dynamic translation.
298
299 This package provides the system emulator with LM32 CPU.
300
301 %description system-lm32 -l pl.UTF-8
302 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
303 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
304
305 Ten pakiet zawiera emulator systemu z procesorem LM32.
306
307 %package system-m68k
308 Summary:        QEMU system emulator for m68k
309 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem m68k
310 Group:          Development/Tools
311 Requires:       %{name}-common = %{version}-%{release}
312 %systempkg_req
313 Obsoletes:      qemu-kvm-system-m68k
314
315 %description system-m68k
316 QEMU is a generic and open source processor emulator which achieves a
317 good emulation speed by using dynamic translation.
318
319 This package provides the system emulator with m68k CPU.
320
321 %description system-m68k -l pl.UTF-8
322 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
323 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
324
325 Ten pakiet zawiera emulator systemu z procesorem m68k.
326
327 %package system-microblaze
328 Summary:        QEMU system emulator for MicroBlaze
329 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MicroBlaze
330 Group:          Development/Tools
331 Requires:       %{name}-common = %{version}-%{release}
332 %systempkg_req
333 Obsoletes:      qemu-kvm-system-microblaze
334
335 %description system-microblaze
336 QEMU is a generic and open source processor emulator which achieves a
337 good emulation speed by using dynamic translation.
338
339 This package provides the system emulator with MicroBlaze CPU.
340
341 %description system-microblaze -l pl.UTF-8
342 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
343 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
344
345 Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
346
347 %package system-mips
348 Summary:        QEMU system emulator for MIPS
349 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MIPS
350 Group:          Development/Tools
351 Requires:       %{name}-common = %{version}-%{release}
352 %systempkg_req
353 Obsoletes:      qemu-kvm-system-mips
354
355 %description system-mips
356 QEMU is a generic and open source processor emulator which achieves a
357 good emulation speed by using dynamic translation.
358
359 This package provides the system emulator with MIPS CPU.
360
361 %description system-mips -l pl.UTF-8
362 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
363 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
364
365 Ten pakiet zawiera emulator systemu z procesorem MIPS.
366
367 %package system-moxie
368 Summary:        QEMU system emulator for Moxie
369 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Moxie
370 Group:          Development/Tools
371 Requires:       %{name}-common = %{version}-%{release}
372 %systempkg_req
373
374 %description system-moxie
375 QEMU is a generic and open source processor emulator which achieves a
376 good emulation speed by using dynamic translation.
377
378 This package provides the system emulator with Moxie CPU.
379
380 %description system-moxie -l pl.UTF-8
381 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
382 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
383
384 Ten pakiet zawiera emulator systemu z procesorem Moxie.
385
386 %package system-or32
387 Summary:        QEMU system emulator for OpenRISC
388 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem OpenRISC
389 Group:          Development/Tools
390 Requires:       %{name}-common = %{version}-%{release}
391 %systempkg_req
392 Obsoletes:      qemu-kvm-system-or32
393
394 %description system-or32
395 QEMU is a generic and open source processor emulator which achieves a
396 good emulation speed by using dynamic translation.
397
398 This package provides the system emulator with OpenRISC CPU.
399
400 %description system-or32 -l pl.UTF-8
401 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
402 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
403
404 Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
405
406 %package system-ppc
407 Summary:        QEMU system emulator for PowerPC
408 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem PowerPC
409 Group:          Development/Tools
410 Requires:       %{name}-common = %{version}-%{release}
411 %systempkg_req
412 Obsoletes:      qemu-kvm-system-ppc
413
414 %description system-ppc
415 QEMU is a generic and open source processor emulator which achieves a
416 good emulation speed by using dynamic translation.
417
418 This package provides the system emulator with PowerPC CPU.
419
420 %description system-ppc -l pl.UTF-8
421 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
422 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
423
424 Ten pakiet zawiera emulator systemu z procesorem PowerPC.
425
426 %package system-s390x
427 Summary:        QEMU system emulator for S390
428 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem S390
429 Group:          Development/Tools
430 Requires:       %{name}-common = %{version}-%{release}
431 %systempkg_req
432 Obsoletes:      qemu-kvm-system-s390x
433
434 %description system-s390x
435 QEMU is a generic and open source processor emulator which achieves a
436 good emulation speed by using dynamic translation.
437
438 This package provides the system emulator with S390 CPU.
439
440 %description system-s390x -l pl.UTF-8
441 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
442 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
443
444 Ten pakiet zawiera emulator systemu z procesorem S390.
445
446 %package system-sh4
447 Summary:        QEMU system emulator for SH4
448 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SH4
449 Group:          Development/Tools
450 Requires:       %{name}-common = %{version}-%{release}
451 %systempkg_req
452 Obsoletes:      qemu-kvm-system-sh4
453
454 %description system-sh4
455 QEMU is a generic and open source processor emulator which achieves a
456 good emulation speed by using dynamic translation.
457
458 This package provides the system emulator with SH4 CPU.
459
460 %description system-sh4 -l pl.UTF-8
461 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
462 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
463
464 Ten pakiet zawiera emulator systemu z procesorem SH4.
465
466 %package system-sparc
467 Summary:        QEMU system emulator for SPARC
468 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SPARC
469 Group:          Development/Tools
470 Requires:       %{name}-common = %{version}-%{release}
471 %systempkg_req
472 Obsoletes:      qemu-kvm-system-sparc
473
474 %description system-sparc
475 QEMU is a generic and open source processor emulator which achieves a
476 good emulation speed by using dynamic translation.
477
478 This package provides the system emulator with SPARC/SPARC64 CPU.
479
480 %description system-sparc -l pl.UTF-8
481 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
482 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
483
484 Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
485
486 %package system-unicore32
487 Summary:        QEMU system emulator for UniCore32
488 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem UniCore32
489 Group:          Development/Tools
490 Requires:       %{name}-common = %{version}-%{release}
491 %systempkg_req
492 Obsoletes:      qemu-kvm-system-unicore32
493
494 %description system-unicore32
495 QEMU is a generic and open source processor emulator which achieves a
496 good emulation speed by using dynamic translation.
497
498 This package provides the system emulator with UniCore32 CPU.
499
500 %description system-unicore32 -l pl.UTF-8
501 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
502 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
503
504 Ten pakiet zawiera emulator systemu z procesorem UniCore32.
505
506 %package system-x86
507 Summary:        QEMU system emulator for x86
508 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem x86
509 Group:          Development/Tools
510 Requires:       %{name}-common = %{version}-%{release}
511 %systempkg_req
512 Obsoletes:      qemu-kvm-system-x86
513
514 %description system-x86
515 QEMU is a generic and open source processor emulator which achieves a
516 good emulation speed by using dynamic translation.
517
518 %description system-x86 -l pl.UTF-8
519 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
520 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
521
522 %package system-xtensa
523 Summary:        QEMU system emulator for Xtensa
524 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Xtensa
525 Group:          Development/Tools
526 Requires:       %{name}-common = %{version}-%{release}
527 %systempkg_req
528 Obsoletes:      qemu-kvm-system-xtensa
529
530 %description system-xtensa
531 QEMU is a generic and open source processor emulator which achieves a
532 good emulation speed by using dynamic translation.
533
534 This package provides the system emulator with Xtensa CPU.
535
536 %description system-xtensa -l pl.UTF-8
537 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
538 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
539
540 Ten pakiet zawiera emulator systemu z procesorem Xtensa.
541
542 %package guest-agent
543 Summary:        QEMU guest agent
544 Summary(pl.UTF-8):      Agent gościa QEMU
545 Group:          Daemons
546 Requires(post,preun,postun):    systemd-units >= 38
547 Requires:       glib2 >= 1:2.12
548 Requires:       systemd-units >= 38
549 Obsoletes:      qemu-kvm-guest-agent
550
551 %description guest-agent
552 QEMU is a generic and open source processor emulator which achieves
553 a good emulation speed by using dynamic translation.
554
555 This package provides an agent to run inside guests, which
556 communicates with the host over a virtio-serial channel named
557 "org.qemu.guest_agent.0".
558
559 This package does not need to be installed on the host OS.
560
561 %description guest-agent -l pl.UTF-8
562 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
563 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
564
565 Ten pakiet udostępnia agenta przeznaczonego do uruchomienia w
566 systemach-gościach, komunikującego się kanałem virtio-serial o nazwie
567 "org.qemu.guest_agent.0".
568
569 Ten pakiet nie musi być zainstalowany w systemie hosta.
570
571 %prep
572 %setup -q
573 %patch0 -p1
574 %patch1 -p1
575 %patch2 -p0
576 %patch3 -p1
577
578 %{__mv} libcacard libcacard-use-system-lib
579
580 # workaround for conflict with alsa/error.h
581 ln -s ../error.h qapi/error.h
582
583 %build
584 ./configure \
585         --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
586         --extra-ldflags="%{rpmldflags}" \
587         --prefix=%{_prefix} \
588         --sysconfdir=%{_sysconfdir} \
589         --cc="%{__cc}" \
590         --host-cc="%{__cc}" \
591         --disable-strip \
592         --enable-attr \
593         --enable-bluez \
594         --enable-brlapi \
595         --enable-cap-ng \
596         --enable-curl \
597         --enable-curses \
598         --enable-docs \
599         --enable-fdt \
600         %{__enable_disable glusterfs} \
601         --enable-libiscsi \
602         --enable-mixemu \
603         %{__enable_disable glx} \
604         %{__enable_disable ceph rbd} \
605         %{__enable_disable rdma} \
606         %{__enable_disable sdl} \
607         --enable-seccomp \
608         %{__enable_disable spice} \
609         --enable-smartcard-nss \
610         --enable-tpm \
611         --enable-usb-redir \
612         --enable-uuid \
613         --enable-vde \
614         --enable-virtfs \
615         --enable-vnc-jpeg \
616         --enable-vnc-png \
617         --enable-vnc-sasl \
618         --enable-vnc-tls \
619         %{__enable_disable xen} \
620         --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
621         --interp-prefix=%{_libdir}/qemu/lib-%%M \
622         --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
623
624 # note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
625 # --libexecdir in configure is nop
626 %{__make} \
627         V=1 \
628         CONFIG_QEMU_HELPERDIR="%{_libdir}"
629
630 # rebuild patched vesa tables with additional widescreen modes.
631 %{__make} -C roms/vgabios stdvga-bios
632
633 %install
634 rm -rf $RPM_BUILD_ROOT
635
636 %{__make} install \
637         DESTDIR=$RPM_BUILD_ROOT \
638         libexecdir=%{_libdir}
639
640 install -d $RPM_BUILD_ROOT%{_sysconfdir}
641 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
642 #!/bin/sh
643
644 EOF
645
646 # For the qemu-guest-agent subpackage install the systemd
647 # service and udev rules.
648 install -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
649 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
650
651 # already packaged
652 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
653 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
654
655 # install patched vesa tables with additional widescreen modes.
656 cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
657
658 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{de_DE,de}
659 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{fr_FR,fr}
660 %find_lang %{name}
661
662 %clean
663 rm -rf $RPM_BUILD_ROOT
664
665 %pre common
666 %groupadd -g 276 qemu
667 %useradd -u 276 -g qemu -c "QEMU User" qemu
668
669 %postun common
670 if [ "$1" = "0" ]; then
671         %userremove qemu
672         %groupremove qemu
673 fi
674
675 %post guest-agent
676 %systemd_reload
677
678 %preun guest-agent
679 %systemd_preun qemu-guest-agent.service
680
681 %postun guest-agent
682 %systemd_reload
683
684 %files
685 %defattr(644,root,root,755)
686
687 %files common -f %{name}.lang
688 %defattr(644,root,root,755)
689 %doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
690 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
691 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
692 %dir %{_sysconfdir}/qemu
693 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
694 %attr(755,root,root) %{_bindir}/qemu-nbd
695 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
696 %{_mandir}/man1/qemu.1*
697 %{_mandir}/man1/virtfs-proxy-helper.1*
698 %{_mandir}/man8/qemu-nbd.8*
699
700 %dir %{_datadir}/qemu
701 %{_datadir}/%{name}/keymaps
702 %{_datadir}/%{name}/qemu-icon.bmp
703 # various bios images
704 %{_datadir}/%{name}/*.aml
705 %{_datadir}/%{name}/*.bin
706 %{_datadir}/%{name}/*.rom
707 %{_datadir}/%{name}/*.dtb
708 %{_datadir}/%{name}/qemu_logo_no_text.svg
709 %{_datadir}/%{name}/openbios-ppc
710 %{_datadir}/%{name}/openbios-sparc*
711 %{_datadir}/%{name}/palcode-clipper
712 %{_datadir}/%{name}/s390-ccw.img
713
714 %files img
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{_bindir}/qemu-img
717 %{_mandir}/man1/qemu-img.1*
718
719 %files user
720 %defattr(644,root,root,755)
721 %attr(755,root,root) %{_bindir}/qemu-alpha
722 %attr(755,root,root) %{_bindir}/qemu-arm
723 %attr(755,root,root) %{_bindir}/qemu-armeb
724 %attr(755,root,root) %{_bindir}/qemu-cris
725 %attr(755,root,root) %{_bindir}/qemu-i386
726 %attr(755,root,root) %{_bindir}/qemu-io
727 %attr(755,root,root) %{_bindir}/qemu-m68k
728 %attr(755,root,root) %{_bindir}/qemu-microblaze
729 %attr(755,root,root) %{_bindir}/qemu-microblazeel
730 %attr(755,root,root) %{_bindir}/qemu-mips
731 %attr(755,root,root) %{_bindir}/qemu-mipsel
732 %attr(755,root,root) %{_bindir}/qemu-mips64
733 %attr(755,root,root) %{_bindir}/qemu-mips64el
734 %attr(755,root,root) %{_bindir}/qemu-mipsn32
735 %attr(755,root,root) %{_bindir}/qemu-mipsn32el
736 %attr(755,root,root) %{_bindir}/qemu-or32
737 %attr(755,root,root) %{_bindir}/qemu-ppc
738 %attr(755,root,root) %{_bindir}/qemu-ppc64
739 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
740 %attr(755,root,root) %{_bindir}/qemu-s390x
741 %attr(755,root,root) %{_bindir}/qemu-sh4
742 %attr(755,root,root) %{_bindir}/qemu-sh4eb
743 %attr(755,root,root) %{_bindir}/qemu-sparc
744 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
745 %attr(755,root,root) %{_bindir}/qemu-sparc64
746 %attr(755,root,root) %{_bindir}/qemu-unicore32
747 %attr(755,root,root) %{_bindir}/qemu-x86_64
748
749 %files system-alpha
750 %defattr(644,root,root,755)
751 %attr(755,root,root) %{_bindir}/qemu-system-alpha
752
753 %files system-arm
754 %defattr(644,root,root,755)
755 %attr(755,root,root) %{_bindir}/qemu-system-arm
756
757 %files system-cris
758 %defattr(644,root,root,755)
759 %attr(755,root,root) %{_bindir}/qemu-system-cris
760
761 %files system-lm32
762 %defattr(644,root,root,755)
763 %attr(755,root,root) %{_bindir}/qemu-system-lm32
764
765 %files system-m68k
766 %defattr(644,root,root,755)
767 %attr(755,root,root) %{_bindir}/qemu-system-m68k
768
769 %files system-microblaze
770 %defattr(644,root,root,755)
771 %attr(755,root,root) %{_bindir}/qemu-system-microblaze
772 %attr(755,root,root) %{_bindir}/qemu-system-microblazeel
773
774 %files system-mips
775 %defattr(644,root,root,755)
776 %attr(755,root,root) %{_bindir}/qemu-system-mips
777 %attr(755,root,root) %{_bindir}/qemu-system-mipsel
778 %attr(755,root,root) %{_bindir}/qemu-system-mips64
779 %attr(755,root,root) %{_bindir}/qemu-system-mips64el
780
781 %files system-moxie
782 %defattr(644,root,root,755)
783 %attr(755,root,root) %{_bindir}/qemu-system-moxie
784
785 %files system-or32
786 %defattr(644,root,root,755)
787 %attr(755,root,root) %{_bindir}/qemu-system-or32
788
789 %files system-ppc
790 %defattr(644,root,root,755)
791 %attr(755,root,root) %{_bindir}/qemu-system-ppc
792 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
793 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
794
795 %files system-s390x
796 %defattr(644,root,root,755)
797 %attr(755,root,root) %{_bindir}/qemu-system-s390x
798
799 %files system-sh4
800 %defattr(644,root,root,755)
801 %attr(755,root,root) %{_bindir}/qemu-system-sh4
802 %attr(755,root,root) %{_bindir}/qemu-system-sh4eb
803
804 %files system-sparc
805 %defattr(644,root,root,755)
806 %attr(755,root,root) %{_bindir}/qemu-system-sparc
807 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
808
809 %files system-unicore32
810 %defattr(644,root,root,755)
811 %attr(755,root,root) %{_bindir}/qemu-system-unicore32
812
813 %files system-x86
814 %defattr(644,root,root,755)
815 %attr(755,root,root) %{_bindir}/qemu-system-i386
816 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
817
818 %files system-xtensa
819 %defattr(644,root,root,755)
820 %attr(755,root,root) %{_bindir}/qemu-system-xtensa
821 %attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
822
823 %files guest-agent
824 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/99-qemu-guest-agent.rules
825 %{systemdunitdir}/qemu-guest-agent.service
826 %attr(755,root,root) %{_bindir}/qemu-ga
This page took 0.091 seconds and 4 git commands to generate.