]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- install qemu VNC sasl config
[packages/qemu.git] / qemu.spec
1 # TODO:
2 # - merge missing bits from qemu-kvm
3 #
4 # Conditional build:
5 %bcond_without  sdl             # SDL UI and audio support
6 %bcond_without  glx             # OpenGL/GLX support
7 %bcond_without  ceph            # Ceph/RBD support
8 %bcond_without  glusterfs       # GlusterFS backend
9 %bcond_without  rdma            # RDMA-based migration support
10 %bcond_with     gtk2            # GTK+ 2.x instead of 3.x
11 %bcond_without  spice           # SPICE support
12 %bcond_with     esd             # EsounD audio support
13 %bcond_without  oss             # OSS audio support
14 %bcond_without  pulseaudio      # PulseAudio audio support
15 %bcond_without  xen             # Xen backend driver support
16
17 Summary:        QEMU CPU Emulator
18 Summary(pl.UTF-8):      QEMU - emulator procesora
19 Name:           qemu
20 Version:        1.6.1
21 Release:        3
22 License:        GPL v2+
23 Group:          Applications/Emulators
24 Source0:        http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
25 # Source0-md5:  3a897d722457c5a895cd6ac79a28fda0
26 Source2:        qemu.binfmt
27 # Loads kvm kernel modules at boot
28 Source3:        kvm-modules-load.conf
29 # Creates /dev/kvm
30 Source4:        80-kvm.rules
31 # KSM control scripts
32 Source5:        ksm.service
33 Source6:        ksm.sysconfig
34 Source7:        ksmctl.c
35 Source8:        ksmtuned.service
36 Source9:        ksmtuned
37 Source10:       ksmtuned.conf
38 Source11:       qemu-guest-agent.service
39 Source12:       99-qemu-guest-agent.rules
40 Patch0:         %{name}-cflags.patch
41 Patch1:         vgabios-widescreens.patch
42 Patch2:         %{name}-whitelist.patch
43 Patch3:         %{name}-system-libcacard.patch
44 # Proof of concept, for reference, do not remove
45 Patch4:         %{name}-kde_virtual_workspaces_hack.patch
46 URL:            http://www.qemu-project.org/
47 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
48 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
49 BuildRequires:  alsa-lib-devel
50 BuildRequires:  bcc
51 BuildRequires:  bluez-libs-devel
52 BuildRequires:  brlapi-devel
53 %{?with_ceph:BuildRequires:     ceph-devel}
54 BuildRequires:  curl-devel
55 BuildRequires:  cyrus-sasl-devel >= 2
56 %{?with_esd:BuildRequires:      esound-devel}
57 BuildRequires:  glib2-devel >= 1:2.12
58 %{?with_glusterfs:BuildRequires:        glusterfs-devel >= 3.4}
59 BuildRequires:  gnutls-devel
60 BuildRequires:  libaio-devel
61 BuildRequires:  libcacard-devel
62 BuildRequires:  libcap-devel
63 BuildRequires:  libcap-ng-devel
64 BuildRequires:  libfdt-devel
65 %{?with_rdma:BuildRequires:     libibverbs-devel}
66 BuildRequires:  libiscsi-devel
67 BuildRequires:  libjpeg-devel
68 BuildRequires:  libpng-devel
69 %{?with_rdma:BuildRequires:     librdmacm-devel}
70 BuildRequires:  libseccomp-devel
71 BuildRequires:  libssh2-devel >= 1.2.8
72 # for usb passthrough, when available
73 #BuildRequires: libusb-devel >= 1.0.13
74 BuildRequires:  libuuid-devel
75 BuildRequires:  ncurses-devel
76 BuildRequires:  nss-devel >= 3.12.8
77 BuildRequires:  perl-Encode
78 BuildRequires:  perl-tools-pod
79 BuildRequires:  pkgconfig
80 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
81 BuildRequires:  rpmbuild(macros) >= 1.644
82 BuildRequires:  sed >= 4.0
83 %if %{with spice}
84 BuildRequires:  spice-protocol >= 0.12.0
85 BuildRequires:  spice-server-devel >= 0.12.0
86 %endif
87 BuildRequires:  texi2html
88 BuildRequires:  texinfo
89 BuildRequires:  usbredir-devel >= 0.6
90 BuildRequires:  vde2-devel
91 BuildRequires:  which
92 %{?with_xen:BuildRequires:      xen-devel >= 3.4}
93 BuildRequires:  xfsprogs-devel
94 BuildRequires:  xorg-lib-libX11-devel
95 BuildRequires:  zlib-devel
96 %if %{with gtk2}
97 BuildRequires:  gtk+2-devel >= 2:2.18.0
98 BuildRequires:  vte0-devel >= 0.24.0
99 %else
100 BuildRequires:  gtk+3-devel >= 3.0.0
101 BuildRequires:  vte-devel >= 0.32.0
102 %endif
103 Requires:       %{name}-img = %{version}-%{release}
104 Requires:       %{name}-system-alpha = %{version}-%{release}
105 Requires:       %{name}-system-arm = %{version}-%{release}
106 Requires:       %{name}-system-cris = %{version}-%{release}
107 Requires:       %{name}-system-lm32 = %{version}-%{release}
108 Requires:       %{name}-system-m68k = %{version}-%{release}
109 Requires:       %{name}-system-microblaze = %{version}-%{release}
110 Requires:       %{name}-system-mips = %{version}-%{release}
111 Requires:       %{name}-system-moxie = %{version}-%{release}
112 Requires:       %{name}-system-or32 = %{version}-%{release}
113 Requires:       %{name}-system-ppc = %{version}-%{release}
114 Requires:       %{name}-system-s390x = %{version}-%{release}
115 Requires:       %{name}-system-sh4 = %{version}-%{release}
116 Requires:       %{name}-system-sparc = %{version}-%{release}
117 Requires:       %{name}-system-unicore32 = %{version}-%{release}
118 Requires:       %{name}-system-x86 = %{version}-%{release}
119 Requires:       %{name}-system-xtensa = %{version}-%{release}
120 Requires:       %{name}-user = %{version}-%{release}
121 Obsoletes:      qemu-kvm
122 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
123
124 %define systempkg_req \
125 Requires:       SDL >= 1.2.1 \
126 Requires:       usbredir >= 0.6 \
127 %if %{with gtk2} \
128 Requires:       gtk+2 >= 2:2.18.0 \
129 Requires:       vte0 >= 0.24.0 \
130 %else \
131 Requires:       gtk+3 >= 3.0.0 \
132 Requires:       vte >= 0.32.0 \
133 %endif
134
135 # some PPC/SPARC boot image in ELF format
136 %define         _noautostrip    .*%{_datadir}/qemu/.*-.*
137
138 %description
139 QEMU is a FAST! processor emulator. By using dynamic translation it
140 achieves a reasonnable speed while being easy to port on new host
141 CPUs. QEMU has two operating modes:
142
143 - User mode emulation. In this mode, QEMU can launch Linux processes
144   compiled for one CPU on another CPU. Linux system calls are converted
145   because of endianness and 32/64 bit mismatches. Wine (Windows
146   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
147
148 - Full system emulation. In this mode, QEMU emulates a full system,
149   including a processor and various peripherials. It can also be used to
150   provide virtual hosting of several virtual PC on a single server.
151
152 %description -l pl.UTF-8
153 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
154 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
155 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
156
157 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
158   procesy linuksowe skompilowane dla jednego procesora na innym
159   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
160   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
161   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
162   cele QEMU.
163
164 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
165   włączając w to procesor i różne urządzenia peryferyjne. Może być także
166   używane do wirtualnego hostowania kilku wirtualnych pecetów na
167   pojedynczym serwerze.
168
169 %package common
170 Summary:        QEMU common files needed by all QEMU targets
171 Summary(pl.UTF-8):      Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
172 Group:          Development/Tools
173 Requires(post,preun,postun):    systemd-units >= 38
174 Requires(postun):       /usr/sbin/groupdel
175 Requires(postun):       /usr/sbin/userdel
176 Requires(pre):  /bin/id
177 Requires(pre):  /usr/bin/getgid
178 Requires(pre):  /usr/sbin/groupadd
179 Requires(pre):  /usr/sbin/useradd
180 Requires:       glib2 >= 1:2.12
181 Requires:       libssh2 >= 1.2.8
182 Requires:       systemd-units >= 38
183 Provides:       group(qemu)
184 Provides:       user(qemu)
185 Obsoletes:      qemu-kvm-common
186 Conflicts:      qemu < 1.0-2
187
188 %description common
189 QEMU is a generic and open source processor emulator which achieves a
190 good emulation speed by using dynamic translation.
191
192 This package provides the common files needed by all QEMU targets.
193
194 %description common -l pl.UTF-8
195 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
196 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
197
198 Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
199 środowiska QEMU.
200
201 %package img
202 Summary:        QEMU command line tool for manipulating disk images
203 Summary(pl.UTF-8):      Narzędzie QEMU do operacji na obrazach dysków
204 Group:          Development/Tools
205 Conflicts:      qemu < 1.0-2
206 Obsoletes:      qemu-kvm-img
207
208 %description img
209 This package provides a command line tool for manipulating disk
210 images.
211
212 %description img -l pl.UTF-8
213 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
214 na obrazach dysków.
215
216 %package user
217 Summary:        QEMU user mode emulation of qemu targets
218 Summary(pl.UTF-8):      QEMU - emulacja trybu użytkownika środowisk qemu
219 Group:          Development/Tools
220 Requires:       %{name}-common = %{version}-%{release}
221 Requires(post,postun):  systemd-units >= 38
222 Requires:       systemd-units >= 38
223 Obsoletes:      qemu-kvm-user
224
225 %description user
226 QEMU is a generic and open source processor emulator which achieves a
227 good emulation speed by using dynamic translation.
228
229 This package provides the user mode emulation of QEMU targets.
230
231 %description user -l pl.UTF-8
232 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
233 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
234
235 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
236
237 %package system-alpha
238 Summary:        QEMU system emulator for Alpha
239 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Alpha
240 Group:          Development/Tools
241 Requires:       %{name}-common = %{version}-%{release}
242 %systempkg_req
243 Obsoletes:      qemu-kvm-system-alpha
244
245 %description system-alpha
246 QEMU is a generic and open source processor emulator which achieves a
247 good emulation speed by using dynamic translation.
248
249 This package provides the system emulator with Alpha CPU.
250
251 %description system-alpha -l pl.UTF-8
252 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
253 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
254
255 Ten pakiet zawiera emulator systemu z procesorem Alpha.
256
257 %package system-arm
258 Summary:        QEMU system emulator for ARM
259 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem ARM
260 Group:          Development/Tools
261 Requires:       %{name}-common = %{version}-%{release}
262 %systempkg_req
263 Obsoletes:      qemu-kvm-system-arm
264
265 %description system-arm
266 QEMU is a generic and open source processor emulator which achieves a
267 good emulation speed by using dynamic translation.
268
269 This package provides the system emulator for ARM.
270
271 %description system-arm -l pl.UTF-8
272 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
273 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
274
275 Ten pakiet zawiera emulator systemu z procesorem ARM.
276
277 %package system-cris
278 Summary:        QEMU system emulator for CRIS
279 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem CRIS
280 Group:          Development/Tools
281 Requires:       %{name}-common = %{version}-%{release}
282 %systempkg_req
283 Obsoletes:      qemu-kvm-system-cris
284
285 %description system-cris
286 QEMU is a generic and open source processor emulator which achieves a
287 good emulation speed by using dynamic translation.
288
289 This package provides the system emulator with CRIS CPU.
290
291 %description system-cris -l pl.UTF-8
292 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
293 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
294
295 Ten pakiet zawiera emulator systemu z procesorem CRIS.
296
297 %package system-lm32
298 Summary:        QEMU system emulator for LM32
299 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem LM32
300 Group:          Development/Tools
301 Requires:       %{name}-common = %{version}-%{release}
302 %systempkg_req
303 Obsoletes:      qemu-kvm-system-lm32
304
305 %description system-lm32
306 QEMU is a generic and open source processor emulator which achieves a
307 good emulation speed by using dynamic translation.
308
309 This package provides the system emulator with LM32 CPU.
310
311 %description system-lm32 -l pl.UTF-8
312 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
313 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
314
315 Ten pakiet zawiera emulator systemu z procesorem LM32.
316
317 %package system-m68k
318 Summary:        QEMU system emulator for m68k
319 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem m68k
320 Group:          Development/Tools
321 Requires:       %{name}-common = %{version}-%{release}
322 %systempkg_req
323 Obsoletes:      qemu-kvm-system-m68k
324
325 %description system-m68k
326 QEMU is a generic and open source processor emulator which achieves a
327 good emulation speed by using dynamic translation.
328
329 This package provides the system emulator with m68k CPU.
330
331 %description system-m68k -l pl.UTF-8
332 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
333 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
334
335 Ten pakiet zawiera emulator systemu z procesorem m68k.
336
337 %package system-microblaze
338 Summary:        QEMU system emulator for MicroBlaze
339 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MicroBlaze
340 Group:          Development/Tools
341 Requires:       %{name}-common = %{version}-%{release}
342 %systempkg_req
343 Obsoletes:      qemu-kvm-system-microblaze
344
345 %description system-microblaze
346 QEMU is a generic and open source processor emulator which achieves a
347 good emulation speed by using dynamic translation.
348
349 This package provides the system emulator with MicroBlaze CPU.
350
351 %description system-microblaze -l pl.UTF-8
352 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
353 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
354
355 Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
356
357 %package system-mips
358 Summary:        QEMU system emulator for MIPS
359 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MIPS
360 Group:          Development/Tools
361 Requires:       %{name}-common = %{version}-%{release}
362 %systempkg_req
363 Obsoletes:      qemu-kvm-system-mips
364
365 %description system-mips
366 QEMU is a generic and open source processor emulator which achieves a
367 good emulation speed by using dynamic translation.
368
369 This package provides the system emulator with MIPS CPU.
370
371 %description system-mips -l pl.UTF-8
372 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
373 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
374
375 Ten pakiet zawiera emulator systemu z procesorem MIPS.
376
377 %package system-moxie
378 Summary:        QEMU system emulator for Moxie
379 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Moxie
380 Group:          Development/Tools
381 Requires:       %{name}-common = %{version}-%{release}
382 %systempkg_req
383
384 %description system-moxie
385 QEMU is a generic and open source processor emulator which achieves a
386 good emulation speed by using dynamic translation.
387
388 This package provides the system emulator with Moxie CPU.
389
390 %description system-moxie -l pl.UTF-8
391 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
392 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
393
394 Ten pakiet zawiera emulator systemu z procesorem Moxie.
395
396 %package system-or32
397 Summary:        QEMU system emulator for OpenRISC
398 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem OpenRISC
399 Group:          Development/Tools
400 Requires:       %{name}-common = %{version}-%{release}
401 %systempkg_req
402 Obsoletes:      qemu-kvm-system-or32
403
404 %description system-or32
405 QEMU is a generic and open source processor emulator which achieves a
406 good emulation speed by using dynamic translation.
407
408 This package provides the system emulator with OpenRISC CPU.
409
410 %description system-or32 -l pl.UTF-8
411 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
412 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
413
414 Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
415
416 %package system-ppc
417 Summary:        QEMU system emulator for PowerPC
418 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem PowerPC
419 Group:          Development/Tools
420 Requires:       %{name}-common = %{version}-%{release}
421 %systempkg_req
422 Obsoletes:      qemu-kvm-system-ppc
423
424 %description system-ppc
425 QEMU is a generic and open source processor emulator which achieves a
426 good emulation speed by using dynamic translation.
427
428 This package provides the system emulator with PowerPC CPU.
429
430 %description system-ppc -l pl.UTF-8
431 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
432 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
433
434 Ten pakiet zawiera emulator systemu z procesorem PowerPC.
435
436 %package system-s390x
437 Summary:        QEMU system emulator for S390
438 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem S390
439 Group:          Development/Tools
440 Requires:       %{name}-common = %{version}-%{release}
441 %systempkg_req
442 Obsoletes:      qemu-kvm-system-s390x
443
444 %description system-s390x
445 QEMU is a generic and open source processor emulator which achieves a
446 good emulation speed by using dynamic translation.
447
448 This package provides the system emulator with S390 CPU.
449
450 %description system-s390x -l pl.UTF-8
451 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
452 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
453
454 Ten pakiet zawiera emulator systemu z procesorem S390.
455
456 %package system-sh4
457 Summary:        QEMU system emulator for SH4
458 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SH4
459 Group:          Development/Tools
460 Requires:       %{name}-common = %{version}-%{release}
461 %systempkg_req
462 Obsoletes:      qemu-kvm-system-sh4
463
464 %description system-sh4
465 QEMU is a generic and open source processor emulator which achieves a
466 good emulation speed by using dynamic translation.
467
468 This package provides the system emulator with SH4 CPU.
469
470 %description system-sh4 -l pl.UTF-8
471 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
472 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
473
474 Ten pakiet zawiera emulator systemu z procesorem SH4.
475
476 %package system-sparc
477 Summary:        QEMU system emulator for SPARC
478 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SPARC
479 Group:          Development/Tools
480 Requires:       %{name}-common = %{version}-%{release}
481 %systempkg_req
482 Obsoletes:      qemu-kvm-system-sparc
483
484 %description system-sparc
485 QEMU is a generic and open source processor emulator which achieves a
486 good emulation speed by using dynamic translation.
487
488 This package provides the system emulator with SPARC/SPARC64 CPU.
489
490 %description system-sparc -l pl.UTF-8
491 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
492 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
493
494 Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
495
496 %package system-unicore32
497 Summary:        QEMU system emulator for UniCore32
498 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem UniCore32
499 Group:          Development/Tools
500 Requires:       %{name}-common = %{version}-%{release}
501 %systempkg_req
502 Obsoletes:      qemu-kvm-system-unicore32
503
504 %description system-unicore32
505 QEMU is a generic and open source processor emulator which achieves a
506 good emulation speed by using dynamic translation.
507
508 This package provides the system emulator with UniCore32 CPU.
509
510 %description system-unicore32 -l pl.UTF-8
511 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
512 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
513
514 Ten pakiet zawiera emulator systemu z procesorem UniCore32.
515
516 %package system-x86
517 Summary:        QEMU system emulator for x86
518 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem x86
519 Group:          Development/Tools
520 Requires:       %{name}-common = %{version}-%{release}
521 %systempkg_req
522 Obsoletes:      kvm
523 Obsoletes:      qemu-kvm-system-x86
524
525 %description system-x86
526 QEMU is a generic and open source processor emulator which achieves a
527 good emulation speed by using dynamic translation.
528
529 %description system-x86 -l pl.UTF-8
530 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
531 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
532
533 %package system-xtensa
534 Summary:        QEMU system emulator for Xtensa
535 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Xtensa
536 Group:          Development/Tools
537 Requires:       %{name}-common = %{version}-%{release}
538 %systempkg_req
539 Obsoletes:      qemu-kvm-system-xtensa
540
541 %description system-xtensa
542 QEMU is a generic and open source processor emulator which achieves a
543 good emulation speed by using dynamic translation.
544
545 This package provides the system emulator with Xtensa CPU.
546
547 %description system-xtensa -l pl.UTF-8
548 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
549 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
550
551 Ten pakiet zawiera emulator systemu z procesorem Xtensa.
552
553 %package guest-agent
554 Summary:        QEMU guest agent
555 Summary(pl.UTF-8):      Agent gościa QEMU
556 Group:          Daemons
557 Requires(post,preun,postun):    systemd-units >= 38
558 Requires:       glib2 >= 1:2.12
559 Requires:       systemd-units >= 38
560 Obsoletes:      qemu-kvm-guest-agent
561
562 %description guest-agent
563 QEMU is a generic and open source processor emulator which achieves
564 a good emulation speed by using dynamic translation.
565
566 This package provides an agent to run inside guests, which
567 communicates with the host over a virtio-serial channel named
568 "org.qemu.guest_agent.0".
569
570 This package does not need to be installed on the host OS.
571
572 %description guest-agent -l pl.UTF-8
573 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
574 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
575
576 Ten pakiet udostępnia agenta przeznaczonego do uruchomienia w
577 systemach-gościach, komunikującego się kanałem virtio-serial o nazwie
578 "org.qemu.guest_agent.0".
579
580 Ten pakiet nie musi być zainstalowany w systemie hosta.
581
582 %prep
583 %setup -q
584 %patch0 -p1
585 %patch1 -p1
586 %patch2 -p0
587 %patch3 -p1
588
589 %{__mv} libcacard libcacard-use-system-lib
590
591 # workaround for conflict with alsa/error.h
592 ln -s ../error.h qapi/error.h
593
594 %build
595 ./configure \
596         --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
597         --extra-ldflags="%{rpmldflags}" \
598         --prefix=%{_prefix} \
599         --sysconfdir=%{_sysconfdir} \
600         --cc="%{__cc}" \
601         --host-cc="%{__cc}" \
602         --disable-strip \
603         --enable-attr \
604         --enable-bluez \
605         --enable-brlapi \
606         --enable-cap-ng \
607         --enable-curl \
608         --enable-curses \
609         --enable-docs \
610         --enable-fdt \
611         %{__enable_disable glusterfs} \
612         --enable-libiscsi \
613         --enable-mixemu \
614         %{__enable_disable glx} \
615         %{__enable_disable ceph rbd} \
616         %{__enable_disable rdma} \
617         %{__enable_disable sdl} \
618         --enable-seccomp \
619         %{__enable_disable spice} \
620         --enable-smartcard-nss \
621         --enable-tpm \
622         --enable-usb-redir \
623         --enable-uuid \
624         --enable-vde \
625         --enable-virtfs \
626         --enable-vnc-jpeg \
627         --enable-vnc-png \
628         --enable-vnc-sasl \
629         --enable-vnc-tls \
630         --enable-kvm \
631         %{__enable_disable xen} \
632         --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
633         --interp-prefix=%{_libdir}/qemu/lib-%%M \
634         --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
635
636 # note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
637 # --libexecdir in configure is nop
638 %{__make} \
639         V=1 \
640         CONFIG_QEMU_HELPERDIR="%{_libdir}"
641
642 # rebuild patched vesa tables with additional widescreen modes.
643 %{__make} -C roms/vgabios stdvga-bios
644
645 %{__cc} %{SOURCE7} %{rpmcflags} -o ksmctl
646
647 %install
648 rm -rf $RPM_BUILD_ROOT
649 install -d $RPM_BUILD_ROOT{%{systemdunitdir},/usr/lib/binfmt.d} \
650         $RPM_BUILD_ROOT/etc/{sysconfig,udev/rules.d,modules-load.d} \
651         $RPM_BUILD_ROOT{%{_sysconfdir}/sasl,%{_sbindir}}
652
653 %{__make} install \
654         DESTDIR=$RPM_BUILD_ROOT \
655         libexecdir=%{_libdir}
656
657 install -d $RPM_BUILD_ROOT%{_sysconfdir}
658 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
659 #!/bin/sh
660
661 EOF
662
663 install -p qemu.sasl $RPM_BUILD_ROOT%{_sysconfdir}/sasl/qemu.conf
664
665 %ifarch %{ix86} %{x8664}
666 install scripts/kvm/kvm_stat $RPM_BUILD_ROOT%{_bindir}
667 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/modules-load.d/kvm.conf
668 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
669 %endif
670
671 install -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/ksm.service
672 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/ksm
673 install -p ksmctl $RPM_BUILD_ROOT%{_sbindir}
674
675 install -p %{SOURCE8} $RPM_BUILD_ROOT%{systemdunitdir}/ksmtuned.service
676 install -p %{SOURCE9} $RPM_BUILD_ROOT%{_sbindir}/ksmtuned
677 install -p %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/ksmtuned.conf
678
679 # For the qemu-guest-agent subpackage install the systemd
680 # service and udev rules.
681 install -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
682 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
683
684 for i in dummy \
685 %ifnarch %{ix86} %{x8664}
686     qemu-i386 \
687 %endif
688 %ifnarch arm
689     qemu-arm \
690 %endif
691 %ifnarch ppc ppc64
692     qemu-ppc \
693 %endif
694 %ifnarch sparc sparc64
695     qemu-sparc \
696 %endif
697 %ifnarch sh4
698     qemu-sh4 \
699 %endif
700 ; do
701         test $i = dummy && continue
702         grep /$i:\$ %{SOURCE2} > $RPM_BUILD_ROOT/usr/lib/binfmt.d/$i.conf
703 done < %{SOURCE2}
704
705 # already packaged
706 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
707 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
708
709 # install patched vesa tables with additional widescreen modes.
710 cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
711
712 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{de_DE,de}
713 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{fr_FR,fr}
714 %find_lang %{name}
715
716 %clean
717 rm -rf $RPM_BUILD_ROOT
718
719 %pre common
720 %groupadd -g 276 qemu
721 %useradd -u 276 -g qemu -c "QEMU User" qemu
722
723 %post common
724 %systemd_post ksm.service
725 %systemd_post ksmtuned.service
726
727 %preun common
728 %systemd_preun ksm.service
729 %systemd_preun ksmtuned.service
730
731 %postun common
732 if [ "$1" = "0" ]; then
733         %userremove qemu
734         %groupremove qemu
735 fi
736 %systemd_reload
737
738 %triggerpostun common -- qemu-common < 1.6.1-4
739 %systemd_trigger ksm.service
740 %systemd_trigger ksmtuned.service
741
742 %post user
743 %systemd_service_restart systemd-binfmt.service
744
745 %postun user
746 %systemd_service_restart systemd-binfmt.service
747
748 %post guest-agent
749 %systemd_reload
750
751 %preun guest-agent
752 %systemd_preun qemu-guest-agent.service
753
754 %postun guest-agent
755 %systemd_reload
756
757 %files
758 %defattr(644,root,root,755)
759
760 %files common -f %{name}.lang
761 %defattr(644,root,root,755)
762 %doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
763 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
764 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
765 %config(noreplace) %verify(not md5 mtime size) /etc/ksmtuned.conf
766 %config(noreplace) %verify(not md5 mtime size) /etc/sasl/qemu.conf
767 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ksm
768 %{systemdunitdir}/ksm.service
769 %{systemdunitdir}/ksmtuned.service
770 %dir %{_sysconfdir}/qemu
771 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
772 %attr(755,root,root) %{_bindir}/qemu-nbd
773 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
774 %attr(755,root,root) %{_sbindir}/ksmctl
775 %attr(755,root,root) %{_sbindir}/ksmtuned
776 %{_mandir}/man1/qemu.1*
777 %{_mandir}/man1/virtfs-proxy-helper.1*
778 %{_mandir}/man8/qemu-nbd.8*
779
780 %dir %{_datadir}/qemu
781 %{_datadir}/%{name}/keymaps
782 %{_datadir}/%{name}/qemu-icon.bmp
783 # various bios images
784 %{_datadir}/%{name}/*.aml
785 %{_datadir}/%{name}/*.bin
786 %{_datadir}/%{name}/*.rom
787 %{_datadir}/%{name}/*.dtb
788 %{_datadir}/%{name}/qemu_logo_no_text.svg
789 %{_datadir}/%{name}/openbios-ppc
790 %{_datadir}/%{name}/openbios-sparc*
791 %{_datadir}/%{name}/palcode-clipper
792 %{_datadir}/%{name}/s390-ccw.img
793
794 %files img
795 %defattr(644,root,root,755)
796 %attr(755,root,root) %{_bindir}/qemu-img
797 %{_mandir}/man1/qemu-img.1*
798
799 %files user
800 %defattr(644,root,root,755)
801 /usr/lib/binfmt.d/qemu-*.conf
802 %attr(755,root,root) %{_bindir}/qemu-alpha
803 %attr(755,root,root) %{_bindir}/qemu-arm
804 %attr(755,root,root) %{_bindir}/qemu-armeb
805 %attr(755,root,root) %{_bindir}/qemu-cris
806 %attr(755,root,root) %{_bindir}/qemu-i386
807 %attr(755,root,root) %{_bindir}/qemu-io
808 %attr(755,root,root) %{_bindir}/qemu-m68k
809 %attr(755,root,root) %{_bindir}/qemu-microblaze
810 %attr(755,root,root) %{_bindir}/qemu-microblazeel
811 %attr(755,root,root) %{_bindir}/qemu-mips
812 %attr(755,root,root) %{_bindir}/qemu-mipsel
813 %attr(755,root,root) %{_bindir}/qemu-mips64
814 %attr(755,root,root) %{_bindir}/qemu-mips64el
815 %attr(755,root,root) %{_bindir}/qemu-mipsn32
816 %attr(755,root,root) %{_bindir}/qemu-mipsn32el
817 %attr(755,root,root) %{_bindir}/qemu-or32
818 %attr(755,root,root) %{_bindir}/qemu-ppc
819 %attr(755,root,root) %{_bindir}/qemu-ppc64
820 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
821 %attr(755,root,root) %{_bindir}/qemu-s390x
822 %attr(755,root,root) %{_bindir}/qemu-sh4
823 %attr(755,root,root) %{_bindir}/qemu-sh4eb
824 %attr(755,root,root) %{_bindir}/qemu-sparc
825 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
826 %attr(755,root,root) %{_bindir}/qemu-sparc64
827 %attr(755,root,root) %{_bindir}/qemu-unicore32
828 %attr(755,root,root) %{_bindir}/qemu-x86_64
829
830 %files system-alpha
831 %defattr(644,root,root,755)
832 %attr(755,root,root) %{_bindir}/qemu-system-alpha
833
834 %files system-arm
835 %defattr(644,root,root,755)
836 %attr(755,root,root) %{_bindir}/qemu-system-arm
837
838 %files system-cris
839 %defattr(644,root,root,755)
840 %attr(755,root,root) %{_bindir}/qemu-system-cris
841
842 %files system-lm32
843 %defattr(644,root,root,755)
844 %attr(755,root,root) %{_bindir}/qemu-system-lm32
845
846 %files system-m68k
847 %defattr(644,root,root,755)
848 %attr(755,root,root) %{_bindir}/qemu-system-m68k
849
850 %files system-microblaze
851 %defattr(644,root,root,755)
852 %attr(755,root,root) %{_bindir}/qemu-system-microblaze
853 %attr(755,root,root) %{_bindir}/qemu-system-microblazeel
854
855 %files system-mips
856 %defattr(644,root,root,755)
857 %attr(755,root,root) %{_bindir}/qemu-system-mips
858 %attr(755,root,root) %{_bindir}/qemu-system-mipsel
859 %attr(755,root,root) %{_bindir}/qemu-system-mips64
860 %attr(755,root,root) %{_bindir}/qemu-system-mips64el
861
862 %files system-moxie
863 %defattr(644,root,root,755)
864 %attr(755,root,root) %{_bindir}/qemu-system-moxie
865
866 %files system-or32
867 %defattr(644,root,root,755)
868 %attr(755,root,root) %{_bindir}/qemu-system-or32
869
870 %files system-ppc
871 %defattr(644,root,root,755)
872 %attr(755,root,root) %{_bindir}/qemu-system-ppc
873 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
874 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
875
876 %files system-s390x
877 %defattr(644,root,root,755)
878 %attr(755,root,root) %{_bindir}/qemu-system-s390x
879
880 %files system-sh4
881 %defattr(644,root,root,755)
882 %attr(755,root,root) %{_bindir}/qemu-system-sh4
883 %attr(755,root,root) %{_bindir}/qemu-system-sh4eb
884
885 %files system-sparc
886 %defattr(644,root,root,755)
887 %attr(755,root,root) %{_bindir}/qemu-system-sparc
888 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
889
890 %files system-unicore32
891 %defattr(644,root,root,755)
892 %attr(755,root,root) %{_bindir}/qemu-system-unicore32
893
894 %files system-x86
895 %defattr(644,root,root,755)
896 %attr(755,root,root) %{_bindir}/qemu-system-i386
897 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
898 %ifarch %{ix86} %{x8664}
899 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/kvm.conf
900 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/80-kvm.rules
901 %attr(755,root,root) %{_bindir}/kvm_stat
902 %endif
903
904 %files system-xtensa
905 %defattr(644,root,root,755)
906 %attr(755,root,root) %{_bindir}/qemu-system-xtensa
907 %attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
908
909 %files guest-agent
910 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/99-qemu-guest-agent.rules
911 %{systemdunitdir}/qemu-guest-agent.service
912 %attr(755,root,root) %{_bindir}/qemu-ga
This page took 0.081497 seconds and 4 git commands to generate.