]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
'without smartcard' bcond fix
[packages/qemu.git] / qemu.spec
1 #
2 # Conditional build:
3 %bcond_without  sdl             # SDL UI and audio support
4 %bcond_without  glx             # OpenGL/GLX support
5 %bcond_without  ceph            # Ceph/RBD support
6 %bcond_without  glusterfs       # GlusterFS backend
7 %bcond_without  rdma            # RDMA-based migration support
8 %bcond_with     gtk2            # GTK+ 2.x instead of 3.x
9 %bcond_without  gtk3            # Do not build GTK UI
10 %bcond_without  spice           # SPICE support
11 %bcond_with     esd             # EsounD audio support
12 %bcond_without  oss             # OSS audio support
13 %bcond_without  pulseaudio      # PulseAudio audio support
14 %bcond_without  xen             # Xen backend driver support
15 %bcond_without  bluetooth       # bluetooth support
16 %bcond_without  brlapi          # brlapi support
17 %bcond_without  smartcard       # smartcard-nss support
18 %bcond_without  iscsi           # iscsi support
19 %bcond_without  seccomp         # seccomp support
20 %bcond_without  usbredir        # usb network redirection support
21
22 %if %{with gtk2}
23 %undefine with_gtk3
24 %endif
25
26 Summary:        QEMU CPU Emulator
27 Summary(pl.UTF-8):      QEMU - emulator procesora
28 Name:           qemu
29 Version:        1.7.1
30 Release:        1
31 License:        GPL v2+
32 Group:          Applications/Emulators
33 Source0:        http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
34 # Source0-md5:  9541063d999cf9659ed7fdce71314f31
35 Source2:        %{name}.binfmt
36 # Loads kvm kernel modules at boot
37 Source3:        kvm-modules-load.conf
38 # Creates /dev/kvm
39 Source4:        80-kvm.rules
40 # KSM control scripts
41 Source5:        ksm.service
42 Source6:        ksm.sysconfig
43 Source7:        ksmctl.c
44 Source8:        ksmtuned.service
45 Source9:        ksmtuned
46 Source10:       ksmtuned.conf
47 Source11:       %{name}-guest-agent.service
48 Source12:       99-%{name}-guest-agent.rules
49 Patch0:         %{name}-cflags.patch
50 Patch1:         vgabios-widescreens.patch
51 Patch2:         %{name}-whitelist.patch
52 Patch3:         %{name}-system-libcacard.patch
53 Patch4:         vmdk3ro.patch
54 Patch5:         %{name}-xattr.patch
55 Patch6:         libjpeg-boolean.patch
56 # Proof of concept, for reference, do not remove
57 Patch400:       %{name}-kde_virtual_workspaces_hack.patch
58 URL:            http://www.qemu-project.org/
59 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
60 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
61 BuildRequires:  alsa-lib-devel
62 BuildRequires:  bcc
63 %{?with_bluetooth:BuildRequires:        bluez-libs-devel}
64 %{?with_brlapi:BuildRequires:   brlapi-devel}
65 %{?with_ceph:BuildRequires:     ceph-devel}
66 BuildRequires:  curl-devel
67 BuildRequires:  cyrus-sasl-devel >= 2
68 %{?with_esd:BuildRequires:      esound-devel}
69 BuildRequires:  glib2-devel >= 1:2.12
70 %{?with_glusterfs:BuildRequires:        glusterfs-devel >= 3.4}
71 BuildRequires:  gnutls-devel
72 BuildRequires:  libaio-devel
73 %{?with_smartcard:BuildRequires:        libcacard-devel}
74 BuildRequires:  libcap-devel
75 BuildRequires:  libcap-ng-devel
76 BuildRequires:  libfdt-devel
77 %{?with_rdma:BuildRequires:     libibverbs-devel}
78 %{?with_iscsi:BuildRequires:    libiscsi-devel}
79 BuildRequires:  libjpeg-devel
80 BuildRequires:  libpng-devel
81 %{?with_rdma:BuildRequires:     librdmacm-devel}
82 %{?with_seccomp:BuildRequires:  libseccomp-devel}
83 BuildRequires:  libssh2-devel >= 1.2.8
84 # for usb passthrough, when available
85 #BuildRequires: libusb-devel >= 1.0.13
86 BuildRequires:  libuuid-devel
87 BuildRequires:  ncurses-devel
88 %{?with_smartcard:BuildRequires:        nss-devel >= 3.12.8}
89 BuildRequires:  perl-Encode
90 BuildRequires:  perl-tools-pod
91 BuildRequires:  pkgconfig
92 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
93 BuildRequires:  rpmbuild(macros) >= 1.644
94 BuildRequires:  sed >= 4.0
95 %if %{with spice}
96 BuildRequires:  spice-protocol >= 0.12.0
97 BuildRequires:  spice-server-devel >= 0.12.0
98 %endif
99 BuildRequires:  texi2html
100 BuildRequires:  texinfo
101 %{?with_usbredir:BuildRequires: usbredir-devel >= 0.6}
102 BuildRequires:  vde2-devel
103 BuildRequires:  which
104 %{?with_xen:BuildRequires:      xen-devel >= 3.4}
105 BuildRequires:  xfsprogs-devel
106 BuildRequires:  xorg-lib-libX11-devel
107 BuildRequires:  zlib-devel
108 %if %{with gtk2}
109 BuildRequires:  gtk+2-devel >= 2:2.18.0
110 BuildRequires:  vte0-devel >= 0.24.0
111 %endif
112 %if %{with gtk3}
113 BuildRequires:  gtk+3-devel >= 3.0.0
114 BuildRequires:  vte-devel >= 0.32.0
115 %endif
116 Requires:       %{name}-img = %{version}-%{release}
117 Requires:       %{name}-system-alpha = %{version}-%{release}
118 Requires:       %{name}-system-arm = %{version}-%{release}
119 Requires:       %{name}-system-cris = %{version}-%{release}
120 Requires:       %{name}-system-lm32 = %{version}-%{release}
121 Requires:       %{name}-system-m68k = %{version}-%{release}
122 Requires:       %{name}-system-microblaze = %{version}-%{release}
123 Requires:       %{name}-system-mips = %{version}-%{release}
124 Requires:       %{name}-system-moxie = %{version}-%{release}
125 Requires:       %{name}-system-or32 = %{version}-%{release}
126 Requires:       %{name}-system-ppc = %{version}-%{release}
127 Requires:       %{name}-system-s390x = %{version}-%{release}
128 Requires:       %{name}-system-sh4 = %{version}-%{release}
129 Requires:       %{name}-system-sparc = %{version}-%{release}
130 Requires:       %{name}-system-unicore32 = %{version}-%{release}
131 Requires:       %{name}-system-x86 = %{version}-%{release}
132 Requires:       %{name}-system-xtensa = %{version}-%{release}
133 Requires:       %{name}-user = %{version}-%{release}
134 Obsoletes:      qemu-kvm
135 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
136
137 %define systempkg_req \
138 Requires:       SDL >= 1.2.1 \
139 %if %{with usbredir} \
140 Requires:       usbredir >= 0.6 \
141 %endif \
142 %if %{with gtk2} \
143 Requires:       gtk+2 >= 2:2.18.0 \
144 Requires:       vte0 >= 0.24.0 \
145 %endif \
146 %if %{with gtk3} \
147 Requires:       gtk+3 >= 3.0.0 \
148 Requires:       vte >= 0.32.0 \
149 %endif
150
151 # some PPC/SPARC boot image in ELF format
152 %define         _noautostrip    .*%{_datadir}/qemu/.*-.*
153
154 %description
155 QEMU is a FAST! processor emulator. By using dynamic translation it
156 achieves a reasonnable speed while being easy to port on new host
157 CPUs. QEMU has two operating modes:
158
159 - User mode emulation. In this mode, QEMU can launch Linux processes
160   compiled for one CPU on another CPU. Linux system calls are converted
161   because of endianness and 32/64 bit mismatches. Wine (Windows
162   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
163
164 - Full system emulation. In this mode, QEMU emulates a full system,
165   including a processor and various peripherials. It can also be used to
166   provide virtual hosting of several virtual PC on a single server.
167
168 %description -l pl.UTF-8
169 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
170 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
171 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
172
173 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
174   procesy linuksowe skompilowane dla jednego procesora na innym
175   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
176   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
177   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
178   cele QEMU.
179
180 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
181   włączając w to procesor i różne urządzenia peryferyjne. Może być także
182   używane do wirtualnego hostowania kilku wirtualnych pecetów na
183   pojedynczym serwerze.
184
185 %package common
186 Summary:        QEMU common files needed by all QEMU targets
187 Summary(pl.UTF-8):      Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
188 Group:          Development/Tools
189 Requires(post,preun,postun):    systemd-units >= 38
190 Requires(postun):       /usr/sbin/groupdel
191 Requires(postun):       /usr/sbin/userdel
192 Requires(pre):  /bin/id
193 Requires(pre):  /usr/bin/getgid
194 Requires(pre):  /usr/sbin/groupadd
195 Requires(pre):  /usr/sbin/useradd
196 Requires:       glib2 >= 1:2.12
197 Requires:       libssh2 >= 1.2.8
198 Requires:       systemd-units >= 38
199 Provides:       group(qemu)
200 Provides:       user(qemu)
201 Obsoletes:      qemu-kvm-common
202 Conflicts:      qemu < 1.0-2
203
204 %description common
205 QEMU is a generic and open source processor emulator which achieves a
206 good emulation speed by using dynamic translation.
207
208 This package provides the common files needed by all QEMU targets.
209
210 %description common -l pl.UTF-8
211 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
212 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
213
214 Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
215 środowiska QEMU.
216
217 %package img
218 Summary:        QEMU command line tool for manipulating disk images
219 Summary(pl.UTF-8):      Narzędzie QEMU do operacji na obrazach dysków
220 Group:          Development/Tools
221 Obsoletes:      qemu-kvm-img
222 Conflicts:      qemu < 1.0-2
223
224 %description img
225 This package provides a command line tool for manipulating disk
226 images.
227
228 %description img -l pl.UTF-8
229 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
230 na obrazach dysków.
231
232 %package user
233 Summary:        QEMU user mode emulation of qemu targets
234 Summary(pl.UTF-8):      QEMU - emulacja trybu użytkownika środowisk qemu
235 Group:          Development/Tools
236 Requires:       %{name}-common = %{version}-%{release}
237 Requires(post,postun):  systemd-units >= 38
238 Requires:       systemd-units >= 38
239 Obsoletes:      qemu-kvm-user
240
241 %description user
242 QEMU is a generic and open source processor emulator which achieves a
243 good emulation speed by using dynamic translation.
244
245 This package provides the user mode emulation of QEMU targets.
246
247 %description user -l pl.UTF-8
248 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
249 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
250
251 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
252
253 %package system-alpha
254 Summary:        QEMU system emulator for Alpha
255 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Alpha
256 Group:          Development/Tools
257 Requires:       %{name}-common = %{version}-%{release}
258 %systempkg_req
259 Obsoletes:      qemu-kvm-system-alpha
260
261 %description system-alpha
262 QEMU is a generic and open source processor emulator which achieves a
263 good emulation speed by using dynamic translation.
264
265 This package provides the system emulator with Alpha CPU.
266
267 %description system-alpha -l pl.UTF-8
268 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
269 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
270
271 Ten pakiet zawiera emulator systemu z procesorem Alpha.
272
273 %package system-arm
274 Summary:        QEMU system emulator for ARM
275 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem ARM
276 Group:          Development/Tools
277 Requires:       %{name}-common = %{version}-%{release}
278 %systempkg_req
279 Obsoletes:      qemu-kvm-system-arm
280
281 %description system-arm
282 QEMU is a generic and open source processor emulator which achieves a
283 good emulation speed by using dynamic translation.
284
285 This package provides the system emulator for ARM.
286
287 %description system-arm -l pl.UTF-8
288 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
289 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
290
291 Ten pakiet zawiera emulator systemu z procesorem ARM.
292
293 %package system-cris
294 Summary:        QEMU system emulator for CRIS
295 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem CRIS
296 Group:          Development/Tools
297 Requires:       %{name}-common = %{version}-%{release}
298 %systempkg_req
299 Obsoletes:      qemu-kvm-system-cris
300
301 %description system-cris
302 QEMU is a generic and open source processor emulator which achieves a
303 good emulation speed by using dynamic translation.
304
305 This package provides the system emulator with CRIS CPU.
306
307 %description system-cris -l pl.UTF-8
308 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
309 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
310
311 Ten pakiet zawiera emulator systemu z procesorem CRIS.
312
313 %package system-lm32
314 Summary:        QEMU system emulator for LM32
315 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem LM32
316 Group:          Development/Tools
317 Requires:       %{name}-common = %{version}-%{release}
318 %systempkg_req
319 Obsoletes:      qemu-kvm-system-lm32
320
321 %description system-lm32
322 QEMU is a generic and open source processor emulator which achieves a
323 good emulation speed by using dynamic translation.
324
325 This package provides the system emulator with LM32 CPU.
326
327 %description system-lm32 -l pl.UTF-8
328 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
329 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
330
331 Ten pakiet zawiera emulator systemu z procesorem LM32.
332
333 %package system-m68k
334 Summary:        QEMU system emulator for m68k
335 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem m68k
336 Group:          Development/Tools
337 Requires:       %{name}-common = %{version}-%{release}
338 %systempkg_req
339 Obsoletes:      qemu-kvm-system-m68k
340
341 %description system-m68k
342 QEMU is a generic and open source processor emulator which achieves a
343 good emulation speed by using dynamic translation.
344
345 This package provides the system emulator with m68k CPU.
346
347 %description system-m68k -l pl.UTF-8
348 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
349 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
350
351 Ten pakiet zawiera emulator systemu z procesorem m68k.
352
353 %package system-microblaze
354 Summary:        QEMU system emulator for MicroBlaze
355 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MicroBlaze
356 Group:          Development/Tools
357 Requires:       %{name}-common = %{version}-%{release}
358 %systempkg_req
359 Obsoletes:      qemu-kvm-system-microblaze
360
361 %description system-microblaze
362 QEMU is a generic and open source processor emulator which achieves a
363 good emulation speed by using dynamic translation.
364
365 This package provides the system emulator with MicroBlaze CPU.
366
367 %description system-microblaze -l pl.UTF-8
368 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
369 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
370
371 Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
372
373 %package system-mips
374 Summary:        QEMU system emulator for MIPS
375 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MIPS
376 Group:          Development/Tools
377 Requires:       %{name}-common = %{version}-%{release}
378 %systempkg_req
379 Obsoletes:      qemu-kvm-system-mips
380
381 %description system-mips
382 QEMU is a generic and open source processor emulator which achieves a
383 good emulation speed by using dynamic translation.
384
385 This package provides the system emulator with MIPS CPU.
386
387 %description system-mips -l pl.UTF-8
388 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
389 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
390
391 Ten pakiet zawiera emulator systemu z procesorem MIPS.
392
393 %package system-moxie
394 Summary:        QEMU system emulator for Moxie
395 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Moxie
396 Group:          Development/Tools
397 Requires:       %{name}-common = %{version}-%{release}
398 %systempkg_req
399
400 %description system-moxie
401 QEMU is a generic and open source processor emulator which achieves a
402 good emulation speed by using dynamic translation.
403
404 This package provides the system emulator with Moxie CPU.
405
406 %description system-moxie -l pl.UTF-8
407 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
408 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
409
410 Ten pakiet zawiera emulator systemu z procesorem Moxie.
411
412 %package system-or32
413 Summary:        QEMU system emulator for OpenRISC
414 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem OpenRISC
415 Group:          Development/Tools
416 Requires:       %{name}-common = %{version}-%{release}
417 %systempkg_req
418 Obsoletes:      qemu-kvm-system-or32
419
420 %description system-or32
421 QEMU is a generic and open source processor emulator which achieves a
422 good emulation speed by using dynamic translation.
423
424 This package provides the system emulator with OpenRISC CPU.
425
426 %description system-or32 -l pl.UTF-8
427 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
428 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
429
430 Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
431
432 %package system-ppc
433 Summary:        QEMU system emulator for PowerPC
434 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem PowerPC
435 Group:          Development/Tools
436 Requires:       %{name}-common = %{version}-%{release}
437 %systempkg_req
438 Obsoletes:      qemu-kvm-system-ppc
439
440 %description system-ppc
441 QEMU is a generic and open source processor emulator which achieves a
442 good emulation speed by using dynamic translation.
443
444 This package provides the system emulator with PowerPC CPU.
445
446 %description system-ppc -l pl.UTF-8
447 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
448 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
449
450 Ten pakiet zawiera emulator systemu z procesorem PowerPC.
451
452 %package system-s390x
453 Summary:        QEMU system emulator for S390
454 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem S390
455 Group:          Development/Tools
456 Requires:       %{name}-common = %{version}-%{release}
457 %systempkg_req
458 Obsoletes:      qemu-kvm-system-s390x
459
460 %description system-s390x
461 QEMU is a generic and open source processor emulator which achieves a
462 good emulation speed by using dynamic translation.
463
464 This package provides the system emulator with S390 CPU.
465
466 %description system-s390x -l pl.UTF-8
467 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
468 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
469
470 Ten pakiet zawiera emulator systemu z procesorem S390.
471
472 %package system-sh4
473 Summary:        QEMU system emulator for SH4
474 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SH4
475 Group:          Development/Tools
476 Requires:       %{name}-common = %{version}-%{release}
477 %systempkg_req
478 Obsoletes:      qemu-kvm-system-sh4
479
480 %description system-sh4
481 QEMU is a generic and open source processor emulator which achieves a
482 good emulation speed by using dynamic translation.
483
484 This package provides the system emulator with SH4 CPU.
485
486 %description system-sh4 -l pl.UTF-8
487 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
488 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
489
490 Ten pakiet zawiera emulator systemu z procesorem SH4.
491
492 %package system-sparc
493 Summary:        QEMU system emulator for SPARC
494 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SPARC
495 Group:          Development/Tools
496 Requires:       %{name}-common = %{version}-%{release}
497 %systempkg_req
498 Obsoletes:      qemu-kvm-system-sparc
499
500 %description system-sparc
501 QEMU is a generic and open source processor emulator which achieves a
502 good emulation speed by using dynamic translation.
503
504 This package provides the system emulator with SPARC/SPARC64 CPU.
505
506 %description system-sparc -l pl.UTF-8
507 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
508 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
509
510 Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
511
512 %package system-unicore32
513 Summary:        QEMU system emulator for UniCore32
514 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem UniCore32
515 Group:          Development/Tools
516 Requires:       %{name}-common = %{version}-%{release}
517 %systempkg_req
518 Obsoletes:      qemu-kvm-system-unicore32
519
520 %description system-unicore32
521 QEMU is a generic and open source processor emulator which achieves a
522 good emulation speed by using dynamic translation.
523
524 This package provides the system emulator with UniCore32 CPU.
525
526 %description system-unicore32 -l pl.UTF-8
527 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
528 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
529
530 Ten pakiet zawiera emulator systemu z procesorem UniCore32.
531
532 %package system-x86
533 Summary:        QEMU system emulator for x86
534 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem x86
535 Group:          Development/Tools
536 Requires:       %{name}-common = %{version}-%{release}
537 %systempkg_req
538 Obsoletes:      kvm
539 Obsoletes:      qemu-kvm-system-x86
540
541 %description system-x86
542 QEMU is a generic and open source processor emulator which achieves a
543 good emulation speed by using dynamic translation.
544
545 %description system-x86 -l pl.UTF-8
546 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
547 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
548
549 %package system-xtensa
550 Summary:        QEMU system emulator for Xtensa
551 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Xtensa
552 Group:          Development/Tools
553 Requires:       %{name}-common = %{version}-%{release}
554 %systempkg_req
555 Obsoletes:      qemu-kvm-system-xtensa
556
557 %description system-xtensa
558 QEMU is a generic and open source processor emulator which achieves a
559 good emulation speed by using dynamic translation.
560
561 This package provides the system emulator with Xtensa CPU.
562
563 %description system-xtensa -l pl.UTF-8
564 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
565 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
566
567 Ten pakiet zawiera emulator systemu z procesorem Xtensa.
568
569 %package guest-agent
570 Summary:        QEMU guest agent
571 Summary(pl.UTF-8):      Agent gościa QEMU
572 Group:          Daemons
573 Requires(post,preun,postun):    systemd-units >= 38
574 Requires:       glib2 >= 1:2.12
575 Requires:       systemd-units >= 38
576 Obsoletes:      qemu-kvm-guest-agent
577
578 %description guest-agent
579 QEMU is a generic and open source processor emulator which achieves a
580 good emulation speed by using dynamic translation.
581
582 This package provides an agent to run inside guests, which
583 communicates with the host over a virtio-serial channel named
584 "org.qemu.guest_agent.0".
585
586 This package does not need to be installed on the host OS.
587
588 %description guest-agent -l pl.UTF-8
589 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
590 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
591
592 Ten pakiet udostępnia agenta przeznaczonego do uruchomienia w
593 systemach-gościach, komunikującego się kanałem virtio-serial o nazwie
594 "org.qemu.guest_agent.0".
595
596 Ten pakiet nie musi być zainstalowany w systemie hosta.
597
598 %prep
599 %setup -q
600 %patch0 -p1
601 %patch1 -p1
602 %patch2 -p0
603 %patch3 -p1
604 %patch4 -p1
605 %patch5 -p1
606 %patch6 -p1
607
608 %{__mv} libcacard libcacard-use-system-lib
609
610 # workaround for conflict with alsa/error.h
611 ln -s ../error.h qapi/error.h
612
613 %build
614 ./configure \
615         --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
616         --extra-ldflags="%{rpmldflags}" \
617         --prefix=%{_prefix} \
618         --sysconfdir=%{_sysconfdir} \
619         --cc="%{__cc}" \
620         --host-cc="%{__cc}" \
621         --disable-strip \
622         --enable-attr \
623         %{__enable_disable bluetooth bluez} \
624         %{__enable_disable brlapi} \
625         --enable-cap-ng \
626         --enable-curl \
627         --enable-curses \
628         --enable-docs \
629         --enable-fdt \
630         %{__enable_disable glusterfs} \
631         %{__enable_disable iscsi libiscsi} \
632         %{__enable_disable glx} \
633         %{__enable_disable ceph rbd} \
634         %{__enable_disable rdma} \
635         %{__enable_disable sdl} \
636         %{__enable_disable seccomp} \
637         %{__enable_disable spice} \
638         %{__enable_disable smartcard smartcard-nss} \
639         --enable-tpm \
640         %{__enable_disable usbredir usb-redir} \
641         --enable-uuid \
642         --enable-vde \
643         --enable-virtfs \
644         --enable-vnc-jpeg \
645         --enable-vnc-png \
646         --enable-vnc-sasl \
647         --enable-vnc-tls \
648         --enable-kvm \
649         %{__enable_disable xen} \
650         --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
651         --interp-prefix=%{_libdir}/qemu/lib-%%M \
652 %if %{without gtk2} && %{without gtk3}
653         --disable-gtk
654 %else
655         --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
656 %endif
657
658 # note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
659 # --libexecdir in configure is nop
660 %{__make} \
661         V=1 \
662         CONFIG_QEMU_HELPERDIR="%{_libdir}" \
663         %{!?with_smartcard:CONFIG_USB_SMARTCARD=n}
664
665 # rebuild patched vesa tables with additional widescreen modes.
666 %{__make} -C roms/vgabios stdvga-bios
667
668 %{__cc} %{SOURCE7} %{rpmcflags} -o ksmctl
669
670 %install
671 rm -rf $RPM_BUILD_ROOT
672 install -d $RPM_BUILD_ROOT{%{systemdunitdir},/usr/lib/binfmt.d} \
673         $RPM_BUILD_ROOT/etc/{sysconfig,udev/rules.d,modules-load.d} \
674         $RPM_BUILD_ROOT{%{_sysconfdir}/sasl,%{_sbindir}}
675
676 %{__make} install \
677         %{!?with_smartcard:CONFIG_USB_SMARTCARD=n} \
678         DESTDIR=$RPM_BUILD_ROOT \
679         libexecdir=%{_libdir}
680
681 install -d $RPM_BUILD_ROOT%{_sysconfdir}
682 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
683 #!/bin/sh
684
685 EOF
686
687 install -p qemu.sasl $RPM_BUILD_ROOT%{_sysconfdir}/sasl/qemu.conf
688
689 %ifarch %{ix86} %{x8664}
690 install -p scripts/kvm/kvm_stat $RPM_BUILD_ROOT%{_bindir}
691 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/modules-load.d/kvm.conf
692 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
693 %endif
694
695 install -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/ksm.service
696 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/ksm
697 install -p ksmctl $RPM_BUILD_ROOT%{_sbindir}
698
699 install -p %{SOURCE8} $RPM_BUILD_ROOT%{systemdunitdir}/ksmtuned.service
700 install -p %{SOURCE9} $RPM_BUILD_ROOT%{_sbindir}/ksmtuned
701 install -p %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/ksmtuned.conf
702
703 # For the qemu-guest-agent subpackage install the systemd
704 # service and udev rules.
705 install -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
706 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
707
708 for i in dummy \
709 %ifnarch %{ix86} %{x8664}
710         qemu-i386 \
711 %endif
712 %ifnarch arm
713         qemu-arm \
714 %endif
715 %ifnarch ppc ppc64
716         qemu-ppc \
717 %endif
718 %ifnarch sparc sparc64
719         qemu-sparc \
720 %endif
721 %ifnarch sh4
722         qemu-sh4 \
723 %endif
724 ; do
725         test $i = dummy && continue
726         grep /$i:\$ %{SOURCE2} > $RPM_BUILD_ROOT/usr/lib/binfmt.d/$i.conf
727 done < %{SOURCE2}
728
729 # packaged as %doc
730 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
731 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
732
733 # install patched vesa tables with additional widescreen modes.
734 cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
735
736 %if %{with gtk2} || %{with gtk3}
737 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{de_DE,de}
738 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{fr_FR,fr}
739 %find_lang %{name}
740 %else
741 : > qemu.lang
742 %endif
743
744 %clean
745 rm -rf $RPM_BUILD_ROOT
746
747 %pre common
748 %groupadd -g 160 kvm
749 %groupadd -g 276 qemu
750 %useradd -u 276 -g qemu -G kvm -c "QEMU User" qemu
751
752 %post common
753 %systemd_post ksm.service
754 %systemd_post ksmtuned.service
755
756 %preun common
757 %systemd_preun ksm.service
758 %systemd_preun ksmtuned.service
759
760 %postun common
761 if [ "$1" = "0" ]; then
762         %userremove qemu
763         %groupremove qemu
764         %groupremove kvm
765 fi
766 %systemd_reload
767
768 %triggerpostun common -- qemu-common < 1.6.1-4
769 %systemd_trigger ksm.service
770 %systemd_trigger ksmtuned.service
771
772 %post user
773 %systemd_service_restart systemd-binfmt.service
774
775 %postun user
776 %systemd_service_restart systemd-binfmt.service
777
778 %post guest-agent
779 %systemd_reload
780
781 %preun guest-agent
782 %systemd_preun qemu-guest-agent.service
783
784 %postun guest-agent
785 %systemd_reload
786
787 %files
788 %defattr(644,root,root,755)
789
790 %files common -f %{name}.lang
791 %defattr(644,root,root,755)
792 %doc README qemu-doc.html qemu-tech.html qmp-commands.txt
793 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
794 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
795 %config(noreplace) %verify(not md5 mtime size) /etc/ksmtuned.conf
796 %config(noreplace) %verify(not md5 mtime size) /etc/sasl/qemu.conf
797 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ksm
798 %{systemdunitdir}/ksm.service
799 %{systemdunitdir}/ksmtuned.service
800 %dir %{_sysconfdir}/qemu
801 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
802 %attr(755,root,root) %{_bindir}/qemu-nbd
803 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
804 %attr(755,root,root) %{_sbindir}/ksmctl
805 %attr(755,root,root) %{_sbindir}/ksmtuned
806 %{_mandir}/man1/qemu.1*
807 %{_mandir}/man1/virtfs-proxy-helper.1*
808 %{_mandir}/man8/qemu-nbd.8*
809
810 %dir %{_datadir}/qemu
811 %{_datadir}/%{name}/keymaps
812 %{_datadir}/%{name}/qemu-icon.bmp
813 # various bios images
814 %{_datadir}/%{name}/*.aml
815 %{_datadir}/%{name}/*.bin
816 %{_datadir}/%{name}/*.rom
817 %{_datadir}/%{name}/*.dtb
818 %{_datadir}/%{name}/qemu_logo_no_text.svg
819 %{_datadir}/%{name}/openbios-ppc
820 %{_datadir}/%{name}/openbios-sparc*
821 %{_datadir}/%{name}/palcode-clipper
822 %{_datadir}/%{name}/s390-ccw.img
823
824 %files img
825 %defattr(644,root,root,755)
826 %attr(755,root,root) %{_bindir}/qemu-img
827 %{_mandir}/man1/qemu-img.1*
828
829 %files user
830 %defattr(644,root,root,755)
831 /usr/lib/binfmt.d/qemu-*.conf
832 %attr(755,root,root) %{_bindir}/qemu-alpha
833 %attr(755,root,root) %{_bindir}/qemu-arm
834 %attr(755,root,root) %{_bindir}/qemu-armeb
835 %attr(755,root,root) %{_bindir}/qemu-cris
836 %attr(755,root,root) %{_bindir}/qemu-i386
837 %attr(755,root,root) %{_bindir}/qemu-io
838 %attr(755,root,root) %{_bindir}/qemu-m68k
839 %attr(755,root,root) %{_bindir}/qemu-microblaze
840 %attr(755,root,root) %{_bindir}/qemu-microblazeel
841 %attr(755,root,root) %{_bindir}/qemu-mips
842 %attr(755,root,root) %{_bindir}/qemu-mipsel
843 %attr(755,root,root) %{_bindir}/qemu-mips64
844 %attr(755,root,root) %{_bindir}/qemu-mips64el
845 %attr(755,root,root) %{_bindir}/qemu-mipsn32
846 %attr(755,root,root) %{_bindir}/qemu-mipsn32el
847 %attr(755,root,root) %{_bindir}/qemu-or32
848 %attr(755,root,root) %{_bindir}/qemu-ppc
849 %attr(755,root,root) %{_bindir}/qemu-ppc64
850 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
851 %attr(755,root,root) %{_bindir}/qemu-s390x
852 %attr(755,root,root) %{_bindir}/qemu-sh4
853 %attr(755,root,root) %{_bindir}/qemu-sh4eb
854 %attr(755,root,root) %{_bindir}/qemu-sparc
855 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
856 %attr(755,root,root) %{_bindir}/qemu-sparc64
857 %attr(755,root,root) %{_bindir}/qemu-unicore32
858 %attr(755,root,root) %{_bindir}/qemu-x86_64
859
860 %files system-alpha
861 %defattr(644,root,root,755)
862 %attr(755,root,root) %{_bindir}/qemu-system-alpha
863
864 %files system-arm
865 %defattr(644,root,root,755)
866 %attr(755,root,root) %{_bindir}/qemu-system-arm
867
868 %files system-cris
869 %defattr(644,root,root,755)
870 %attr(755,root,root) %{_bindir}/qemu-system-cris
871
872 %files system-lm32
873 %defattr(644,root,root,755)
874 %attr(755,root,root) %{_bindir}/qemu-system-lm32
875
876 %files system-m68k
877 %defattr(644,root,root,755)
878 %attr(755,root,root) %{_bindir}/qemu-system-m68k
879
880 %files system-microblaze
881 %defattr(644,root,root,755)
882 %attr(755,root,root) %{_bindir}/qemu-system-microblaze
883 %attr(755,root,root) %{_bindir}/qemu-system-microblazeel
884
885 %files system-mips
886 %defattr(644,root,root,755)
887 %attr(755,root,root) %{_bindir}/qemu-system-mips
888 %attr(755,root,root) %{_bindir}/qemu-system-mipsel
889 %attr(755,root,root) %{_bindir}/qemu-system-mips64
890 %attr(755,root,root) %{_bindir}/qemu-system-mips64el
891
892 %files system-moxie
893 %defattr(644,root,root,755)
894 %attr(755,root,root) %{_bindir}/qemu-system-moxie
895
896 %files system-or32
897 %defattr(644,root,root,755)
898 %attr(755,root,root) %{_bindir}/qemu-system-or32
899
900 %files system-ppc
901 %defattr(644,root,root,755)
902 %attr(755,root,root) %{_bindir}/qemu-system-ppc
903 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
904 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
905
906 %files system-s390x
907 %defattr(644,root,root,755)
908 %attr(755,root,root) %{_bindir}/qemu-system-s390x
909
910 %files system-sh4
911 %defattr(644,root,root,755)
912 %attr(755,root,root) %{_bindir}/qemu-system-sh4
913 %attr(755,root,root) %{_bindir}/qemu-system-sh4eb
914
915 %files system-sparc
916 %defattr(644,root,root,755)
917 %attr(755,root,root) %{_bindir}/qemu-system-sparc
918 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
919
920 %files system-unicore32
921 %defattr(644,root,root,755)
922 %attr(755,root,root) %{_bindir}/qemu-system-unicore32
923
924 %files system-x86
925 %defattr(644,root,root,755)
926 %attr(755,root,root) %{_bindir}/qemu-system-i386
927 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
928 %ifarch %{ix86} %{x8664}
929 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/kvm.conf
930 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/80-kvm.rules
931 %attr(755,root,root) %{_bindir}/kvm_stat
932 %endif
933
934 %files system-xtensa
935 %defattr(644,root,root,755)
936 %attr(755,root,root) %{_bindir}/qemu-system-xtensa
937 %attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
938
939 %files guest-agent
940 %defattr(644,root,root,755)
941 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/99-qemu-guest-agent.rules
942 %{systemdunitdir}/qemu-guest-agent.service
943 %attr(755,root,root) %{_bindir}/qemu-ga
This page took 0.098571 seconds and 4 git commands to generate.