]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- removed obsolete usbredir patch
[packages/qemu.git] / qemu.spec
1 # TODO:
2 # - --enable-glusterfs
3 # - qemu-system-ppc -hda ac-ppc.img says:
4 #   qemu: could not open disk image ac-ppc.img: error "Success"
5 #   qemu-0.12.2-2.x86_64.rpm - broken
6 #   qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
7 #   qemu-0.15.0-2.x86_64.rpm - qemu-system-sparc/ppc booting with -kernel, -initrd options stalls in openbios prompt
8 #   qemu-0.11.1-*.x86_64.rpm - OK
9 #
10 # Conditional build:
11 %bcond_without  sdl             # SDL UI and audio support
12 %bcond_without  opengl          # OpenGL support
13 %bcond_without  ceph            # Ceph/RBD support
14 %bcond_with     glusterfs       # GlusterFS backend
15 %bcond_without  spice           # SPICE support
16 %bcond_with     esd             # EsounD audio support
17 %bcond_without  oss             # OSS audio support
18 %bcond_without  pulseaudio      # PulseAudio audio support
19 %bcond_without  xen             # Xen backend driver support
20
21 Summary:        QEMU CPU Emulator
22 Summary(pl.UTF-8):      QEMU - emulator procesora
23 Name:           qemu
24 Version:        1.3.0
25 Release:        0.1
26 License:        GPL v2+
27 Group:          Applications/Emulators
28 Source0:        http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
29 # Source0-md5:  a4030ddd2ba324152a97d65d3c0b247d
30 Patch0:         %{name}-cflags.patch
31 Patch1:         vgabios-widescreens.patch
32 Patch2:         %{name}-whitelist.patch
33 Patch3:         %{name}-system-libcacard.patch
34 # Proof of concept, for reference, do not remove
35 Patch4:         %{name}-kde_virtual_workspaces_hack.patch
36 URL:            http://www.qemu-project.org/
37 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
38 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
39 BuildRequires:  alsa-lib-devel
40 BuildRequires:  bluez-libs-devel
41 BuildRequires:  brlapi-devel
42 %{?with_ceph:BuildRequires:     ceph-devel}
43 BuildRequires:  curl-devel
44 BuildRequires:  cyrus-sasl-devel >= 2
45 %{?with_esd:BuildRequires:      esound-devel}
46 BuildRequires:  glib2-devel >= 1:2.12
47 BuildRequires:  gnutls-devel
48 BuildRequires:  libaio-devel
49 BuildRequires:  libcacard-devel
50 BuildRequires:  libcap-devel
51 BuildRequires:  libcap-ng-devel
52 BuildRequires:  libfdt-devel
53 BuildRequires:  libiscsi-devel
54 BuildRequires:  libjpeg-devel
55 BuildRequires:  libpng-devel
56 BuildRequires:  libseccomp-devel
57 BuildRequires:  libuuid-devel
58 BuildRequires:  ncurses-devel
59 BuildRequires:  nss-devel >= 3.12.8
60 BuildRequires:  perl-Encode
61 BuildRequires:  perl-tools-pod
62 BuildRequires:  pkgconfig
63 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
64 BuildRequires:  sed >= 4.0
65 %if %{with spice}
66 BuildRequires:  spice-protocol >= 0.8.0
67 BuildRequires:  spice-server-devel >= 0.8.2
68 %endif
69 BuildRequires:  texi2html
70 BuildRequires:  texinfo
71 BuildRequires:  usbredir-devel >= 0.5.3
72 BuildRequires:  vde2-devel
73 BuildRequires:  which
74 %{?with_xen:BuildRequires:      xen-devel >= 3.4}
75 BuildRequires:  xfsprogs-devel
76 BuildRequires:  xorg-lib-libX11-devel
77 BuildRequires:  zlib-devel
78 Requires:       %{name}-img = %{version}-%{release}
79 Requires:       %{name}-system-alpha = %{version}-%{release}
80 Requires:       %{name}-system-arm = %{version}-%{release}
81 Requires:       %{name}-system-cris = %{version}-%{release}
82 Requires:       %{name}-system-lm32 = %{version}-%{release}
83 Requires:       %{name}-system-m68k = %{version}-%{release}
84 Requires:       %{name}-system-microblaze = %{version}-%{release}
85 Requires:       %{name}-system-mips = %{version}-%{release}
86 Requires:       %{name}-system-or32 = %{version}-%{release}
87 Requires:       %{name}-system-ppc = %{version}-%{release}
88 Requires:       %{name}-system-s390x = %{version}-%{release}
89 Requires:       %{name}-system-sh4 = %{version}-%{release}
90 Requires:       %{name}-system-sparc = %{version}-%{release}
91 Requires:       %{name}-system-unicore32 = %{version}-%{release}
92 Requires:       %{name}-system-x86 = %{version}-%{release}
93 Requires:       %{name}-system-xtensa = %{version}-%{release}
94 Requires:       %{name}-user = %{version}-%{release}
95 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97 %define systempkg_req \
98 Requires:       SDL >= 1.2.1 \
99 Requires:       usbredir >= 0.5.3
100
101 # some PPC/SPARC boot image in ELF format
102 %define         _noautostrip    .*%{_datadir}/qemu/.*-.*
103
104 %description
105 QEMU is a FAST! processor emulator. By using dynamic translation it
106 achieves a reasonnable speed while being easy to port on new host
107 CPUs. QEMU has two operating modes:
108
109 - User mode emulation. In this mode, QEMU can launch Linux processes
110   compiled for one CPU on another CPU. Linux system calls are converted
111   because of endianness and 32/64 bit mismatches. Wine (Windows
112   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
113
114 - Full system emulation. In this mode, QEMU emulates a full system,
115   including a processor and various peripherials. It can also be used to
116   provide virtual hosting of several virtual PC on a single server.
117
118 %description -l pl.UTF-8
119 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
120 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
121 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
122
123 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
124   procesy linuksowe skompilowane dla jednego procesora na innym
125   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
126   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
127   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
128   cele QEMU.
129
130 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
131   włączając w to procesor i różne urządzenia peryferyjne. Może być także
132   używane do wirtualnego hostowania kilku wirtualnych pecetów na
133   pojedynczym serwerze.
134
135 %package common
136 Summary:        QEMU common files needed by all QEMU targets
137 Summary(pl.UTF-8):      Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
138 Group:          Development/Tools
139 Requires:       glib2 >= 1:2.12
140 Conflicts:      qemu < 1.0-2
141
142 %description common
143 QEMU is a generic and open source processor emulator which achieves a
144 good emulation speed by using dynamic translation.
145
146 This package provides the common files needed by all QEMU targets.
147
148 %description common -l pl.UTF-8
149 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
150 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
151
152 Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
153 środowiska QEMU.
154
155 %package img
156 Summary:        QEMU command line tool for manipulating disk images
157 Summary(pl.UTF-8):      Narzędzie QEMU do operacji na obrazach dysków
158 Group:          Development/Tools
159 Conflicts:      qemu < 1.0-2
160
161 %description img
162 This package provides a command line tool for manipulating disk
163 images.
164
165 %description img -l pl.UTF-8
166 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
167 na obrazach dysków.
168
169 %package user
170 Summary:        QEMU user mode emulation of qemu targets
171 Summary(pl.UTF-8):      QEMU - emulacja trybu użytkownika środowisk qemu
172 Group:          Development/Tools
173 Requires:       %{name}-common = %{version}-%{release}
174
175 %description user
176 QEMU is a generic and open source processor emulator which achieves a
177 good emulation speed by using dynamic translation.
178
179 This package provides the user mode emulation of QEMU targets.
180
181 %description user -l pl.UTF-8
182 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
183 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
184
185 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
186
187 %package system-alpha
188 Summary:        QEMU system emulator for Alpha
189 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Alpha
190 Group:          Development/Tools
191 Requires:       %{name}-common = %{version}-%{release}
192 %systempkg_req
193
194 %description system-alpha
195 QEMU is a generic and open source processor emulator which achieves a
196 good emulation speed by using dynamic translation.
197
198 This package provides the system emulator with Alpha CPU.
199
200 %description system-alpha -l pl.UTF-8
201 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
202 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
203
204 Ten pakiet zawiera emulator systemu z procesorem Alpha.
205
206 %package system-arm
207 Summary:        QEMU system emulator for ARM
208 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem ARM
209 Group:          Development/Tools
210 Requires:       %{name}-common = %{version}-%{release}
211 %systempkg_req
212
213 %description system-arm
214 QEMU is a generic and open source processor emulator which achieves a
215 good emulation speed by using dynamic translation.
216
217 This package provides the system emulator for ARM.
218
219 %description system-arm -l pl.UTF-8
220 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
221 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
222
223 Ten pakiet zawiera emulator systemu z procesorem ARM.
224
225 %package system-cris
226 Summary:        QEMU system emulator for CRIS
227 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem CRIS
228 Group:          Development/Tools
229 Requires:       %{name}-common = %{version}-%{release}
230 %systempkg_req
231
232 %description system-cris
233 QEMU is a generic and open source processor emulator which achieves a
234 good emulation speed by using dynamic translation.
235
236 This package provides the system emulator with CRIS CPU.
237
238 %description system-cris -l pl.UTF-8
239 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
240 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
241
242 Ten pakiet zawiera emulator systemu z procesorem CRIS.
243
244 %package system-lm32
245 Summary:        QEMU system emulator for LM32
246 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem LM32
247 Group:          Development/Tools
248 Requires:       %{name}-common = %{version}-%{release}
249 %systempkg_req
250
251 %description system-lm32
252 QEMU is a generic and open source processor emulator which achieves a
253 good emulation speed by using dynamic translation.
254
255 This package provides the system emulator with LM32 CPU.
256
257 %description system-lm32 -l pl.UTF-8
258 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
259 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
260
261 Ten pakiet zawiera emulator systemu z procesorem LM32.
262
263 %package system-m68k
264 Summary:        QEMU system emulator for m68k
265 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem m68k
266 Group:          Development/Tools
267 Requires:       %{name}-common = %{version}-%{release}
268 %systempkg_req
269
270 %description system-m68k
271 QEMU is a generic and open source processor emulator which achieves a
272 good emulation speed by using dynamic translation.
273
274 This package provides the system emulator with m68k CPU.
275
276 %description system-m68k -l pl.UTF-8
277 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
278 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
279
280 Ten pakiet zawiera emulator systemu z procesorem m68k.
281
282 %package system-microblaze
283 Summary:        QEMU system emulator for MicroBlaze
284 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MicroBlaze
285 Group:          Development/Tools
286 Requires:       %{name}-common = %{version}-%{release}
287 %systempkg_req
288
289 %description system-microblaze
290 QEMU is a generic and open source processor emulator which achieves a
291 good emulation speed by using dynamic translation.
292
293 This package provides the system emulator with MicroBlaze CPU.
294
295 %description system-microblaze -l pl.UTF-8
296 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
297 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
298
299 Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
300
301 %package system-mips
302 Summary:        QEMU system emulator for MIPS
303 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MIPS
304 Group:          Development/Tools
305 Requires:       %{name}-common = %{version}-%{release}
306 %systempkg_req
307
308 %description system-mips
309 QEMU is a generic and open source processor emulator which achieves a
310 good emulation speed by using dynamic translation.
311
312 This package provides the system emulator with MIPS CPU.
313
314 %description system-mips -l pl.UTF-8
315 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
316 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
317
318 Ten pakiet zawiera emulator systemu z procesorem MIPS.
319
320 %package system-or32
321 Summary:        QEMU system emulator for OpenRISC
322 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem OpenRISC
323 Group:          Development/Tools
324 Requires:       %{name}-common = %{version}-%{release}
325 %systempkg_req
326
327 %description system-or32
328 QEMU is a generic and open source processor emulator which achieves a
329 good emulation speed by using dynamic translation.
330
331 This package provides the system emulator with OpenRISC CPU.
332
333 %description system-or32 -l pl.UTF-8
334 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
335 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
336
337 Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
338
339 %package system-ppc
340 Summary:        QEMU system emulator for PowerPC
341 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem PowerPC
342 Group:          Development/Tools
343 Requires:       %{name}-common = %{version}-%{release}
344 %systempkg_req
345
346 %description system-ppc
347 QEMU is a generic and open source processor emulator which achieves a
348 good emulation speed by using dynamic translation.
349
350 This package provides the system emulator with PowerPC CPU.
351
352 %description system-ppc -l pl.UTF-8
353 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
354 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
355
356 Ten pakiet zawiera emulator systemu z procesorem PowerPC.
357
358 %package system-s390x
359 Summary:        QEMU system emulator for S390
360 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem S390
361 Group:          Development/Tools
362 Requires:       %{name}-common = %{version}-%{release}
363 %systempkg_req
364
365 %description system-s390x
366 QEMU is a generic and open source processor emulator which achieves a
367 good emulation speed by using dynamic translation.
368
369 This package provides the system emulator with S390 CPU.
370
371 %description system-s390x -l pl.UTF-8
372 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
373 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
374
375 Ten pakiet zawiera emulator systemu z procesorem S390.
376
377 %package system-sh4
378 Summary:        QEMU system emulator for SH4
379 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SH4
380 Group:          Development/Tools
381 Requires:       %{name}-common = %{version}-%{release}
382 %systempkg_req
383
384 %description system-sh4
385 QEMU is a generic and open source processor emulator which achieves a
386 good emulation speed by using dynamic translation.
387
388 This package provides the system emulator with SH4 CPU.
389
390 %description system-sh4 -l pl.UTF-8
391 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
392 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
393
394 Ten pakiet zawiera emulator systemu z procesorem SH4.
395
396 %package system-sparc
397 Summary:        QEMU system emulator for SPARC
398 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SPARC
399 Group:          Development/Tools
400 Requires:       %{name}-common = %{version}-%{release}
401 %systempkg_req
402
403 %description system-sparc
404 QEMU is a generic and open source processor emulator which achieves a
405 good emulation speed by using dynamic translation.
406
407 This package provides the system emulator with SPARC/SPARC64 CPU.
408
409 %description system-sparc -l pl.UTF-8
410 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
411 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
412
413 Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
414
415 %package system-unicore32
416 Summary:        QEMU system emulator for UniCore32
417 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem UniCore32
418 Group:          Development/Tools
419 Requires:       %{name}-common = %{version}-%{release}
420 %systempkg_req
421
422 %description system-unicore32
423 QEMU is a generic and open source processor emulator which achieves a
424 good emulation speed by using dynamic translation.
425
426 This package provides the system emulator with UniCore32 CPU.
427
428 %description system-unicore32 -l pl.UTF-8
429 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
430 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
431
432 Ten pakiet zawiera emulator systemu z procesorem UniCore32.
433
434 %package system-x86
435 Summary:        QEMU system emulator for x86
436 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem x86
437 Group:          Development/Tools
438 Requires:       %{name}-common = %{version}-%{release}
439 %systempkg_req
440
441 %description system-x86
442 QEMU is a generic and open source processor emulator which achieves a
443 good emulation speed by using dynamic translation.
444
445 %description system-x86 -l pl.UTF-8
446 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
447 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
448
449 %package system-xtensa
450 Summary:        QEMU system emulator for Xtensa
451 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Xtensa
452 Group:          Development/Tools
453 Requires:       %{name}-common = %{version}-%{release}
454 %systempkg_req
455
456 %description system-xtensa
457 QEMU is a generic and open source processor emulator which achieves a
458 good emulation speed by using dynamic translation.
459
460 This package provides the system emulator with Xtensa CPU.
461
462 %description system-xtensa -l pl.UTF-8
463 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
464 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
465
466 Ten pakiet zawiera emulator systemu z procesorem Xtensa.
467
468 %prep
469 %setup -q
470 %patch0 -p1
471 %patch1 -p1
472 %patch2 -p0
473 %patch3 -p1
474
475 %{__mv} libcacard libcacard-use-system-lib
476
477 # workaround for conflict with alsa/error.h
478 ln -s ../error.h qapi/error.h
479
480 %build
481 ./configure \
482         --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
483         --extra-ldflags="%{rpmldflags}" \
484         --prefix=%{_prefix} \
485         --sysconfdir=%{_sysconfdir} \
486         --cc="%{__cc}" \
487         --host-cc="%{__cc}" \
488         --disable-strip \
489         --enable-attr \
490         --enable-bluez \
491         --enable-brlapi \
492         --enable-cap-ng \
493         --enable-curl \
494         --enable-curses \
495         --enable-docs \
496         --enable-fdt \
497         %{__enable_disable glusterfs} \
498         --enable-libiscsi \
499         --enable-mixemu \
500         %{__enable_disable opengl} \
501         %{__enable_disable ceph rbd} \
502         %{__enable_disable sdl} \
503         --enable-seccomp \
504         %{__enable_disable spice} \
505         --enable-smartcard \
506         --enable-smartcard-nss \
507         --enable-usb-redir \
508         --enable-uuid \
509         --enable-vde \
510         --enable-virtfs \
511         --enable-vnc-jpeg \
512         --enable-vnc-png \
513         --enable-vnc-sasl \
514         --enable-vnc-tls \
515         %{__enable_disable xen} \
516         --audio-card-list="ac97,es1370,sb16,cs4231a,adlib,gus,hda" \
517         --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
518         --interp-prefix=%{_libdir}/qemu/lib-%%M
519 # note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
520 # --libexecdir in configure is nop
521 %{__make} \
522         V=1 \
523         CONFIG_QEMU_HELPERDIR="%{_libdir}"
524
525 # rebuild patched vesa tables with additional widescreen modes.
526 %{__make} -C roms/vgabios stdvga-bios
527
528 %install
529 rm -rf $RPM_BUILD_ROOT
530
531 %{__make} install \
532         DESTDIR=$RPM_BUILD_ROOT \
533         libexecdir=%{_libdir}
534
535 install -d $RPM_BUILD_ROOT%{_sysconfdir}
536 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
537 #!/bin/sh
538
539 EOF
540
541 # already packaged
542 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
543 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
544
545 # install patched vesa tables with additional widescreen modes.
546 cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
547
548 %clean
549 rm -rf $RPM_BUILD_ROOT
550
551 %files
552 %defattr(644,root,root,755)
553
554 %files common
555 %defattr(644,root,root,755)
556 %doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
557 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
558 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
559 %dir %{_sysconfdir}/qemu
560 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
561 %attr(755,root,root) %{_bindir}/qemu-nbd
562 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
563 %{_mandir}/man1/qemu.1*
564 %{_mandir}/man1/virtfs-proxy-helper.1*
565 %{_mandir}/man8/qemu-nbd.8*
566
567 %dir %{_datadir}/qemu
568 %{_datadir}/%{name}/keymaps
569 %{_datadir}/%{name}/qemu-icon.bmp
570 # various bios images
571 %{_datadir}/%{name}/*.bin
572 %{_datadir}/%{name}/*.rom
573 %{_datadir}/%{name}/*.dtb
574 %{_datadir}/%{name}/openbios-ppc
575 %{_datadir}/%{name}/openbios-sparc*
576 %{_datadir}/%{name}/palcode-clipper
577
578 %files img
579 %defattr(644,root,root,755)
580 %attr(755,root,root) %{_bindir}/qemu-img
581 %{_mandir}/man1/qemu-img.1*
582
583 %files user
584 %defattr(644,root,root,755)
585 %attr(755,root,root) %{_bindir}/qemu-alpha
586 %attr(755,root,root) %{_bindir}/qemu-arm
587 %attr(755,root,root) %{_bindir}/qemu-armeb
588 %attr(755,root,root) %{_bindir}/qemu-cris
589 %attr(755,root,root) %{_bindir}/qemu-ga
590 %attr(755,root,root) %{_bindir}/qemu-i386
591 %attr(755,root,root) %{_bindir}/qemu-io
592 %attr(755,root,root) %{_bindir}/qemu-m68k
593 %attr(755,root,root) %{_bindir}/qemu-microblaze
594 %attr(755,root,root) %{_bindir}/qemu-microblazeel
595 %attr(755,root,root) %{_bindir}/qemu-mips
596 %attr(755,root,root) %{_bindir}/qemu-mipsel
597 %attr(755,root,root) %{_bindir}/qemu-or32
598 %attr(755,root,root) %{_bindir}/qemu-ppc
599 %attr(755,root,root) %{_bindir}/qemu-ppc64
600 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
601 %attr(755,root,root) %{_bindir}/qemu-s390x
602 %attr(755,root,root) %{_bindir}/qemu-sh4
603 %attr(755,root,root) %{_bindir}/qemu-sh4eb
604 %attr(755,root,root) %{_bindir}/qemu-sparc
605 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
606 %attr(755,root,root) %{_bindir}/qemu-sparc64
607 %attr(755,root,root) %{_bindir}/qemu-unicore32
608 %attr(755,root,root) %{_bindir}/qemu-x86_64
609
610 %files system-alpha
611 %defattr(644,root,root,755)
612 %attr(755,root,root) %{_bindir}/qemu-system-alpha
613
614 %files system-arm
615 %defattr(644,root,root,755)
616 %attr(755,root,root) %{_bindir}/qemu-system-arm
617
618 %files system-cris
619 %defattr(644,root,root,755)
620 %attr(755,root,root) %{_bindir}/qemu-system-cris
621
622 %files system-lm32
623 %defattr(644,root,root,755)
624 %attr(755,root,root) %{_bindir}/qemu-system-lm32
625
626 %files system-m68k
627 %defattr(644,root,root,755)
628 %attr(755,root,root) %{_bindir}/qemu-system-m68k
629
630 %files system-microblaze
631 %defattr(644,root,root,755)
632 %attr(755,root,root) %{_bindir}/qemu-system-microblaze
633 %attr(755,root,root) %{_bindir}/qemu-system-microblazeel
634
635 %files system-mips
636 %defattr(644,root,root,755)
637 %attr(755,root,root) %{_bindir}/qemu-system-mips
638 %attr(755,root,root) %{_bindir}/qemu-system-mipsel
639 %attr(755,root,root) %{_bindir}/qemu-system-mips64
640 %attr(755,root,root) %{_bindir}/qemu-system-mips64el
641
642 %files system-or32
643 %defattr(644,root,root,755)
644 %attr(755,root,root) %{_bindir}/qemu-system-or32
645
646 %files system-ppc
647 %defattr(644,root,root,755)
648 %attr(755,root,root) %{_bindir}/qemu-system-ppc
649 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
650 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
651
652 %files system-s390x
653 %defattr(644,root,root,755)
654 %attr(755,root,root) %{_bindir}/qemu-system-s390x
655
656 %files system-sh4
657 %defattr(644,root,root,755)
658 %attr(755,root,root) %{_bindir}/qemu-system-sh4
659 %attr(755,root,root) %{_bindir}/qemu-system-sh4eb
660
661 %files system-sparc
662 %defattr(644,root,root,755)
663 %attr(755,root,root) %{_bindir}/qemu-system-sparc
664 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
665
666 %files system-unicore32
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{_bindir}/qemu-system-unicore32
669
670 %files system-x86
671 %defattr(644,root,root,755)
672 %attr(755,root,root) %{_bindir}/qemu-system-i386
673 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
674
675 %files system-xtensa
676 %defattr(644,root,root,755)
677 %attr(755,root,root) %{_bindir}/qemu-system-xtensa
678 %attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
This page took 0.093244 seconds and 4 git commands to generate.