]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- kvm kernel modules loading support on x86 archs
[packages/qemu.git] / qemu.spec
1 # TODO:
2 # - merge missing bits from qemu-kvm
3 #
4 # Conditional build:
5 %bcond_without  sdl             # SDL UI and audio support
6 %bcond_without  glx             # OpenGL/GLX support
7 %bcond_without  ceph            # Ceph/RBD support
8 %bcond_without  glusterfs       # GlusterFS backend
9 %bcond_without  rdma            # RDMA-based migration support
10 %bcond_with     gtk2            # GTK+ 2.x instead of 3.x
11 %bcond_without  spice           # SPICE support
12 %bcond_with     esd             # EsounD audio support
13 %bcond_without  oss             # OSS audio support
14 %bcond_without  pulseaudio      # PulseAudio audio support
15 %bcond_without  xen             # Xen backend driver support
16
17 Summary:        QEMU CPU Emulator
18 Summary(pl.UTF-8):      QEMU - emulator procesora
19 Name:           qemu
20 Version:        1.6.1
21 Release:        3
22 License:        GPL v2+
23 Group:          Applications/Emulators
24 Source0:        http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
25 # Source0-md5:  3a897d722457c5a895cd6ac79a28fda0
26 # Loads kvm kernel modules at boot
27 Source3:        kvm-modules-load.conf
28 # Creates /dev/kvm
29 Source4:        80-kvm.rules
30 # KSM control scripts
31 Source5:        ksm.service
32 Source6:        ksm.sysconfig
33 Source7:        ksmctl.c
34 Source8:        ksmtuned.service
35 Source9:        ksmtuned
36 Source10:       ksmtuned.conf
37 Source11:       qemu-guest-agent.service
38 Source12:       99-qemu-guest-agent.rules
39 Patch0:         %{name}-cflags.patch
40 Patch1:         vgabios-widescreens.patch
41 Patch2:         %{name}-whitelist.patch
42 Patch3:         %{name}-system-libcacard.patch
43 # Proof of concept, for reference, do not remove
44 Patch4:         %{name}-kde_virtual_workspaces_hack.patch
45 URL:            http://www.qemu-project.org/
46 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
47 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
48 BuildRequires:  alsa-lib-devel
49 BuildRequires:  bcc
50 BuildRequires:  bluez-libs-devel
51 BuildRequires:  brlapi-devel
52 %{?with_ceph:BuildRequires:     ceph-devel}
53 BuildRequires:  curl-devel
54 BuildRequires:  cyrus-sasl-devel >= 2
55 %{?with_esd:BuildRequires:      esound-devel}
56 BuildRequires:  glib2-devel >= 1:2.12
57 %{?with_glusterfs:BuildRequires:        glusterfs-devel >= 3.4}
58 BuildRequires:  gnutls-devel
59 BuildRequires:  libaio-devel
60 BuildRequires:  libcacard-devel
61 BuildRequires:  libcap-devel
62 BuildRequires:  libcap-ng-devel
63 BuildRequires:  libfdt-devel
64 %{?with_rdma:BuildRequires:     libibverbs-devel}
65 BuildRequires:  libiscsi-devel
66 BuildRequires:  libjpeg-devel
67 BuildRequires:  libpng-devel
68 %{?with_rdma:BuildRequires:     librdmacm-devel}
69 BuildRequires:  libseccomp-devel
70 BuildRequires:  libssh2-devel >= 1.2.8
71 # for usb passthrough, when available
72 #BuildRequires: libusb-devel >= 1.0.13
73 BuildRequires:  libuuid-devel
74 BuildRequires:  ncurses-devel
75 BuildRequires:  nss-devel >= 3.12.8
76 BuildRequires:  perl-Encode
77 BuildRequires:  perl-tools-pod
78 BuildRequires:  pkgconfig
79 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
80 BuildRequires:  rpmbuild(macros) >= 1.202
81 BuildRequires:  sed >= 4.0
82 %if %{with spice}
83 BuildRequires:  spice-protocol >= 0.12.0
84 BuildRequires:  spice-server-devel >= 0.12.0
85 %endif
86 BuildRequires:  texi2html
87 BuildRequires:  texinfo
88 BuildRequires:  usbredir-devel >= 0.6
89 BuildRequires:  vde2-devel
90 BuildRequires:  which
91 %{?with_xen:BuildRequires:      xen-devel >= 3.4}
92 BuildRequires:  xfsprogs-devel
93 BuildRequires:  xorg-lib-libX11-devel
94 BuildRequires:  zlib-devel
95 %if %{with gtk2}
96 BuildRequires:  gtk+2-devel >= 2:2.18.0
97 BuildRequires:  vte0-devel >= 0.24.0
98 %else
99 BuildRequires:  gtk+3-devel >= 3.0.0
100 BuildRequires:  vte-devel >= 0.32.0
101 %endif
102 Requires:       %{name}-img = %{version}-%{release}
103 Requires:       %{name}-system-alpha = %{version}-%{release}
104 Requires:       %{name}-system-arm = %{version}-%{release}
105 Requires:       %{name}-system-cris = %{version}-%{release}
106 Requires:       %{name}-system-lm32 = %{version}-%{release}
107 Requires:       %{name}-system-m68k = %{version}-%{release}
108 Requires:       %{name}-system-microblaze = %{version}-%{release}
109 Requires:       %{name}-system-mips = %{version}-%{release}
110 Requires:       %{name}-system-moxie = %{version}-%{release}
111 Requires:       %{name}-system-or32 = %{version}-%{release}
112 Requires:       %{name}-system-ppc = %{version}-%{release}
113 Requires:       %{name}-system-s390x = %{version}-%{release}
114 Requires:       %{name}-system-sh4 = %{version}-%{release}
115 Requires:       %{name}-system-sparc = %{version}-%{release}
116 Requires:       %{name}-system-unicore32 = %{version}-%{release}
117 Requires:       %{name}-system-x86 = %{version}-%{release}
118 Requires:       %{name}-system-xtensa = %{version}-%{release}
119 Requires:       %{name}-user = %{version}-%{release}
120 Obsoletes:      qemu-kvm
121 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
122
123 %define systempkg_req \
124 Requires:       SDL >= 1.2.1 \
125 Requires:       usbredir >= 0.6 \
126 %if %{with gtk2} \
127 Requires:       gtk+2 >= 2:2.18.0 \
128 Requires:       vte0 >= 0.24.0 \
129 %else \
130 Requires:       gtk+3 >= 3.0.0 \
131 Requires:       vte >= 0.32.0 \
132 %endif
133
134 # some PPC/SPARC boot image in ELF format
135 %define         _noautostrip    .*%{_datadir}/qemu/.*-.*
136
137 %description
138 QEMU is a FAST! processor emulator. By using dynamic translation it
139 achieves a reasonnable speed while being easy to port on new host
140 CPUs. QEMU has two operating modes:
141
142 - User mode emulation. In this mode, QEMU can launch Linux processes
143   compiled for one CPU on another CPU. Linux system calls are converted
144   because of endianness and 32/64 bit mismatches. Wine (Windows
145   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
146
147 - Full system emulation. In this mode, QEMU emulates a full system,
148   including a processor and various peripherials. It can also be used to
149   provide virtual hosting of several virtual PC on a single server.
150
151 %description -l pl.UTF-8
152 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
153 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
154 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
155
156 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
157   procesy linuksowe skompilowane dla jednego procesora na innym
158   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
159   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
160   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
161   cele QEMU.
162
163 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
164   włączając w to procesor i różne urządzenia peryferyjne. Może być także
165   używane do wirtualnego hostowania kilku wirtualnych pecetów na
166   pojedynczym serwerze.
167
168 %package common
169 Summary:        QEMU common files needed by all QEMU targets
170 Summary(pl.UTF-8):      Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
171 Group:          Development/Tools
172 Requires(post,preun,postun):    systemd-units >= 38
173 Requires(postun):       /usr/sbin/groupdel
174 Requires(postun):       /usr/sbin/userdel
175 Requires(pre):  /bin/id
176 Requires(pre):  /usr/bin/getgid
177 Requires(pre):  /usr/sbin/groupadd
178 Requires(pre):  /usr/sbin/useradd
179 Requires:       glib2 >= 1:2.12
180 Requires:       libssh2 >= 1.2.8
181 Requires:       systemd-units >= 38
182 Provides:       group(qemu)
183 Provides:       user(qemu)
184 Obsoletes:      qemu-kvm-common
185 Conflicts:      qemu < 1.0-2
186
187 %description common
188 QEMU is a generic and open source processor emulator which achieves a
189 good emulation speed by using dynamic translation.
190
191 This package provides the common files needed by all QEMU targets.
192
193 %description common -l pl.UTF-8
194 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
195 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
196
197 Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
198 środowiska QEMU.
199
200 %package img
201 Summary:        QEMU command line tool for manipulating disk images
202 Summary(pl.UTF-8):      Narzędzie QEMU do operacji na obrazach dysków
203 Group:          Development/Tools
204 Conflicts:      qemu < 1.0-2
205 Obsoletes:      qemu-kvm-img
206
207 %description img
208 This package provides a command line tool for manipulating disk
209 images.
210
211 %description img -l pl.UTF-8
212 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
213 na obrazach dysków.
214
215 %package user
216 Summary:        QEMU user mode emulation of qemu targets
217 Summary(pl.UTF-8):      QEMU - emulacja trybu użytkownika środowisk qemu
218 Group:          Development/Tools
219 Requires:       %{name}-common = %{version}-%{release}
220 Obsoletes:      qemu-kvm-user
221
222 %description user
223 QEMU is a generic and open source processor emulator which achieves a
224 good emulation speed by using dynamic translation.
225
226 This package provides the user mode emulation of QEMU targets.
227
228 %description user -l pl.UTF-8
229 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
230 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
231
232 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
233
234 %package system-alpha
235 Summary:        QEMU system emulator for Alpha
236 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Alpha
237 Group:          Development/Tools
238 Requires:       %{name}-common = %{version}-%{release}
239 %systempkg_req
240 Obsoletes:      qemu-kvm-system-alpha
241
242 %description system-alpha
243 QEMU is a generic and open source processor emulator which achieves a
244 good emulation speed by using dynamic translation.
245
246 This package provides the system emulator with Alpha CPU.
247
248 %description system-alpha -l pl.UTF-8
249 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
250 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
251
252 Ten pakiet zawiera emulator systemu z procesorem Alpha.
253
254 %package system-arm
255 Summary:        QEMU system emulator for ARM
256 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem ARM
257 Group:          Development/Tools
258 Requires:       %{name}-common = %{version}-%{release}
259 %systempkg_req
260 Obsoletes:      qemu-kvm-system-arm
261
262 %description system-arm
263 QEMU is a generic and open source processor emulator which achieves a
264 good emulation speed by using dynamic translation.
265
266 This package provides the system emulator for ARM.
267
268 %description system-arm -l pl.UTF-8
269 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
270 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
271
272 Ten pakiet zawiera emulator systemu z procesorem ARM.
273
274 %package system-cris
275 Summary:        QEMU system emulator for CRIS
276 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem CRIS
277 Group:          Development/Tools
278 Requires:       %{name}-common = %{version}-%{release}
279 %systempkg_req
280 Obsoletes:      qemu-kvm-system-cris
281
282 %description system-cris
283 QEMU is a generic and open source processor emulator which achieves a
284 good emulation speed by using dynamic translation.
285
286 This package provides the system emulator with CRIS CPU.
287
288 %description system-cris -l pl.UTF-8
289 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
290 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
291
292 Ten pakiet zawiera emulator systemu z procesorem CRIS.
293
294 %package system-lm32
295 Summary:        QEMU system emulator for LM32
296 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem LM32
297 Group:          Development/Tools
298 Requires:       %{name}-common = %{version}-%{release}
299 %systempkg_req
300 Obsoletes:      qemu-kvm-system-lm32
301
302 %description system-lm32
303 QEMU is a generic and open source processor emulator which achieves a
304 good emulation speed by using dynamic translation.
305
306 This package provides the system emulator with LM32 CPU.
307
308 %description system-lm32 -l pl.UTF-8
309 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
310 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
311
312 Ten pakiet zawiera emulator systemu z procesorem LM32.
313
314 %package system-m68k
315 Summary:        QEMU system emulator for m68k
316 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem m68k
317 Group:          Development/Tools
318 Requires:       %{name}-common = %{version}-%{release}
319 %systempkg_req
320 Obsoletes:      qemu-kvm-system-m68k
321
322 %description system-m68k
323 QEMU is a generic and open source processor emulator which achieves a
324 good emulation speed by using dynamic translation.
325
326 This package provides the system emulator with m68k CPU.
327
328 %description system-m68k -l pl.UTF-8
329 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
330 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
331
332 Ten pakiet zawiera emulator systemu z procesorem m68k.
333
334 %package system-microblaze
335 Summary:        QEMU system emulator for MicroBlaze
336 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MicroBlaze
337 Group:          Development/Tools
338 Requires:       %{name}-common = %{version}-%{release}
339 %systempkg_req
340 Obsoletes:      qemu-kvm-system-microblaze
341
342 %description system-microblaze
343 QEMU is a generic and open source processor emulator which achieves a
344 good emulation speed by using dynamic translation.
345
346 This package provides the system emulator with MicroBlaze CPU.
347
348 %description system-microblaze -l pl.UTF-8
349 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
350 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
351
352 Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
353
354 %package system-mips
355 Summary:        QEMU system emulator for MIPS
356 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MIPS
357 Group:          Development/Tools
358 Requires:       %{name}-common = %{version}-%{release}
359 %systempkg_req
360 Obsoletes:      qemu-kvm-system-mips
361
362 %description system-mips
363 QEMU is a generic and open source processor emulator which achieves a
364 good emulation speed by using dynamic translation.
365
366 This package provides the system emulator with MIPS CPU.
367
368 %description system-mips -l pl.UTF-8
369 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
370 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
371
372 Ten pakiet zawiera emulator systemu z procesorem MIPS.
373
374 %package system-moxie
375 Summary:        QEMU system emulator for Moxie
376 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Moxie
377 Group:          Development/Tools
378 Requires:       %{name}-common = %{version}-%{release}
379 %systempkg_req
380
381 %description system-moxie
382 QEMU is a generic and open source processor emulator which achieves a
383 good emulation speed by using dynamic translation.
384
385 This package provides the system emulator with Moxie CPU.
386
387 %description system-moxie -l pl.UTF-8
388 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
389 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
390
391 Ten pakiet zawiera emulator systemu z procesorem Moxie.
392
393 %package system-or32
394 Summary:        QEMU system emulator for OpenRISC
395 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem OpenRISC
396 Group:          Development/Tools
397 Requires:       %{name}-common = %{version}-%{release}
398 %systempkg_req
399 Obsoletes:      qemu-kvm-system-or32
400
401 %description system-or32
402 QEMU is a generic and open source processor emulator which achieves a
403 good emulation speed by using dynamic translation.
404
405 This package provides the system emulator with OpenRISC CPU.
406
407 %description system-or32 -l pl.UTF-8
408 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
409 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
410
411 Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
412
413 %package system-ppc
414 Summary:        QEMU system emulator for PowerPC
415 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem PowerPC
416 Group:          Development/Tools
417 Requires:       %{name}-common = %{version}-%{release}
418 %systempkg_req
419 Obsoletes:      qemu-kvm-system-ppc
420
421 %description system-ppc
422 QEMU is a generic and open source processor emulator which achieves a
423 good emulation speed by using dynamic translation.
424
425 This package provides the system emulator with PowerPC CPU.
426
427 %description system-ppc -l pl.UTF-8
428 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
429 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
430
431 Ten pakiet zawiera emulator systemu z procesorem PowerPC.
432
433 %package system-s390x
434 Summary:        QEMU system emulator for S390
435 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem S390
436 Group:          Development/Tools
437 Requires:       %{name}-common = %{version}-%{release}
438 %systempkg_req
439 Obsoletes:      qemu-kvm-system-s390x
440
441 %description system-s390x
442 QEMU is a generic and open source processor emulator which achieves a
443 good emulation speed by using dynamic translation.
444
445 This package provides the system emulator with S390 CPU.
446
447 %description system-s390x -l pl.UTF-8
448 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
449 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
450
451 Ten pakiet zawiera emulator systemu z procesorem S390.
452
453 %package system-sh4
454 Summary:        QEMU system emulator for SH4
455 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SH4
456 Group:          Development/Tools
457 Requires:       %{name}-common = %{version}-%{release}
458 %systempkg_req
459 Obsoletes:      qemu-kvm-system-sh4
460
461 %description system-sh4
462 QEMU is a generic and open source processor emulator which achieves a
463 good emulation speed by using dynamic translation.
464
465 This package provides the system emulator with SH4 CPU.
466
467 %description system-sh4 -l pl.UTF-8
468 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
469 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
470
471 Ten pakiet zawiera emulator systemu z procesorem SH4.
472
473 %package system-sparc
474 Summary:        QEMU system emulator for SPARC
475 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SPARC
476 Group:          Development/Tools
477 Requires:       %{name}-common = %{version}-%{release}
478 %systempkg_req
479 Obsoletes:      qemu-kvm-system-sparc
480
481 %description system-sparc
482 QEMU is a generic and open source processor emulator which achieves a
483 good emulation speed by using dynamic translation.
484
485 This package provides the system emulator with SPARC/SPARC64 CPU.
486
487 %description system-sparc -l pl.UTF-8
488 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
489 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
490
491 Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
492
493 %package system-unicore32
494 Summary:        QEMU system emulator for UniCore32
495 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem UniCore32
496 Group:          Development/Tools
497 Requires:       %{name}-common = %{version}-%{release}
498 %systempkg_req
499 Obsoletes:      qemu-kvm-system-unicore32
500
501 %description system-unicore32
502 QEMU is a generic and open source processor emulator which achieves a
503 good emulation speed by using dynamic translation.
504
505 This package provides the system emulator with UniCore32 CPU.
506
507 %description system-unicore32 -l pl.UTF-8
508 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
509 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
510
511 Ten pakiet zawiera emulator systemu z procesorem UniCore32.
512
513 %package system-x86
514 Summary:        QEMU system emulator for x86
515 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem x86
516 Group:          Development/Tools
517 Requires:       %{name}-common = %{version}-%{release}
518 %systempkg_req
519 Obsoletes:      qemu-kvm-system-x86
520
521 %description system-x86
522 QEMU is a generic and open source processor emulator which achieves a
523 good emulation speed by using dynamic translation.
524
525 %description system-x86 -l pl.UTF-8
526 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
527 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
528
529 %package system-xtensa
530 Summary:        QEMU system emulator for Xtensa
531 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Xtensa
532 Group:          Development/Tools
533 Requires:       %{name}-common = %{version}-%{release}
534 %systempkg_req
535 Obsoletes:      qemu-kvm-system-xtensa
536
537 %description system-xtensa
538 QEMU is a generic and open source processor emulator which achieves a
539 good emulation speed by using dynamic translation.
540
541 This package provides the system emulator with Xtensa CPU.
542
543 %description system-xtensa -l pl.UTF-8
544 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
545 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
546
547 Ten pakiet zawiera emulator systemu z procesorem Xtensa.
548
549 %package guest-agent
550 Summary:        QEMU guest agent
551 Summary(pl.UTF-8):      Agent gościa QEMU
552 Group:          Daemons
553 Requires(post,preun,postun):    systemd-units >= 38
554 Requires:       glib2 >= 1:2.12
555 Requires:       systemd-units >= 38
556 Obsoletes:      qemu-kvm-guest-agent
557
558 %description guest-agent
559 QEMU is a generic and open source processor emulator which achieves
560 a good emulation speed by using dynamic translation.
561
562 This package provides an agent to run inside guests, which
563 communicates with the host over a virtio-serial channel named
564 "org.qemu.guest_agent.0".
565
566 This package does not need to be installed on the host OS.
567
568 %description guest-agent -l pl.UTF-8
569 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
570 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
571
572 Ten pakiet udostępnia agenta przeznaczonego do uruchomienia w
573 systemach-gościach, komunikującego się kanałem virtio-serial o nazwie
574 "org.qemu.guest_agent.0".
575
576 Ten pakiet nie musi być zainstalowany w systemie hosta.
577
578 %prep
579 %setup -q
580 %patch0 -p1
581 %patch1 -p1
582 %patch2 -p0
583 %patch3 -p1
584
585 %{__mv} libcacard libcacard-use-system-lib
586
587 # workaround for conflict with alsa/error.h
588 ln -s ../error.h qapi/error.h
589
590 %build
591 ./configure \
592         --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
593         --extra-ldflags="%{rpmldflags}" \
594         --prefix=%{_prefix} \
595         --sysconfdir=%{_sysconfdir} \
596         --cc="%{__cc}" \
597         --host-cc="%{__cc}" \
598         --disable-strip \
599         --enable-attr \
600         --enable-bluez \
601         --enable-brlapi \
602         --enable-cap-ng \
603         --enable-curl \
604         --enable-curses \
605         --enable-docs \
606         --enable-fdt \
607         %{__enable_disable glusterfs} \
608         --enable-libiscsi \
609         --enable-mixemu \
610         %{__enable_disable glx} \
611         %{__enable_disable ceph rbd} \
612         %{__enable_disable rdma} \
613         %{__enable_disable sdl} \
614         --enable-seccomp \
615         %{__enable_disable spice} \
616         --enable-smartcard-nss \
617         --enable-tpm \
618         --enable-usb-redir \
619         --enable-uuid \
620         --enable-vde \
621         --enable-virtfs \
622         --enable-vnc-jpeg \
623         --enable-vnc-png \
624         --enable-vnc-sasl \
625         --enable-vnc-tls \
626         --enable-kvm \
627         %{__enable_disable xen} \
628         --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
629         --interp-prefix=%{_libdir}/qemu/lib-%%M \
630         --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
631
632 # note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
633 # --libexecdir in configure is nop
634 %{__make} \
635         V=1 \
636         CONFIG_QEMU_HELPERDIR="%{_libdir}"
637
638 # rebuild patched vesa tables with additional widescreen modes.
639 %{__make} -C roms/vgabios stdvga-bios
640
641 %{__cc} %{SOURCE7} %{rpmcflags} -o ksmctl
642
643 %install
644 rm -rf $RPM_BUILD_ROOT
645 install -d $RPM_BUILD_ROOT{%{systemdunitdir},/usr/lib/binfmt.d} \
646         $RPM_BUILD_ROOT/etc/{sysconfig,udev/rules.d,modules-load.d} \
647         $RPM_BUILD_ROOT{%{_sysconfdir}/sasl,%{_sbindir}}
648
649 %{__make} install \
650         DESTDIR=$RPM_BUILD_ROOT \
651         libexecdir=%{_libdir}
652
653 install -d $RPM_BUILD_ROOT%{_sysconfdir}
654 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
655 #!/bin/sh
656
657 EOF
658
659 %ifarch %{ix86} %{x8664}
660 install scripts/kvm/kvm_stat $RPM_BUILD_ROOT%{_bindir}
661 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/modules-load.d/kvm.conf
662 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
663 %endif
664
665 install -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/ksm.service
666 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/ksm
667 install -p ksmctl $RPM_BUILD_ROOT%{_sbindir}
668
669 install -p %{SOURCE8} $RPM_BUILD_ROOT%{systemdunitdir}/ksmtuned.service
670 install -p %{SOURCE9} $RPM_BUILD_ROOT%{_sbindir}/ksmtuned
671 install -p %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/ksmtuned.conf
672
673 # For the qemu-guest-agent subpackage install the systemd
674 # service and udev rules.
675 install -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
676 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
677
678 # already packaged
679 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
680 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
681
682 # install patched vesa tables with additional widescreen modes.
683 cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
684
685 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{de_DE,de}
686 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{fr_FR,fr}
687 %find_lang %{name}
688
689 %clean
690 rm -rf $RPM_BUILD_ROOT
691
692 %pre common
693 %groupadd -g 276 qemu
694 %useradd -u 276 -g qemu -c "QEMU User" qemu
695
696 %post common
697 %systemd_post ksm.service
698 %systemd_post ksmtuned.service
699
700 %preun common
701 %systemd_preun ksm.service
702 %systemd_preun ksmtuned.service
703
704 %postun common
705 if [ "$1" = "0" ]; then
706         %userremove qemu
707         %groupremove qemu
708 fi
709 %systemd_reload
710
711 %triggerpostun common -- qemu-common < 1.6.1-4
712 %systemd_trigger ksm.service
713 %systemd_trigger ksmtuned.service
714
715 %post guest-agent
716 %systemd_reload
717
718 %preun guest-agent
719 %systemd_preun qemu-guest-agent.service
720
721 %postun guest-agent
722 %systemd_reload
723
724 %files
725 %defattr(644,root,root,755)
726
727 %files common -f %{name}.lang
728 %defattr(644,root,root,755)
729 %doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
730 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
731 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
732 %config(noreplace) %verify(not md5 mtime size) /etc/ksmtuned.conf
733 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ksm
734 %{systemdunitdir}/ksm.service
735 %{systemdunitdir}/ksmtuned.service
736 %dir %{_sysconfdir}/qemu
737 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
738 %attr(755,root,root) %{_bindir}/qemu-nbd
739 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
740 %attr(755,root,root) %{_sbindir}/ksmctl
741 %attr(755,root,root) %{_sbindir}/ksmtuned
742 %{_mandir}/man1/qemu.1*
743 %{_mandir}/man1/virtfs-proxy-helper.1*
744 %{_mandir}/man8/qemu-nbd.8*
745
746 %dir %{_datadir}/qemu
747 %{_datadir}/%{name}/keymaps
748 %{_datadir}/%{name}/qemu-icon.bmp
749 # various bios images
750 %{_datadir}/%{name}/*.aml
751 %{_datadir}/%{name}/*.bin
752 %{_datadir}/%{name}/*.rom
753 %{_datadir}/%{name}/*.dtb
754 %{_datadir}/%{name}/qemu_logo_no_text.svg
755 %{_datadir}/%{name}/openbios-ppc
756 %{_datadir}/%{name}/openbios-sparc*
757 %{_datadir}/%{name}/palcode-clipper
758 %{_datadir}/%{name}/s390-ccw.img
759
760 %files img
761 %defattr(644,root,root,755)
762 %attr(755,root,root) %{_bindir}/qemu-img
763 %{_mandir}/man1/qemu-img.1*
764
765 %files user
766 %defattr(644,root,root,755)
767 %attr(755,root,root) %{_bindir}/qemu-alpha
768 %attr(755,root,root) %{_bindir}/qemu-arm
769 %attr(755,root,root) %{_bindir}/qemu-armeb
770 %attr(755,root,root) %{_bindir}/qemu-cris
771 %attr(755,root,root) %{_bindir}/qemu-i386
772 %attr(755,root,root) %{_bindir}/qemu-io
773 %attr(755,root,root) %{_bindir}/qemu-m68k
774 %attr(755,root,root) %{_bindir}/qemu-microblaze
775 %attr(755,root,root) %{_bindir}/qemu-microblazeel
776 %attr(755,root,root) %{_bindir}/qemu-mips
777 %attr(755,root,root) %{_bindir}/qemu-mipsel
778 %attr(755,root,root) %{_bindir}/qemu-mips64
779 %attr(755,root,root) %{_bindir}/qemu-mips64el
780 %attr(755,root,root) %{_bindir}/qemu-mipsn32
781 %attr(755,root,root) %{_bindir}/qemu-mipsn32el
782 %attr(755,root,root) %{_bindir}/qemu-or32
783 %attr(755,root,root) %{_bindir}/qemu-ppc
784 %attr(755,root,root) %{_bindir}/qemu-ppc64
785 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
786 %attr(755,root,root) %{_bindir}/qemu-s390x
787 %attr(755,root,root) %{_bindir}/qemu-sh4
788 %attr(755,root,root) %{_bindir}/qemu-sh4eb
789 %attr(755,root,root) %{_bindir}/qemu-sparc
790 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
791 %attr(755,root,root) %{_bindir}/qemu-sparc64
792 %attr(755,root,root) %{_bindir}/qemu-unicore32
793 %attr(755,root,root) %{_bindir}/qemu-x86_64
794
795 %files system-alpha
796 %defattr(644,root,root,755)
797 %attr(755,root,root) %{_bindir}/qemu-system-alpha
798
799 %files system-arm
800 %defattr(644,root,root,755)
801 %attr(755,root,root) %{_bindir}/qemu-system-arm
802
803 %files system-cris
804 %defattr(644,root,root,755)
805 %attr(755,root,root) %{_bindir}/qemu-system-cris
806
807 %files system-lm32
808 %defattr(644,root,root,755)
809 %attr(755,root,root) %{_bindir}/qemu-system-lm32
810
811 %files system-m68k
812 %defattr(644,root,root,755)
813 %attr(755,root,root) %{_bindir}/qemu-system-m68k
814
815 %files system-microblaze
816 %defattr(644,root,root,755)
817 %attr(755,root,root) %{_bindir}/qemu-system-microblaze
818 %attr(755,root,root) %{_bindir}/qemu-system-microblazeel
819
820 %files system-mips
821 %defattr(644,root,root,755)
822 %attr(755,root,root) %{_bindir}/qemu-system-mips
823 %attr(755,root,root) %{_bindir}/qemu-system-mipsel
824 %attr(755,root,root) %{_bindir}/qemu-system-mips64
825 %attr(755,root,root) %{_bindir}/qemu-system-mips64el
826
827 %files system-moxie
828 %defattr(644,root,root,755)
829 %attr(755,root,root) %{_bindir}/qemu-system-moxie
830
831 %files system-or32
832 %defattr(644,root,root,755)
833 %attr(755,root,root) %{_bindir}/qemu-system-or32
834
835 %files system-ppc
836 %defattr(644,root,root,755)
837 %attr(755,root,root) %{_bindir}/qemu-system-ppc
838 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
839 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
840
841 %files system-s390x
842 %defattr(644,root,root,755)
843 %attr(755,root,root) %{_bindir}/qemu-system-s390x
844
845 %files system-sh4
846 %defattr(644,root,root,755)
847 %attr(755,root,root) %{_bindir}/qemu-system-sh4
848 %attr(755,root,root) %{_bindir}/qemu-system-sh4eb
849
850 %files system-sparc
851 %defattr(644,root,root,755)
852 %attr(755,root,root) %{_bindir}/qemu-system-sparc
853 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
854
855 %files system-unicore32
856 %defattr(644,root,root,755)
857 %attr(755,root,root) %{_bindir}/qemu-system-unicore32
858
859 %files system-x86
860 %defattr(644,root,root,755)
861 %attr(755,root,root) %{_bindir}/qemu-system-i386
862 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
863 %ifarch %{ix86} %{x8664}
864 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/kvm.conf
865 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/80-kvm.rules
866 %attr(755,root,root) %{_bindir}/kvm_stat
867 %endif
868
869 %files system-xtensa
870 %defattr(644,root,root,755)
871 %attr(755,root,root) %{_bindir}/qemu-system-xtensa
872 %attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
873
874 %files guest-agent
875 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/99-qemu-guest-agent.rules
876 %{systemdunitdir}/qemu-guest-agent.service
877 %attr(755,root,root) %{_bindir}/qemu-ga
This page took 0.114407 seconds and 4 git commands to generate.