]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- removed antique TODO
[packages/qemu.git] / qemu.spec
1 # TODO:
2 # - merge missing bits from qemu-kvm
3 #
4 # Conditional build:
5 %bcond_without  sdl             # SDL UI and audio support
6 %bcond_without  glx             # OpenGL/GLX support
7 %bcond_without  ceph            # Ceph/RBD support
8 %bcond_without  glusterfs       # GlusterFS backend
9 %bcond_without  rdma            # RDMA-based migration support
10 %bcond_with     gtk2            # GTK+ 2.x instead of 3.x
11 %bcond_without  spice           # SPICE support
12 %bcond_with     esd             # EsounD audio support
13 %bcond_without  oss             # OSS audio support
14 %bcond_without  pulseaudio      # PulseAudio audio support
15 %bcond_without  xen             # Xen backend driver support
16
17 Summary:        QEMU CPU Emulator
18 Summary(pl.UTF-8):      QEMU - emulator procesora
19 Name:           qemu
20 Version:        1.6.1
21 Release:        3
22 License:        GPL v2+
23 Group:          Applications/Emulators
24 Source0:        http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
25 # Source0-md5:  3a897d722457c5a895cd6ac79a28fda0
26 Source11:       qemu-guest-agent.service
27 Source12:       99-qemu-guest-agent.rules
28 Patch0:         %{name}-cflags.patch
29 Patch1:         vgabios-widescreens.patch
30 Patch2:         %{name}-whitelist.patch
31 Patch3:         %{name}-system-libcacard.patch
32 # Proof of concept, for reference, do not remove
33 Patch4:         %{name}-kde_virtual_workspaces_hack.patch
34 URL:            http://www.qemu-project.org/
35 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
36 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
37 BuildRequires:  alsa-lib-devel
38 BuildRequires:  bcc
39 BuildRequires:  bluez-libs-devel
40 BuildRequires:  brlapi-devel
41 %{?with_ceph:BuildRequires:     ceph-devel}
42 BuildRequires:  curl-devel
43 BuildRequires:  cyrus-sasl-devel >= 2
44 %{?with_esd:BuildRequires:      esound-devel}
45 BuildRequires:  glib2-devel >= 1:2.12
46 %{?with_glusterfs:BuildRequires:        glusterfs-devel >= 3.4}
47 BuildRequires:  gnutls-devel
48 BuildRequires:  libaio-devel
49 BuildRequires:  libcacard-devel
50 BuildRequires:  libcap-devel
51 BuildRequires:  libcap-ng-devel
52 BuildRequires:  libfdt-devel
53 %{?with_rdma:BuildRequires:     libibverbs-devel}
54 BuildRequires:  libiscsi-devel
55 BuildRequires:  libjpeg-devel
56 BuildRequires:  libpng-devel
57 %{?with_rdma:BuildRequires:     librdmacm-devel}
58 BuildRequires:  libseccomp-devel
59 BuildRequires:  libssh2-devel >= 1.2.8
60 # for usb passthrough, when available
61 #BuildRequires: libusb-devel >= 1.0.13
62 BuildRequires:  libuuid-devel
63 BuildRequires:  ncurses-devel
64 BuildRequires:  nss-devel >= 3.12.8
65 BuildRequires:  perl-Encode
66 BuildRequires:  perl-tools-pod
67 BuildRequires:  pkgconfig
68 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
69 BuildRequires:  rpmbuild(macros) >= 1.202
70 BuildRequires:  sed >= 4.0
71 %if %{with spice}
72 BuildRequires:  spice-protocol >= 0.12.0
73 BuildRequires:  spice-server-devel >= 0.12.0
74 %endif
75 BuildRequires:  texi2html
76 BuildRequires:  texinfo
77 BuildRequires:  usbredir-devel >= 0.6
78 BuildRequires:  vde2-devel
79 BuildRequires:  which
80 %{?with_xen:BuildRequires:      xen-devel >= 3.4}
81 BuildRequires:  xfsprogs-devel
82 BuildRequires:  xorg-lib-libX11-devel
83 BuildRequires:  zlib-devel
84 %if %{with gtk2}
85 BuildRequires:  gtk+2-devel >= 2:2.18.0
86 BuildRequires:  vte0-devel >= 0.24.0
87 %else
88 BuildRequires:  gtk+3-devel >= 3.0.0
89 BuildRequires:  vte-devel >= 0.32.0
90 %endif
91 Requires:       %{name}-img = %{version}-%{release}
92 Requires:       %{name}-system-alpha = %{version}-%{release}
93 Requires:       %{name}-system-arm = %{version}-%{release}
94 Requires:       %{name}-system-cris = %{version}-%{release}
95 Requires:       %{name}-system-lm32 = %{version}-%{release}
96 Requires:       %{name}-system-m68k = %{version}-%{release}
97 Requires:       %{name}-system-microblaze = %{version}-%{release}
98 Requires:       %{name}-system-mips = %{version}-%{release}
99 Requires:       %{name}-system-moxie = %{version}-%{release}
100 Requires:       %{name}-system-or32 = %{version}-%{release}
101 Requires:       %{name}-system-ppc = %{version}-%{release}
102 Requires:       %{name}-system-s390x = %{version}-%{release}
103 Requires:       %{name}-system-sh4 = %{version}-%{release}
104 Requires:       %{name}-system-sparc = %{version}-%{release}
105 Requires:       %{name}-system-unicore32 = %{version}-%{release}
106 Requires:       %{name}-system-x86 = %{version}-%{release}
107 Requires:       %{name}-system-xtensa = %{version}-%{release}
108 Requires:       %{name}-user = %{version}-%{release}
109 Obsoletes:      qemu-kvm
110 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
111
112 %define systempkg_req \
113 Requires:       SDL >= 1.2.1 \
114 Requires:       usbredir >= 0.6 \
115 %if %{with gtk2} \
116 Requires:       gtk+2 >= 2:2.18.0 \
117 Requires:       vte0 >= 0.24.0 \
118 %else \
119 Requires:       gtk+3 >= 3.0.0 \
120 Requires:       vte >= 0.32.0 \
121 %endif
122
123 # some PPC/SPARC boot image in ELF format
124 %define         _noautostrip    .*%{_datadir}/qemu/.*-.*
125
126 %description
127 QEMU is a FAST! processor emulator. By using dynamic translation it
128 achieves a reasonnable speed while being easy to port on new host
129 CPUs. QEMU has two operating modes:
130
131 - User mode emulation. In this mode, QEMU can launch Linux processes
132   compiled for one CPU on another CPU. Linux system calls are converted
133   because of endianness and 32/64 bit mismatches. Wine (Windows
134   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
135
136 - Full system emulation. In this mode, QEMU emulates a full system,
137   including a processor and various peripherials. It can also be used to
138   provide virtual hosting of several virtual PC on a single server.
139
140 %description -l pl.UTF-8
141 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
142 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
143 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
144
145 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
146   procesy linuksowe skompilowane dla jednego procesora na innym
147   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
148   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
149   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
150   cele QEMU.
151
152 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
153   włączając w to procesor i różne urządzenia peryferyjne. Może być także
154   używane do wirtualnego hostowania kilku wirtualnych pecetów na
155   pojedynczym serwerze.
156
157 %package common
158 Summary:        QEMU common files needed by all QEMU targets
159 Summary(pl.UTF-8):      Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
160 Group:          Development/Tools
161 Requires(postun):       /usr/sbin/groupdel
162 Requires(postun):       /usr/sbin/userdel
163 Requires(pre):  /bin/id
164 Requires(pre):  /usr/bin/getgid
165 Requires(pre):  /usr/sbin/groupadd
166 Requires(pre):  /usr/sbin/useradd
167 Requires:       glib2 >= 1:2.12
168 Requires:       libssh2 >= 1.2.8
169 Provides:       group(qemu)
170 Provides:       user(qemu)
171 Obsoletes:      qemu-kvm-common
172 Conflicts:      qemu < 1.0-2
173
174 %description common
175 QEMU is a generic and open source processor emulator which achieves a
176 good emulation speed by using dynamic translation.
177
178 This package provides the common files needed by all QEMU targets.
179
180 %description common -l pl.UTF-8
181 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
182 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
183
184 Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
185 środowiska QEMU.
186
187 %package img
188 Summary:        QEMU command line tool for manipulating disk images
189 Summary(pl.UTF-8):      Narzędzie QEMU do operacji na obrazach dysków
190 Group:          Development/Tools
191 Conflicts:      qemu < 1.0-2
192 Obsoletes:      qemu-kvm-img
193
194 %description img
195 This package provides a command line tool for manipulating disk
196 images.
197
198 %description img -l pl.UTF-8
199 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
200 na obrazach dysków.
201
202 %package user
203 Summary:        QEMU user mode emulation of qemu targets
204 Summary(pl.UTF-8):      QEMU - emulacja trybu użytkownika środowisk qemu
205 Group:          Development/Tools
206 Requires:       %{name}-common = %{version}-%{release}
207 Obsoletes:      qemu-kvm-user
208
209 %description user
210 QEMU is a generic and open source processor emulator which achieves a
211 good emulation speed by using dynamic translation.
212
213 This package provides the user mode emulation of QEMU targets.
214
215 %description user -l pl.UTF-8
216 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
217 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
218
219 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
220
221 %package system-alpha
222 Summary:        QEMU system emulator for Alpha
223 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Alpha
224 Group:          Development/Tools
225 Requires:       %{name}-common = %{version}-%{release}
226 %systempkg_req
227 Obsoletes:      qemu-kvm-system-alpha
228
229 %description system-alpha
230 QEMU is a generic and open source processor emulator which achieves a
231 good emulation speed by using dynamic translation.
232
233 This package provides the system emulator with Alpha CPU.
234
235 %description system-alpha -l pl.UTF-8
236 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
237 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
238
239 Ten pakiet zawiera emulator systemu z procesorem Alpha.
240
241 %package system-arm
242 Summary:        QEMU system emulator for ARM
243 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem ARM
244 Group:          Development/Tools
245 Requires:       %{name}-common = %{version}-%{release}
246 %systempkg_req
247 Obsoletes:      qemu-kvm-system-arm
248
249 %description system-arm
250 QEMU is a generic and open source processor emulator which achieves a
251 good emulation speed by using dynamic translation.
252
253 This package provides the system emulator for ARM.
254
255 %description system-arm -l pl.UTF-8
256 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
257 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
258
259 Ten pakiet zawiera emulator systemu z procesorem ARM.
260
261 %package system-cris
262 Summary:        QEMU system emulator for CRIS
263 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem CRIS
264 Group:          Development/Tools
265 Requires:       %{name}-common = %{version}-%{release}
266 %systempkg_req
267 Obsoletes:      qemu-kvm-system-cris
268
269 %description system-cris
270 QEMU is a generic and open source processor emulator which achieves a
271 good emulation speed by using dynamic translation.
272
273 This package provides the system emulator with CRIS CPU.
274
275 %description system-cris -l pl.UTF-8
276 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
277 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
278
279 Ten pakiet zawiera emulator systemu z procesorem CRIS.
280
281 %package system-lm32
282 Summary:        QEMU system emulator for LM32
283 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem LM32
284 Group:          Development/Tools
285 Requires:       %{name}-common = %{version}-%{release}
286 %systempkg_req
287 Obsoletes:      qemu-kvm-system-lm32
288
289 %description system-lm32
290 QEMU is a generic and open source processor emulator which achieves a
291 good emulation speed by using dynamic translation.
292
293 This package provides the system emulator with LM32 CPU.
294
295 %description system-lm32 -l pl.UTF-8
296 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
297 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
298
299 Ten pakiet zawiera emulator systemu z procesorem LM32.
300
301 %package system-m68k
302 Summary:        QEMU system emulator for m68k
303 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem m68k
304 Group:          Development/Tools
305 Requires:       %{name}-common = %{version}-%{release}
306 %systempkg_req
307 Obsoletes:      qemu-kvm-system-m68k
308
309 %description system-m68k
310 QEMU is a generic and open source processor emulator which achieves a
311 good emulation speed by using dynamic translation.
312
313 This package provides the system emulator with m68k CPU.
314
315 %description system-m68k -l pl.UTF-8
316 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
317 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
318
319 Ten pakiet zawiera emulator systemu z procesorem m68k.
320
321 %package system-microblaze
322 Summary:        QEMU system emulator for MicroBlaze
323 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MicroBlaze
324 Group:          Development/Tools
325 Requires:       %{name}-common = %{version}-%{release}
326 %systempkg_req
327 Obsoletes:      qemu-kvm-system-microblaze
328
329 %description system-microblaze
330 QEMU is a generic and open source processor emulator which achieves a
331 good emulation speed by using dynamic translation.
332
333 This package provides the system emulator with MicroBlaze CPU.
334
335 %description system-microblaze -l pl.UTF-8
336 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
337 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
338
339 Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
340
341 %package system-mips
342 Summary:        QEMU system emulator for MIPS
343 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MIPS
344 Group:          Development/Tools
345 Requires:       %{name}-common = %{version}-%{release}
346 %systempkg_req
347 Obsoletes:      qemu-kvm-system-mips
348
349 %description system-mips
350 QEMU is a generic and open source processor emulator which achieves a
351 good emulation speed by using dynamic translation.
352
353 This package provides the system emulator with MIPS CPU.
354
355 %description system-mips -l pl.UTF-8
356 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
357 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
358
359 Ten pakiet zawiera emulator systemu z procesorem MIPS.
360
361 %package system-moxie
362 Summary:        QEMU system emulator for Moxie
363 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Moxie
364 Group:          Development/Tools
365 Requires:       %{name}-common = %{version}-%{release}
366 %systempkg_req
367
368 %description system-moxie
369 QEMU is a generic and open source processor emulator which achieves a
370 good emulation speed by using dynamic translation.
371
372 This package provides the system emulator with Moxie CPU.
373
374 %description system-moxie -l pl.UTF-8
375 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
376 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
377
378 Ten pakiet zawiera emulator systemu z procesorem Moxie.
379
380 %package system-or32
381 Summary:        QEMU system emulator for OpenRISC
382 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem OpenRISC
383 Group:          Development/Tools
384 Requires:       %{name}-common = %{version}-%{release}
385 %systempkg_req
386 Obsoletes:      qemu-kvm-system-or32
387
388 %description system-or32
389 QEMU is a generic and open source processor emulator which achieves a
390 good emulation speed by using dynamic translation.
391
392 This package provides the system emulator with OpenRISC CPU.
393
394 %description system-or32 -l pl.UTF-8
395 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
396 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
397
398 Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
399
400 %package system-ppc
401 Summary:        QEMU system emulator for PowerPC
402 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem PowerPC
403 Group:          Development/Tools
404 Requires:       %{name}-common = %{version}-%{release}
405 %systempkg_req
406 Obsoletes:      qemu-kvm-system-ppc
407
408 %description system-ppc
409 QEMU is a generic and open source processor emulator which achieves a
410 good emulation speed by using dynamic translation.
411
412 This package provides the system emulator with PowerPC CPU.
413
414 %description system-ppc -l pl.UTF-8
415 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
416 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
417
418 Ten pakiet zawiera emulator systemu z procesorem PowerPC.
419
420 %package system-s390x
421 Summary:        QEMU system emulator for S390
422 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem S390
423 Group:          Development/Tools
424 Requires:       %{name}-common = %{version}-%{release}
425 %systempkg_req
426 Obsoletes:      qemu-kvm-system-s390x
427
428 %description system-s390x
429 QEMU is a generic and open source processor emulator which achieves a
430 good emulation speed by using dynamic translation.
431
432 This package provides the system emulator with S390 CPU.
433
434 %description system-s390x -l pl.UTF-8
435 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
436 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
437
438 Ten pakiet zawiera emulator systemu z procesorem S390.
439
440 %package system-sh4
441 Summary:        QEMU system emulator for SH4
442 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SH4
443 Group:          Development/Tools
444 Requires:       %{name}-common = %{version}-%{release}
445 %systempkg_req
446 Obsoletes:      qemu-kvm-system-sh4
447
448 %description system-sh4
449 QEMU is a generic and open source processor emulator which achieves a
450 good emulation speed by using dynamic translation.
451
452 This package provides the system emulator with SH4 CPU.
453
454 %description system-sh4 -l pl.UTF-8
455 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
456 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
457
458 Ten pakiet zawiera emulator systemu z procesorem SH4.
459
460 %package system-sparc
461 Summary:        QEMU system emulator for SPARC
462 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SPARC
463 Group:          Development/Tools
464 Requires:       %{name}-common = %{version}-%{release}
465 %systempkg_req
466 Obsoletes:      qemu-kvm-system-sparc
467
468 %description system-sparc
469 QEMU is a generic and open source processor emulator which achieves a
470 good emulation speed by using dynamic translation.
471
472 This package provides the system emulator with SPARC/SPARC64 CPU.
473
474 %description system-sparc -l pl.UTF-8
475 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
476 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
477
478 Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
479
480 %package system-unicore32
481 Summary:        QEMU system emulator for UniCore32
482 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem UniCore32
483 Group:          Development/Tools
484 Requires:       %{name}-common = %{version}-%{release}
485 %systempkg_req
486 Obsoletes:      qemu-kvm-system-unicore32
487
488 %description system-unicore32
489 QEMU is a generic and open source processor emulator which achieves a
490 good emulation speed by using dynamic translation.
491
492 This package provides the system emulator with UniCore32 CPU.
493
494 %description system-unicore32 -l pl.UTF-8
495 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
496 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
497
498 Ten pakiet zawiera emulator systemu z procesorem UniCore32.
499
500 %package system-x86
501 Summary:        QEMU system emulator for x86
502 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem x86
503 Group:          Development/Tools
504 Requires:       %{name}-common = %{version}-%{release}
505 %systempkg_req
506 Obsoletes:      qemu-kvm-system-x86
507
508 %description system-x86
509 QEMU is a generic and open source processor emulator which achieves a
510 good emulation speed by using dynamic translation.
511
512 %description system-x86 -l pl.UTF-8
513 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
514 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
515
516 %package system-xtensa
517 Summary:        QEMU system emulator for Xtensa
518 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Xtensa
519 Group:          Development/Tools
520 Requires:       %{name}-common = %{version}-%{release}
521 %systempkg_req
522 Obsoletes:      qemu-kvm-system-xtensa
523
524 %description system-xtensa
525 QEMU is a generic and open source processor emulator which achieves a
526 good emulation speed by using dynamic translation.
527
528 This package provides the system emulator with Xtensa CPU.
529
530 %description system-xtensa -l pl.UTF-8
531 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
532 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
533
534 Ten pakiet zawiera emulator systemu z procesorem Xtensa.
535
536 %package guest-agent
537 Summary:        QEMU guest agent
538 Summary(pl.UTF-8):      Agent gościa QEMU
539 Group:          Daemons
540 Requires(post,preun,postun):    systemd-units >= 38
541 Requires:       glib2 >= 1:2.12
542 Requires:       systemd-units >= 38
543 Obsoletes:      qemu-kvm-guest-agent
544
545 %description guest-agent
546 QEMU is a generic and open source processor emulator which achieves
547 a good emulation speed by using dynamic translation.
548
549 This package provides an agent to run inside guests, which
550 communicates with the host over a virtio-serial channel named
551 "org.qemu.guest_agent.0".
552
553 This package does not need to be installed on the host OS.
554
555 %description guest-agent -l pl.UTF-8
556 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
557 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
558
559 Ten pakiet udostępnia agenta przeznaczonego do uruchomienia w
560 systemach-gościach, komunikującego się kanałem virtio-serial o nazwie
561 "org.qemu.guest_agent.0".
562
563 Ten pakiet nie musi być zainstalowany w systemie hosta.
564
565 %prep
566 %setup -q
567 %patch0 -p1
568 %patch1 -p1
569 %patch2 -p0
570 %patch3 -p1
571
572 %{__mv} libcacard libcacard-use-system-lib
573
574 # workaround for conflict with alsa/error.h
575 ln -s ../error.h qapi/error.h
576
577 %build
578 ./configure \
579         --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
580         --extra-ldflags="%{rpmldflags}" \
581         --prefix=%{_prefix} \
582         --sysconfdir=%{_sysconfdir} \
583         --cc="%{__cc}" \
584         --host-cc="%{__cc}" \
585         --disable-strip \
586         --enable-attr \
587         --enable-bluez \
588         --enable-brlapi \
589         --enable-cap-ng \
590         --enable-curl \
591         --enable-curses \
592         --enable-docs \
593         --enable-fdt \
594         %{__enable_disable glusterfs} \
595         --enable-libiscsi \
596         --enable-mixemu \
597         %{__enable_disable glx} \
598         %{__enable_disable ceph rbd} \
599         %{__enable_disable rdma} \
600         %{__enable_disable sdl} \
601         --enable-seccomp \
602         %{__enable_disable spice} \
603         --enable-smartcard-nss \
604         --enable-tpm \
605         --enable-usb-redir \
606         --enable-uuid \
607         --enable-vde \
608         --enable-virtfs \
609         --enable-vnc-jpeg \
610         --enable-vnc-png \
611         --enable-vnc-sasl \
612         --enable-vnc-tls \
613         %{__enable_disable xen} \
614         --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
615         --interp-prefix=%{_libdir}/qemu/lib-%%M \
616         --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
617
618 # note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
619 # --libexecdir in configure is nop
620 %{__make} \
621         V=1 \
622         CONFIG_QEMU_HELPERDIR="%{_libdir}"
623
624 # rebuild patched vesa tables with additional widescreen modes.
625 %{__make} -C roms/vgabios stdvga-bios
626
627 %install
628 rm -rf $RPM_BUILD_ROOT
629
630 %{__make} install \
631         DESTDIR=$RPM_BUILD_ROOT \
632         libexecdir=%{_libdir}
633
634 install -d $RPM_BUILD_ROOT%{_sysconfdir}
635 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
636 #!/bin/sh
637
638 EOF
639
640 # For the qemu-guest-agent subpackage install the systemd
641 # service and udev rules.
642 install -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
643 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
644
645 # already packaged
646 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
647 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
648
649 # install patched vesa tables with additional widescreen modes.
650 cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
651
652 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{de_DE,de}
653 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{fr_FR,fr}
654 %find_lang %{name}
655
656 %clean
657 rm -rf $RPM_BUILD_ROOT
658
659 %pre common
660 %groupadd -g 276 qemu
661 %useradd -u 276 -g qemu -c "QEMU User" qemu
662
663 %postun common
664 if [ "$1" = "0" ]; then
665         %userremove qemu
666         %groupremove qemu
667 fi
668
669 %post guest-agent
670 %systemd_reload
671
672 %preun guest-agent
673 %systemd_preun qemu-guest-agent.service
674
675 %postun guest-agent
676 %systemd_reload
677
678 %files
679 %defattr(644,root,root,755)
680
681 %files common -f %{name}.lang
682 %defattr(644,root,root,755)
683 %doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
684 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
685 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
686 %dir %{_sysconfdir}/qemu
687 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
688 %attr(755,root,root) %{_bindir}/qemu-nbd
689 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
690 %{_mandir}/man1/qemu.1*
691 %{_mandir}/man1/virtfs-proxy-helper.1*
692 %{_mandir}/man8/qemu-nbd.8*
693
694 %dir %{_datadir}/qemu
695 %{_datadir}/%{name}/keymaps
696 %{_datadir}/%{name}/qemu-icon.bmp
697 # various bios images
698 %{_datadir}/%{name}/*.aml
699 %{_datadir}/%{name}/*.bin
700 %{_datadir}/%{name}/*.rom
701 %{_datadir}/%{name}/*.dtb
702 %{_datadir}/%{name}/qemu_logo_no_text.svg
703 %{_datadir}/%{name}/openbios-ppc
704 %{_datadir}/%{name}/openbios-sparc*
705 %{_datadir}/%{name}/palcode-clipper
706 %{_datadir}/%{name}/s390-ccw.img
707
708 %files img
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{_bindir}/qemu-img
711 %{_mandir}/man1/qemu-img.1*
712
713 %files user
714 %defattr(644,root,root,755)
715 %attr(755,root,root) %{_bindir}/qemu-alpha
716 %attr(755,root,root) %{_bindir}/qemu-arm
717 %attr(755,root,root) %{_bindir}/qemu-armeb
718 %attr(755,root,root) %{_bindir}/qemu-cris
719 %attr(755,root,root) %{_bindir}/qemu-i386
720 %attr(755,root,root) %{_bindir}/qemu-io
721 %attr(755,root,root) %{_bindir}/qemu-m68k
722 %attr(755,root,root) %{_bindir}/qemu-microblaze
723 %attr(755,root,root) %{_bindir}/qemu-microblazeel
724 %attr(755,root,root) %{_bindir}/qemu-mips
725 %attr(755,root,root) %{_bindir}/qemu-mipsel
726 %attr(755,root,root) %{_bindir}/qemu-mips64
727 %attr(755,root,root) %{_bindir}/qemu-mips64el
728 %attr(755,root,root) %{_bindir}/qemu-mipsn32
729 %attr(755,root,root) %{_bindir}/qemu-mipsn32el
730 %attr(755,root,root) %{_bindir}/qemu-or32
731 %attr(755,root,root) %{_bindir}/qemu-ppc
732 %attr(755,root,root) %{_bindir}/qemu-ppc64
733 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
734 %attr(755,root,root) %{_bindir}/qemu-s390x
735 %attr(755,root,root) %{_bindir}/qemu-sh4
736 %attr(755,root,root) %{_bindir}/qemu-sh4eb
737 %attr(755,root,root) %{_bindir}/qemu-sparc
738 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
739 %attr(755,root,root) %{_bindir}/qemu-sparc64
740 %attr(755,root,root) %{_bindir}/qemu-unicore32
741 %attr(755,root,root) %{_bindir}/qemu-x86_64
742
743 %files system-alpha
744 %defattr(644,root,root,755)
745 %attr(755,root,root) %{_bindir}/qemu-system-alpha
746
747 %files system-arm
748 %defattr(644,root,root,755)
749 %attr(755,root,root) %{_bindir}/qemu-system-arm
750
751 %files system-cris
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{_bindir}/qemu-system-cris
754
755 %files system-lm32
756 %defattr(644,root,root,755)
757 %attr(755,root,root) %{_bindir}/qemu-system-lm32
758
759 %files system-m68k
760 %defattr(644,root,root,755)
761 %attr(755,root,root) %{_bindir}/qemu-system-m68k
762
763 %files system-microblaze
764 %defattr(644,root,root,755)
765 %attr(755,root,root) %{_bindir}/qemu-system-microblaze
766 %attr(755,root,root) %{_bindir}/qemu-system-microblazeel
767
768 %files system-mips
769 %defattr(644,root,root,755)
770 %attr(755,root,root) %{_bindir}/qemu-system-mips
771 %attr(755,root,root) %{_bindir}/qemu-system-mipsel
772 %attr(755,root,root) %{_bindir}/qemu-system-mips64
773 %attr(755,root,root) %{_bindir}/qemu-system-mips64el
774
775 %files system-moxie
776 %defattr(644,root,root,755)
777 %attr(755,root,root) %{_bindir}/qemu-system-moxie
778
779 %files system-or32
780 %defattr(644,root,root,755)
781 %attr(755,root,root) %{_bindir}/qemu-system-or32
782
783 %files system-ppc
784 %defattr(644,root,root,755)
785 %attr(755,root,root) %{_bindir}/qemu-system-ppc
786 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
787 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
788
789 %files system-s390x
790 %defattr(644,root,root,755)
791 %attr(755,root,root) %{_bindir}/qemu-system-s390x
792
793 %files system-sh4
794 %defattr(644,root,root,755)
795 %attr(755,root,root) %{_bindir}/qemu-system-sh4
796 %attr(755,root,root) %{_bindir}/qemu-system-sh4eb
797
798 %files system-sparc
799 %defattr(644,root,root,755)
800 %attr(755,root,root) %{_bindir}/qemu-system-sparc
801 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
802
803 %files system-unicore32
804 %defattr(644,root,root,755)
805 %attr(755,root,root) %{_bindir}/qemu-system-unicore32
806
807 %files system-x86
808 %defattr(644,root,root,755)
809 %attr(755,root,root) %{_bindir}/qemu-system-i386
810 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
811
812 %files system-xtensa
813 %defattr(644,root,root,755)
814 %attr(755,root,root) %{_bindir}/qemu-system-xtensa
815 %attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
816
817 %files guest-agent
818 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/99-qemu-guest-agent.rules
819 %{systemdunitdir}/qemu-guest-agent.service
820 %attr(755,root,root) %{_bindir}/qemu-ga
This page took 0.098314 seconds and 4 git commands to generate.