]> git.pld-linux.org Git - packages/qemu.git/blame_incremental - qemu.spec
- added obsoletes for qemu-kvm packages
[packages/qemu.git] / qemu.spec
... / ...
CommitLineData
1# TODO:
2# - merge missing bits from qemu-kvm
3# - qemu-system-ppc -hda ac-ppc.img says:
4# qemu: could not open disk image ac-ppc.img: error "Success"
5# qemu-0.12.2-2.x86_64.rpm - broken
6# qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
7# qemu-0.15.0-2.x86_64.rpm - qemu-system-sparc/ppc booting with -kernel, -initrd options stalls in openbios prompt
8# qemu-0.11.1-*.x86_64.rpm - OK
9#
10# Conditional build:
11%bcond_without sdl # SDL UI and audio support
12%bcond_without glx # OpenGL/GLX support
13%bcond_without ceph # Ceph/RBD support
14%bcond_without glusterfs # GlusterFS backend
15%bcond_without rdma # RDMA-based migration support
16%bcond_with gtk2 # GTK+ 2.x instead of 3.x
17%bcond_without spice # SPICE support
18%bcond_with esd # EsounD audio support
19%bcond_without oss # OSS audio support
20%bcond_without pulseaudio # PulseAudio audio support
21%bcond_without xen # Xen backend driver support
22
23Summary: QEMU CPU Emulator
24Summary(pl.UTF-8): QEMU - emulator procesora
25Name: qemu
26Version: 1.6.1
27Release: 3
28License: GPL v2+
29Group: Applications/Emulators
30Source0: http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
31# Source0-md5: 3a897d722457c5a895cd6ac79a28fda0
32Patch0: %{name}-cflags.patch
33Patch1: vgabios-widescreens.patch
34Patch2: %{name}-whitelist.patch
35Patch3: %{name}-system-libcacard.patch
36# Proof of concept, for reference, do not remove
37Patch4: %{name}-kde_virtual_workspaces_hack.patch
38URL: http://www.qemu-project.org/
39%{?with_opengl:BuildRequires: OpenGL-GLX-devel}
40%{?with_sdl:BuildRequires: SDL-devel >= 1.2.1}
41BuildRequires: alsa-lib-devel
42BuildRequires: bcc
43BuildRequires: bluez-libs-devel
44BuildRequires: brlapi-devel
45%{?with_ceph:BuildRequires: ceph-devel}
46BuildRequires: curl-devel
47BuildRequires: cyrus-sasl-devel >= 2
48%{?with_esd:BuildRequires: esound-devel}
49BuildRequires: glib2-devel >= 1:2.12
50%{?with_glusterfs:BuildRequires: glusterfs-devel >= 3.4}
51BuildRequires: gnutls-devel
52BuildRequires: libaio-devel
53BuildRequires: libcacard-devel
54BuildRequires: libcap-devel
55BuildRequires: libcap-ng-devel
56BuildRequires: libfdt-devel
57%{?with_rdma:BuildRequires: libibverbs-devel}
58BuildRequires: libiscsi-devel
59BuildRequires: libjpeg-devel
60BuildRequires: libpng-devel
61%{?with_rdma:BuildRequires: librdmacm-devel}
62BuildRequires: libseccomp-devel
63BuildRequires: libssh2-devel >= 1.2.8
64# for usb passthrough, when available
65#BuildRequires: libusb-devel >= 1.0.13
66BuildRequires: libuuid-devel
67BuildRequires: ncurses-devel
68BuildRequires: nss-devel >= 3.12.8
69BuildRequires: perl-Encode
70BuildRequires: perl-tools-pod
71BuildRequires: pkgconfig
72%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
73BuildRequires: rpmbuild(macros) >= 1.202
74BuildRequires: sed >= 4.0
75%if %{with spice}
76BuildRequires: spice-protocol >= 0.12.0
77BuildRequires: spice-server-devel >= 0.12.0
78%endif
79BuildRequires: texi2html
80BuildRequires: texinfo
81BuildRequires: usbredir-devel >= 0.6
82BuildRequires: vde2-devel
83BuildRequires: which
84%{?with_xen:BuildRequires: xen-devel >= 3.4}
85BuildRequires: xfsprogs-devel
86BuildRequires: xorg-lib-libX11-devel
87BuildRequires: zlib-devel
88%if %{with gtk2}
89BuildRequires: gtk+2-devel >= 2:2.18.0
90BuildRequires: vte0-devel >= 0.24.0
91%else
92BuildRequires: gtk+3-devel >= 3.0.0
93BuildRequires: vte-devel >= 0.32.0
94%endif
95Requires: %{name}-img = %{version}-%{release}
96Requires: %{name}-system-alpha = %{version}-%{release}
97Requires: %{name}-system-arm = %{version}-%{release}
98Requires: %{name}-system-cris = %{version}-%{release}
99Requires: %{name}-system-lm32 = %{version}-%{release}
100Requires: %{name}-system-m68k = %{version}-%{release}
101Requires: %{name}-system-microblaze = %{version}-%{release}
102Requires: %{name}-system-mips = %{version}-%{release}
103Requires: %{name}-system-moxie = %{version}-%{release}
104Requires: %{name}-system-or32 = %{version}-%{release}
105Requires: %{name}-system-ppc = %{version}-%{release}
106Requires: %{name}-system-s390x = %{version}-%{release}
107Requires: %{name}-system-sh4 = %{version}-%{release}
108Requires: %{name}-system-sparc = %{version}-%{release}
109Requires: %{name}-system-unicore32 = %{version}-%{release}
110Requires: %{name}-system-x86 = %{version}-%{release}
111Requires: %{name}-system-xtensa = %{version}-%{release}
112Requires: %{name}-user = %{version}-%{release}
113Obsoletes: qemu-kvm
114BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
115
116%define systempkg_req \
117Requires: SDL >= 1.2.1 \
118Requires: usbredir >= 0.6 \
119%if %{with gtk2} \
120Requires: gtk+2 >= 2:2.18.0 \
121Requires: vte0 >= 0.24.0 \
122%else \
123Requires: gtk+3 >= 3.0.0 \
124Requires: vte >= 0.32.0 \
125%endif
126
127# some PPC/SPARC boot image in ELF format
128%define _noautostrip .*%{_datadir}/qemu/.*-.*
129
130%description
131QEMU is a FAST! processor emulator. By using dynamic translation it
132achieves a reasonnable speed while being easy to port on new host
133CPUs. QEMU has two operating modes:
134
135- User mode emulation. In this mode, QEMU can launch Linux processes
136 compiled for one CPU on another CPU. Linux system calls are converted
137 because of endianness and 32/64 bit mismatches. Wine (Windows
138 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
139
140- Full system emulation. In this mode, QEMU emulates a full system,
141 including a processor and various peripherials. It can also be used to
142 provide virtual hosting of several virtual PC on a single server.
143
144%description -l pl.UTF-8
145QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
146tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
147aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
148
149- Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
150 procesy linuksowe skompilowane dla jednego procesora na innym
151 procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
152 niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
153 słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
154 cele QEMU.
155
156- Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
157 włączając w to procesor i różne urządzenia peryferyjne. Może być także
158 używane do wirtualnego hostowania kilku wirtualnych pecetów na
159 pojedynczym serwerze.
160
161%package common
162Summary: QEMU common files needed by all QEMU targets
163Summary(pl.UTF-8): Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
164Group: Development/Tools
165Requires(postun): /usr/sbin/groupdel
166Requires(postun): /usr/sbin/userdel
167Requires(pre): /bin/id
168Requires(pre): /usr/bin/getgid
169Requires(pre): /usr/sbin/groupadd
170Requires(pre): /usr/sbin/useradd
171Requires: glib2 >= 1:2.12
172Requires: libssh2 >= 1.2.8
173Provides: group(qemu)
174Provides: user(qemu)
175Obsoletes: qemu-kvm-common
176Conflicts: qemu < 1.0-2
177
178%description common
179QEMU is a generic and open source processor emulator which achieves a
180good emulation speed by using dynamic translation.
181
182This package provides the common files needed by all QEMU targets.
183
184%description common -l pl.UTF-8
185QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
186dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
187
188Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
189środowiska QEMU.
190
191%package img
192Summary: QEMU command line tool for manipulating disk images
193Summary(pl.UTF-8): Narzędzie QEMU do operacji na obrazach dysków
194Group: Development/Tools
195Conflicts: qemu < 1.0-2
196Obsoletes: qemu-kvm-img
197
198%description img
199This package provides a command line tool for manipulating disk
200images.
201
202%description img -l pl.UTF-8
203Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
204na obrazach dysków.
205
206%package user
207Summary: QEMU user mode emulation of qemu targets
208Summary(pl.UTF-8): QEMU - emulacja trybu użytkownika środowisk qemu
209Group: Development/Tools
210Requires: %{name}-common = %{version}-%{release}
211Obsoletes: qemu-kvm-user
212
213%description user
214QEMU is a generic and open source processor emulator which achieves a
215good emulation speed by using dynamic translation.
216
217This package provides the user mode emulation of QEMU targets.
218
219%description user -l pl.UTF-8
220QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
221dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
222
223Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
224
225%package system-alpha
226Summary: QEMU system emulator for Alpha
227Summary(pl.UTF-8): QEMU - emulator systemu z procesorem Alpha
228Group: Development/Tools
229Requires: %{name}-common = %{version}-%{release}
230%systempkg_req
231Obsoletes: qemu-kvm-system-alpha
232
233%description system-alpha
234QEMU is a generic and open source processor emulator which achieves a
235good emulation speed by using dynamic translation.
236
237This package provides the system emulator with Alpha CPU.
238
239%description system-alpha -l pl.UTF-8
240QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
241dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
242
243Ten pakiet zawiera emulator systemu z procesorem Alpha.
244
245%package system-arm
246Summary: QEMU system emulator for ARM
247Summary(pl.UTF-8): QEMU - emulator systemu z procesorem ARM
248Group: Development/Tools
249Requires: %{name}-common = %{version}-%{release}
250%systempkg_req
251Obsoletes: qemu-kvm-system-arm
252
253%description system-arm
254QEMU is a generic and open source processor emulator which achieves a
255good emulation speed by using dynamic translation.
256
257This package provides the system emulator for ARM.
258
259%description system-arm -l pl.UTF-8
260QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
261dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
262
263Ten pakiet zawiera emulator systemu z procesorem ARM.
264
265%package system-cris
266Summary: QEMU system emulator for CRIS
267Summary(pl.UTF-8): QEMU - emulator systemu z procesorem CRIS
268Group: Development/Tools
269Requires: %{name}-common = %{version}-%{release}
270%systempkg_req
271Obsoletes: qemu-kvm-system-cris
272
273%description system-cris
274QEMU is a generic and open source processor emulator which achieves a
275good emulation speed by using dynamic translation.
276
277This package provides the system emulator with CRIS CPU.
278
279%description system-cris -l pl.UTF-8
280QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
281dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
282
283Ten pakiet zawiera emulator systemu z procesorem CRIS.
284
285%package system-lm32
286Summary: QEMU system emulator for LM32
287Summary(pl.UTF-8): QEMU - emulator systemu z procesorem LM32
288Group: Development/Tools
289Requires: %{name}-common = %{version}-%{release}
290%systempkg_req
291Obsoletes: qemu-kvm-system-lm32
292
293%description system-lm32
294QEMU is a generic and open source processor emulator which achieves a
295good emulation speed by using dynamic translation.
296
297This package provides the system emulator with LM32 CPU.
298
299%description system-lm32 -l pl.UTF-8
300QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
301dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
302
303Ten pakiet zawiera emulator systemu z procesorem LM32.
304
305%package system-m68k
306Summary: QEMU system emulator for m68k
307Summary(pl.UTF-8): QEMU - emulator systemu z procesorem m68k
308Group: Development/Tools
309Requires: %{name}-common = %{version}-%{release}
310%systempkg_req
311Obsoletes: qemu-kvm-system-m68k
312
313%description system-m68k
314QEMU is a generic and open source processor emulator which achieves a
315good emulation speed by using dynamic translation.
316
317This package provides the system emulator with m68k CPU.
318
319%description system-m68k -l pl.UTF-8
320QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
321dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
322
323Ten pakiet zawiera emulator systemu z procesorem m68k.
324
325%package system-microblaze
326Summary: QEMU system emulator for MicroBlaze
327Summary(pl.UTF-8): QEMU - emulator systemu z procesorem MicroBlaze
328Group: Development/Tools
329Requires: %{name}-common = %{version}-%{release}
330%systempkg_req
331Obsoletes: qemu-kvm-system-microblaze
332
333%description system-microblaze
334QEMU is a generic and open source processor emulator which achieves a
335good emulation speed by using dynamic translation.
336
337This package provides the system emulator with MicroBlaze CPU.
338
339%description system-microblaze -l pl.UTF-8
340QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
341dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
342
343Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
344
345%package system-mips
346Summary: QEMU system emulator for MIPS
347Summary(pl.UTF-8): QEMU - emulator systemu z procesorem MIPS
348Group: Development/Tools
349Requires: %{name}-common = %{version}-%{release}
350%systempkg_req
351Obsoletes: qemu-kvm-system-mips
352
353%description system-mips
354QEMU is a generic and open source processor emulator which achieves a
355good emulation speed by using dynamic translation.
356
357This package provides the system emulator with MIPS CPU.
358
359%description system-mips -l pl.UTF-8
360QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
361dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
362
363Ten pakiet zawiera emulator systemu z procesorem MIPS.
364
365%package system-moxie
366Summary: QEMU system emulator for Moxie
367Summary(pl.UTF-8): QEMU - emulator systemu z procesorem Moxie
368Group: Development/Tools
369Requires: %{name}-common = %{version}-%{release}
370%systempkg_req
371
372%description system-moxie
373QEMU is a generic and open source processor emulator which achieves a
374good emulation speed by using dynamic translation.
375
376This package provides the system emulator with Moxie CPU.
377
378%description system-moxie -l pl.UTF-8
379QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
380dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
381
382Ten pakiet zawiera emulator systemu z procesorem Moxie.
383
384%package system-or32
385Summary: QEMU system emulator for OpenRISC
386Summary(pl.UTF-8): QEMU - emulator systemu z procesorem OpenRISC
387Group: Development/Tools
388Requires: %{name}-common = %{version}-%{release}
389%systempkg_req
390Obsoletes: qemu-kvm-system-or32
391
392%description system-or32
393QEMU is a generic and open source processor emulator which achieves a
394good emulation speed by using dynamic translation.
395
396This package provides the system emulator with OpenRISC CPU.
397
398%description system-or32 -l pl.UTF-8
399QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
400dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
401
402Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
403
404%package system-ppc
405Summary: QEMU system emulator for PowerPC
406Summary(pl.UTF-8): QEMU - emulator systemu z procesorem PowerPC
407Group: Development/Tools
408Requires: %{name}-common = %{version}-%{release}
409%systempkg_req
410Obsoletes: qemu-kvm-system-ppc
411
412%description system-ppc
413QEMU is a generic and open source processor emulator which achieves a
414good emulation speed by using dynamic translation.
415
416This package provides the system emulator with PowerPC CPU.
417
418%description system-ppc -l pl.UTF-8
419QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
420dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
421
422Ten pakiet zawiera emulator systemu z procesorem PowerPC.
423
424%package system-s390x
425Summary: QEMU system emulator for S390
426Summary(pl.UTF-8): QEMU - emulator systemu z procesorem S390
427Group: Development/Tools
428Requires: %{name}-common = %{version}-%{release}
429%systempkg_req
430Obsoletes: qemu-kvm-system-s390x
431
432%description system-s390x
433QEMU is a generic and open source processor emulator which achieves a
434good emulation speed by using dynamic translation.
435
436This package provides the system emulator with S390 CPU.
437
438%description system-s390x -l pl.UTF-8
439QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
440dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
441
442Ten pakiet zawiera emulator systemu z procesorem S390.
443
444%package system-sh4
445Summary: QEMU system emulator for SH4
446Summary(pl.UTF-8): QEMU - emulator systemu z procesorem SH4
447Group: Development/Tools
448Requires: %{name}-common = %{version}-%{release}
449%systempkg_req
450Obsoletes: qemu-kvm-system-sh4
451
452%description system-sh4
453QEMU is a generic and open source processor emulator which achieves a
454good emulation speed by using dynamic translation.
455
456This package provides the system emulator with SH4 CPU.
457
458%description system-sh4 -l pl.UTF-8
459QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
460dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
461
462Ten pakiet zawiera emulator systemu z procesorem SH4.
463
464%package system-sparc
465Summary: QEMU system emulator for SPARC
466Summary(pl.UTF-8): QEMU - emulator systemu z procesorem SPARC
467Group: Development/Tools
468Requires: %{name}-common = %{version}-%{release}
469%systempkg_req
470Obsoletes: qemu-kvm-system-sparc
471
472%description system-sparc
473QEMU is a generic and open source processor emulator which achieves a
474good emulation speed by using dynamic translation.
475
476This package provides the system emulator with SPARC/SPARC64 CPU.
477
478%description system-sparc -l pl.UTF-8
479QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
480dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
481
482Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
483
484%package system-unicore32
485Summary: QEMU system emulator for UniCore32
486Summary(pl.UTF-8): QEMU - emulator systemu z procesorem UniCore32
487Group: Development/Tools
488Requires: %{name}-common = %{version}-%{release}
489%systempkg_req
490Obsoletes: qemu-kvm-system-unicore32
491
492%description system-unicore32
493QEMU is a generic and open source processor emulator which achieves a
494good emulation speed by using dynamic translation.
495
496This package provides the system emulator with UniCore32 CPU.
497
498%description system-unicore32 -l pl.UTF-8
499QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
500dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
501
502Ten pakiet zawiera emulator systemu z procesorem UniCore32.
503
504%package system-x86
505Summary: QEMU system emulator for x86
506Summary(pl.UTF-8): QEMU - emulator systemu z procesorem x86
507Group: Development/Tools
508Requires: %{name}-common = %{version}-%{release}
509%systempkg_req
510Obsoletes: qemu-kvm-system-x86
511
512%description system-x86
513QEMU is a generic and open source processor emulator which achieves a
514good emulation speed by using dynamic translation.
515
516%description system-x86 -l pl.UTF-8
517QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
518dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
519
520%package system-xtensa
521Summary: QEMU system emulator for Xtensa
522Summary(pl.UTF-8): QEMU - emulator systemu z procesorem Xtensa
523Group: Development/Tools
524Requires: %{name}-common = %{version}-%{release}
525%systempkg_req
526Obsoletes: qemu-kvm-system-xtensa
527
528%description system-xtensa
529QEMU is a generic and open source processor emulator which achieves a
530good emulation speed by using dynamic translation.
531
532This package provides the system emulator with Xtensa CPU.
533
534%description system-xtensa -l pl.UTF-8
535QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
536dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
537
538Ten pakiet zawiera emulator systemu z procesorem Xtensa.
539
540%prep
541%setup -q
542%patch0 -p1
543%patch1 -p1
544%patch2 -p0
545%patch3 -p1
546
547%{__mv} libcacard libcacard-use-system-lib
548
549# workaround for conflict with alsa/error.h
550ln -s ../error.h qapi/error.h
551
552%build
553./configure \
554 --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
555 --extra-ldflags="%{rpmldflags}" \
556 --prefix=%{_prefix} \
557 --sysconfdir=%{_sysconfdir} \
558 --cc="%{__cc}" \
559 --host-cc="%{__cc}" \
560 --disable-strip \
561 --enable-attr \
562 --enable-bluez \
563 --enable-brlapi \
564 --enable-cap-ng \
565 --enable-curl \
566 --enable-curses \
567 --enable-docs \
568 --enable-fdt \
569 %{__enable_disable glusterfs} \
570 --enable-libiscsi \
571 --enable-mixemu \
572 %{__enable_disable glx} \
573 %{__enable_disable ceph rbd} \
574 %{__enable_disable rdma} \
575 %{__enable_disable sdl} \
576 --enable-seccomp \
577 %{__enable_disable spice} \
578 --enable-smartcard-nss \
579 --enable-tpm \
580 --enable-usb-redir \
581 --enable-uuid \
582 --enable-vde \
583 --enable-virtfs \
584 --enable-vnc-jpeg \
585 --enable-vnc-png \
586 --enable-vnc-sasl \
587 --enable-vnc-tls \
588 %{__enable_disable xen} \
589 --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
590 --interp-prefix=%{_libdir}/qemu/lib-%%M \
591 --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
592
593# note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
594# --libexecdir in configure is nop
595%{__make} \
596 V=1 \
597 CONFIG_QEMU_HELPERDIR="%{_libdir}"
598
599# rebuild patched vesa tables with additional widescreen modes.
600%{__make} -C roms/vgabios stdvga-bios
601
602%install
603rm -rf $RPM_BUILD_ROOT
604
605%{__make} install \
606 DESTDIR=$RPM_BUILD_ROOT \
607 libexecdir=%{_libdir}
608
609install -d $RPM_BUILD_ROOT%{_sysconfdir}
610cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
611#!/bin/sh
612
613EOF
614
615# already packaged
616%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
617%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
618
619# install patched vesa tables with additional widescreen modes.
620cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
621
622%{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{de_DE,de}
623%{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{fr_FR,fr}
624%find_lang %{name}
625
626%clean
627rm -rf $RPM_BUILD_ROOT
628
629%pre common
630%groupadd -g 276 qemu
631%useradd -u 276 -g qemu -c "QEMU User" qemu
632
633%postun common
634if [ "$1" = "0" ]; then
635 %userremove qemu
636 %groupremove qemu
637fi
638
639%files
640%defattr(644,root,root,755)
641
642%files common -f %{name}.lang
643%defattr(644,root,root,755)
644%doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
645%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
646%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
647%dir %{_sysconfdir}/qemu
648%attr(755,root,root) %{_bindir}/virtfs-proxy-helper
649%attr(755,root,root) %{_bindir}/qemu-nbd
650%attr(755,root,root) %{_libdir}/qemu-bridge-helper
651%{_mandir}/man1/qemu.1*
652%{_mandir}/man1/virtfs-proxy-helper.1*
653%{_mandir}/man8/qemu-nbd.8*
654
655%dir %{_datadir}/qemu
656%{_datadir}/%{name}/keymaps
657%{_datadir}/%{name}/qemu-icon.bmp
658# various bios images
659%{_datadir}/%{name}/*.aml
660%{_datadir}/%{name}/*.bin
661%{_datadir}/%{name}/*.rom
662%{_datadir}/%{name}/*.dtb
663%{_datadir}/%{name}/qemu_logo_no_text.svg
664%{_datadir}/%{name}/openbios-ppc
665%{_datadir}/%{name}/openbios-sparc*
666%{_datadir}/%{name}/palcode-clipper
667%{_datadir}/%{name}/s390-ccw.img
668
669%files img
670%defattr(644,root,root,755)
671%attr(755,root,root) %{_bindir}/qemu-img
672%{_mandir}/man1/qemu-img.1*
673
674%files user
675%defattr(644,root,root,755)
676%attr(755,root,root) %{_bindir}/qemu-alpha
677%attr(755,root,root) %{_bindir}/qemu-arm
678%attr(755,root,root) %{_bindir}/qemu-armeb
679%attr(755,root,root) %{_bindir}/qemu-cris
680%attr(755,root,root) %{_bindir}/qemu-ga
681%attr(755,root,root) %{_bindir}/qemu-i386
682%attr(755,root,root) %{_bindir}/qemu-io
683%attr(755,root,root) %{_bindir}/qemu-m68k
684%attr(755,root,root) %{_bindir}/qemu-microblaze
685%attr(755,root,root) %{_bindir}/qemu-microblazeel
686%attr(755,root,root) %{_bindir}/qemu-mips
687%attr(755,root,root) %{_bindir}/qemu-mipsel
688%attr(755,root,root) %{_bindir}/qemu-mips64
689%attr(755,root,root) %{_bindir}/qemu-mips64el
690%attr(755,root,root) %{_bindir}/qemu-mipsn32
691%attr(755,root,root) %{_bindir}/qemu-mipsn32el
692%attr(755,root,root) %{_bindir}/qemu-or32
693%attr(755,root,root) %{_bindir}/qemu-ppc
694%attr(755,root,root) %{_bindir}/qemu-ppc64
695%attr(755,root,root) %{_bindir}/qemu-ppc64abi32
696%attr(755,root,root) %{_bindir}/qemu-s390x
697%attr(755,root,root) %{_bindir}/qemu-sh4
698%attr(755,root,root) %{_bindir}/qemu-sh4eb
699%attr(755,root,root) %{_bindir}/qemu-sparc
700%attr(755,root,root) %{_bindir}/qemu-sparc32plus
701%attr(755,root,root) %{_bindir}/qemu-sparc64
702%attr(755,root,root) %{_bindir}/qemu-unicore32
703%attr(755,root,root) %{_bindir}/qemu-x86_64
704
705%files system-alpha
706%defattr(644,root,root,755)
707%attr(755,root,root) %{_bindir}/qemu-system-alpha
708
709%files system-arm
710%defattr(644,root,root,755)
711%attr(755,root,root) %{_bindir}/qemu-system-arm
712
713%files system-cris
714%defattr(644,root,root,755)
715%attr(755,root,root) %{_bindir}/qemu-system-cris
716
717%files system-lm32
718%defattr(644,root,root,755)
719%attr(755,root,root) %{_bindir}/qemu-system-lm32
720
721%files system-m68k
722%defattr(644,root,root,755)
723%attr(755,root,root) %{_bindir}/qemu-system-m68k
724
725%files system-microblaze
726%defattr(644,root,root,755)
727%attr(755,root,root) %{_bindir}/qemu-system-microblaze
728%attr(755,root,root) %{_bindir}/qemu-system-microblazeel
729
730%files system-mips
731%defattr(644,root,root,755)
732%attr(755,root,root) %{_bindir}/qemu-system-mips
733%attr(755,root,root) %{_bindir}/qemu-system-mipsel
734%attr(755,root,root) %{_bindir}/qemu-system-mips64
735%attr(755,root,root) %{_bindir}/qemu-system-mips64el
736
737%files system-moxie
738%defattr(644,root,root,755)
739%attr(755,root,root) %{_bindir}/qemu-system-moxie
740
741%files system-or32
742%defattr(644,root,root,755)
743%attr(755,root,root) %{_bindir}/qemu-system-or32
744
745%files system-ppc
746%defattr(644,root,root,755)
747%attr(755,root,root) %{_bindir}/qemu-system-ppc
748%attr(755,root,root) %{_bindir}/qemu-system-ppc64
749%attr(755,root,root) %{_bindir}/qemu-system-ppcemb
750
751%files system-s390x
752%defattr(644,root,root,755)
753%attr(755,root,root) %{_bindir}/qemu-system-s390x
754
755%files system-sh4
756%defattr(644,root,root,755)
757%attr(755,root,root) %{_bindir}/qemu-system-sh4
758%attr(755,root,root) %{_bindir}/qemu-system-sh4eb
759
760%files system-sparc
761%defattr(644,root,root,755)
762%attr(755,root,root) %{_bindir}/qemu-system-sparc
763%attr(755,root,root) %{_bindir}/qemu-system-sparc64
764
765%files system-unicore32
766%defattr(644,root,root,755)
767%attr(755,root,root) %{_bindir}/qemu-system-unicore32
768
769%files system-x86
770%defattr(644,root,root,755)
771%attr(755,root,root) %{_bindir}/qemu-system-i386
772%attr(755,root,root) %{_bindir}/qemu-system-x86_64
773
774%files system-xtensa
775%defattr(644,root,root,755)
776%attr(755,root,root) %{_bindir}/qemu-system-xtensa
777%attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
This page took 0.071119 seconds and 4 git commands to generate.