]> git.pld-linux.org Git - packages/qalculate-gtk.git/commitdiff
- up to 2.9.0 auto/th/qalculate-gtk-2.9.0-1
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 16 Feb 2019 13:23:02 +0000 (14:23 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 16 Feb 2019 13:23:02 +0000 (14:23 +0100)
desktop.patch [deleted file]
qalculate-gtk.spec
qalculate-wformat-security.patch [deleted file]

diff --git a/desktop.patch b/desktop.patch
deleted file mode 100644 (file)
index 37fa0c0..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-Update to latest freedesktop spec.
-
---- data/qalculate-gtk.desktop.in
-+++ data/qalculate-gtk.desktop.in
-@@ -1,11 +1,9 @@
- [Desktop Entry]
--Encoding=UTF-8
- _Name=Qalculate!
- _Comment=Powerful and easy to use calculator
- Exec=qalculate-gtk
--Icon=qalculate.png
-+Icon=qalculate
- Terminal=false
- Type=Application
- StartupNotify=true
--Categories=GNOME;Application;Utility;
--
-+Categories=GTK;Utility;
index 15050d41faf0cc604ea2269c8e2fc17b306d215d..ca0c748266b1f5dd491d9f94be4470e2d3a42081 100644 (file)
@@ -1,15 +1,13 @@
 Summary:       Modern desktop calculator
 Summary(pl.UTF-8):     Nowoczesny kalkulator
 Name:          qalculate-gtk
-Version:       0.9.7
-Release:       2
+Version:       2.9.0
+Release:       1
 License:       GPL
 Group:         Applications/Math
-Source0:       http://downloads.sourceforge.net/qalculate/%{name}-%{version}.tar.gz
-# Source0-md5: 7a7ab4680e285690ca3625992f477f0f
-Patch0:                desktop.patch
-Patch1:                qalculate-wformat-security.patch
-URL:           http://qalculate.sourceforge.net/
+Source0:       https://github.com/Qalculate/qalculate-gtk/releases/download/v%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 1d7c7797eb01d601f6b9f4f5ac4f3bfc
+URL:           http://qalculate.github.io/
 BuildRequires: automake
 BuildRequires: cln-devel >= 1.1.0
 BuildRequires: gtk+2-devel >= 2:2.4.0
@@ -17,7 +15,7 @@ BuildRequires:        intltool
 BuildRequires: libglade2-devel >= 2.0
 BuildRequires: libgnome-devel >= 2.0.0
 BuildRequires: libgnomeui-devel >= 2.0.0
-BuildRequires: libqalculate-devel >= 0.9.7-3
+BuildRequires: libqalculate-devel >= 2.8.0
 BuildRequires: libtool
 BuildRequires: libxml2-devel >= 2.3.8
 BuildRequires: pkgconfig
@@ -41,8 +39,6 @@ graficzny interfejs (GTK+).
 
 %prep
 %setup -q
-%patch0 -p0
-%patch1 -p0
 
 %build
 %configure
@@ -66,9 +62,8 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS README TODO
+%doc AUTHORS ChangeLog NEWS README TODO doc/html
 %attr(755,root,root) %{_bindir}/*
 %{_desktopdir}/*.desktop
-%{_datadir}/%{name}
 %{_pixmapsdir}/*.png
-%{_omf_dest_dir}/%{name}
+%{_datadir}/appdata/qalculate-gtk.appdata.xml
diff --git a/qalculate-wformat-security.patch b/qalculate-wformat-security.patch
deleted file mode 100644 (file)
index db5185d..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-Description: Fix compiling with -Werror=format-security.
- Prevents format string attacks.
-Author: Simon Ruderich <simon@ruderich.org>
-Last-Update: 2013-05-23
-
---- src/callbacks.cc
-+++ src/callbacks.cc.new
-@@ -388,12 +388,12 @@ void wrap_expression_selection() {
- }
- void show_message(const gchar *text, GtkWidget *win) {
--      GtkWidget *edialog = gtk_message_dialog_new(GTK_WINDOW(win), GTK_DIALOG_DESTROY_WITH_PARENT, GTK_MESSAGE_ERROR, GTK_BUTTONS_CLOSE, text);
-+      GtkWidget *edialog = gtk_message_dialog_new(GTK_WINDOW(win), GTK_DIALOG_DESTROY_WITH_PARENT, GTK_MESSAGE_ERROR, GTK_BUTTONS_CLOSE, "%s", text);
-       gtk_dialog_run(GTK_DIALOG(edialog));
-       gtk_widget_destroy(edialog);
- }
- bool ask_question(const gchar *text, GtkWidget *win) {
--      GtkWidget *edialog = gtk_message_dialog_new(GTK_WINDOW(win), GTK_DIALOG_DESTROY_WITH_PARENT, GTK_MESSAGE_ERROR, GTK_BUTTONS_YES_NO, text);
-+      GtkWidget *edialog = gtk_message_dialog_new(GTK_WINDOW(win), GTK_DIALOG_DESTROY_WITH_PARENT, GTK_MESSAGE_ERROR, GTK_BUTTONS_YES_NO, "%s", text);
-       int question_answer = gtk_dialog_run(GTK_DIALOG(edialog));
-       gtk_widget_destroy(edialog);
-       return question_answer == GTK_RESPONSE_YES;
-@@ -654,7 +654,7 @@ void display_errors(GtkTextIter *iter =
-                                       GTK_DIALOG_DESTROY_WITH_PARENT,
-                                       GTK_MESSAGE_INFO,
-                                       GTK_BUTTONS_CLOSE,
--                                      CALCULATOR->message()->message().c_str());
-+                                      "%s", CALCULATOR->message()->message().c_str());
-                       gtk_dialog_run(GTK_DIALOG(edialog));
-                       gtk_widget_destroy(edialog);
-               }
-@@ -667,14 +667,14 @@ void display_errors(GtkTextIter *iter =
-                                       GTK_DIALOG_DESTROY_WITH_PARENT,
-                                       GTK_MESSAGE_ERROR,
-                                       GTK_BUTTONS_CLOSE,
--                                      str.c_str());
-+                                      "%s", str.c_str());
-               } else {
-                       edialog = gtk_message_dialog_new(
-                                       GTK_WINDOW(win),
-                                       GTK_DIALOG_DESTROY_WITH_PARENT,
-                                       GTK_MESSAGE_WARNING,
-                                       GTK_BUTTONS_CLOSE,
--                                      str.c_str());
-+                                      "%s", str.c_str());
-               }
-               gtk_dialog_run(GTK_DIALOG(edialog));
This page took 0.236457 seconds and 4 git commands to generate.