]> git.pld-linux.org Git - packages/python3.git/commitdiff
- updated to 3.0.1
authorArtur Frysiak <artur@frysiak.net>
Wed, 25 Feb 2009 10:24:35 +0000 (10:24 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    python3-noarch_to_datadir.patch -> 1.2

python3-noarch_to_datadir.patch

index 0198a306694eca3da10e2997b23149f4a641afc0..8450022534076c8936299c55d7e5dad40cb4da67 100644 (file)
@@ -1,82 +1,5 @@
-diff -Nur Python-2.5.orig/Lib/distutils/command/install.py Python-2.5/Lib/distutils/command/install.py
---- Python-2.5.orig/Lib/distutils/command/install.py   2007-03-17 16:26:13.803357750 +0000
-+++ Python-2.5/Lib/distutils/command/install.py        2007-03-17 16:26:50.821671250 +0000
-@@ -40,14 +40,14 @@
- INSTALL_SCHEMES = {
-     'unix_prefix': {
--        'purelib': '$base/lib/python$py_version_short/site-packages',
-+        'purelib': '$base/share/python$py_version_short/site-packages',
-         'platlib': '$platbase/'+libname+'/python$py_version_short/site-packages',
-         'headers': '$base/include/python$py_version_short/$dist_name',
-         'scripts': '$base/bin',
-         'data'   : '$base',
-         },
-     'unix_home': {
--        'purelib': '$base/lib/python',
-+        'purelib': '$base/share/python',
-         'platlib': '$base/'+libname+'/python',
-         'headers': '$base/include/python/$dist_name',
-         'scripts': '$base/bin',
-diff -Nur Python-2.5.orig/Lib/distutils/sysconfig.py Python-2.5/Lib/distutils/sysconfig.py
---- Python-2.5.orig/Lib/distutils/sysconfig.py 2007-03-17 16:26:13.803357750 +0000
-+++ Python-2.5/Lib/distutils/sysconfig.py      2007-03-17 16:26:50.821671250 +0000
-@@ -99,12 +99,12 @@
-         prefix = plat_specific and EXEC_PREFIX or PREFIX
-     if os.name == "posix":
--        if plat_specific:
--            lib = sys.lib
-+        if plat_specific: 
-+            libpython = os.path.join(prefix,
-+                                 sys.lib, "python" + get_python_version())
-         else:
--            lib = 'lib'
--        libpython = os.path.join(prefix,
--                                 lib, "python" + get_python_version())
-+            libpython = os.path.join(prefix,
-+                                 "share", "python" + get_python_version())
-         if standard_lib:
-             return libpython
-         else:
-diff -Nur Python-2.5.orig/Lib/site.py Python-2.5/Lib/site.py
---- Python-2.5.orig/Lib/site.py        2007-03-17 16:26:13.803357750 +0000
-+++ Python-2.5/Lib/site.py     2007-03-17 16:26:50.825671500 +0000
-@@ -185,13 +185,12 @@
-                                          sys.lib,
-                                          "python" + sys.version[:3],
-                                          "site-packages"),
--                            os.path.join(prefix, sys.lib, "site-python")]
--                if sys.lib != 'lib':
--                    sitedirs.append(os.path.join(prefix,
--                                                 'lib',
--                                                 "python" + sys.version[:3],
--                                                 "site-packages"))
--                    sitedirs.append(os.path.join(prefix, 'lib', "site-python"))
-+                            os.path.join(prefix, sys.lib, "site-python"),
-+                            os.path.join(prefix,
-+                                         "share",
-+                                         "python" + sys.version[:3],
-+                                         "site-packages"),
-+                            os.path.join(prefix, "share", "site-python")]
-             else:
-                 sitedirs = [prefix, os.path.join(prefix, sys.lib, "site-packages")]
-             if sys.platform == 'darwin':
-diff -Nur Python-2.5.orig/Makefile.pre.in Python-2.5/Makefile.pre.in
---- Python-2.5.orig/Makefile.pre.in    2007-03-17 16:26:13.807358000 +0000
-+++ Python-2.5/Makefile.pre.in 2007-03-17 16:26:50.821671250 +0000
-@@ -90,7 +90,7 @@
- MANDIR=               @mandir@
- INCLUDEDIR=   @includedir@
- CONFINCLUDEDIR=       $(exec_prefix)/include
--SCRIPTDIR=    $(prefix)/$(LIB)
-+SCRIPTDIR=    $(prefix)/share
- # Detailed destination directories
- BINLIBDEST=   $(LIBDIR)/python$(VERSION)
-diff -Nur Python-2.5.orig/Modules/getpath.c Python-2.5/Modules/getpath.c
---- Python-2.5.orig/Modules/getpath.c  2007-03-17 16:26:13.807358000 +0000
-+++ Python-2.5/Modules/getpath.c       2007-03-17 16:26:50.825671500 +0000
+--- Python-3.0.1/Modules/getpath.c.wiget       2009-02-25 10:58:09.000000000 +0100
++++ Python-3.0.1/Modules/getpath.c     2009-02-25 11:21:43.000000000 +0100
 @@ -126,7 +126,8 @@
  
  #ifndef PYTHONPATH
@@ -87,57 +10,124 @@ diff -Nur Python-2.5.orig/Modules/getpath.c Python-2.5/Modules/getpath.c
  #endif
  
  #ifndef LANDMARK
-@@ -137,7 +138,8 @@
- static char exec_prefix[MAXPATHLEN+1];
- static char progpath[MAXPATHLEN+1];
- static char *module_search_path = NULL;
- static char lib_python[] = LIB_PYTHON VERSION;
-+static char share_python[] = "share/python" VERSION;
+@@ -138,6 +139,7 @@ static wchar_t exec_prefix[MAXPATHLEN+1]
+ static wchar_t progpath[MAXPATHLEN+1];
+ static wchar_t *module_search_path = NULL;
+ static wchar_t lib_python[] = LIB_PYTHON VERSION;
++static wchar_t share_python[] = L"share/python" VERSION;
  
- static void
- reduce(char *dir)
-@@ -275,7 +277,7 @@
-         delim = strchr(prefix, DELIM);
+ /* In principle, this should use HAVE__WSTAT, and _wstat
+    should be detected by autoconf. However, no current
+@@ -338,7 +340,7 @@ search_for_prefix(wchar_t *argv0_path, w
+         delim = wcschr(prefix, DELIM);
          if (delim)
-             *delim = '\0';
+             *delim = L'\0';
 -        joinpath(prefix, lib_python);
 +        joinpath(prefix, share_python);
          joinpath(prefix, LANDMARK);
          return 1;
      }
-@@ -298,7 +300,7 @@
+@@ -361,7 +363,7 @@ search_for_prefix(wchar_t *argv0_path, w
      copy_absolute(prefix, argv0_path);
      do {
-         n = strlen(prefix);
+         n = wcslen(prefix);
 -        joinpath(prefix, lib_python);
 +        joinpath(prefix, share_python);
          joinpath(prefix, LANDMARK);
          if (ismodule(prefix))
              return 1;
-@@ -308,7 +310,7 @@
+@@ -371,7 +373,7 @@ search_for_prefix(wchar_t *argv0_path, w
  
      /* Look at configure's PREFIX */
-     strncpy(prefix, PREFIX, MAXPATHLEN);
+     wcsncpy(prefix, L"" PREFIX, MAXPATHLEN);
 -    joinpath(prefix, lib_python);
 +    joinpath(prefix, share_python);
      joinpath(prefix, LANDMARK);
      if (ismodule(prefix))
          return 1;
-@@ -519,7 +521,7 @@
+@@ -598,7 +600,7 @@ calculate_path(void)
              fprintf(stderr,
                  "Could not find platform independent libraries <prefix>\n");
-         strncpy(prefix, PREFIX, MAXPATHLEN);
+         wcsncpy(prefix, L"" PREFIX, MAXPATHLEN);
 -        joinpath(prefix, lib_python);
 +        joinpath(prefix, share_python);
      }
      else
          reduce(prefix);
-@@ -532,7 +534,7 @@
+@@ -611,7 +613,7 @@ calculate_path(void)
      }
      else
-         strncpy(zip_path, PREFIX, MAXPATHLEN);
--    joinpath(zip_path, "lib/python00.zip");
+         wcsncpy(zip_path, L"" PREFIX, MAXPATHLEN);
+-    joinpath(zip_path, L"lib/python00.zip");
 +    joinpath(zip_path, LIB_PYTHON "00.zip");
-     bufsz = strlen(zip_path); /* Replace "00" with version */
+     bufsz = wcslen(zip_path); /* Replace "00" with version */
      zip_path[bufsz - 6] = VERSION[0];
      zip_path[bufsz - 5] = VERSION[2];
+--- Python-3.0.1/Lib/site.py.wiget     2009-02-25 10:58:09.000000000 +0100
++++ Python-3.0.1/Lib/site.py   2009-02-25 11:03:48.000000000 +0100
+@@ -262,11 +262,10 @@ def addsitepackages(known_paths):
+                                         "python" + sys.version[:3],
+                                         "site-packages"))
+             sitedirs.append(os.path.join(prefix, sys.lib, "site-python"))
+-            if sys.lib != 'lib':
+-                sitedirs.append(os.path.join(prefix, 'lib',
+-                                            "python" + sys.version[:3],
+-                                            "site-packages"))
+-                sitedirs.append(os.path.join(prefix, 'lib', "site-python"))
++            sitedirs.append(os.path.join(prefix, 'share',
++                                        "python" + sys.version[:3],
++                                        "site-packages"))
++            sitedirs.append(os.path.join(prefix, 'share', "site-python"))
+               
+         else:
+             sitedirs.append(prefix)
+--- Python-3.0.1/Lib/distutils/sysconfig.py.wiget      2009-02-25 10:58:09.000000000 +0100
++++ Python-3.0.1/Lib/distutils/sysconfig.py    2009-02-25 10:58:09.000000000 +0100
+@@ -114,12 +114,12 @@ def get_python_lib(plat_specific=0, stan
+         prefix = plat_specific and EXEC_PREFIX or PREFIX
+     if os.name == "posix":
+-        if plat_specific:
+-            lib = sys.lib
++        if plat_specific: 
++            libpython = os.path.join(prefix,
++                                 sys.lib, "python" + get_python_version())
+         else:
+-            lib = 'lib'
+-        libpython = os.path.join(prefix,
+-                                 lib, "python" + get_python_version())
++            libpython = os.path.join(prefix,
++                                 "share", "python" + get_python_version())
+         if standard_lib:
+             return libpython
+         else:
+--- Python-3.0.1/Lib/distutils/command/install.py.wiget        2009-02-25 10:58:09.000000000 +0100
++++ Python-3.0.1/Lib/distutils/command/install.py      2009-02-25 10:58:09.000000000 +0100
+@@ -40,14 +40,14 @@ else:
+ INSTALL_SCHEMES = {
+     'unix_prefix': {
+-        'purelib': '$base/lib/python$py_version_short/site-packages',
++        'purelib': '$base/share/python$py_version_short/site-packages',
+         'platlib': '$platbase/'+libname+'/python$py_version_short/site-packages',
+         'headers': '$base/include/python$py_version_short/$dist_name',
+         'scripts': '$base/bin',
+         'data'   : '$base',
+         },
+     'unix_home': {
+-        'purelib': '$base/lib/python',
++        'purelib': '$base/share/python',
+         'platlib': '$base/'+libname+'/python',
+         'headers': '$base/include/python/$dist_name',
+         'scripts': '$base/bin',
+--- Python-3.0.1/Makefile.pre.in.wiget 2009-02-25 10:58:09.000000000 +0100
++++ Python-3.0.1/Makefile.pre.in       2009-02-25 10:58:09.000000000 +0100
+@@ -93,7 +93,7 @@ LIBDIR=              $(exec_prefix)/$(LIB)
+ MANDIR=               @mandir@
+ INCLUDEDIR=   @includedir@
+ CONFINCLUDEDIR=       $(exec_prefix)/include
+-SCRIPTDIR=    $(prefix)/$(LIB)
++SCRIPTDIR=    $(prefix)/share
+ # Detailed destination directories
+ BINLIBDEST=   $(LIBDIR)/python$(VERSION)
This page took 0.063188 seconds and 4 git commands to generate.