]> git.pld-linux.org Git - packages/python3.git/commitdiff
- started to work on python 3.2 (merged DEVEL branch)
authorwrobell <wrobell@pld-linux.org>
Tue, 22 Feb 2011 00:51:46 +0000 (00:51 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    python3-ac_fixes.patch -> 1.3
    python3-lib64.patch -> 1.5
    python3-pythonpath.patch -> 1.6
    python3.spec -> 1.37

python3-ac_fixes.patch
python3-lib64.patch
python3-pythonpath.patch
python3.spec

index e89ee25bceda1a6a329773e85e12aee1af386032..7e04e8029a68d912b7bfddc04a806979b530c62a 100644 (file)
@@ -1,10 +1,10 @@
---- Python-2.5b2/configure.in.orig     2006-07-06 11:13:35.000000000 +0100
-+++ Python-2.5b2/configure.in  2006-07-12 16:30:30.000000000 +0100
-@@ -753,13 +753,13 @@
+--- Python-3.2b1/configure.in.orig     2010-12-12 16:18:42.000000000 +0000
++++ Python-3.2b1/configure.in  2010-12-12 16:20:34.000000000 +0000
+@@ -879,13 +879,13 @@
            if test "$Py_DEBUG" = 'true' ; then
                # Optimization messes up debuggers, so turn it off for
                # debug builds.
--              OPT="-g -Wall $STRICT_PROTO"
+-              OPT="-g -O0 -Wall $STRICT_PROTO"
 +              OPT="-g $CPPFLAGS $CFLAGS -Wall $STRICT_PROTO"
            else
 -              OPT="-g $WRAP -O3 -Wall $STRICT_PROTO"
            ;;
        esac
        case $ac_sys_system in
---- Python-2.5c1.orig/Makefile.pre.in  2006-07-30 17:20:10.000000000 +0100
-+++ Python-2.5c1/Makefile.pre.in       2006-08-25 17:51:05.000000000 +0100
-@@ -852,7 +852,7 @@
-       $(INSTALL_SCRIPT) $(srcdir)/install-sh $(DESTDIR)$(LIBPL)/install-sh
-       # Substitution happens here, as the completely-expanded BINDIR
-       # is not available in configure
--      sed -e "s,@EXENAME@,$(BINDIR)/python$(VERSION)$(EXE)," < $(srcdir)/Misc/python-config.in >python-config
-+      sed -e "s,@EXENAME@,$(BINDIR)/python$(EXE)," < $(srcdir)/Misc/python-config.in >python-config
-       $(INSTALL_SCRIPT) python-config $(DESTDIR)$(BINDIR)/python$(VERSION)-config
-       rm python-config
-       @if [ -s Modules/python.exp -a \
index cf4493e6af2c09558e430247f7295322c65f9ad2..2319b63f7a42faa7c32e9ff94b8e6f47bca32285 100644 (file)
@@ -281,14 +281,3 @@ diff -Nur Python-2.5b2.orig/setup.py Python-2.5b2/setup.py
                                     extra_link_args=readline_extra_link_args,
                                     libraries=readline_libs) )
          if platform not in ['mac']:
-@@ -1244,8 +1244,8 @@
-             added_lib_dirs.append('/usr/openwin/lib')
-         elif os.path.exists('/usr/X11R6/include'):
-             include_dirs.append('/usr/X11R6/include')
--            added_lib_dirs.append('/usr/X11R6/lib64')
--            added_lib_dirs.append('/usr/X11R6/lib')
-+            added_lib_dirs.append('/usr/X11R6/'+sys.lib)
-+            #added_lib_dirs.append('/usr/X11R6/lib')
-         elif os.path.exists('/usr/X11R5/include'):
-             include_dirs.append('/usr/X11R5/include')
-             added_lib_dirs.append('/usr/X11R5/lib')
index b6dec9067a5de9802ef0e40ab919587ec0c7087d..fe5e48ebfbf956b1cca7e61d733d1c0ec8081447 100644 (file)
@@ -1,14 +1,3 @@
---- Python-3.0.1/Modules/getpath.c.wiget       2009-02-12 16:56:48.000000000 +0100
-+++ Python-3.0.1/Modules/getpath.c     2009-03-14 18:12:32.000000000 +0100
-@@ -481,7 +481,7 @@ calculate_path(void)
-       * "#!/opt/python2.3/bin/python", the kernel only passes "python"
-       * as argv[0], which falls through to the $PATH search below.
-       * If /opt/python2.3/bin isn't in your path, or is near the end,
--      * this algorithm may incorrectly find /usr/bin/python. To work
-+      * this algorithm may incorrectly find /usr/bin/python3. To work
-       * around this, we can use _NSGetExecutablePath to get a better
-       * hint of what the intended interpreter was, although this
-       * will fail if a relative path was used. but in that case,
 --- Python-3.0.1/Lib/distutils/tests/test_build_scripts.py.wiget       2004-08-26 07:44:02.000000000 +0200
 +++ Python-3.0.1/Lib/distutils/tests/test_build_scripts.py     2009-03-14 18:12:32.000000000 +0100
 @@ -58,7 +58,7 @@ class BuildScriptsTestCase(support.Tempd
                                      "# bogus script w/ Python sh-bang\n"
                                      "pass\n"))
          write_script("shell.sh", ("#!/bin/sh\n"
---- Python-3.0.1/Lib/test/test_optparse.py.wiget       2008-05-20 23:35:26.000000000 +0200
-+++ Python-3.0.1/Lib/test/test_optparse.py     2009-03-14 18:12:32.000000000 +0100
-@@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python3
- #
- # Test suite for Optik.  Supplied by Johannes Gijsbers
---- Python-3.0.1/Lib/test/test_bz2.py.wiget    2008-07-16 05:43:04.000000000 +0200
-+++ Python-3.0.1/Lib/test/test_bz2.py  2009-03-14 18:12:32.000000000 +0100
-@@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python3
- from test import support
- from test.support import TESTFN
 --- Python-3.0.1/Lib/cgi.py.wiget      2008-12-04 21:11:57.000000000 +0100
 +++ Python-3.0.1/Lib/cgi.py    2009-03-14 18:12:32.000000000 +0100
 @@ -1,6 +1,6 @@
  # intentionally NOT "/usr/bin/env python".  On many systems
  # (e.g. Solaris), /usr/local/bin is not in $PATH as passed to CGI
  # scripts, and /usr/local/bin is the default directory where Python is
---- Python-3.0.1/Demo/cgi/cgi2.py.wiget        2007-08-06 23:07:53.000000000 +0200
-+++ Python-3.0.1/Demo/cgi/cgi2.py      2009-03-14 18:12:32.000000000 +0100
-@@ -1,4 +1,4 @@
--#!/usr/local/bin/python
-+#!/usr/bin/python3
- """CGI test 2 - basic use of cgi module."""
---- Python-3.0.1/Demo/cgi/cgi1.py.wiget        2007-07-17 22:59:35.000000000 +0200
-+++ Python-3.0.1/Demo/cgi/cgi1.py      2009-03-14 18:12:32.000000000 +0100
-@@ -1,4 +1,4 @@
--#!/usr/local/bin/python
-+#!/usr/bin/python3
- """CGI test 1 - check server setup."""
---- Python-3.0.1/Demo/cgi/cgi3.py.wiget        2002-10-17 17:53:02.000000000 +0200
-+++ Python-3.0.1/Demo/cgi/cgi3.py      2009-03-14 18:12:32.000000000 +0100
-@@ -1,4 +1,4 @@
--#!/usr/local/bin/python
-+#!/usr/bin/python3
- """CGI test 3 (persistent data)."""
---- Python-3.0.1/Demo/tix/INSTALL.txt.wiget    2001-11-11 15:07:37.000000000 +0100
-+++ Python-3.0.1/Demo/tix/INSTALL.txt  2009-03-14 18:12:32.000000000 +0100
-@@ -71,7 +71,7 @@ _tkinter _tkinter.c tkappinit.c -DWITH_A
- You should now have a working Tix implementation in Python. To see if all
- is as it should be, run the 'tixwidgets.py' script in the Demo/tix directory.
- Under X windows, do
--      /usr/local/bin/python Demo/tix/tixwidgets.py
-+      /usr/bin/python3 Demo/tix/tixwidgets.py
- If this does not work, you may need to tell python where to find
- the Tcl, Tk and Tix library files. This is done by setting the
-@@ -80,7 +80,7 @@ TCL_LIBRARY, TK_LIBRARY and TIX_LIBRARY 
-       env     TCL_LIBRARY=/usr/local/lib/tcl8.3 \
-               TK_LIBRARY=/usr/local/lib/tk8.3 \
-               TIX_LIBRARY=/usr/local/lib/tix8.1 \
--              /usr/local/bin/python Demo/tix/tixwidgets.py
-+              /usr/bin/python3 Demo/tix/tixwidgets.py
- If you find any bugs or have suggestions for improvement, please report them
---- Python-3.0.1/Tools/faqwiz/faqw.py.wiget    2008-02-23 19:30:17.000000000 +0100
-+++ Python-3.0.1/Tools/faqwiz/faqw.py  2009-03-14 18:12:32.000000000 +0100
-@@ -1,4 +1,4 @@
--#! /usr/local/bin/python
-+#! /usr/bin/python3
- """FAQ wizard bootstrap."""
-@@ -10,7 +10,7 @@
- # executable.
- # You need to edit the first line and the lines that define FAQDIR and
--# SRCDIR, below: change /usr/local/bin/python to where your Python
-+# SRCDIR, below: change /usr/bin/python3 to where your Python
- # interpreter lives, change the value for FAQDIR to where your FAQ
- # lives, and change the value for SRCDIR to where your faqwiz.py
- # module lives.  The faqconf.py and faqcust.py files live there, too.
---- Python-3.0.1/Tools/pybench/README.wiget    2009-02-07 18:28:46.000000000 +0100
-+++ Python-3.0.1/Tools/pybench/README  2009-03-14 18:12:32.000000000 +0100
-@@ -142,7 +142,7 @@ Benchmark: 2006-06-12 12:09:25
-     Python:
-        Implementation: CPython
--       Executable:   /usr/local/bin/python
-+       Executable:   /usr/bin/python3
-        Version:      3.0
-        Compiler:     GCC 3.3.4 (pre 3.3.5 20040809)
-        Bits:         64bit
 --- Python-3.0.1/Tools/pybench/pybench.py.wiget        2009-02-07 18:28:46.000000000 +0100
 +++ Python-3.0.1/Tools/pybench/pybench.py      2009-03-14 18:12:32.000000000 +0100
 @@ -1,4 +1,4 @@
  
  """ A Python Benchmark Suite
  
---- Python-3.0.1/Tools/scripts/README.wiget    2007-10-13 20:56:00.000000000 +0200
-+++ Python-3.0.1/Tools/scripts/README  2009-03-14 18:12:32.000000000 +0100
-@@ -44,7 +44,7 @@ ndiff.py             Intelligent diff between text 
- nm2def.py             Create a template for PC/python_nt.def (Marc Lemburg)
- objgraph.py           Print object graph from nm output on a library
- parseentities.py      Utility for parsing HTML entity definitions
--pathfix.py            Change #!/usr/local/bin/python into something else
-+pathfix.py            Change #!/usr/bin/python3 into something else
- pdeps.py              Print dependencies between Python modules
- pickle2db.py          Load a pickle generated by db2pickle.py to a database
- pindent.py            Indent Python code, giving block-closing comments
---- Python-3.0.1/Tools/scripts/parseentities.py.wiget  2008-05-16 17:23:30.000000000 +0200
-+++ Python-3.0.1/Tools/scripts/parseentities.py        2009-03-14 18:12:32.000000000 +0100
-@@ -1,4 +1,4 @@
--#!/usr/local/bin/python
-+#!/usr/bin/python3
- """ Utility for parsing HTML entity definitions available from:
-       http://www.w3.org/ as e.g.
 --- Python-3.0.1/Tools/scripts/fixps.py.wiget  2007-08-03 19:06:41.000000000 +0200
 +++ Python-3.0.1/Tools/scripts/fixps.py        2009-03-14 18:12:32.000000000 +0100
 @@ -15,13 +15,13 @@ def main():
                        '/usr/bin/env python', line)
          print(filename, ':', repr(line))
          f = open(filename, "w")
---- Python-3.0.1/Doc/install/index.rst.wiget   2009-01-04 01:09:41.000000000 +0100
-+++ Python-3.0.1/Doc/install/index.rst 2009-03-14 18:12:32.000000000 +0100
-@@ -362,16 +362,16 @@ However, if you are installing Python mo
- them to go in :file:`/usr/local/lib/python2.{X}` rather than
- :file:`/usr/lib/python2.{X}`.  This can be done with ::
--   /usr/bin/python setup.py install --prefix=/usr/local
-+   /usr/bin/python3 setup.py install --prefix=/usr/local
- Another possibility is a network filesystem where the name used to write to a
- remote directory is different from the name used to read it: for example, the
--Python interpreter accessed as :file:`/usr/local/bin/python` might search for
-+Python interpreter accessed as :file:`/usr/bin/python3` might search for
- modules in :file:`/usr/local/lib/python2.{X}`, but those modules would have to
- be installed to, say, :file:`/mnt/{@server}/export/lib/python2.{X}`.  This could
- be done with ::
--   /usr/local/bin/python setup.py install --prefix=/mnt/@server/export
-+   /usr/bin/python3 setup.py install --prefix=/mnt/@server/export
- In either case, the :option:`--prefix` option defines the installation base, and
- the :option:`--exec-prefix` option defines the platform-specific installation
 --- Python-3.0.1/Doc/README.txt.wiget  2009-02-13 00:46:00.000000000 +0100
 +++ Python-3.0.1/Doc/README.txt        2009-03-14 18:12:32.000000000 +0100
 @@ -37,7 +37,7 @@ the top-level index `build/html/index.ht
  
  Available make targets are:
  
---- Python-3.0.1/Doc/tutorial/interpreter.rst.wiget    2009-01-04 01:04:26.000000000 +0100
-+++ Python-3.0.1/Doc/tutorial/interpreter.rst  2009-03-14 18:13:35.000000000 +0100
-@@ -10,11 +10,11 @@ Using the Python Interpreter
- Invoking the Interpreter
- ========================
--The Python interpreter is usually installed as :file:`/usr/local/bin/python3.1`
-+The Python interpreter is usually installed as :file:`/usr/local/bin/python3`
- on those machines where it is available; putting :file:`/usr/local/bin` in your
- Unix shell's search path makes it possible to start it by typing the command ::
--   python3.1
-+   python3
- to the shell. [#]_ Since the choice of the directory where the interpreter lives
- is an installation option, other places are possible; check with your local
---- Python-3.0.1/Doc/c-api/init.rst.wiget      2009-02-06 03:50:18.000000000 +0100
-+++ Python-3.0.1/Doc/c-api/init.rst    2009-03-14 18:12:32.000000000 +0100
-@@ -194,7 +194,7 @@ Initialization, Finalization, and Thread
-    Return the *prefix* for installed platform-independent files. This is derived
-    through a number of complicated rules from the program name set with
-    :cfunc:`Py_SetProgramName` and some environment variables; for example, if the
--   program name is ``'/usr/local/bin/python'``, the prefix is ``'/usr/local'``. The
-+   program name is ``'/usr/bin/python3'``, the prefix is ``'/usr/local'``. The
-    returned string points into static storage; the caller should not modify its
-    value.  This corresponds to the :makevar:`prefix` variable in the top-level
-    :file:`Makefile` and the :option:`--prefix` argument to the :program:`configure`
-@@ -207,7 +207,7 @@ Initialization, Finalization, and Thread
-    Return the *exec-prefix* for installed platform-*dependent* files.  This is
-    derived through a number of complicated rules from the program name set with
-    :cfunc:`Py_SetProgramName` and some environment variables; for example, if the
--   program name is ``'/usr/local/bin/python'``, the exec-prefix is
-+   program name is ``'/usr/bin/python3'``, the exec-prefix is
-    ``'/usr/local'``.  The returned string points into static storage; the caller
-    should not modify its value.  This corresponds to the :makevar:`exec_prefix`
-    variable in the top-level :file:`Makefile` and the :option:`--exec-prefix`
---- Python-3.0.1/Doc/c-api/intro.rst.wiget     2009-01-17 19:00:58.000000000 +0100
-+++ Python-3.0.1/Doc/c-api/intro.rst   2009-03-14 18:12:32.000000000 +0100
-@@ -536,7 +536,7 @@ where the executable named :file:`python
- path (the environment variable :envvar:`PATH`).
- For instance, if the Python executable is found in
--:file:`/usr/local/bin/python`, it will assume that the libraries are in
-+:file:`/usr/bin/python3`, it will assume that the libraries are in
- :file:`/usr/local/lib/python{X.Y}`.  (In fact, this particular path is also
- the "fallback" location, used when no executable file named :file:`python` is
- found along :envvar:`PATH`.)  The user can override this behavior by setting the
---- Python-3.0.1/Doc/library/cgi.rst.wiget     2008-09-04 00:49:01.000000000 +0200
-+++ Python-3.0.1/Doc/library/cgi.rst   2009-03-14 18:12:32.000000000 +0100
-@@ -360,7 +360,7 @@ mode should be ``0o755`` octal (use ``ch
- first line of the script contains ``#!`` starting in column 1 followed by the
- pathname of the Python interpreter, for instance::
--   #!/usr/local/bin/python
-+   #!/usr/bin/python3
- Make sure the Python interpreter exists and is executable by "others".
---- Python-3.0.1/PC/os2vacpp/readme.txt.wiget  2006-03-01 07:28:58.000000000 +0100
-+++ Python-3.0.1/PC/os2vacpp/readme.txt        2009-03-14 18:12:32.000000000 +0100
-@@ -78,7 +78,7 @@ A few new attributes have been added to 
- -- Using Python as the Default OS/2 Batch Language
- Note that OS/2 supports the Unix technique of putting the special
--comment line at the time of scripts e.g. "#!/usr/bin/python" in
-+comment line at the time of scripts e.g. "#!/usr/bin/python3" in
- a different syntactic form.  To do this, put your script into a file
- with a .CMD extension and added 'extproc' to the top as follows:
---- Python-3.0.1/Misc/HISTORY.wiget    2008-02-22 17:37:40.000000000 +0100
-+++ Python-3.0.1/Misc/HISTORY  2009-03-14 18:12:32.000000000 +0100
-@@ -13231,9 +13231,9 @@ but not in sys.argv[0], so you can still
- were invoked.
- - It is now recommended to use ``#!/usr/bin/env python'' instead of
--``#!/usr/local/bin/python'' at the start of executable scripts, except
-+``#!/usr/bin/python3'' at the start of executable scripts, except
- for CGI scripts.  It has been determined that the use of /usr/bin/env
--is more portable than that of /usr/local/bin/python -- scripts almost
-+is more portable than that of /usr/bin/python3 -- scripts almost
- never have to be edited when the Python interpreter lives in a
- non-standard place.  Note that this doesn't work for CGI scripts since
- the python executable often doesn't live in the HTTP server's default
-@@ -16518,7 +16518,7 @@ assign a function object to sys.exitfunc
- Python exits or receives a SIGTERM or SIGHUP signal.
- The interpreter is now generally assumed to live in
--/usr/local/bin/python (as opposed to /usr/local/python).  The script
-+/usr/bin/python3 (as opposed to /usr/local/python).  The script
- demo/scripts/fixps.py will update old scripts in place (you can easily
- modify it to do other similar changes).
index 6c29a9ceb74d3b4bcb94327508a01acfede153e7..ee5fc2d12528e4e74a715d4354ef02333a9b7b46 100644 (file)
@@ -16,9 +16,9 @@
 # tests which fail because of some unknown/unresolved reason (this list should be empty)
 %define                broken_tests test_httpservers test_distutils test_cmd_line test_pydoc test_telnetlib test_zlib
 
-%define        beta            %{nil}
+%define        beta            b1
 
-%define py_ver         3.1
+%define py_ver         3.2
 %define py_prefix      %{_prefix}
 %define py_libdir      %{py_prefix}/%{_lib}/python%{py_ver}
 %define py_incdir      %{_includedir}/python%{py_ver}
@@ -34,13 +34,13 @@ Summary(ru.UTF-8):  Язык программирования очень высо
 Summary(tr.UTF-8):     X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
 Summary(uk.UTF-8):     Мова програмування дуже високого рівня з X-інтерфейсом
 Name:          python3
-Version:       %{py_ver}.2
-Release:       3
+Version:       %{py_ver}
+Release:       0.%{beta}.1
 Epoch:         1
 License:       PSF
 Group:         Applications
 Source0:       http://www.python.org/ftp/python/%{version}/Python-%{version}%{beta}.tar.bz2
-# Source0-md5: 45350b51b58a46b029fb06c61257e350
+# Source0-md5: 3ad06a5b080d7b32958b4af2e44b64d3
 Patch0:                %{name}-pythonpath.patch
 Patch1:                %{name}-ac_fixes.patch
 Patch2:                %{name}-lib64.patch
@@ -355,59 +355,6 @@ Static python library.
 %description static -l pl.UTF-8
 Statyczna biblioteka Pythona.
 
-%package doc
-Summary:       Documentation on Python
-Summary(de.UTF-8):     Dokumentation zu Python
-Summary(es.UTF-8):     Documentación para Python
-Summary(fr.UTF-8):     Documentation sur Python
-Summary(pl.UTF-8):     Dokumentacja do Pythona
-Summary(pt_BR.UTF-8):  Documentação para a linguagem de programação Python
-Summary(ru.UTF-8):     Документация по языку Python
-Summary(tr.UTF-8):     Python belgeleri
-Summary(uk.UTF-8):     Документація по мові Python
-Group:         Documentation
-
-%description doc
-This package contains documentation on the Python language and
-interpretor as a mix of plain ASCII files and LaTeX sources.
-
-%description doc -l de.UTF-8
-Dieses Paket enthält Dokumentationen zu Python (Sprache und
-Interpreter) in Form von einfachen ASCII-Dateien und LaTeX-Quellen.
-
-%description doc -l es.UTF-8
-Documentación para Python. Contiene archivos en texto y PostScript.
-
-%description doc -l fr.UTF-8
-Ce paquetage contient la documentation sur le langage python et sur
-son interpréteur sous forme de fichiers ASCII et LaTeX.
-
-%description doc -l pl.UTF-8
-Oficjalna dokumentacja do Pythona. Zawiera przykładowe programy,
-narzędzia i dokumentację. Strony podręcznika man znajdują się w
-głównym pakiecie. Ten pakiet nie zawiera źródeł dokumentacji
-napisanych w LaTeXu, tylko gotowe do wykorzystania pliki postscriptowe
-i HTML.
-
-%description doc -l pt_BR.UTF-8
-O pacote python-doc contém documentação para a linguagem de
-programação e para o interpretador Python. Fornecida em arquivos texto
-e Postcript.
-
-%description doc -l ru.UTF-8
-Этот пакет содержит документацию по собственно языку Python и по
-исполняющему его интерпретатору в виде набора текстовых файлов и
-исходных текстов в формате LaTeX.
-
-%description doc -l tr.UTF-8
-Bu paket, Python dili ile ilgili belgeleri ve düz ASCII dosyaları ve
-LaTeX kaynaklarının bir karışımı olan yorumlayıcıyı içerir.
-
-%description doc -l uk.UTF-8
-Цей пакет містить документацію по власне мові Python та по виконуючому
-її інтерпретатору у вигляді набора текстових файлів та вихідних
-текстів у форматі LaTeX.
-
 %package doc-info
 Summary:       Documentation on Python in texinfo format
 Summary(pl.UTF-8):     Dokumentacja do Pythona w formacie texinfo
@@ -484,10 +431,9 @@ Przykłady te są dla Pythona 2.3.4, nie %{version}.
 %setup -q -n Python-%{version}%{beta}
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
-sed -i -e 's=@EXENAME@=%{_bindir}/python3=' Misc/python-config.in
+#%patch2 -p1
+#%patch3 -p1
+#%patch4 -p1
 
 %build
 sed -i -e 's#-ltermcap#-ltinfo#g' configure*
@@ -548,12 +494,6 @@ install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
 install Doc/info/python*info* $RPM_BUILD_ROOT%{_infodir}
 %endif
 
-install Makefile.pre.in $RPM_BUILD_ROOT%{py_libdir}/config
-
-mv $RPM_BUILD_ROOT{%{py_libdir}/config,%{_libdir}}/libpython%{py_ver}.a
-ln -sf libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}/libpython.a
-ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython%{py_ver}.so
-
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 cp -a Tools Demo $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
This page took 0.055252 seconds and 4 git commands to generate.