]> git.pld-linux.org Git - packages/python3.git/commitdiff
Partial update to 3.10.0.
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 7 Nov 2021 18:46:26 +0000 (19:46 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 7 Nov 2021 18:46:26 +0000 (19:46 +0100)
python3-BLDLIBRARY.patch
python3-install_prefix.patch
python3-makefile-location.patch [deleted file]
python3-multilib.patch
python3.spec

index 10000abef684b53adff649faa769416459c2b3a7..865b51b534a2e5ff36c5d29f2032023f5b95d058 100644 (file)
 @@ -588,7 +588,7 @@ clinic: check-clean-src $(srcdir)/Module
  
  # Build the interpreter
- $(BUILDPYTHON):       Programs/python.o $(LIBRARY) $(LDLIBRARY) $(PY3LIBRARY) $(EXPORTSYMS)
+ $(BUILDPYTHON):       Programs/python.o $(LIBRARY_DEPS)
 -      $(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
-+      $(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/python.o $(BLDLIBDIR) $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
++      $(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/python.o $(BLDLIBDIR) $(LIBS) $(MODLIBS) $(SYSLIBS)
  
  platform: $(BUILDPYTHON) pybuilddir.txt
        $(RUNSHARED) $(PYTHON_FOR_BUILD) -c 'import sys ; from sysconfig import get_platform ; print("%s-%d.%d" % (get_platform(), *sys.version_info[:2]))' >platform
 @@ -723,7 +723,7 @@ Makefile Modules/config.c: Makefile.pre
  
  
- Programs/_testembed: Programs/_testembed.o $(LIBRARY) $(LDLIBRARY) $(PY3LIBRARY) $(EXPORTSYMS)
+ Programs/_testembed: Programs/_testembed.o $(LIBRARY_DEPS)
 -      $(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
-+      $(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBDIR) $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
++      $(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBDIR) $(LIBS) $(MODLIBS) $(SYSLIBS)
  
  ############################################################################
  # Importlib
          RUNSHARED=LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
          INSTSONAME="$LDLIBRARY".$SOVERSION
          if test "$with_pydebug" != yes
-@@ -1166,7 +1169,8 @@
+@@ -1147,7 +1147,8 @@ if test $enable_shared = "yes"; then
            ;;
-     Linux*|GNU*|NetBSD*|FreeBSD*|DragonFly*|OpenBSD*)
+     Linux*|GNU*|NetBSD*|FreeBSD*|DragonFly*|OpenBSD*|VxWorks*)
          LDLIBRARY='libpython$(LDVERSION).so'
 -        BLDLIBRARY='-L. -lpython$(LDVERSION)'
-+        BLDLIBDIR='-L.'
++        BLDLIBDIR='-Wl,-R,$(LIBDIR) -L.'
 +        BLDLIBRARY='-lpython$(VERSION)'
          RUNSHARED=LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
          INSTSONAME="$LDLIBRARY".$SOVERSION
index 54cafeac21026b98ed0aef739d5d28d69732c712..b342314192d08cd1d10aa8aaf96f4d7c3fd3ee56 100644 (file)
@@ -21,19 +21,19 @@ diff -urNp -x '*.orig' Python-3.9.2.org/Lib/distutils/command/install.py Python-
              else:
                  if self.exec_prefix is None:
 diff -urNp -x '*.orig' Python-3.9.2.org/Lib/distutils/sysconfig.py Python-3.9.2/Lib/distutils/sysconfig.py
---- Python-3.9.2.org/Lib/distutils/sysconfig.py        2021-02-25 18:41:13.927933162 +0100
-+++ Python-3.9.2/Lib/distutils/sysconfig.py    2021-02-25 18:41:15.634652993 +0100
-@@ -19,6 +19,10 @@ from .errors import DistutilsPlatformErr
- # These are needed in a couple of spots, so just compute them once.
- PREFIX = os.path.normpath(sys.prefix)
- EXEC_PREFIX = os.path.normpath(sys.exec_prefix)
-+if PREFIX == "/usr":
-+    PREFIX = "/usr/local"
-+if EXEC_PREFIX == "/usr":
-+    EXEC_PREFIX = "/usr/local"
- BASE_PREFIX = os.path.normpath(sys.base_prefix)
- BASE_EXEC_PREFIX = os.path.normpath(sys.base_exec_prefix)
+--- Python-3.10.0/Lib/distutils/sysconfig.py~  2021-10-20 22:42:16.000000000 +0200
++++ Python-3.10.0/Lib/distutils/sysconfig.py   2021-10-20 22:53:54.943156539 +0200
+@@ -320,6 +320,10 @@ def get_python_lib(plat_specific=0, stan
+     If 'prefix' is supplied, use it instead of sys.base_prefix or
+     sys.base_exec_prefix -- i.e., ignore 'plat_specific'.
+     """
++    if PREFIX == "/usr":
++        PREFIX = "/usr/local"
++    if EXEC_PREFIX == "/usr":
++        EXEC_PREFIX = "/usr/local"
+     if prefix is None:
+         if standard_lib:
+             prefix = plat_specific and BASE_EXEC_PREFIX or BASE_PREFIX
 diff -urNp -x '*.orig' Python-3.9.2.org/Lib/site.py Python-3.9.2/Lib/site.py
 --- Python-3.9.2.org/Lib/site.py       2021-02-25 18:41:13.924599724 +0100
 +++ Python-3.9.2/Lib/site.py   2021-02-25 18:41:15.634652993 +0100
diff --git a/python3-makefile-location.patch b/python3-makefile-location.patch
deleted file mode 100644 (file)
index 2dbb571..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urNp -x '*.orig' Python-3.9.2.org/Lib/distutils/sysconfig.py Python-3.9.2/Lib/distutils/sysconfig.py
---- Python-3.9.2.org/Lib/distutils/sysconfig.py        2021-02-25 18:40:49.900518043 +0100
-+++ Python-3.9.2/Lib/distutils/sysconfig.py    2021-02-25 18:40:51.570570064 +0100
-@@ -260,7 +260,7 @@ def get_makefile_filename():
-     """Return full pathname of installed Makefile from the Python build."""
-     if python_build:
-         return os.path.join(_sys_home or project_base, "Makefile")
--    lib_dir = get_python_lib(plat_specific=0, standard_lib=1)
-+    lib_dir = get_python_lib(plat_specific=1, standard_lib=1)
-     config_file = 'config-{}{}'.format(get_python_version(), build_flags)
-     if hasattr(sys.implementation, '_multiarch'):
-         config_file += '-%s' % sys.implementation._multiarch
index f27da6f2677960c7b9731c767ce94455da6d8e12..49417ceb9e5cc64eb4f854906040210cbfdb55a9 100644 (file)
@@ -1,23 +1,3 @@
-diff -urNp -x '*.orig' Python-3.9.2.org/Lib/distutils/command/install.py Python-3.9.2/Lib/distutils/command/install.py
---- Python-3.9.2.org/Lib/distutils/command/install.py  2021-02-19 13:31:44.000000000 +0100
-+++ Python-3.9.2/Lib/distutils/command/install.py      2021-02-25 18:40:00.705652346 +0100
-@@ -29,14 +29,14 @@ WINDOWS_SCHEME = {
- INSTALL_SCHEMES = {
-     'unix_prefix': {
--        'purelib': '$base/lib/python$py_version_short/site-packages',
-+        'purelib': '$base/$platlibdir/python$py_version_short/site-packages',
-         'platlib': '$platbase/$platlibdir/python$py_version_short/site-packages',
-         'headers': '$base/include/python$py_version_short$abiflags/$dist_name',
-         'scripts': '$base/bin',
-         'data'   : '$base',
-         },
-     'unix_home': {
--        'purelib': '$base/lib/python',
-+        'purelib': '$base/$platlibdir/python',
-         'platlib': '$base/$platlibdir/python',
-         'headers': '$base/include/python/$dist_name',
-         'scripts': '$base/bin',
 diff -urNp -x '*.orig' Python-3.9.2.org/Lib/distutils/sysconfig.py Python-3.9.2/Lib/distutils/sysconfig.py
 --- Python-3.9.2.org/Lib/distutils/sysconfig.py        2021-02-19 13:31:44.000000000 +0100
 +++ Python-3.9.2/Lib/distutils/sysconfig.py    2021-02-25 18:40:00.705652346 +0100
@@ -64,15 +44,6 @@ diff -urNp -x '*.orig' Python-3.9.2.org/Lib/site.py Python-3.9.2/Lib/site.py
 diff -urNp -x '*.orig' Python-3.9.2.org/Lib/sysconfig.py Python-3.9.2/Lib/sysconfig.py
 --- Python-3.9.2.org/Lib/sysconfig.py  2021-02-19 13:31:44.000000000 +0100
 +++ Python-3.9.2/Lib/sysconfig.py      2021-02-25 18:40:00.705652346 +0100
-@@ -27,7 +27,7 @@ _INSTALL_SCHEMES = {
-     'posix_prefix': {
-         'stdlib': '{installed_base}/{platlibdir}/python{py_version_short}',
-         'platstdlib': '{platbase}/{platlibdir}/python{py_version_short}',
--        'purelib': '{base}/lib/python{py_version_short}/site-packages',
-+        'purelib': '{base}/{platlibdir}/python{py_version_short}/site-packages',
-         'platlib': '{platbase}/{platlibdir}/python{py_version_short}/site-packages',
-         'include':
-             '{installed_base}/include/python{py_version_short}{abiflags}',
 @@ -37,10 +37,10 @@ _INSTALL_SCHEMES = {
          'data': '{base}',
          },
@@ -88,15 +59,17 @@ diff -urNp -x '*.orig' Python-3.9.2.org/Lib/sysconfig.py Python-3.9.2/Lib/syscon
          'include': '{installed_base}/include/python',
          'platinclude': '{installed_base}/include/python',
          'scripts': '{base}/bin',
-@@ -69,7 +69,7 @@ _INSTALL_SCHEMES = {
-     'posix_user': {
-         'stdlib': '{userbase}/{platlibdir}/python{py_version_short}',
-         'platstdlib': '{userbase}/{platlibdir}/python{py_version_short}',
--        'purelib': '{userbase}/lib/python{py_version_short}/site-packages',
-+        'purelib': '{userbase}/{platlibdir}/python{py_version_short}/site-packages',
-         'platlib': '{userbase}/{platlibdir}/python{py_version_short}/site-packages',
-         'include': '{userbase}/include/python{py_version_short}',
-         'scripts': '{userbase}/bin',
+@@ -100,8 +100,8 @@ if _HAS_USER_BASE:
+         'posix_user': {
+             'stdlib': '{userbase}/{platlibdir}/python{py_version_short}',
+             'platstdlib': '{userbase}/{platlibdir}/python{py_version_short}',
+-            'purelib': '{userbase}/lib/python{py_version_short}/site-packages',
+-            'platlib': '{userbase}/lib/python{py_version_short}/site-packages',
++            'purelib': '{userbase}/{platlibdir}/python{py_version_short}/site-packages',
++            'platlib': '{userbase}/{platlibdir}/python{py_version_short}/site-packages',
+             'include': '{userbase}/include/python{py_version_short}',
+             'scripts': '{userbase}/bin',
+             'data': '{userbase}',
 @@ -490,7 +490,11 @@ def get_config_h_filename():
          else:
              inc_dir = _sys_home or _PROJECT_BASE
@@ -109,22 +82,21 @@ diff -urNp -x '*.orig' Python-3.9.2.org/Lib/sysconfig.py Python-3.9.2/Lib/syscon
 +        inc_dir = os.path.join(get_path('stdlib'), config_dir_name)
      return os.path.join(inc_dir, 'pyconfig.h')
  
-diff -urNp -x '*.orig' Python-3.9.2.org/Makefile.pre.in Python-3.9.2/Makefile.pre.in
---- Python-3.9.2.org/Makefile.pre.in   2021-02-19 13:31:44.000000000 +0100
-+++ Python-3.9.2/Makefile.pre.in       2021-02-25 18:40:00.705652346 +0100
-@@ -1634,9 +1634,9 @@ libainstall:     @DEF_MAKE_RULE@ python-conf
-       @if test -d $(LIBRARY); then :; else \
-               if test "$(PYTHONFRAMEWORKDIR)" = no-framework; then \
-                       if test "$(SHLIB_SUFFIX)" = .dll; then \
--                              $(INSTALL_DATA) $(LDLIBRARY) $(DESTDIR)$(LIBPL) ; \
-+                              $(INSTALL_DATA) $(LDLIBRARY) $(DESTDIR)$(LIBDIR) ; \
+
+--- Python-3.10.0/Makefile.pre.in~     2021-10-04 19:40:46.000000000 +0200
++++ Python-3.10.0/Makefile.pre.in      2021-10-20 22:21:30.573156183 +0200
+@@ -1707,9 +1707,9 @@ libainstall:     @DEF_MAKE_RULE@ python-conf
+               if test -d $(LIBRARY); then :; else \
+                       if test "$(PYTHONFRAMEWORKDIR)" = no-framework; then \
+                               if test "$(SHLIB_SUFFIX)" = .dll; then \
+-                                      $(INSTALL_DATA) $(LDLIBRARY) $(DESTDIR)$(LIBPL) ; \
++                                      $(INSTALL_DATA) $(LDLIBRARY) $(DESTDIR)$(LIBDIR) ; \
+                               else \
+-                                      $(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
++                                      $(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBDIR)/$(LIBRARY) ; \
+                               fi; \
                        else \
--                              $(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
-+                              $(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBDIR)/$(LIBRARY) ; \
-                       fi; \
-               else \
-                       echo Skip install of $(LIBRARY) - use make frameworkinstall; \
+                               echo Skip install of $(LIBRARY) - use make frameworkinstall; \
 diff -urNp -x '*.orig' Python-3.9.2.org/setup.py Python-3.9.2/setup.py
 --- Python-3.9.2.org/setup.py  2021-02-19 13:31:44.000000000 +0100
 +++ Python-3.9.2/setup.py      2021-02-25 18:40:00.708985783 +0100
index 26e47a8be1afc4712d71559f3738f52a5991bda8..6d7283ab2c6458525b594675e9975dbc80f116de 100644 (file)
@@ -30,7 +30,7 @@
 %define                _python_target_abi      %{?_gnu}
 %endif
 
-%define py_ver         3.9
+%define py_ver         3.10
 %define py_abi         %{py_ver}
 %define        py_platform     %{py_abi}-%{_target_base_arch}-%{_target_os}%{?_python_target_abi}
 %define py_prefix      %{_prefix}
@@ -48,19 +48,19 @@ Summary(ru.UTF-8):  Язык программирования очень высо
 Summary(tr.UTF-8):     X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
 Summary(uk.UTF-8):     Мова програмування дуже високого рівня з X-інтерфейсом
 Name:          python3
-Version:       %{py_ver}.7
-Release:       2
+Version:       %{py_ver}.0
+Release:       0.1
 Epoch:         1
 License:       PSF
 Group:         Development/Languages/Python
 Source0:       https://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
-# Source0-md5: fddb060b483bc01850a3f412eea1d954
+# Source0-md5: 3e7035d272680f80e3ce4e8eb492d580
 Source1:       pyconfig.h.in
 Patch0:                %{name}-pythonpath.patch
 Patch1:                %{name}-ac_fixes.patch
 Patch2:                %{name}-multilib.patch
 Patch3:                %{name}-no_cmdline_tests.patch
-Patch4:                %{name}-makefile-location.patch
+
 Patch5:                %{name}-config.patch
 Patch6:                %{name}-BLDLIBRARY.patch
 Patch7:                %{name}-db.patch
@@ -498,7 +498,7 @@ Moduły testowe dla Pythona.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
+
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
This page took 0.142215 seconds and 4 git commands to generate.