]> git.pld-linux.org Git - packages/python3.git/commitdiff
- up to 3.7.4 auto/th/python3-3.7.4-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 9 Jul 2019 19:19:46 +0000 (21:19 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 9 Jul 2019 19:19:46 +0000 (21:19 +0200)
python3-tests_with_pythonpath.patch
python3.spec

index ef74c4d1e7e27c9922d909fc9d46dd542368d98e..579ef1e36c9e6b67dcba014b95be5468706045ea 100644 (file)
@@ -87,29 +87,28 @@ diff -dur -x '*~' Python-3.5.0.orig/Lib/test/test_site.py Python-3.5.0/Lib/test/
      def test_abs_paths(self):
          # Make sure all imported modules have their __file__ and __cached__
          # attributes as absolute paths.  Arranging to put the Lib directory on
-diff -dur -x '*~' Python-3.5.0.orig/Lib/test/test_venv.py Python-3.5.0/Lib/test/test_venv.py
---- Python-3.5.0.orig/Lib/test/test_venv.py    2015-09-13 13:41:23.000000000 +0200
-+++ Python-3.5.0/Lib/test/test_venv.py 2015-12-03 18:35:52.227001621 +0100
-@@ -111,6 +111,7 @@
-         self.assertTrue(os.path.exists(fn), 'File %r should exist.' % fn)
+--- Python-3.7.4/Lib/test/test_venv.py~        2019-07-08 20:03:50.000000000 +0200
++++ Python-3.7.4/Lib/test/test_venv.py 2019-07-09 08:37:18.251706609 +0200
+@@ -129,6 +129,7 @@ class BasicTest(BaseTest):
+         self.assertEqual(context.prompt, '(My prompt) ')
  
-     @skipInVenv
+     @requireVenvCreate
 +    @unittest.skipIf("PYTHONPATH" in os.environ, "$PYTHONPATH set")
      def test_prefixes(self):
          """
          Test that the prefix values are as expected.
-@@ -249,6 +250,7 @@
+@@ -266,6 +267,7 @@ class BasicTest(BaseTest):
      # point to the venv being used to run the test, and we lose the link
      # to the source build - so Python can't initialise properly.
-     @skipInVenv
+     @requireVenvCreate
 +    @unittest.skipIf("PYTHONPATH" in os.environ, "$PYTHONPATH set")
      def test_executable(self):
          """
          Test that the sys.executable value is as expected.
-@@ -279,6 +281,7 @@
+@@ -326,6 +328,7 @@ class BasicTest(BaseTest):
+         self.assertEqual(out.strip(), "python".encode())
  
- @skipInVenv
+ @requireVenvCreate
 +@unittest.skipIf("PYTHONPATH" in os.environ, "$PYTHONPATH set")
  class EnsurePipTest(BaseTest):
      """Test venv module installation of pip."""
index ae331a42a70210bd932c73dfad4f5605eb8f2bbd..04ae7d3d8b3927328a41a3c9be1fc9b3ff9ef526 100644 (file)
@@ -41,13 +41,13 @@ Summary(ru.UTF-8):  Язык программирования очень высо
 Summary(tr.UTF-8):     X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
 Summary(uk.UTF-8):     Мова програмування дуже високого рівня з X-інтерфейсом
 Name:          python3
-Version:       %{py_ver}.3
+Version:       %{py_ver}.4
 Release:       1
 Epoch:         1
 License:       PSF
 Group:         Development/Languages/Python
 Source0:       https://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
-# Source0-md5: 93df27aec0cd18d6d42173e601ffbbfd
+# Source0-md5: d33e4aae66097051c2eca45ee3604803
 Source1:       pyconfig.h.in
 Patch0:                %{name}-pythonpath.patch
 Patch1:                %{name}-ac_fixes.patch
This page took 0.268759 seconds and 4 git commands to generate.