]> git.pld-linux.org Git - packages/python3.git/commitdiff
- updated to 3.5.1 auto/th/python3-3.5.1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 5 Mar 2016 18:55:08 +0000 (19:55 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 5 Mar 2016 18:55:08 +0000 (19:55 +0100)
- removed obsolete atomic patch
- test_ssl and test_httplib tests fail for me because of cert ca issues(?)

python3-atomic.patch [deleted file]
python3.spec

diff --git a/python3-atomic.patch b/python3-atomic.patch
deleted file mode 100644 (file)
index be77c2a..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-
-# HG changeset patch
-# User Victor Stinner <victor.stinner@gmail.com>
-# Date 1442581594 -7200
-# Node ID d4fcb362f7c66b25b22ddc0d27db0cc96acc727b
-# Parent  d04a0954e142f873adee88ec5bc1c1d81cd46bc4
-Issue #25150: Hide the private _Py_atomic_xxx symbols from the public
-Python.h header to fix a compilation error with OpenMP. PyThreadState_GET()
-becomes an alias to PyThreadState_Get() to avoid ABI incompatibilies.
-
-It is important that the _PyThreadState_Current variable is always accessed
-with the same implementation of pyatomic.h. Use the PyThreadState_Get()
-function so extension modules will all reuse the same implementation.
-
-diff --git a/Include/pyatomic.h b/Include/pyatomic.h
---- a/Include/pyatomic.h
-+++ b/Include/pyatomic.h
-@@ -1,8 +1,6 @@
--/* Issue #23644: <stdatomic.h> is incompatible with C++, see:
--   https://gcc.gnu.org/bugzilla/show_bug.cgi?id=60932 */
--#if !defined(Py_LIMITED_API) && !defined(__cplusplus)
- #ifndef Py_ATOMIC_H
- #define Py_ATOMIC_H
-+#ifdef Py_BUILD_CORE
- #include "dynamic_annotations.h"
-@@ -248,5 +246,5 @@ static __inline__ void
- #define _Py_atomic_load_relaxed(ATOMIC_VAL) \
-     _Py_atomic_load_explicit(ATOMIC_VAL, _Py_memory_order_relaxed)
-+#endif  /* Py_BUILD_CORE */
- #endif  /* Py_ATOMIC_H */
--#endif  /* Py_LIMITED_API */
-diff --git a/Include/pystate.h b/Include/pystate.h
---- a/Include/pystate.h
-+++ b/Include/pystate.h
-@@ -177,20 +177,13 @@ PyAPI_FUNC(int) PyThreadState_SetAsyncEx
- /* Variable and macro for in-line access to current thread state */
- /* Assuming the current thread holds the GIL, this is the
--   PyThreadState for the current thread.
--
--   Issue #23644: pyatomic.h is incompatible with C++ (yet). Disable
--   PyThreadState_GET() optimization: declare it as an alias to
--   PyThreadState_Get(), as done for limited API. */
--#if !defined(Py_LIMITED_API) && !defined(__cplusplus)
-+   PyThreadState for the current thread. */
-+#ifdef Py_BUILD_CORE
- PyAPI_DATA(_Py_atomic_address) _PyThreadState_Current;
--#endif
--
--#if defined(Py_DEBUG) || defined(Py_LIMITED_API) || defined(__cplusplus)
--#define PyThreadState_GET() PyThreadState_Get()
-+#  define PyThreadState_GET() \
-+             ((PyThreadState*)_Py_atomic_load_relaxed(&_PyThreadState_Current))
- #else
--#define PyThreadState_GET() \
--    ((PyThreadState*)_Py_atomic_load_relaxed(&_PyThreadState_Current))
-+#  define PyThreadState_GET() PyThreadState_Get()
- #endif
- typedef
-diff --git a/Misc/NEWS b/Misc/NEWS
---- a/Misc/NEWS
-+++ b/Misc/NEWS
-@@ -11,6 +11,10 @@ Release date: TBA
- Core and Builtins
- -----------------
-+- Issue #25150: Hide the private _Py_atomic_xxx symbols from the public
-+  Python.h header to fix a compilation error with OpenMP. PyThreadState_GET()
-+  becomes an alias to PyThreadState_Get() to avoid ABI incompatibilies.
-+
- Library
- -------
-
index 4c13b431e3a3e1b8ff7f30edf302da504c5f4f2c..f4f4d108cfb39acac560261b778bf5952d2dda7a 100644 (file)
@@ -33,27 +33,26 @@ Summary(ru.UTF-8):  Язык программирования очень высо
 Summary(tr.UTF-8):     X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
 Summary(uk.UTF-8):     Мова програмування дуже високого рівня з X-інтерфейсом
 Name:          python3
-Version:       %{py_ver}.0
-Release:       9
+Version:       %{py_ver}.1
+Release:       1
 Epoch:         1
 License:       PSF
-Group:         Applications
-Source0:       http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
-# Source0-md5: d149d2812f10cbe04c042232e7964171
+Group:         Development/Languages/Python
+Source0:       https://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
+# Source0-md5: e9ea6f2623fffcdd871b7b19113fde80
 Source1:       pyconfig.h.in
 Patch0:                %{name}-pythonpath.patch
 Patch1:                %{name}-ac_fixes.patch
 Patch2:                %{name}-multilib.patch
 Patch3:                %{name}-no_cmdline_tests.patch
 Patch4:                %{name}-makefile-location.patch
-Patch5:                %{name}-atomic.patch
 Patch6:                python-distro.patch
 Patch7:                %{name}-db.patch
 Patch8:                %{name}-install_prefix.patch
 Patch9:                %{name}-tests_with_pythonpath.patch
 Patch10:       %{name}-bdist_rpm.patch
 Patch11:       %{name}-installcompile.patch
-URL:           http://www.python.org/
+URL:           https://www.python.org/
 BuildRequires: autoconf >= 2.65
 BuildRequires: automake
 BuildRequires: bluez-libs-devel
@@ -473,7 +472,6 @@ Moduły testowe dla Pythona.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
@@ -611,12 +609,13 @@ install -p Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext%{py_ver}
 install -p Tools/scripts/reindent.py $RPM_BUILD_ROOT%{_bindir}/pyreindent%{py_ver}
 
 # just to cut the noise, as they are not packaged (now)
-%{__rm} $RPM_BUILD_ROOT%{py_libdir}/plat-*/regen
 %{__rm} $RPM_BUILD_ROOT%{py_libdir}/ctypes/macholib/fetch_macholib*
-%{__rm} $RPM_BUILD_ROOT%{py_libdir}/site-packages/README
 %{__rm} $RPM_BUILD_ROOT%{py_libdir}/distutils/command/wininst*.exe
 %{__rm} $RPM_BUILD_ROOT%{py_libdir}/idlelib/*.bat
 %{__rm} $RPM_BUILD_ROOT%{py_libdir}/idlelib/*.pyw
+%{__rm} $RPM_BUILD_ROOT%{py_libdir}/idlelib/help.html
+%{__rm} $RPM_BUILD_ROOT%{py_libdir}/plat-*/regen
+%{__rm} $RPM_BUILD_ROOT%{py_libdir}/site-packages/README
 
 # currently provided by python-2to3, consider switching to this one
 %{__rm} $RPM_BUILD_ROOT%{_bindir}/2to3
This page took 0.12379 seconds and 4 git commands to generate.