]> git.pld-linux.org Git - packages/python3.git/commitdiff
- up to 3.6.4 auto/th/python3-3.6.4-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 19 Dec 2017 14:07:59 +0000 (15:07 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 19 Dec 2017 14:07:59 +0000 (15:07 +0100)
python3-multilib.patch
python3.spec

index 3075ba414204c7bb744d1e1e7b15314a6b9725f0..5a9d38fc3713ea40f23835f8a08d005a3f2059f8 100644 (file)
@@ -337,16 +337,15 @@ diff -dur Python-3.5.0.orig/configure.ac Python-3.5.0/configure.ac
 diff -dur Python-3.5.0.orig/setup.py Python-3.5.0/setup.py
 --- Python-3.5.0.orig/setup.py 2015-09-13 13:41:26.000000000 +0200
 +++ Python-3.5.0/setup.py      2015-12-03 17:31:03.877613811 +0100
-@@ -526,8 +526,7 @@
-         # be assumed that no additional -I,-L directives are needed.
-         if not cross_compiling:
-             lib_dirs = self.compiler.library_dirs + [
--                '/lib64', '/usr/lib64',
--                '/lib', '/usr/lib',
-+                '/' + sys.lib, '/usr/' + sys.lib
-                 ]
-             inc_dirs = self.compiler.include_dirs + ['/usr/include']
-         else:
+@@ -569,7 +569,7 @@ class PyBuildExt(build_ext):
+             add_dir_to_list(self.compiler.include_dirs,
+                             sysconfig.get_config_var("INCLUDEDIR"))
+-        system_lib_dirs = ['/lib64', '/usr/lib64', '/lib', '/usr/lib']
++        system_lib_dirs = ['/' + sys.lib, '/usr/' + sys.lib]
+         system_include_dirs = ['/usr/include']
+         # lib_dirs and inc_dirs are used to search for files;
+         # if a file is found in one of those directories, it can
 @@ -750,11 +749,11 @@
              elif curses_library:
                  readline_libs.append(curses_library)
index e5a33fa656ff562ea2a7a4ac9f74d2fd1efd397c..2dac2251d166885038e61af8a91746f08017a53b 100644 (file)
@@ -38,13 +38,13 @@ Summary(ru.UTF-8):  Язык программирования очень высо
 Summary(tr.UTF-8):     X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
 Summary(uk.UTF-8):     Мова програмування дуже високого рівня з X-інтерфейсом
 Name:          python3
-Version:       %{py_ver}.3
+Version:       %{py_ver}.4
 Release:       1
 Epoch:         1
 License:       PSF
 Group:         Development/Languages/Python
 Source0:       https://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
-# Source0-md5: b9c2c36c33fb89bda1fefd37ad5af9be
+# Source0-md5: 1325134dd525b4a2c3272a1a0214dd54
 Source1:       pyconfig.h.in
 Patch0:                %{name}-pythonpath.patch
 Patch1:                %{name}-ac_fixes.patch
This page took 0.06489 seconds and 4 git commands to generate.