]> git.pld-linux.org Git - packages/python3.git/blob - python3.spec
- the %{py_libdir}/config-* dir is required to run python, moved from -devel, to...
[packages/python3.git] / python3.spec
1 #
2 # TODO:
3 # - fix tests
4 # - check unpackaged files
5
6 # Conditional build:
7 %bcond_with     info                    # info pages (requires emacs)
8 %bcond_without  tkinter                 # disables tkinter module building
9 %bcond_with     tests                   # disables Python testing
10 %bcond_with     verbose_tests           # runs tests in verbose mode
11 #
12 # tests which will not work on 64-bit platforms
13 %define         no64bit_tests   test_audioop test_rgbimg test_imageop
14 # tests which may fail because of builder environment limitations (no /proc or /dev/pts)
15 %define         nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
16
17 # tests which fail because of some unknown/unresolved reason (this list should be empty)
18 #   test_site: fails because our site.py is patched to include both /usr/share/... and /usr/lib...
19 #   test_gdb: fails, as the gdb uses old python version
20 %define         broken_tests test_httpservers test_distutils test_cmd_line test_pydoc test_telnetlib test_zlib test_gdb test_site
21
22 %define py_ver          3.2
23 %define py_abi          %{py_ver}mu
24 %define py_prefix       %{_prefix}
25 %define py_libdir       %{py_prefix}/%{_lib}/python%{py_ver}
26 %define py_incdir       %{_includedir}/python%{py_abi}
27 %define py_sitedir      %{py_libdir}/site-packages
28 %define py_dyndir       %{py_libdir}/lib-dynload
29
30 Summary:        Very high level scripting language with X interface
31 Summary(es.UTF-8):      Lenguaje script de alto nivel con interfaz X
32 Summary(fr.UTF-8):      Langage de script de très haut niveau avec interface X
33 Summary(pl.UTF-8):      Python - język obiektowy wysokiego poziomu
34 Summary(pt_BR.UTF-8):   Linguagem de programação interpretada de alto nível
35 Summary(ru.UTF-8):      Язык программирования очень высокого уровня с X-интерфейсом
36 Summary(tr.UTF-8):      X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
37 Summary(uk.UTF-8):      Мова програмування дуже високого рівня з X-інтерфейсом
38 Name:           python3
39 Version:        %{py_ver}.1
40 Release:        1
41 Epoch:          1
42 License:        PSF
43 Group:          Applications
44 Source0:        http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
45 # Source0-md5:  2cf014296afc18897daa7b79414ad773
46 Patch0:         %{name}-pythonpath.patch
47 Patch1:         %{name}-ac_fixes.patch
48 Patch2:         %{name}-lib64.patch
49 Patch3:         %{name}-noarch_to_datadir.patch
50 Patch4:         %{name}-bug11254.patch
51 Patch5:         %{name}-no_cmdline_tests.patch
52 URL:            http://www.python.org/
53 BuildRequires:  autoconf >= 2.65
54 BuildRequires:  bluez-libs-devel
55 BuildRequires:  bzip2-devel
56 BuildRequires:  db-devel >= 4
57 %{?with_info:BuildRequires:     emacs >= 21}
58 BuildRequires:  expat-devel >= 1:1.95.7
59 BuildRequires:  file
60 BuildRequires:  gdbm-devel >= 1.8.3
61 BuildRequires:  gmp-devel >= 4.0
62 BuildRequires:  libffi-devel
63 BuildRequires:  libstdc++-devel
64 BuildRequires:  ncurses-ext-devel >= 5.2
65 BuildRequires:  openssl-devel >= 0.9.8
66 BuildRequires:  readline-devel >= 5.0
67 BuildRequires:  rpm-pythonprov
68 BuildRequires:  sed >= 4.0
69 BuildRequires:  sqlite3-devel >= 3.3.5
70 BuildRequires:  tar >= 1:1.22
71 %{?with_info:BuildRequires:     tetex-makeindex}
72 %{?with_tkinter:BuildRequires:  tix-devel >= 1:8.1.4-4}
73 %{?with_tkinter:BuildRequires:  tk-devel >= 8.4.3}
74 BuildRequires:  zlib-devel
75 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78 %define         specflags_ppc   -D__ppc__=1
79 %define         specflags_ppc64 -D__ppc64__=1
80
81 %if %{with verbose_tests}
82 %define test_flags -v -l -x
83 %else
84 %define test_flags -w -l -x
85 %endif
86
87 %ifarch alpha ia64 ppc64 sparc64 ppc64 %{x8664}
88 %define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
89 %else
90 %define test_list %{nobuilder_tests} %{broken_tests}
91 %endif
92
93 %ifarch sparc
94 %define test_list %{nobuilder_tests} %{broken_tests} test_fcntl test_ioctl
95 %endif
96
97 %description
98 Python is an interpreted, interactive, object-oriented programming
99 language. It incorporates modules, exceptions, dynamic typing, very
100 high level dynamic data types, and classes. Python combines remarkable
101 power with very clear syntax. It has interfaces to many system calls
102 and libraries, as well as to various window systems, and is extensible
103 in C or C++. It is also usable as an extension language for
104 applications that need a programmable interface. Finally, Python is
105 portable: it runs on many brands of UNIX, on the Mac, and on PCs under
106 MS-DOS, Windows, Windows NT, and OS/2.
107
108 This package contains the Python binary.
109
110 %description -l de.UTF-8
111 Python ist eine interpretierte, interaktive, objektorientierte
112 Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
113 Python enthält Module, Klassen, Exceptions, High-Level dynamische
114 Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
115 zu vielen Systemaufrufen und Libraries, sowie verschiedene
116 Fenstersysteme (X11, Motif, Tk, Mac und MFC)
117
118 Programmierer können neue built-in-Module für Python in C oder C++
119 schreiben. Python kann auch als Erweiterungssprache für Applikationen
120 benutzt werden, die ein programmierbares Interface brauchen. Dieses
121 Paket enthält die meisten Standard-Python-Module, und Module zum
122 Ansprechen von Tix (Tk-widget set) und RPM.
123
124 %description -l es.UTF-8
125 Python es un lenguaje de scripts interpretado orientado a objetos.
126 Contiene soporte para carga dinámica de objetos, clases, módulos y
127 excepciones.
128
129 Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
130 través de código C, tornando Python fácil de usar en ambientes
131 particulares/personalizados. Este paquete Python incluye la mayoría de
132 los módulos padrón Python, junto con módulos para crear interfaces
133 para el conjunto de componentes Tix para Tk y RPM.
134
135 %description -l fr.UTF-8
136 Python est un langage de script interprété et orienté objet. Il gère
137 le chargement dynamique des objets, les classes, les modules et les
138 exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
139 avec du code C est simple, ce qui rend Python facile à utiliser dans
140 des configs personnalisées.
141
142 Ce paquetage Python contient la plupart des modules Python standards,
143 ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
144 et RPM.
145
146 %description -l pl.UTF-8
147 Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
148 językiem programowania. Jest modularny, obsługuje wyjątki, dynamiczne
149 typy, zaawansowane dynamiczne struktury danych i klasy. Python łączy w
150 sobie duże możliwości i przejrzystą składnię. Posiada interfejsy do
151 wielu wywołań systemowych i bibliotek, w tym również do różnych
152 bibliotek okienkowych. Możliwości jego można jeszcze rozszerzać
153 poprzez odpowiednie moduły pisane w C lub C++. Python może być również
154 użyty jako element aplikacji, którym potrzebny jest interpreter do
155 skryptów. I wreszcie, Python jest wieloplatformowy, działa na wielu
156 odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
157 OS/2.
158
159 Ten pakiet zawiera binarkę Pythona.
160
161 %description -l pt_BR.UTF-8
162 Python é uma linguagem de scripts interpretada orientada a objetos.
163 Contém suporte para carga dinâmica de objetos, classes, módulos e
164 exceções. Adicionar interfaces para novos sistemas de biblioteca
165 através de código C é simples, tornando Python fácil de usar em
166 ambientes particulares/personalizados.
167
168 Este pacote Python inclui a maioria do módulos padrão Python, junto
169 com módulos para interfaceamento para o conjunto de componentes Tix
170 para Tk e RPM.
171
172 %description -l ru.UTF-8
173 Python - это интерпретируемый, объектно-ориентированный язык
174 программирования. Он поддерживает динамическую загрузку объектов,
175 классы, модули и обработку исключительных ситуаций (exceptions).
176 Простота добавления интерфейсов к новым системным библиотекам через
177 код на языке C делает Python хорошим выбором для использования в
178 специальных конфигурациях.
179
180 %description -l tr.UTF-8
181 Python, nesneye yönelik bir kabuk yorumlayıcıdır. Nesnelerin,
182 sınıfların, modüllerin ve aykırı durumların dinamik yüklenmelerine
183 destek verir. C koduyla birlikte kullanımı son derece kolaydır. Bu
184 paket, standart Python birimlerinin çoğunun yanısıra Tk ve RPM için
185 arayüz birimlerini de içerir.
186
187 %description -l uk.UTF-8
188 Python - це інтерпретована, об'єктно-орієнтована мова програмування.
189 Він підтримує динамічну загрузку об'єктів, класи, модулі та обробку
190 виключних ситуацій (exceptions). Простота додавання інтерфейсів для
191 нових системних бібліотек через код на мові C робить Python добрим
192 вибором для використання в спеціальних конфігураціях.
193
194 %package libs
195 Summary:        Python library
196 Summary(pl.UTF-8):      Biblioteka języka Python
197 Group:          Libraries/Python
198 # broken detection in rpm/pythondeps.sh
199 Provides:       python(abi) = %{py_ver}
200 # for compatibility with existing Ac packages
201 Provides:       python(bytecode) = %{py_ver}
202 %{!?with_info:Obsoletes:        python3-doc-info}
203
204 %description libs
205 Python shared library and very essental modules for Python binary.
206
207 %description libs -l pl.UTF-8
208 Biblioteka współdzielona języka Python oraz bardzo podstawowe moduły
209 dla Pythona.
210
211 %package modules
212 Summary:        Python modules
213 Summary(pl.UTF-8):      Moduły języka Python
214 Group:          Libraries/Python
215 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
216 Obsoletes:      python3-modules-sqlite
217
218 %description modules
219 Python officially distributed modules.
220
221 %description modules -l pl.UTF-8
222 Oficjalnie rozprowadzane moduły języka Python.
223
224 %package -n pydoc3
225 Summary:        Python interactive module documentation access support
226 Summary(pl.UTF-8):      Interaktywne korzystanie z dokumentacji modułów języka Python
227 Group:          Applications
228 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
229
230 %description -n pydoc3
231 Python interactive module documentation access support.
232
233 %description -n pydoc3 -l pl.UTF-8
234 Interaktywne korzystanie z dokumentacji modułów języka Python.
235
236 %package -n idle3
237 Summary:        IDE for Python language
238 Summary(pl.UTF-8):      IDE dla języka Python
239 Group:          Applications
240 Requires:       %{name}-tkinter = %{epoch}:%{version}-%{release}
241
242 %description -n idle3
243 IDE for Python language.
244
245 %description -n idle3 -l pl.UTF-8
246 IDE dla języka Python.
247
248 %package devel
249 Summary:        Libraries and header files for building python code
250 Summary(de.UTF-8):      Libraries und Header-Dateien zum Erstellen von Python-Code
251 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para construir programas en python
252 Summary(fr.UTF-8):      Bibliothèques et en-têtes pour construire du code python
253 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki Pythona
254 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para o Python
255 Summary(ru.UTF-8):      Библиотеки и хедеры для построения кода на языке Python
256 Summary(tr.UTF-8):      Python ile geliştirme yapmak için gerekli dosyalar
257 Summary(uk.UTF-8):      Бібліотеки та хедери для програмування на мові Python
258 Group:          Development/Languages/Python
259 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
260
261 %description devel
262 The Python interpreter is relatively easy to extend with dynamically
263 loaded extensions and to embed in other programs. This package
264 contains the header files and libraries which are needed to do both of
265 these tasks.
266
267 %description devel -l de.UTF-8
268 Der Python-Interpretierer ist relativ einfach anhand von dynamisch
269 ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
270 integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
271 die für beide Aufgaben erforderlich sind.
272
273 %description devel -l es.UTF-8
274 El interpretador Python permite incluir con facilidad extensiones
275 cargadas dinámicamente. Python es también fácil de ser empotrado en
276 otros programas. Este paquete contiene los archivos de inclusión y
277 bibliotecas necesarios para estas dos tareas.
278
279 %description devel -l fr.UTF-8
280 L'interpréteur Python est relativement facile à étendre avec des
281 extensions chargées dynamiquement et à insérer dans d'autres
282 programmes. Ce paquetage contient les en-têtes et les bibliothèques
283 nécessaires à ces deux tâches.
284
285 %description devel -l pl.UTF-8
286 Interpreter Pythona jest w miarę łatwy do rozszerzania przy pomocy
287 dynamicznie ładowanych rozszerzeń napisanych w C lub C++ oraz
288 osadzania w innych programach. Ten pakiet zawiera pliki nagłówkowe i
289 wszystko inne co potrzebne do tych celów.
290
291 %description devel -l pt_BR.UTF-8
292 O interpretador Python permite incluir com facilidade extensões
293 carregadas dinamicamente. Python é também fácil de ser embutido em
294 outros programas. Este pacote contém os arquivos de inclusão e
295 bibliotecas necessários para estas duas tarefas.
296
297 %description devel -l ru.UTF-8
298 Интерпретатор Python относительно легко расширяется при помощи
299 динамически загружаемых расширений и встраивается в другие программы.
300 Этот пакет содержит хедеры и библиотеки, необходимые для обеих этих
301 задач.
302
303 %description devel -l tr.UTF-8
304 Bu paket, Python ile geliştirme yapılabilmesi için gerekli başlık
305 dosyalarını ve kitaplıkları içerir.
306
307 %description devel -l uk.UTF-8
308 Інтерпретатор Python відносно легко розширюється за допомогою
309 розширень з динамічною загрузкою та вбудовується в інші програми. Цей
310 пакет містить хедери та бібліотеки, необхідні для обох цих задач.
311
312 %package devel-src
313 Summary:        Python module sources
314 Summary(pl.UTF-8):      Pliki źródłowe modułów Pythona
315 Group:          Development/Languages/Python
316 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
317
318 %description devel-src
319 Python module sources.
320
321 %description devel-src -l pl.UTF-8
322 Pliki źródłowe modułów Pythona.
323
324 %package devel-tools
325 Summary:        Python development tools
326 Summary(pl.UTF-8):      Narzędzia programistyczne języka Python
327 Group:          Development/Languages/Python
328 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
329
330 %description devel-tools
331 Python development tools such as profilers and debugger.
332
333 %description devel-tools -l pl.UTF-8
334 Narzędzia programistyczne języka Python takie jak profiler oraz
335 debugger.
336
337 %package 2to3
338 Summary:        Automated Python 2 to 3 code translation
339 Summary(pl.UTF-8):      Automatyczne tłumaczenie kodu Pythona 2 do 3
340 Group:          Development/Languages/Pythona
341
342 %description 2to3
343 2to3 is a Python program that reads Python 2.x source code and applies
344 a series of fixers to transform it into valid Python 3.x code. The
345 standard library contains a rich set of fixers that will handle almost
346 all code. 2to3 supporting library lib2to3 is, however, a flexible and
347 generic library, so it is possible to write your own fixers for 2to3.
348 lib2to3 could also be adapted to custom applications in which Python
349 code needs to be edited automatically.
350
351 %description 2to3 -l pl.UTF-8
352 2to3 to program w Pythonie czytający od źródłowy w Pythonie 2.x i
353 aplikujący serię poprawek przekształcających go w poprawny kod w
354 Pythonie 3.x. Biblioteka standardowa zawiera duży zbiór poprawek
355 obsługujących większość kodu. Biblioteka wspierająca 2to3 (lib2to3)
356 jest jednak elastyczną i ogólną biblioteką, więc można pisać własne
357 poprawki dla 2to3. lib2to3 można także zaadaptować na potrzeby
358 własnych zastosowań, w których kod w Pythonie musi być modyfikowany
359 automatycznie.
360
361 %package static
362 Summary:        Static python library
363 Summary(pl.UTF-8):      Statyczna biblioteka Pythona
364 Group:          Development/Languages/Python
365 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
366
367 %description static
368 Static python library.
369
370 %description static -l pl.UTF-8
371 Statyczna biblioteka Pythona.
372
373 %package doc-info
374 Summary:        Documentation on Python in texinfo format
375 Summary(pl.UTF-8):      Dokumentacja do Pythona w formacie texinfo
376 Group:          Documentation
377
378 %description doc-info
379 Documentation on Python in texinfo format.
380
381 %description doc-info -l pl.UTF-8
382 Dokumentacja do Pythona w formacie texinfo.
383
384 %package tkinter
385 Summary:        Standard Python interface to the Tk GUI toolkit
386 Summary(de.UTF-8):      Grafische Tk-Schnittstelle für Python
387 Summary(es.UTF-8):      Interfaz de GUI Tk para Python
388 Summary(fr.UTF-8):      Interface graphique Tk pour Python
389 Summary(pl.UTF-8):      Standardowy interfejs Pythona do biblioteki Tk
390 Summary(pt_BR.UTF-8):   Interface GUI Tk para Phyton
391 Summary(tr.UTF-8):      Python için grafik kullanıcı arayüzü
392 Group:          Libraries/Python
393 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
394 Requires:       tcl >= 8.4.3
395 Requires:       tix >= 1:8.1.4-4
396 Requires:       tk >= 8.4.3
397
398 %description tkinter
399 Standard Python interface to the Tk GUI toolkit.
400
401 %description tkinter -l de.UTF-8
402 Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
403 vielen Konfigurations-Tools genutzt.
404
405 %description tkinter -l es.UTF-8
406 Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por muchas
407 herramientas de configuración.
408
409 %description tkinter -l fr.UTF-8
410 Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
411 beaucoup des outils de configuration.
412
413 %description tkinter -l pl.UTF-8
414 Standardowy interfejs Pythona do biblioteki Tk.
415
416 %description tkinter -l pt_BR.UTF-8
417 Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
418 muitas ferramentas de configuração.
419
420 %description tkinter -l ru.UTF-8
421 Графический интерфейс (GUI) для Python, построенный на Tcl/Tk.
422
423 %description tkinter -l tr.UTF-8
424 Python için Tcl/Tk'ye dayalı ve pek çok ayarlama aracı tarafından
425 kullanılan grafik bir arayüzdür.
426
427 %description tkinter -l uk.UTF-8
428 Графічний інтерфейс (GUI) для Python, побудований на Tcl/Tk.
429
430 %package examples
431 Summary:        Example programs in Python
432 Summary(pl.UTF-8):      Przykładowe programy w Pythonie
433 Group:          Development/Languages/Python
434
435 %description examples
436 Example programs in Python.
437
438 These are for Python 2.3.4, not %{version}.
439
440 %description examples -l pl.UTF-8
441 Przykładowe programy w Pythonie.
442
443 Przykłady te są dla Pythona 2.3.4, nie %{version}.
444
445 %prep
446 %setup -q -n Python-%{version}
447 %patch0 -p1
448 %patch1 -p1
449 %patch2 -p1
450 %patch3 -p1
451 %patch4 -p1
452 %patch5 -p1
453
454 %build
455 %{__autoconf}
456 CPPFLAGS="-I/usr/include/ncursesw %{rpmcppflags}"; export CPPFLAGS
457 %configure \
458         --with-cxx-main="%{__cxx}" \
459         --enable-shared \
460         --enable-ipv6 \
461         --with-dbmliborder=gdbm:bdb \
462         --with-wide-unicode \
463         --with-signal-module \
464         --with-tsc \
465         --with-threads \
466         --with-doc-strings \
467         --with-fpectl \
468         --with-system-ffi \
469         --with-computed-gotos \
470         LINKCC='$(PURIFY) $(CXX)' \
471         LDSHARED='$(CC) $(CFLAGS) -shared' \
472         BLDSHARED='$(CC) $(CFLAGS) -shared' \
473         LDFLAGS="%{rpmcflags} %{rpmldflags}"
474
475 %{__make} \
476         OPT="%{rpmcflags} -fno-caller-saves" 2>&1 | awk '
477 BEGIN { fail = 0; logmsg = ""; }
478 {
479         if ($0 ~ /\*\*\* WARNING:/) {
480                 fail = 1;
481                 logmsg = logmsg $0;
482         }
483         print $0;
484 }
485 END { if (fail) { print "\nPROBLEMS FOUND:"; print logmsg; exit(1); } }'
486
487 LC_ALL=C
488 export LC_ALL
489 %if %{with tests}
490 binlibdir=`echo build/lib.*`
491 %{__make} test \
492         TESTOPTS="%{test_flags} %{test_list}" \
493         TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:`pwd`/$binlibdir ./python -tt"
494 %endif
495
496 %install
497 rm -rf $RPM_BUILD_ROOT
498 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
499         $RPM_BUILD_ROOT{%{py_sitedir},%{_mandir}/man1} \
500         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
501         $RPM_BUILD_ROOT%{_infodir} \
502         $RPM_BUILD_ROOT/etc/shrc.d
503
504 %{__make} install \
505         DESTDIR=$RPM_BUILD_ROOT
506
507 %if %{with info}
508 %{__make} -C Doc/info
509 install Doc/info/python*info* $RPM_BUILD_ROOT%{_infodir}
510 %endif
511
512 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
513 cp -a Tools $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
514
515 #
516 # create several useful aliases, such as timeit.py, profile.py, pdb.py, smtpd.py
517 #
518
519 # for python devel tools
520 for script in timeit profile pdb pstats; do
521     echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
522 done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
523
524 echo alias pygettext%{py_ver}.py='"pygettext%{py_ver}"' \
525         >> $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
526
527 sed 's/=/ /' \
528         < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh \
529         > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.csh
530
531 # for python modules
532 for script in smtpd webbrowser; do
533     echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
534 done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh
535
536 sed 's/=/ /' \
537         < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh \
538         > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.csh
539
540 # xgettext specific for Python code
541 #
542 # we will have two commands: pygettext.py (an alias) and pygettext;
543 # this way there are no import (which is impossible now) conflicts and
544 # pygettext.py is provided for compatibility
545 install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext%{py_ver}
546
547 # just to cut the noise, as they are not packaged (now)
548 # first tests (probably could be packaged)
549 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/test
550 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/test
551 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/distutils/tests
552 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/email/test
553 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/importlib/test
554 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/lib2to3/tests
555 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/sqlite3/test
556 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/tkinter/test
557 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/unittest/test
558
559 # other files
560 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/plat-*/regen
561 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/macholib/fetch_macholib*
562 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/site-packages/README
563 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/distutils/command/wininst*.exe
564 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.bat
565 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.pyw
566
567 # currently provided by python-2to3, consider switching to this one
568 %{__rm} $RPM_BUILD_ROOT%{_bindir}/2to3
569
570 # that seems to be only an empty extension template
571 %{__rm} $RPM_BUILD_ROOT%{py_dyndir}/xxlimited.*.so
572
573 # already in %%doc
574 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/LICENSE.txt
575
576 %clean
577 rm -rf $RPM_BUILD_ROOT
578
579 %post   libs -p /sbin/ldconfig
580 %postun libs -p /sbin/ldconfig
581
582 %post   doc-info -p /sbin/postshell
583 -/usr/sbin/fix-info-dir -c %{_infodir}
584
585 %postun doc-info -p /sbin/postshell
586 -/usr/sbin/fix-info-dir -c %{_infodir}
587
588 %files
589 %defattr(644,root,root,755)
590 %attr(755,root,root) %{_bindir}/python%{py_ver}
591 %attr(755,root,root) %{_bindir}/python%{py_abi}
592 %attr(755,root,root) %{_bindir}/python3
593 %{_mandir}/man1/python%{py_ver}.1*
594
595 %files libs
596 %defattr(644,root,root,755)
597 %doc LICENSE
598 %attr(755,root,root) %{_libdir}/libpython%{py_abi}.so.*.*
599
600 %dir %{py_libdir}
601 %dir %{py_dyndir}
602 %dir %{py_sitedir}
603 %dir %{py_scriptdir}
604 %dir %{py_sitescriptdir}
605 %{py_scriptdir}/__pycache__
606
607 # shared modules required by python library
608 %attr(755,root,root) %{py_dyndir}/_struct.cpython-*.so
609
610 # modules required by python library
611 %{py_scriptdir}/_abcoll.py
612 %{py_scriptdir}/_weakrefset.py
613 %{py_scriptdir}/abc.py
614 %{py_scriptdir}/codecs.py
615 %{py_scriptdir}/copyreg.py
616 %{py_scriptdir}/genericpath.py
617 %{py_scriptdir}/locale.py
618 %{py_scriptdir}/io.py
619 %{py_scriptdir}/posixpath.py
620 %{py_scriptdir}/site.py
621 %{py_scriptdir}/stat.py
622 %{py_scriptdir}/os.py
623 # needed by the dynamic sys.lib patch
624 %{py_scriptdir}/types.py
625
626 # encodings required by python library
627 %dir %{py_scriptdir}/encodings
628 %{py_scriptdir}/encodings/__pycache__
629 %{py_scriptdir}/encodings/*.py
630
631 %dir %{py_libdir}/config-%{py_abi}
632 %attr(755,root,root) %{py_libdir}/config-%{py_abi}/makesetup
633 %attr(755,root,root) %{py_libdir}/config-%{py_abi}/install-sh
634 %{py_libdir}/config-%{py_abi}/Makefile
635 %{py_libdir}/config-%{py_abi}/Setup
636 %{py_libdir}/config-%{py_abi}/Setup.config
637 %{py_libdir}/config-%{py_abi}/Setup.local
638 %{py_libdir}/config-%{py_abi}/config.c
639 %{py_libdir}/config-%{py_abi}/config.c.in
640 %{py_libdir}/config-%{py_abi}/python.o
641
642 %files modules
643 %defattr(644,root,root,755)
644 /etc/shrc.d/python*-modules*
645 %exclude %{py_scriptdir}/_abcoll.py
646 %exclude %{py_scriptdir}/_weakrefset.py
647 %exclude %{py_scriptdir}/abc.py
648 %exclude %{py_scriptdir}/codecs.py
649 %exclude %{py_scriptdir}/copyreg.py
650 %exclude %{py_scriptdir}/genericpath.py
651 %exclude %{py_scriptdir}/io.py
652 %exclude %{py_scriptdir}/locale.py
653 %exclude %{py_scriptdir}/posixpath.py
654 %exclude %{py_scriptdir}/pdb.py
655 %exclude %{py_scriptdir}/profile.py
656 %exclude %{py_scriptdir}/pstats.py
657 %exclude %{py_scriptdir}/pydoc.py
658 %exclude %{py_scriptdir}/site.py
659 %exclude %{py_scriptdir}/stat.py
660 %exclude %{py_scriptdir}/timeit.py
661 %exclude %{py_scriptdir}/os.py
662 %exclude %{py_scriptdir}/encodings/*.py
663 %exclude %{py_scriptdir}/types.py
664
665 %{py_scriptdir}/*.py
666
667 %{py_dyndir}/Python-%{version}-py*.egg-info
668
669 #
670 # list .so modules to be sure that all of them are built
671 #
672
673 # modules below do not work on 64-bit architectures
674 # see Python README file for explanation
675 %ifnarch alpha ia64 ppc64 sparc64 %{x8664}
676 %attr(755,root,root) %{py_dyndir}/audioop.cpython-*.so
677 %endif
678
679 %attr(755,root,root) %{py_dyndir}/_bisect.cpython-*.so
680 %attr(755,root,root) %{py_dyndir}/_codecs_cn.cpython-*.so
681 %attr(755,root,root) %{py_dyndir}/_codecs_hk.cpython-*.so
682 %attr(755,root,root) %{py_dyndir}/_codecs_iso2022.cpython-*.so
683 %attr(755,root,root) %{py_dyndir}/_codecs_jp.cpython-*.so
684 %attr(755,root,root) %{py_dyndir}/_codecs_kr.cpython-*.so
685 %attr(755,root,root) %{py_dyndir}/_codecs_tw.cpython-*.so
686 %attr(755,root,root) %{py_dyndir}/_csv.cpython-*.so
687 %attr(755,root,root) %{py_dyndir}/_ctypes*.cpython-*.so
688 %attr(755,root,root) %{py_dyndir}/_curses_panel.cpython-*.so
689 %attr(755,root,root) %{py_dyndir}/_curses.cpython-*.so
690 %attr(755,root,root) %{py_dyndir}/_datetime.cpython-*.so
691 %ifnarch sparc64
692 %attr(755,root,root) %{py_dyndir}/_dbm.cpython-*.so
693 %endif
694 %attr(755,root,root) %{py_dyndir}/_elementtree.cpython-*.so
695 %attr(755,root,root) %{py_dyndir}/_gdbm.cpython-*.so
696 %attr(755,root,root) %{py_dyndir}/_hashlib.cpython-*.so
697 %attr(755,root,root) %{py_dyndir}/_heapq.cpython-*.so
698 %attr(755,root,root) %{py_dyndir}/_json.cpython-*.so
699 %attr(755,root,root) %{py_dyndir}/_lsprof.cpython-*.so
700 %attr(755,root,root) %{py_dyndir}/_multibytecodec.cpython-*.so
701 %attr(755,root,root) %{py_dyndir}/_multiprocessing.cpython-*.so
702 %attr(755,root,root) %{py_dyndir}/_pickle.cpython-*.so
703 %attr(755,root,root) %{py_dyndir}/_posixsubprocess.cpython-*.so
704 %attr(755,root,root) %{py_dyndir}/_random.cpython-*.so
705 %attr(755,root,root) %{py_dyndir}/_socket.cpython-*.so
706 %attr(755,root,root) %{py_dyndir}/_ssl.cpython-*.so
707 %attr(755,root,root) %{py_dyndir}/_testcapi.cpython-*.so
708 %attr(755,root,root) %{py_dyndir}/array.cpython-*.so
709 %attr(755,root,root) %{py_dyndir}/atexit.cpython-*.so
710 %attr(755,root,root) %{py_dyndir}/audioop.cpython-*.so
711 %attr(755,root,root) %{py_dyndir}/binascii.cpython-*.so
712 %attr(755,root,root) %{py_dyndir}/bz2.cpython-*.so
713 %attr(755,root,root) %{py_dyndir}/cmath.cpython-*.so
714 %attr(755,root,root) %{py_dyndir}/crypt.cpython-*.so
715 %attr(755,root,root) %{py_dyndir}/fcntl.cpython-*.so
716 %attr(755,root,root) %{py_dyndir}/grp.cpython-*.so
717 %attr(755,root,root) %{py_dyndir}/math.cpython-*.so
718 %attr(755,root,root) %{py_dyndir}/mmap.cpython-*.so
719 %attr(755,root,root) %{py_dyndir}/nis.cpython-*.so
720 %attr(755,root,root) %{py_dyndir}/ossaudiodev.cpython-*.so
721 %attr(755,root,root) %{py_dyndir}/parser.cpython-*.so
722 %attr(755,root,root) %{py_dyndir}/pyexpat.cpython-*.so
723 %attr(755,root,root) %{py_dyndir}/readline.cpython-*.so
724 %attr(755,root,root) %{py_dyndir}/resource.cpython-*.so
725 %attr(755,root,root) %{py_dyndir}/select.cpython-*.so
726 %attr(755,root,root) %{py_dyndir}/syslog.cpython-*.so
727 %attr(755,root,root) %{py_dyndir}/termios.cpython-*.so
728 %attr(755,root,root) %{py_dyndir}/time.cpython-*.so
729 %attr(755,root,root) %{py_dyndir}/spwd.cpython-*.so
730 %attr(755,root,root) %{py_dyndir}/unicodedata.cpython-*.so
731 %attr(755,root,root) %{py_dyndir}/zlib.cpython-*.so
732
733 %dir %{py_scriptdir}/plat-*
734 %{py_scriptdir}/plat-*/__pycache__
735 %{py_scriptdir}/plat-*/*.py
736
737 %{py_scriptdir}/concurrent
738
739 %dir %{py_scriptdir}/ctypes
740 %dir %{py_scriptdir}/ctypes/macholib
741 %{py_scriptdir}/ctypes/__pycache__
742 %{py_scriptdir}/ctypes/macholib/__pycache__
743
744 %{py_scriptdir}/ctypes/*.py
745 %{py_scriptdir}/ctypes/macholib/*.py
746 %doc %{py_scriptdir}/ctypes/macholib/README.ctypes
747
748 %dir %{py_scriptdir}/curses
749 %{py_scriptdir}/curses/__pycache__
750 %{py_scriptdir}/curses/*.py
751
752 %dir %{py_scriptdir}/dbm
753 %{py_scriptdir}/dbm/__pycache__
754 %{py_scriptdir}/dbm/*.py
755
756 %dir %{py_scriptdir}/distutils
757 %dir %{py_scriptdir}/distutils/command
758 %doc %{py_scriptdir}/distutils/README
759 %{py_scriptdir}/distutils/__pycache__
760 %{py_scriptdir}/distutils/command/__pycache__
761 %{py_scriptdir}/distutils/*.py
762 %{py_scriptdir}/distutils/command/*.py
763 %{py_scriptdir}/distutils/command/command_template
764
765 %dir %{py_scriptdir}/email
766 %dir %{py_scriptdir}/email/mime
767 %{py_scriptdir}/email/__pycache__
768 %{py_scriptdir}/email/mime/__pycache__
769 %{py_scriptdir}/email/*.py
770 %{py_scriptdir}/email/mime/*.py
771
772 %dir %{py_scriptdir}/html
773 %{py_scriptdir}/html/*.py
774 %{py_scriptdir}/html/__pycache__
775
776 %dir %{py_scriptdir}/http
777 %{py_scriptdir}/http/__pycache__
778 %{py_scriptdir}/http/*.py
779
780 %dir %{py_scriptdir}/importlib
781 %{py_scriptdir}/importlib/__pycache__
782 %{py_scriptdir}/importlib/*.py
783
784 %dir %{py_scriptdir}/json
785 %{py_scriptdir}/json/__pycache__
786 %{py_scriptdir}/json/*.py
787
788 %dir %{py_scriptdir}/logging
789 %{py_scriptdir}/logging/__pycache__
790 %{py_scriptdir}/logging/*.py
791
792 %dir %{py_scriptdir}/multiprocessing
793 %{py_scriptdir}/multiprocessing/__pycache__
794 %{py_scriptdir}/multiprocessing/*.py
795 %dir %{py_scriptdir}/multiprocessing/dummy
796 %{py_scriptdir}/multiprocessing/dummy/__pycache__
797 %{py_scriptdir}/multiprocessing/dummy/*.py
798
799 %{py_scriptdir}/turtledemo
800 %{py_scriptdir}/unittest
801
802 %dir %{py_scriptdir}/urllib
803 %{py_scriptdir}/urllib/__pycache__
804 %{py_scriptdir}/urllib/*.py
805
806 %dir %{py_scriptdir}/wsgiref
807 %{py_scriptdir}/wsgiref/__pycache__
808 %{py_scriptdir}/wsgiref/*.py
809 %{py_scriptdir}/wsgiref.egg-info
810
811 %dir %{py_scriptdir}/xml
812 %dir %{py_scriptdir}/xml/dom
813 %dir %{py_scriptdir}/xml/etree
814 %dir %{py_scriptdir}/xml/parsers
815 %dir %{py_scriptdir}/xml/sax
816 %{py_scriptdir}/xml/__pycache__
817 %{py_scriptdir}/xml/dom/__pycache__
818 %{py_scriptdir}/xml/etree/__pycache__
819 %{py_scriptdir}/xml/parsers/__pycache__
820 %{py_scriptdir}/xml/sax/__pycache__
821 %{py_scriptdir}/xml/*.py
822 %{py_scriptdir}/xml/dom/*.py
823 %{py_scriptdir}/xml/etree/*.py
824 %{py_scriptdir}/xml/parsers/*.py
825 %{py_scriptdir}/xml/sax/*.py
826
827 %dir %{py_scriptdir}/xmlrpc
828 %{py_scriptdir}/xmlrpc/__pycache__
829 %{py_scriptdir}/xmlrpc/*.py
830
831 %attr(755,root,root) %{py_dyndir}/_sqlite3.cpython-*.so
832 %dir %{py_scriptdir}/sqlite3
833 %{py_scriptdir}/sqlite3/__pycache__
834 %{py_scriptdir}/sqlite3/*.py
835
836 %files -n pydoc3
837 %defattr(644,root,root,755)
838 %attr(755,root,root) %{_bindir}/pydoc3
839 %attr(755,root,root) %{_bindir}/pydoc3.2
840 %{py_scriptdir}/pydoc.py
841 %dir %{py_scriptdir}/pydoc_data
842 %{py_scriptdir}/pydoc_data/__pycache__
843 %{py_scriptdir}/pydoc_data/*.py
844 %{py_scriptdir}/pydoc_data/*.css
845
846 %files -n idle3
847 %defattr(644,root,root,755)
848 %attr(755,root,root) %{_bindir}/idle3
849 %attr(755,root,root) %{_bindir}/idle3.2
850 %dir %{py_scriptdir}/idlelib
851 %dir %{py_scriptdir}/idlelib/Icons
852 %{py_scriptdir}/idlelib/__pycache__
853 %{py_scriptdir}/idlelib/*.py
854 %doc %{py_scriptdir}/idlelib/*.txt
855 %doc %{py_scriptdir}/idlelib/ChangeLog
856 %{py_scriptdir}/idlelib/Icons/*
857 %{py_scriptdir}/idlelib/*.def
858
859 %files devel
860 %defattr(644,root,root,755)
861 %doc Misc/{ACKS,NEWS,README,README.valgrind,valgrind-python.supp}
862 %attr(755,root,root) %{_bindir}/python%{py_ver}-config
863 %attr(755,root,root) %{_bindir}/python%{py_abi}-config
864 %attr(755,root,root) %{_bindir}/python3-config
865 %attr(755,root,root) %{_libdir}/libpython%{py_abi}.so
866 %attr(755,root,root) %{_libdir}/libpython3.so
867 %dir %{py_incdir}
868 %{py_incdir}/*.h
869 %{_pkgconfigdir}/python3.pc
870 %{_pkgconfigdir}/python-%{py_ver}.pc
871 %{_pkgconfigdir}/python-%{py_ver}mu.pc
872
873 %files devel-tools
874 %defattr(644,root,root,755)
875 /etc/shrc.d/python*-devel*
876
877 %attr(755,root,root) %{_bindir}/pygettext%{py_ver}
878
879 %{py_scriptdir}/pdb.py
880 %{py_scriptdir}/profile.py
881 %{py_scriptdir}/pstats.py
882 %{py_scriptdir}/timeit.py
883
884 %files 2to3
885 %attr(755,root,root) %{_bindir}/2to3-%{py_ver}
886 %dir %{py_scriptdir}/lib2to3
887 %{py_scriptdir}/lib2to3/__pycache__
888 %{py_scriptdir}/lib2to3/*.txt
889 %{py_scriptdir}/lib2to3/*.pickle
890 %{py_scriptdir}/lib2to3/*.py
891 %dir %{py_scriptdir}/lib2to3/fixes
892 %{py_scriptdir}/lib2to3/fixes/__pycache__
893 %{py_scriptdir}/lib2to3/fixes/*.py
894 %dir %{py_scriptdir}/lib2to3/pgen2
895 %{py_scriptdir}/lib2to3/pgen2/__pycache__
896 %{py_scriptdir}/lib2to3/pgen2/*.py
897
898 %files static
899 %defattr(644,root,root,755)
900 %{_libdir}/libpython%{py_abi}.a
901
902 %files examples
903 %defattr(644,root,root,755)
904 %{_examplesdir}/%{name}-%{version}
905
906 %if %{with info}
907 %files doc-info
908 %defattr(644,root,root,755)
909 %{_infodir}/*.info*
910 %endif
911
912 %if %{with tkinter}
913 %files tkinter
914 %defattr(644,root,root,755)
915 %dir %{py_scriptdir}/tkinter
916 %{py_scriptdir}/tkinter/__pycache__
917 %{py_scriptdir}/tkinter/*.py
918 %attr(755,root,root) %{py_dyndir}/_tkinter.cpython-*.so
919 %endif
This page took 0.220177 seconds and 4 git commands to generate.