]> git.pld-linux.org Git - packages/python3.git/blob - python3.spec
- there is no pdb.doc now
[packages/python3.git] / python3.spec
1 #
2 # TODO:
3 # - decide what to do with __pycache__:
4 #   1) package *.py sources in main and use __pycache__ dirs (and package them)
5 #   2) don't package __pycache__, manually invoke py_compileall everywhere (i.e. stick to python2-way)
6 # - fix tests
7 # - check unpackaged files
8
9 # Conditional build:
10 %bcond_with     info                    # info pages (requires emacs)
11 %bcond_without  tkinter                 # disables tkinter module building
12 %bcond_without  tests                   # disables Python testing
13 %bcond_with     verbose_tests           # runs tests in verbose mode
14 #
15 # tests which will not work on 64-bit platforms
16 %define         no64bit_tests   test_audioop test_rgbimg test_imageop
17 # tests which may fail because of builder environment limitations (no /proc or /dev/pts)
18 %define         nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
19 # tests which fail because of some unknown/unresolved reason (this list should be empty)
20 %define         broken_tests test_httpservers test_distutils test_cmd_line test_pydoc test_telnetlib test_zlib
21
22 %define py_ver          3.2
23 %define py_abi          %{py_ver}mu
24 %define py_prefix       %{_prefix}
25 %define py_libdir       %{py_prefix}/%{_lib}/python%{py_ver}
26 %define py_incdir       %{_includedir}/python%{py_abi}
27 %define py_sitedir      %{py_libdir}/site-packages
28 %define py_dyndir       %{py_libdir}/lib-dynload
29
30 Summary:        Very high level scripting language with X interface
31 Summary(es.UTF-8):      Lenguaje script de alto nivel con interfaz X
32 Summary(fr.UTF-8):      Langage de script de très haut niveau avec interface X
33 Summary(pl.UTF-8):      Python - język obiektowy wysokiego poziomu
34 Summary(pt_BR.UTF-8):   Linguagem de programação interpretada de alto nível
35 Summary(ru.UTF-8):      Язык программирования очень высокого уровня с X-интерфейсом
36 Summary(tr.UTF-8):      X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
37 Summary(uk.UTF-8):      Мова програмування дуже високого рівня з X-інтерфейсом
38 Name:           python3
39 Version:        %{py_ver}
40 Release:        0.1
41 Epoch:          1
42 License:        PSF
43 Group:          Applications
44 Source0:        http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
45 # Source0-md5:  563c0b4b8c8596e332cc076c4f013971
46 Patch0:         %{name}-pythonpath.patch
47 Patch1:         %{name}-ac_fixes.patch
48 Patch2:         %{name}-lib64.patch
49 Patch3:         %{name}-noarch_to_datadir.patch
50 URL:            http://www.python.org/
51 BuildRequires:  autoconf
52 BuildRequires:  bluez-libs-devel
53 BuildRequires:  bzip2-devel
54 BuildRequires:  db-devel >= 4
55 %{?with_info:BuildRequires:     emacs >= 21}
56 BuildRequires:  expat-devel >= 1:1.95.7
57 BuildRequires:  file
58 BuildRequires:  gdbm-devel >= 1.8.3
59 BuildRequires:  gmp-devel >= 4.0
60 BuildRequires:  libffi-devel
61 BuildRequires:  libstdc++-devel
62 BuildRequires:  ncurses-ext-devel >= 5.2
63 BuildRequires:  openssl-devel >= 0.9.8
64 BuildRequires:  readline-devel >= 5.0
65 BuildRequires:  rpm-pythonprov
66 BuildRequires:  sed >= 4.0
67 BuildRequires:  sqlite3-devel >= 3.3.5
68 %{?with_info:BuildRequires:     tetex-makeindex}
69 %{?with_tkinter:BuildRequires:  tix-devel >= 1:8.1.4-4}
70 %{?with_tkinter:BuildRequires:  tk-devel >= 8.4.3}
71 BuildRequires:  zlib-devel
72 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %define         specflags_ppc   -D__ppc__=1
76 %define         specflags_ppc64 -D__ppc64__=1
77
78 %if %{with verbose_tests}
79 %define test_flags -v -l -x
80 %else
81 %define test_flags -w -l -x
82 %endif
83
84 %ifarch alpha ia64 ppc64 sparc64 ppc64 %{x8664}
85 %define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
86 %else
87 %define test_list %{nobuilder_tests} %{broken_tests}
88 %endif
89
90 %ifarch sparc
91 %define test_list %{nobuilder_tests} %{broken_tests} test_fcntl test_ioctl
92 %endif
93
94 %description
95 Python is an interpreted, interactive, object-oriented programming
96 language. It incorporates modules, exceptions, dynamic typing, very
97 high level dynamic data types, and classes. Python combines remarkable
98 power with very clear syntax. It has interfaces to many system calls
99 and libraries, as well as to various window systems, and is extensible
100 in C or C++. It is also usable as an extension language for
101 applications that need a programmable interface. Finally, Python is
102 portable: it runs on many brands of UNIX, on the Mac, and on PCs under
103 MS-DOS, Windows, Windows NT, and OS/2.
104
105 This package contains the Python binary.
106
107 %description -l de.UTF-8
108 Python ist eine interpretierte, interaktive, objektorientierte
109 Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
110 Python enthält Module, Klassen, Exceptions, High-Level dynamische
111 Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
112 zu vielen Systemaufrufen und Libraries, sowie verschiedene
113 Fenstersysteme (X11, Motif, Tk, Mac und MFC)
114
115 Programmierer können neue built-in-Module für Python in C oder C++
116 schreiben. Python kann auch als Erweiterungssprache für Applikationen
117 benutzt werden, die ein programmierbares Interface brauchen. Dieses
118 Paket enthält die meisten Standard-Python-Module, und Module zum
119 Ansprechen von Tix (Tk-widget set) und RPM.
120
121 %description -l es.UTF-8
122 Python es un lenguaje de scripts interpretado orientado a objetos.
123 Contiene soporte para carga dinámica de objetos, clases, módulos y
124 excepciones.
125
126 Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
127 través de código C, tornando Python fácil de usar en ambientes
128 particulares/personalizados. Este paquete Python incluye la mayoría de
129 los módulos padrón Python, junto con módulos para crear interfaces
130 para el conjunto de componentes Tix para Tk y RPM.
131
132 %description -l fr.UTF-8
133 Python est un langage de script interprété et orienté objet. Il gère
134 le chargement dynamique des objets, les classes, les modules et les
135 exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
136 avec du code C est simple, ce qui rend Python facile à utiliser dans
137 des configs personnalisées.
138
139 Ce paquetage Python contient la plupart des modules Python standards,
140 ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
141 et RPM.
142
143 %description -l pl.UTF-8
144 Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
145 językiem programowania. Jest modularny, obsługuje wyjątki, dynamiczne
146 typy, zaawansowane dynamiczne struktury danych i klasy. Python łączy w
147 sobie duże możliwości i przejrzystą składnię. Posiada interfejsy do
148 wielu wywołań systemowych i bibliotek, w tym również do różnych
149 bibliotek okienkowych. Możliwości jego można jeszcze rozszerzać
150 poprzez odpowiednie moduły pisane w C lub C++. Python może być również
151 użyty jako element aplikacji, którym potrzebny jest interpreter do
152 skryptów. I wreszcie, Python jest wieloplatformowy, działa na wielu
153 odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
154 OS/2.
155
156 Ten pakiet zawiera binarkę Pythona.
157
158 %description -l pt_BR.UTF-8
159 Python é uma linguagem de scripts interpretada orientada a objetos.
160 Contém suporte para carga dinâmica de objetos, classes, módulos e
161 exceções. Adicionar interfaces para novos sistemas de biblioteca
162 através de código C é simples, tornando Python fácil de usar em
163 ambientes particulares/personalizados.
164
165 Este pacote Python inclui a maioria do módulos padrão Python, junto
166 com módulos para interfaceamento para o conjunto de componentes Tix
167 para Tk e RPM.
168
169 %description -l ru.UTF-8
170 Python - это интерпретируемый, объектно-ориентированный язык
171 программирования. Он поддерживает динамическую загрузку объектов,
172 классы, модули и обработку исключительных ситуаций (exceptions).
173 Простота добавления интерфейсов к новым системным библиотекам через
174 код на языке C делает Python хорошим выбором для использования в
175 специальных конфигурациях.
176
177 %description -l tr.UTF-8
178 Python, nesneye yönelik bir kabuk yorumlayıcıdır. Nesnelerin,
179 sınıfların, modüllerin ve aykırı durumların dinamik yüklenmelerine
180 destek verir. C koduyla birlikte kullanımı son derece kolaydır. Bu
181 paket, standart Python birimlerinin çoğunun yanısıra Tk ve RPM için
182 arayüz birimlerini de içerir.
183
184 %description -l uk.UTF-8
185 Python - це інтерпретована, об'єктно-орієнтована мова програмування.
186 Він підтримує динамічну загрузку об'єктів, класи, модулі та обробку
187 виключних ситуацій (exceptions). Простота додавання інтерфейсів для
188 нових системних бібліотек через код на мові C робить Python добрим
189 вибором для використання в спеціальних конфігураціях.
190
191 %package libs
192 Summary:        Python library
193 Summary(pl.UTF-8):      Biblioteka języka Python
194 Group:          Libraries/Python
195 # broken detection in rpm/pythondeps.sh
196 Provides:       python(abi) = %{py_ver}
197 # for compatibility with existing Ac packages
198 Provides:       python(bytecode) = %{py_ver}
199 %{!?with_info:Obsoletes:        python3-doc-info}
200
201 %description libs
202 Python shared library and very essental modules for Python binary.
203
204 %description libs -l pl.UTF-8
205 Biblioteka współdzielona języka Python oraz bardzo podstawowe moduły
206 dla Pythona.
207
208 %package modules
209 Summary:        Python modules
210 Summary(pl.UTF-8):      Moduły języka Python
211 Group:          Libraries/Python
212 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
213 Obsoletes:      python3-modules-sqlite
214
215 %description modules
216 Python officially distributed modules.
217
218 %description modules -l pl.UTF-8
219 Oficjalnie rozprowadzane moduły języka Python.
220
221 %package -n pydoc3
222 Summary:        Python interactive module documentation access support
223 Summary(pl.UTF-8):      Interaktywne korzystanie z dokumentacji modułów języka Python
224 Group:          Applications
225 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
226
227 %description -n pydoc3
228 Python interactive module documentation access support.
229
230 %description -n pydoc3 -l pl.UTF-8
231 Interaktywne korzystanie z dokumentacji modułów języka Python.
232
233 %package -n idle3
234 Summary:        IDE for Python language
235 Summary(pl.UTF-8):      IDE dla języka Python
236 Group:          Applications
237 Requires:       %{name}-tkinter = %{epoch}:%{version}-%{release}
238
239 %description -n idle3
240 IDE for Python language.
241
242 %description -n idle3 -l pl.UTF-8
243 IDE dla języka Python.
244
245 %package devel
246 Summary:        Libraries and header files for building python code
247 Summary(de.UTF-8):      Libraries und Header-Dateien zum Erstellen von Python-Code
248 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para construir programas en python
249 Summary(fr.UTF-8):      Bibliothèques et en-têtes pour construire du code python
250 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki Pythona
251 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para o Python
252 Summary(ru.UTF-8):      Библиотеки и хедеры для построения кода на языке Python
253 Summary(tr.UTF-8):      Python ile geliştirme yapmak için gerekli dosyalar
254 Summary(uk.UTF-8):      Бібліотеки та хедери для програмування на мові Python
255 Group:          Development/Languages/Python
256 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
257
258 %description devel
259 The Python interpreter is relatively easy to extend with dynamically
260 loaded extensions and to embed in other programs. This package
261 contains the header files and libraries which are needed to do both of
262 these tasks.
263
264 %description devel -l de.UTF-8
265 Der Python-Interpretierer ist relativ einfach anhand von dynamisch
266 ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
267 integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
268 die für beide Aufgaben erforderlich sind.
269
270 %description devel -l es.UTF-8
271 El interpretador Python permite incluir con facilidad extensiones
272 cargadas dinámicamente. Python es también fácil de ser empotrado en
273 otros programas. Este paquete contiene los archivos de inclusión y
274 bibliotecas necesarios para estas dos tareas.
275
276 %description devel -l fr.UTF-8
277 L'interpréteur Python est relativement facile à étendre avec des
278 extensions chargées dynamiquement et à insérer dans d'autres
279 programmes. Ce paquetage contient les en-têtes et les bibliothèques
280 nécessaires à ces deux tâches.
281
282 %description devel -l pl.UTF-8
283 Interpreter Pythona jest w miarę łatwy do rozszerzania przy pomocy
284 dynamicznie ładowanych rozszerzeń napisanych w C lub C++ oraz
285 osadzania w innych programach. Ten pakiet zawiera pliki nagłówkowe i
286 wszystko inne co potrzebne do tych celów.
287
288 %description devel -l pt_BR.UTF-8
289 O interpretador Python permite incluir com facilidade extensões
290 carregadas dinamicamente. Python é também fácil de ser embutido em
291 outros programas. Este pacote contém os arquivos de inclusão e
292 bibliotecas necessários para estas duas tarefas.
293
294 %description devel -l ru.UTF-8
295 Интерпретатор Python относительно легко расширяется при помощи
296 динамически загружаемых расширений и встраивается в другие программы.
297 Этот пакет содержит хедеры и библиотеки, необходимые для обеих этих
298 задач.
299
300 %description devel -l tr.UTF-8
301 Bu paket, Python ile geliştirme yapılabilmesi için gerekli başlık
302 dosyalarını ve kitaplıkları içerir.
303
304 %description devel -l uk.UTF-8
305 Інтерпретатор Python відносно легко розширюється за допомогою
306 розширень з динамічною загрузкою та вбудовується в інші програми. Цей
307 пакет містить хедери та бібліотеки, необхідні для обох цих задач.
308
309 %package devel-src
310 Summary:        Python module sources
311 Summary(pl.UTF-8):      Pliki źródłowe modułów Pythona
312 Group:          Development/Languages/Python
313 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
314
315 %description devel-src
316 Python module sources.
317
318 %description devel-src -l pl.UTF-8
319 Pliki źródłowe modułów Pythona.
320
321 %package devel-tools
322 Summary:        Python development tools
323 Summary(pl.UTF-8):      Narzędzia programistyczne języka Python
324 Group:          Development/Languages/Python
325 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
326
327 %description devel-tools
328 Python development tools such as profilers and debugger.
329
330 %description devel-tools -l pl.UTF-8
331 Narzędzia programistyczne języka Python takie jak profiler oraz
332 debugger.
333
334 %package 2to3
335 Summary:        Automated Python 2 to 3 code translation
336 Summary(pl.UTF-8):      Automatyczne tłumaczenie kodu Pythona 2 do 3
337 Group:          Development/Languages/Pythona
338
339 %description 2to3
340 2to3 is a Python program that reads Python 2.x source code and applies
341 a series of fixers to transform it into valid Python 3.x code. The
342 standard library contains a rich set of fixers that will handle almost
343 all code. 2to3 supporting library lib2to3 is, however, a flexible and
344 generic library, so it is possible to write your own fixers for 2to3.
345 lib2to3 could also be adapted to custom applications in which Python
346 code needs to be edited automatically.
347
348 %description 2to3 -l pl.UTF-8
349 2to3 to program w Pythonie czytający od źródłowy w Pythonie 2.x i
350 aplikujący serię poprawek przekształcających go w poprawny kod w
351 Pythonie 3.x. Biblioteka standardowa zawiera duży zbiór poprawek
352 obsługujących większość kodu. Biblioteka wspierająca 2to3 (lib2to3)
353 jest jednak elastyczną i ogólną biblioteką, więc można pisać własne
354 poprawki dla 2to3. lib2to3 można także zaadaptować na potrzeby
355 własnych zastosowań, w których kod w Pythonie musi być modyfikowany
356 automatycznie.
357
358 %package static
359 Summary:        Static python library
360 Summary(pl.UTF-8):      Statyczna biblioteka Pythona
361 Group:          Development/Languages/Python
362 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
363
364 %description static
365 Static python library.
366
367 %description static -l pl.UTF-8
368 Statyczna biblioteka Pythona.
369
370 %package doc-info
371 Summary:        Documentation on Python in texinfo format
372 Summary(pl.UTF-8):      Dokumentacja do Pythona w formacie texinfo
373 Group:          Documentation
374
375 %description doc-info
376 Documentation on Python in texinfo format.
377
378 %description doc-info -l pl.UTF-8
379 Dokumentacja do Pythona w formacie texinfo.
380
381 %package tkinter
382 Summary:        Standard Python interface to the Tk GUI toolkit
383 Summary(de.UTF-8):      Grafische Tk-Schnittstelle für Python
384 Summary(es.UTF-8):      Interfaz de GUI Tk para Python
385 Summary(fr.UTF-8):      Interface graphique Tk pour Python
386 Summary(pl.UTF-8):      Standardowy interfejs Pythona do biblioteki Tk
387 Summary(pt_BR.UTF-8):   Interface GUI Tk para Phyton
388 Summary(tr.UTF-8):      Python için grafik kullanıcı arayüzü
389 Group:          Libraries/Python
390 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
391 Requires:       tcl >= 8.4.3
392 Requires:       tix >= 1:8.1.4-4
393 Requires:       tk >= 8.4.3
394
395 %description tkinter
396 Standard Python interface to the Tk GUI toolkit.
397
398 %description tkinter -l de.UTF-8
399 Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
400 vielen Konfigurations-Tools genutzt.
401
402 %description tkinter -l es.UTF-8
403 Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por muchas
404 herramientas de configuración.
405
406 %description tkinter -l fr.UTF-8
407 Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
408 beaucoup des outils de configuration.
409
410 %description tkinter -l pl.UTF-8
411 Standardowy interfejs Pythona do biblioteki Tk.
412
413 %description tkinter -l pt_BR.UTF-8
414 Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
415 muitas ferramentas de configuração.
416
417 %description tkinter -l ru.UTF-8
418 Графический интерфейс (GUI) для Python, построенный на Tcl/Tk.
419
420 %description tkinter -l tr.UTF-8
421 Python için Tcl/Tk'ye dayalı ve pek çok ayarlama aracı tarafından
422 kullanılan grafik bir arayüzdür.
423
424 %description tkinter -l uk.UTF-8
425 Графічний інтерфейс (GUI) для Python, побудований на Tcl/Tk.
426
427 %package examples
428 Summary:        Example programs in Python
429 Summary(pl.UTF-8):      Przykładowe programy w Pythonie
430 Group:          Development/Languages/Python
431
432 %description examples
433 Example programs in Python.
434
435 These are for Python 2.3.4, not %{version}.
436
437 %description examples -l pl.UTF-8
438 Przykładowe programy w Pythonie.
439
440 Przykłady te są dla Pythona 2.3.4, nie %{version}.
441
442 %prep
443 %setup -q -n Python-%{version}
444 %patch0 -p1
445 %patch1 -p1
446 %patch2 -p1
447 %patch3 -p1
448
449 %build
450 %{__autoconf}
451 CPPFLAGS="-I/usr/include/ncursesw %{rpmcppflags}"; export CPPFLAGS
452 %configure \
453         --with-cxx-main="%{__cxx}" \
454         --enable-shared \
455         --enable-ipv6 \
456         --with-dbmliborder=gdbm:bdb \
457         --with-wide-unicode \
458         --with-signal-module \
459         --with-tsc \
460         --with-threads \
461         --with-doc-strings \
462         --with-fpectl \
463         --with-system-ffi \
464         --with-computed-gotos \
465         LINKCC='$(PURIFY) $(CXX)' \
466         LDSHARED='$(CC) $(CFLAGS) -shared' \
467         BLDSHARED='$(CC) $(CFLAGS) -shared' \
468         LDFLAGS="%{rpmcflags} %{rpmldflags}"
469
470 %{__make} \
471         OPT="%{rpmcflags} -fno-caller-saves" 2>&1 | awk '
472 BEGIN { fail = 0; logmsg = ""; }
473 {
474         if ($0 ~ /\*\*\* WARNING:/) {
475                 fail = 1;
476                 logmsg = logmsg $0;
477         }
478         print $0;
479 }
480 END { if (fail) { print "\nPROBLEMS FOUND:"; print logmsg; exit(1); } }'
481
482 LC_ALL=C
483 export LC_ALL
484 %if %{with tests}
485 binlibdir=`echo build/lib.*`
486 %{__make} test \
487         TESTOPTS="%{test_flags} %{test_list}" \
488         TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:$binlibdir ./python -tt"
489 %endif
490
491 %install
492 rm -rf $RPM_BUILD_ROOT
493 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
494         $RPM_BUILD_ROOT{%{py_sitedir},%{_mandir}/man1} \
495         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
496         $RPM_BUILD_ROOT%{_infodir} \
497         $RPM_BUILD_ROOT/etc/shrc.d
498
499 %{__make} install \
500         DESTDIR=$RPM_BUILD_ROOT
501
502 %if %{with info}
503 %{__make} -C Doc/info
504 install Doc/info/python*info* $RPM_BUILD_ROOT%{_infodir}
505 %endif
506
507 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
508 cp -a Tools $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
509
510 #
511 # create several useful aliases, such as timeit.py, profile.py, pdb.py, smtpd.py
512 #
513
514 # for python devel tools
515 for script in timeit profile pdb pstats; do
516     echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
517 done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
518
519 echo alias pygettext%{py_ver}.py='"pygettext%{py_ver}"' \
520         >> $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
521
522 sed 's/=/ /' \
523         < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh \
524         > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.csh
525
526 # for python modules
527 for script in smtpd webbrowser; do
528     echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
529 done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh
530
531 sed 's/=/ /' \
532         < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh \
533         > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.csh
534
535 # xgettext specific for Python code
536 #
537 # we will have two commands: pygettext.py (an alias) and pygettext;
538 # this way there are no import (which is impossible now) conflicts and
539 # pygettext.py is provided for compatibility
540 install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext%{py_ver}
541
542 # just to cut the noise, as they are not packaged (now)
543 # first tests
544 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/test
545 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/test
546 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/distutils/tests
547 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/email/test
548 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/importlib/test
549 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/lib2to3/tests
550 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/sqlite3/test
551 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/tkinter/test
552
553 # other files
554 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/plat-*/regen
555 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/macholib/fetch_macholib*
556 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/site-packages/README
557 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/distutils/command/wininst*.exe
558 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.bat
559 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.pyw
560 # already in %%doc
561 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/LICENSE.txt
562
563 %clean
564 rm -rf $RPM_BUILD_ROOT
565
566 %post   libs -p /sbin/ldconfig
567 %postun libs -p /sbin/ldconfig
568
569 %post   doc-info -p /sbin/postshell
570 -/usr/sbin/fix-info-dir -c %{_infodir}
571
572 %postun doc-info -p /sbin/postshell
573 -/usr/sbin/fix-info-dir -c %{_infodir}
574
575 %files
576 %defattr(644,root,root,755)
577 %attr(755,root,root) %{_bindir}/python%{py_ver}
578 %attr(755,root,root) %{_bindir}/python%{py_abi}
579 %attr(755,root,root) %{_bindir}/python3
580 %{_mandir}/man1/python%{py_ver}.1*
581
582 %files libs
583 %defattr(644,root,root,755)
584 %doc LICENSE
585 %attr(755,root,root) %{_libdir}/libpython%{py_abi}.so.*.*
586
587 %dir %{py_libdir}
588 %dir %{py_dyndir}
589 %dir %{py_sitedir}
590 %dir %{py_scriptdir}
591 %dir %{py_sitescriptdir}
592
593 # shared modules required by python library
594 %attr(755,root,root) %{py_dyndir}/_struct.cpython-*.so
595
596 # modules required by python library
597 %{py_scriptdir}/_abcoll.py[co]
598 %{py_scriptdir}/_weakrefset.py[co]
599 %{py_scriptdir}/abc.py[co]
600 %{py_scriptdir}/codecs.py[co]
601 %{py_scriptdir}/copyreg.py[co]
602 %{py_scriptdir}/genericpath.py[co]
603 %{py_scriptdir}/locale.py[co]
604 %{py_scriptdir}/io.py[co]
605 %{py_scriptdir}/posixpath.py[co]
606 %{py_scriptdir}/site.py[co]
607 %{py_scriptdir}/stat.py[co]
608 %{py_scriptdir}/os.py[co]
609 # needed by the dynamic sys.lib patch
610 %{py_scriptdir}/types.py[co]
611
612 # encodings required by python library
613 %dir %{py_scriptdir}/encodings
614 %{py_scriptdir}/encodings/*.py[co]
615
616 %files modules
617 %defattr(644,root,root,755)
618 /etc/shrc.d/python*-modules*
619 %exclude %{py_scriptdir}/_abcoll.py[co]
620 %exclude %{py_scriptdir}/_weakrefset.py[co]
621 %exclude %{py_scriptdir}/abc.py[co]
622 %exclude %{py_scriptdir}/codecs.py[co]
623 %exclude %{py_scriptdir}/copyreg.py[co]
624 %exclude %{py_scriptdir}/genericpath.py[co]
625 %exclude %{py_scriptdir}/io.py[co]
626 %exclude %{py_scriptdir}/locale.py[co]
627 %exclude %{py_scriptdir}/posixpath.py[co]
628 %exclude %{py_scriptdir}/pdb.py[co]
629 %exclude %{py_scriptdir}/profile.py[co]
630 %exclude %{py_scriptdir}/pstats.py[co]
631 %exclude %{py_scriptdir}/pydoc.py[co]
632 %exclude %{py_scriptdir}/site.py[co]
633 %exclude %{py_scriptdir}/stat.py[co]
634 %exclude %{py_scriptdir}/timeit.py[co]
635 %exclude %{py_scriptdir}/os.py[co]
636 %exclude %{py_scriptdir}/encodings/*.py[co]
637 %exclude %{py_scriptdir}/types.py[co]
638
639 %{py_scriptdir}/*.py[co]
640
641 %{py_dyndir}/Python-%{py_ver}-py*.egg-info
642
643 #
644 # list .so modules to be sure that all of them are built
645 #
646
647 # modules below do not work on 64-bit architectures
648 # see Python README file for explanation
649 %ifnarch alpha ia64 ppc64 sparc64 %{x8664}
650 %attr(755,root,root) %{py_dyndir}/audioop.cpython-*.so
651 %endif
652
653 %attr(755,root,root) %{py_dyndir}/_bisect.cpython-*.so
654 %attr(755,root,root) %{py_dyndir}/_codecs_cn.cpython-*.so
655 %attr(755,root,root) %{py_dyndir}/_codecs_hk.cpython-*.so
656 %attr(755,root,root) %{py_dyndir}/_codecs_iso2022.cpython-*.so
657 %attr(755,root,root) %{py_dyndir}/_codecs_jp.cpython-*.so
658 %attr(755,root,root) %{py_dyndir}/_codecs_kr.cpython-*.so
659 %attr(755,root,root) %{py_dyndir}/_codecs_tw.cpython-*.so
660 %attr(755,root,root) %{py_dyndir}/_csv.cpython-*.so
661 %attr(755,root,root) %{py_dyndir}/_ctypes*.cpython-*.so
662 %attr(755,root,root) %{py_dyndir}/_curses_panel.cpython-*.so
663 %attr(755,root,root) %{py_dyndir}/_curses.cpython-*.so
664 %attr(755,root,root) %{py_dyndir}/_datetime.cpython-*.so
665 %ifnarch sparc64
666 %attr(755,root,root) %{py_dyndir}/_dbm.cpython-*.so
667 %endif
668 %attr(755,root,root) %{py_dyndir}/_elementtree.cpython-*.so
669 %attr(755,root,root) %{py_dyndir}/_gdbm.cpython-*.so
670 %attr(755,root,root) %{py_dyndir}/_hashlib.cpython-*.so
671 %attr(755,root,root) %{py_dyndir}/_heapq.cpython-*.so
672 %attr(755,root,root) %{py_dyndir}/_json.cpython-*.so
673 %attr(755,root,root) %{py_dyndir}/_lsprof.cpython-*.so
674 %attr(755,root,root) %{py_dyndir}/_multibytecodec.cpython-*.so
675 %attr(755,root,root) %{py_dyndir}/_multiprocessing.cpython-*.so
676 %attr(755,root,root) %{py_dyndir}/_pickle.cpython-*.so
677 %attr(755,root,root) %{py_dyndir}/_random.cpython-*.so
678 %attr(755,root,root) %{py_dyndir}/_socket.cpython-*.so
679 %attr(755,root,root) %{py_dyndir}/_ssl.cpython-*.so
680 %attr(755,root,root) %{py_dyndir}/_testcapi.cpython-*.so
681 %attr(755,root,root) %{py_dyndir}/array.cpython-*.so
682 %attr(755,root,root) %{py_dyndir}/atexit.cpython-*.so
683 %attr(755,root,root) %{py_dyndir}/binascii.cpython-*.so
684 %attr(755,root,root) %{py_dyndir}/bz2.cpython-*.so
685 %attr(755,root,root) %{py_dyndir}/cmath.cpython-*.so
686 %attr(755,root,root) %{py_dyndir}/crypt.cpython-*.so
687 %attr(755,root,root) %{py_dyndir}/fcntl.cpython-*.so
688 %attr(755,root,root) %{py_dyndir}/grp.cpython-*.so
689 %attr(755,root,root) %{py_dyndir}/math.cpython-*.so
690 %attr(755,root,root) %{py_dyndir}/mmap.cpython-*.so
691 %attr(755,root,root) %{py_dyndir}/nis.cpython-*.so
692 %attr(755,root,root) %{py_dyndir}/ossaudiodev.cpython-*.so
693 %attr(755,root,root) %{py_dyndir}/parser.cpython-*.so
694 %attr(755,root,root) %{py_dyndir}/pyexpat.cpython-*.so
695 %attr(755,root,root) %{py_dyndir}/readline.cpython-*.so
696 %attr(755,root,root) %{py_dyndir}/resource.cpython-*.so
697 %attr(755,root,root) %{py_dyndir}/select.cpython-*.so
698 %attr(755,root,root) %{py_dyndir}/syslog.cpython-*.so
699 %attr(755,root,root) %{py_dyndir}/termios.cpython-*.so
700 %attr(755,root,root) %{py_dyndir}/time.cpython-*.so
701 %attr(755,root,root) %{py_dyndir}/spwd.cpython-*.so
702 %attr(755,root,root) %{py_dyndir}/unicodedata.cpython-*.so
703 %attr(755,root,root) %{py_dyndir}/zlib.cpython-*.so
704
705 %dir %{py_scriptdir}/plat-*
706 %{py_scriptdir}/plat-*/*.py[co]
707
708 %dir %{py_scriptdir}/ctypes
709 %dir %{py_scriptdir}/ctypes/macholib
710
711 %{py_scriptdir}/ctypes/*.py[co]
712 %{py_scriptdir}/ctypes/macholib/*.py[co]
713 %doc %{py_scriptdir}/ctypes/macholib/README.ctypes
714
715 %dir %{py_scriptdir}/curses
716 %{py_scriptdir}/curses/*.py[co]
717
718 %dir %{py_scriptdir}/dbm
719 %{py_scriptdir}/dbm/*.py[co]
720
721 %dir %{py_scriptdir}/distutils
722 %dir %{py_scriptdir}/distutils/command
723 %doc %{py_scriptdir}/distutils/README
724 %{py_scriptdir}/distutils/*.py[co]
725 %{py_scriptdir}/distutils/command/*.py[co]
726 %{py_scriptdir}/distutils/command/command_template
727
728 %dir %{py_scriptdir}/email
729 %dir %{py_scriptdir}/email/mime
730 %{py_scriptdir}/email/*.py[co]
731 %{py_scriptdir}/email/mime/*.py[co]
732
733 %dir %{py_scriptdir}/html
734 %{py_scriptdir}/html/*.py[co]
735
736 %dir %{py_scriptdir}/http
737 %{py_scriptdir}/http/*.py[co]
738
739 %dir %{py_scriptdir}/importlib
740 %{py_scriptdir}/importlib/*.py[co]
741
742 %dir %{py_scriptdir}/json
743 %{py_scriptdir}/json/*.py[co]
744
745 %dir %{py_scriptdir}/logging
746 %{py_scriptdir}/logging/*.py[co]
747
748 %dir %{py_scriptdir}/multiprocessing
749 %{py_scriptdir}/multiprocessing/*.py[co]
750 %dir %{py_scriptdir}/multiprocessing/dummy
751 %{py_scriptdir}/multiprocessing/dummy/*.py[co]
752
753 %dir %{py_scriptdir}/urllib
754 %{py_scriptdir}/urllib/*.py[co]
755
756 %dir %{py_scriptdir}/wsgiref
757 %{py_scriptdir}/wsgiref/*.py[co]
758 %{py_scriptdir}/wsgiref.egg-info
759
760 %dir %{py_scriptdir}/xml
761 %dir %{py_scriptdir}/xml/dom
762 %dir %{py_scriptdir}/xml/etree
763 %dir %{py_scriptdir}/xml/parsers
764 %dir %{py_scriptdir}/xml/sax
765 %{py_scriptdir}/xml/*.py[co]
766 %{py_scriptdir}/xml/dom/*.py[co]
767 %{py_scriptdir}/xml/etree/*.py[co]
768 %{py_scriptdir}/xml/parsers/*.py[co]
769 %{py_scriptdir}/xml/sax/*.py[co]
770
771 %dir %{py_scriptdir}/xmlrpc
772 %{py_scriptdir}/xmlrpc/*.py[co]
773
774 %attr(755,root,root) %{py_dyndir}/_sqlite3.cpython-*.so
775 %dir %{py_scriptdir}/sqlite3
776 %{py_scriptdir}/sqlite3/*.py[co]
777
778 %files -n pydoc3
779 %defattr(644,root,root,755)
780 %attr(755,root,root) %{_bindir}/pydoc3
781 %{py_scriptdir}/pydoc.py[co]
782 %dir %{py_scriptdir}/pydoc_data
783 %{py_scriptdir}/pydoc_data/*.py[co]
784
785 %files -n idle3
786 %defattr(644,root,root,755)
787 %attr(755,root,root) %{_bindir}/idle3
788 %dir %{py_scriptdir}/idlelib
789 %dir %{py_scriptdir}/idlelib/Icons
790 %{py_scriptdir}/idlelib/*.py[co]
791 %doc %{py_scriptdir}/idlelib/*.txt
792 %doc %{py_scriptdir}/idlelib/ChangeLog
793 %{py_scriptdir}/idlelib/Icons/*
794 %{py_scriptdir}/idlelib/*.def
795
796 %files devel
797 %defattr(644,root,root,755)
798 %doc Misc/{ACKS,NEWS,README,README.valgrind,valgrind-python.supp}
799 %attr(755,root,root) %{_bindir}/python%{py_ver}-config
800 %attr(755,root,root) %{_bindir}/python%{py_abi}-config
801 %attr(755,root,root) %{_bindir}/python3-config
802 %attr(755,root,root) %{_libdir}/libpython%{py_abi}.so
803 %attr(755,root,root) %{_libdir}/libpython3.so
804 %dir %{py_incdir}
805 %{py_incdir}/*.h
806 %{_pkgconfigdir}/python-%{py_ver}.pc
807 %{_pkgconfigdir}/python-%{py_abi}.pc
808 %{_pkgconfigdir}/python3.pc
809
810 %dir %{py_libdir}/config-%{py_abi}
811 %attr(755,root,root) %{py_libdir}/config-%{py_abi}/makesetup
812 %attr(755,root,root) %{py_libdir}/config-%{py_abi}/install-sh
813 %{py_libdir}/config-%{py_abi}/Makefile
814 %{py_libdir}/config-%{py_abi}/Setup
815 %{py_libdir}/config-%{py_abi}/Setup.config
816 %{py_libdir}/config-%{py_abi}/Setup.local
817 %{py_libdir}/config-%{py_abi}/config.c
818 %{py_libdir}/config-%{py_abi}/config.c.in
819 %{py_libdir}/config-%{py_abi}/python.o
820
821 %files devel-src
822 %defattr(644,root,root,755)
823 %attr(-,root,root) %{py_scriptdir}/*.py
824 %{py_scriptdir}/plat-*/*.py
825 %{py_scriptdir}/ctypes/*.py
826 %{py_scriptdir}/ctypes/macholib/*.py
827 %{py_scriptdir}/curses/*.py
828 %{py_scriptdir}/dbm/*.py
829 %{py_scriptdir}/distutils/*.py
830 %{py_scriptdir}/distutils/command/*.py
831 %{py_scriptdir}/email/*.py
832 %{py_scriptdir}/email/mime/*.py
833 %{py_scriptdir}/encodings/*.py
834 %{py_scriptdir}/html/*.py
835 %{py_scriptdir}/http/*.py
836 %{py_scriptdir}/idlelib/*.py
837 %{py_scriptdir}/importlib/*.py
838 %{py_scriptdir}/json/*.py
839 %{py_scriptdir}/lib2to3/*.py
840 %{py_scriptdir}/lib2to3/pgen2/*.py
841 %{py_scriptdir}/logging/*.py
842 %{py_scriptdir}/multiprocessing/*.py
843 %{py_scriptdir}/multiprocessing/dummy/*.py
844 %{py_scriptdir}/pydoc_data/*.py
845 %{py_scriptdir}/sqlite3/*.py
846 %{py_scriptdir}/tkinter/*.py
847 %{py_scriptdir}/urllib/*.py
848 %{py_scriptdir}/wsgiref/*.py
849 %{py_scriptdir}/xml/*.py
850 %{py_scriptdir}/xml/dom/*.py
851 %{py_scriptdir}/xml/etree/*.py
852 %{py_scriptdir}/xml/parsers/*.py
853 %{py_scriptdir}/xml/sax/*.py
854 %{py_scriptdir}/xmlrpc/*.py
855
856 %files devel-tools
857 %defattr(644,root,root,755)
858 /etc/shrc.d/python*-devel*
859
860 %attr(755,root,root) %{_bindir}/pygettext%{py_ver}
861
862 %{py_scriptdir}/pdb.py[co]
863 %{py_scriptdir}/profile.py[co]
864 %{py_scriptdir}/pstats.py[co]
865 %{py_scriptdir}/timeit.py[co]
866
867 %files 2to3
868 %attr(755,root,root) %{_bindir}/2to3-%{py_ver}
869 %dir %{py_scriptdir}/lib2to3
870 %{py_scriptdir}/lib2to3/*.txt
871 %{py_scriptdir}/lib2to3/*.pickle
872 %{py_scriptdir}/lib2to3/*.py[co]
873 %dir %{py_scriptdir}/lib2to3/fixes
874 %{py_scriptdir}/lib2to3/fixes/*.py
875 %{py_scriptdir}/lib2to3/fixes/*.py[co]
876 %dir %{py_scriptdir}/lib2to3/pgen2
877 %{py_scriptdir}/lib2to3/pgen2/*.py[co]
878
879 %files static
880 %defattr(644,root,root,755)
881 %{py_libdir}/config-%{py_abi}/libpython%{py_abi}.a
882
883 %files examples
884 %defattr(644,root,root,755)
885 %{_examplesdir}/%{name}-%{version}
886
887 %if %{with info}
888 %files doc-info
889 %defattr(644,root,root,755)
890 %{_infodir}/*.info*
891 %endif
892
893 %if %{with tkinter}
894 %files tkinter
895 %defattr(644,root,root,755)
896 %dir %{py_scriptdir}/tkinter
897 %{py_scriptdir}/tkinter/*.py[co]
898 %attr(755,root,root) %{py_dyndir}/_tkinter.cpython-*.so
899 %endif
This page took 0.094645 seconds and 4 git commands to generate.