]> git.pld-linux.org Git - packages/python3.git/blob - python3.spec
c26e6fbaa3a951e602a7b2cc9efb2792d521c27e
[packages/python3.git] / python3.spec
1
2 # Conditional build:
3 %bcond_with     info                    # info pages (requires emacs)
4 %bcond_without  tkinter                 # disables tkinter module building
5 %bcond_without  tests                   # disables Python testing
6 %bcond_with     verbose_tests           # runs tests in verbose mode
7 %bcond_with     openssl097
8 #
9 # tests which will not work on 64-bit platforms
10 %define         no64bit_tests   test_audioop test_rgbimg test_imageop
11 # tests which may fail because of builder environment limitations (no /proc or /dev/pts)
12 %define         nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
13 # tests which fail because of some unknown/unresolved reason (this list should be empty)
14 %define         broken_tests test_httpservers
15
16 %define beta            %{nil}
17
18 %define py_ver          3.0
19 %define py_prefix       %{_prefix}
20 %define py_libdir       %{py_prefix}/%{_lib}/python%{py_ver}
21 %define py_incdir       %{_includedir}/python%{py_ver}
22 %define py_sitedir      %{py_libdir}/site-packages
23 %define py_dyndir       %{py_libdir}/lib-dynload
24
25 Summary:        Very high level scripting language with X interface
26 Summary(es.UTF-8):      Lenguaje script de alto nivel con interfaz X
27 Summary(fr.UTF-8):      Langage de script de très haut niveau avec interface X
28 Summary(pl.UTF-8):      Python - język obiektowy wysokiego poziomu
29 Summary(pt_BR.UTF-8):   Linguagem de programação interpretada de alto nível
30 Summary(ru.UTF-8):      Язык программирования очень высокого уровня с X-интерфейсом
31 Summary(tr.UTF-8):      X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
32 Summary(uk.UTF-8):      Мова програмування дуже високого рівня з X-інтерфейсом
33 Name:           python30
34 Version:        %{py_ver}.1
35 Release:        0.1
36 Epoch:          1
37 License:        PSF
38 Group:          Applications
39 Source0:        http://www.python.org/ftp/python/%{version}/Python-%{version}%{beta}.tar.bz2
40 # Source0-md5:  7291eac6a9a7a3642e309c78b8d744e5
41 Patch1:         %{name}-pythonpath.patch
42 Patch2:         %{name}-no_ndbm.patch
43 Patch3:         %{name}-ac_fixes.patch
44 Patch4:         %{name}-lib64.patch
45 Patch5:         %{name}-noarch_to_datadir.patch
46 Patch6:         %{name}-doc_path.patch
47 Patch7:         %{name}-db4.6.patch
48 URL:            http://www.python.org/
49 BuildRequires:  autoconf
50 BuildRequires:  bluez-libs-devel
51 BuildRequires:  bzip2-devel
52 BuildRequires:  db-devel >= 4
53 %{?with_info:BuildRequires:     emacs >= 21}
54 BuildRequires:  expat-devel >= 1:1.95.7
55 BuildRequires:  file
56 BuildRequires:  gdbm-devel >= 1.8.3
57 BuildRequires:  gmp-devel >= 4.0
58 BuildRequires:  libffi-devel
59 BuildRequires:  libstdc++-devel
60 BuildRequires:  ncurses-ext-devel >= 5.2
61 %if %{with openssl097}
62 BuildRequires:  openssl-devel < 0.9.8
63 %else
64 BuildRequires:  openssl-devel >= 0.9.8
65 %endif
66 BuildRequires:  readline-devel >= 5.0
67 BuildRequires:  rpm-pythonprov
68 BuildRequires:  sed >= 4.0
69 BuildRequires:  sqlite3-devel >= 3.3.5
70 %{?with_info:BuildRequires:     tetex-makeindex}
71 %{?with_tkinter:BuildRequires:  tix-devel >= 1:8.1.4-4}
72 %{?with_tkinter:BuildRequires:  tk-devel >= 8.4.3}
73 BuildRequires:  zlib-devel
74 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %if %{with verbose_tests}
78 %define test_flags -v -l -x
79 %else
80 %define test_flags -l -x
81 %endif
82
83 %ifarch alpha ia64 ppc64 sparc64 ppc64 %{x8664}
84 %define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
85 %else
86 %define test_list %{nobuilder_tests} %{broken_tests}
87 %endif
88
89 %ifarch sparc
90 %define test_list %{nobuilder_tests} %{broken_tests} test_fcntl test_ioctl
91 %endif
92
93 %description
94 Python is an interpreted, interactive, object-oriented programming
95 language. It incorporates modules, exceptions, dynamic typing, very
96 high level dynamic data types, and classes. Python combines remarkable
97 power with very clear syntax. It has interfaces to many system calls
98 and libraries, as well as to various window systems, and is extensible
99 in C or C++. It is also usable as an extension language for
100 applications that need a programmable interface. Finally, Python is
101 portable: it runs on many brands of UNIX, on the Mac, and on PCs under
102 MS-DOS, Windows, Windows NT, and OS/2.
103
104 This package contains the Python binary.
105
106 %description -l de.UTF-8
107 Python ist eine interpretierte, interaktive, objektorientierte
108 Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
109 Python enthält Module, Klassen, Exceptions, High-Level dynamische
110 Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
111 zu vielen Systemaufrufen und Libraries, sowie verschiedene
112 Fenstersysteme (X11, Motif, Tk, Mac und MFC)
113
114 Programmierer können neue built-in-Module für Python in C oder C++
115 schreiben. Python kann auch als Erweiterungssprache für Applikationen
116 benutzt werden, die ein programmierbares Interface brauchen. Dieses
117 Paket enthält die meisten Standard-Python-Module, und Module zum
118 Ansprechen von Tix (Tk-widget set) und RPM.
119
120 %description -l es.UTF-8
121 Python es un lenguaje de scripts interpretado orientado a objetos.
122 Contiene soporte para carga dinámica de objetos, clases, módulos y
123 excepciones.
124
125 Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
126 través de código C, tornando Python fácil de usar en ambientes
127 particulares/personalizados. Este paquete Python incluye la mayoría de
128 los módulos padrón Python, junto con módulos para crear interfaces
129 para el conjunto de componentes Tix para Tk y RPM.
130
131 %description -l fr.UTF-8
132 Python est un langage de script interprété et orienté objet. Il gère
133 le chargement dynamique des objets, les classes, les modules et les
134 exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
135 avec du code C est simple, ce qui rend Python facile à utiliser dans
136 des configs personnalisées.
137
138 Ce paquetage Python contient la plupart des modules Python standards,
139 ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
140 et RPM.
141
142 %description -l pl.UTF-8
143 Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
144 językiem programowania. Jest modularny, obsługuje wyjątki, dynamiczne
145 typy, zaawansowane dynamiczne struktury danych i klasy. Python łączy w
146 sobie duże możliwości i przejrzystą składnię. Posiada interfejsy do
147 wielu wywołań systemowych i bibliotek, w tym również do różnych
148 bibliotek okienkowych. Możliwości jego można jeszcze rozszerzać
149 poprzez odpowiednie moduły pisane w C lub C++. Python może być również
150 użyty jako element aplikacji, którym potrzebny jest interpreter do
151 skryptów. I wreszcie, Python jest wieloplatformowy, działa na wielu
152 odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
153 OS/2.
154
155 Ten pakiet zawiera binarkę Pythona.
156
157 %description -l pt_BR.UTF-8
158 Python é uma linguagem de scripts interpretada orientada a objetos.
159 Contém suporte para carga dinâmica de objetos, classes, módulos e
160 exceções. Adicionar interfaces para novos sistemas de biblioteca
161 através de código C é simples, tornando Python fácil de usar em
162 ambientes particulares/personalizados.
163
164 Este pacote Python inclui a maioria do módulos padrão Python, junto
165 com módulos para interfaceamento para o conjunto de componentes Tix
166 para Tk e RPM.
167
168 %description -l ru.UTF-8
169 Python - это интерпретируемый, объектно-ориентированный язык
170 программирования. Он поддерживает динамическую загрузку объектов,
171 классы, модули и обработку исключительных ситуаций (exceptions).
172 Простота добавления интерфейсов к новым системным библиотекам через
173 код на языке C делает Python хорошим выбором для использования в
174 специальных конфигурациях.
175
176 %description -l tr.UTF-8
177 Python, nesneye yönelik bir kabuk yorumlayıcıdır. Nesnelerin,
178 sınıfların, modüllerin ve aykırı durumların dinamik yüklenmelerine
179 destek verir. C koduyla birlikte kullanımı son derece kolaydır. Bu
180 paket, standart Python birimlerinin çoğunun yanısıra Tk ve RPM için
181 arayüz birimlerini de içerir.
182
183 %description -l uk.UTF-8
184 Python - це інтерпретована, об'єктно-орієнтована мова програмування.
185 Він підтримує динамічну загрузку об'єктів, класи, модулі та обробку
186 виключних ситуацій (exceptions). Простота додавання інтерфейсів для
187 нових системних бібліотек через код на мові C робить Python добрим
188 вибором для використання в спеціальних конфігураціях.
189
190 %package libs
191 Summary:        Python library
192 Summary(pl.UTF-8):      Biblioteka języka Python
193 Group:          Libraries/Python
194 # broken detection in rpm/pythondeps.sh
195 Provides:       python(abi) = %{py_ver}
196 # for compatibility with existing Ac packages
197 Provides:       python(bytecode) = %{py_ver}
198 %{!?with_info:Obsoletes:        python30-doc-info}
199
200 %description libs
201 Python shared library and very essental modules for Python binary.
202
203 %description libs -l pl.UTF-8
204 Biblioteka współdzielona języka Python oraz bardzo podstawowe moduły
205 dla Pythona.
206
207 %package modules
208 Summary:        Python modules
209 Summary(pl.UTF-8):      Moduły języka Python
210 Group:          Libraries/Python
211 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
212
213 %description modules
214 Python officially distributed modules.
215
216 %description modules -l pl.UTF-8
217 Oficjalnie rozprowadzane moduły języka Python.
218
219 %package modules-sqlite
220 Summary:        Python SQLite modules
221 Summary(pl.UTF-8):      Moduły SQLite języka Python
222 Group:          Libraries/Python
223 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
224
225 %description modules-sqlite
226 Python officially distributed sqlite module.
227
228 %description modules-sqlite -l pl.UTF-8
229 Oficjalnie rozprowadzany moduł sqlite języka Python.
230
231 %package -n pydoc30
232 Summary:        Python interactive module documentation access support
233 Summary(pl.UTF-8):      Interaktywne korzystanie z dokumentacji modułów języka Python
234 Group:          Applications
235 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
236
237 %description -n pydoc30
238 Python interactive module documentation access support.
239
240 %description -n pydoc30 -l pl.UTF-8
241 Interaktywne korzystanie z dokumentacji modułów języka Python.
242
243 %package -n idle30
244 Summary:        IDE for Python language
245 Summary(pl.UTF-8):      IDE dla języka Python
246 Group:          Applications
247 Requires:       %{name}-tkinter = %{epoch}:%{version}-%{release}
248
249 %description -n idle30
250 IDE for Python language.
251
252 %description -n idle30 -l pl.UTF-8
253 IDE dla języka Python.
254
255 %package devel
256 Summary:        Libraries and header files for building python code
257 Summary(de.UTF-8):      Libraries und Header-Dateien zum Erstellen von Python-Code
258 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para construir programas en python
259 Summary(fr.UTF-8):      Bibliothèques et en-têtes pour construire du code python
260 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki Pythona
261 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para o Python
262 Summary(ru.UTF-8):      Библиотеки и хедеры для построения кода на языке Python
263 Summary(tr.UTF-8):      Python ile geliştirme yapmak için gerekli dosyalar
264 Summary(uk.UTF-8):      Бібліотеки та хедери для програмування на мові Python
265 Group:          Development/Languages/Python
266 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
267 Obsoletes:      python-devel
268
269 %description devel
270 The Python interpreter is relatively easy to extend with dynamically
271 loaded extensions and to embed in other programs. This package
272 contains the header files and libraries which are needed to do both of
273 these tasks.
274
275 %description devel -l de.UTF-8
276 Der Python-Interpretierer ist relativ einfach anhand von dynamisch
277 ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
278 integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
279 die für beide Aufgaben erforderlich sind.
280
281 %description devel -l es.UTF-8
282 El interpretador Python permite incluir con facilidad extensiones
283 cargadas dinámicamente. Python es también fácil de ser empotrado en
284 otros programas. Este paquete contiene los archivos de inclusión y
285 bibliotecas necesarios para estas dos tareas.
286
287 %description devel -l fr.UTF-8
288 L'interpréteur Python est relativement facile à étendre avec des
289 extensions chargées dynamiquement et à insérer dans d'autres
290 programmes. Ce paquetage contient les en-têtes et les bibliothèques
291 nécessaires à ces deux tâches.
292
293 %description devel -l pl.UTF-8
294 Interpreter Pythona jest w miarę łatwy do rozszerzania przy pomocy
295 dynamicznie ładowanych rozszerzeń napisanych w C lub C++ oraz
296 osadzania w innych programach. Ten pakiet zawiera pliki nagłówkowe i
297 wszystko inne co potrzebne do tych celów.
298
299 %description devel -l pt_BR.UTF-8
300 O interpretador Python permite incluir com facilidade extensões
301 carregadas dinamicamente. Python é também fácil de ser embutido em
302 outros programas. Este pacote contém os arquivos de inclusão e
303 bibliotecas necessários para estas duas tarefas.
304
305 %description devel -l ru.UTF-8
306 Интерпретатор Python относительно легко расширяется при помощи
307 динамически загружаемых расширений и встраивается в другие программы.
308 Этот пакет содержит хедеры и библиотеки, необходимые для обеих этих
309 задач.
310
311 %description devel -l tr.UTF-8
312 Bu paket, Python ile geliştirme yapılabilmesi için gerekli başlık
313 dosyalarını ve kitaplıkları içerir.
314
315 %description devel -l uk.UTF-8
316 Інтерпретатор Python відносно легко розширюється за допомогою
317 розширень з динамічною загрузкою та вбудовується в інші програми. Цей
318 пакет містить хедери та бібліотеки, необхідні для обох цих задач.
319
320 %package devel-src
321 Summary:        Python module sources
322 Summary(pl.UTF-8):      Pliki źródłowe modułów Pythona
323 Group:          Development/Languages/Python
324 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
325
326 %description devel-src
327 Python module sources.
328
329 %description devel-src -l pl.UTF-8
330 Pliki źródłowe modułów Pythona.
331
332 %package devel-tools
333 Summary:        Python development tools
334 Summary(pl.UTF-8):      Narzędzia programistyczne języka Python
335 Group:          Development/Languages/Python
336 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
337
338 %description devel-tools
339 Python development tools such as profilers and debugger.
340
341 %description devel-tools -l pl.UTF-8
342 Narzędzia programistyczne języka Python takie jak profiler oraz
343 debugger.
344
345 %package static
346 Summary:        Static python library
347 Summary(pl.UTF-8):      Statyczna biblioteka Pythona
348 Group:          Development/Languages/Python
349 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
350
351 %description static
352 Static python library.
353
354 %description static -l pl.UTF-8
355 Statyczna biblioteka Pythona.
356
357 %package doc
358 Summary:        Documentation on Python
359 Summary(de.UTF-8):      Dokumentation zu Python
360 Summary(es.UTF-8):      Documentación para Python
361 Summary(fr.UTF-8):      Documentation sur Python
362 Summary(pl.UTF-8):      Dokumentacja do Pythona
363 Summary(pt_BR.UTF-8):   Documentação para a linguagem de programação Python
364 Summary(ru.UTF-8):      Документация по языку Python
365 Summary(tr.UTF-8):      Python belgeleri
366 Summary(uk.UTF-8):      Документація по мові Python
367 Group:          Documentation
368
369 %description doc
370 This package contains documentation on the Python language and
371 interpretor as a mix of plain ASCII files and LaTeX sources.
372
373 %description doc -l de.UTF-8
374 Dieses Paket enthält Dokumentationen zu Python (Sprache und
375 Interpreter) in Form von einfachen ASCII-Dateien und LaTeX-Quellen.
376
377 %description doc -l es.UTF-8
378 Documentación para Python. Contiene archivos en texto y PostScript.
379
380 %description doc -l fr.UTF-8
381 Ce paquetage contient la documentation sur le langage python et sur
382 son interpréteur sous forme de fichiers ASCII et LaTeX.
383
384 %description doc -l pl.UTF-8
385 Oficjalna dokumentacja do Pythona. Zawiera przykładowe programy,
386 narzędzia i dokumentację. Strony podręcznika man znajdują się w
387 głównym pakiecie. Ten pakiet nie zawiera źródeł dokumentacji
388 napisanych w LaTeXu, tylko gotowe do wykorzystania pliki postscriptowe
389 i HTML.
390
391 %description doc -l pt_BR.UTF-8
392 O pacote python-doc contém documentação para a linguagem de
393 programação e para o interpretador Python. Fornecida em arquivos texto
394 e Postcript.
395
396 %description doc -l ru.UTF-8
397 Этот пакет содержит документацию по собственно языку Python и по
398 исполняющему его интерпретатору в виде набора текстовых файлов и
399 исходных текстов в формате LaTeX.
400
401 %description doc -l tr.UTF-8
402 Bu paket, Python dili ile ilgili belgeleri ve düz ASCII dosyaları ve
403 LaTeX kaynaklarının bir karışımı olan yorumlayıcıyı içerir.
404
405 %description doc -l uk.UTF-8
406 Цей пакет містить документацію по власне мові Python та по виконуючому
407 її інтерпретатору у вигляді набора текстових файлів та вихідних
408 текстів у форматі LaTeX.
409
410 %package doc-info
411 Summary:        Documentation on Python in texinfo format
412 Summary(pl.UTF-8):      Dokumentacja do Pythona w formacie texinfo
413 Group:          Documentation
414
415 %description doc-info
416 Documentation on Python in texinfo format.
417
418 %description doc-info -l pl.UTF-8
419 Dokumentacja do Pythona w formacie texinfo.
420
421 %package tkinter
422 Summary:        Standard Python interface to the Tk GUI toolkit
423 Summary(de.UTF-8):      Grafische Tk-Schnittstelle für Python
424 Summary(es.UTF-8):      Interfaz de GUI Tk para Python
425 Summary(fr.UTF-8):      Interface graphique Tk pour Python
426 Summary(pl.UTF-8):      Standardowy interfejs Pythona do biblioteki Tk
427 Summary(pt_BR.UTF-8):   Interface GUI Tk para Phyton
428 Summary(tr.UTF-8):      Python için grafik kullanıcı arayüzü
429 Group:          Libraries/Python
430 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
431 Requires:       tcl >= 8.4.3
432 Requires:       tix >= 1:8.1.4-4
433 Requires:       tk >= 8.4.3
434
435 %description tkinter
436 Standard Python interface to the Tk GUI toolkit.
437
438 %description tkinter -l de.UTF-8
439 Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
440 vielen Konfigurations-Tools genutzt.
441
442 %description tkinter -l es.UTF-8
443 Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por muchas
444 herramientas de configuración.
445
446 %description tkinter -l fr.UTF-8
447 Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
448 beaucoup des outils de configuration.
449
450 %description tkinter -l pl.UTF-8
451 Standardowy interfejs Pythona do biblioteki Tk.
452
453 %description tkinter -l pt_BR.UTF-8
454 Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
455 muitas ferramentas de configuração.
456
457 %description tkinter -l ru.UTF-8
458 Графический интерфейс (GUI) для Python, построенный на Tcl/Tk.
459
460 %description tkinter -l tr.UTF-8
461 Python için Tcl/Tk'ye dayalı ve pek çok ayarlama aracı tarafından
462 kullanılan grafik bir arayüzdür.
463
464 %description tkinter -l uk.UTF-8
465 Графічний інтерфейс (GUI) для Python, побудований на Tcl/Tk.
466
467 %package examples
468 Summary:        Example programs in Python
469 Summary(pl.UTF-8):      Przykładowe programy w Pythonie
470 Group:          Development/Languages/Python
471
472 %description examples
473 Example programs in Python.
474
475 These are for Python 2.3.4, not %{version}.
476
477 %description examples -l pl.UTF-8
478 Przykładowe programy w Pythonie.
479
480 Przykłady te są dla Pythona 2.3.4, nie %{version}.
481
482 %prep
483 %setup -q -n Python-%{version}%{beta}
484 #patch1 -p1
485 %patch2 -p1
486 %patch3 -p1
487 %patch4 -p1
488 %patch5 -p1 -b .wiget
489 #patch6 -p1
490 #patch7 -p1
491
492 %build
493 sed -i -e 's#-ltermcap#-ltinfo#g' configure*
494 %{__autoconf}
495 CPPFLAGS="-I/usr/include/ncursesw"; export CPPFLAGS
496 #       --with-wctype-functions \
497 %configure \
498         --with-cxx-main="%{__cxx}" \
499         --enable-shared \
500         --enable-ipv6 \
501         --with-wide-unicode \
502         --with-signal-module \
503         --with-tsc \
504         --with-threads \
505         --with-doc-strings \
506         --with-fpectl \
507         --with-system-ffi \
508         LINKCC='$(PURIFY) $(CXX)' \
509         LDSHARED='$(CC) $(CFLAGS) -shared' \
510         BLDSHARED='$(CC) $(CFLAGS) -shared' \
511         LDFLAGS="%{rpmcflags} %{rpmldflags}"
512
513 %{__make} \
514         OPT="%{rpmcflags}" 2>&1 | awk '
515 BEGIN { fail = 0; logmsg = ""; }
516 {
517         if ($0 ~ /\*\*\* WARNING:/) {
518                 fail = 1;
519                 logmsg = logmsg $0;
520         }
521         print $0;
522 }
523 END { if (fail) { print "\nPROBLEMS FOUND:"; print logmsg; exit(1); } }'
524
525 LC_ALL=C
526 export LC_ALL
527 %if %{with tests}
528 binlibdir=`echo build/lib.*`
529 %{__make} test \
530         TESTOPTS="%{test_flags} %{test_list}" \
531         TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:$binlibdir ./python -tt"
532 %endif
533
534 %install
535 rm -rf $RPM_BUILD_ROOT
536 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
537         $RPM_BUILD_ROOT{%{py_sitedir},%{_mandir}/man1} \
538         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
539         $RPM_BUILD_ROOT%{_infodir} \
540         $RPM_BUILD_ROOT/etc/shrc.d
541
542 %{__make} install \
543         DESTDIR=$RPM_BUILD_ROOT
544
545 %if %{with info}
546 %{__make} -C Doc/info
547 install Doc/info/python*info* $RPM_BUILD_ROOT%{_infodir}
548 %endif
549
550 install Makefile.pre.in $RPM_BUILD_ROOT%{py_libdir}/config
551
552 mv $RPM_BUILD_ROOT{%{py_libdir}/config,%{_libdir}}/libpython%{py_ver}.a
553 ln -sf libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}/libpython.a
554 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython.so
555 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython%{py_ver}.so
556
557 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
558 cp -a Tools Demo $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
559
560 #
561 # create several useful aliases, such as timeit.py, profile.py, pdb.py, smtpd.py
562 #
563
564 # for python devel tools
565 for script in timeit profile pdb pstats; do
566     echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
567 done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
568
569 echo alias pygettext%{py_ver}.py='"pygettext%{py_ver}"' \
570         >> $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
571
572 sed 's/=/ /' \
573         < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh \
574         > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.csh
575
576 # for python modules
577 for script in smtpd webbrowser; do
578     echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
579 done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh
580
581 sed 's/=/ /' \
582         < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh \
583         > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.csh
584
585 # xgettext specific for Python code
586 #
587 # we will have two commands: pygettext.py (an alias) and pygettext;
588 # this way there are no import (which is impossible now) conflicts and
589 # pygettext.py is provided for compatibility
590 install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext%{py_ver}
591
592 # add py_ver
593 for script in idle pydoc; do
594         mv $RPM_BUILD_ROOT%{_bindir}/${script} $RPM_BUILD_ROOT%{_bindir}/${script}%{py_ver}
595 done
596 #mv $RPM_BUILD_ROOT%{_mandir}/man1/python.1 $RPM_BUILD_ROOT%{_mandir}/man1/python%{py_ver}.1
597
598 # just to cut the noise, as they are not packaged (now)
599 # first tests
600 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/test
601 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/bsddb/test
602 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/test
603 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/distutils/tests
604 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/email/test
605 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/sqlite3/test
606 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/json/tests
607 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/lib2to3/tests
608
609 # other files
610 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/plat-*/regen
611 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/macholib/fetch_macholib*
612 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/site-packages/README
613 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/distutils/command/wininst*.exe
614 # already in %%doc
615 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/pdb.doc
616 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/LICENSE.txt
617
618 %clean
619 rm -rf $RPM_BUILD_ROOT
620
621 %post   libs -p /sbin/ldconfig
622 %postun libs -p /sbin/ldconfig
623
624 %post doc-info  -p      /sbin/postshell
625 -/usr/sbin/fix-info-dir -c %{_infodir}
626
627 %postun doc-info        -p      /sbin/postshell
628 -/usr/sbin/fix-info-dir -c %{_infodir}
629
630 %files
631 %defattr(644,root,root,755)
632 %attr(755,root,root) %{_bindir}/python%{py_ver}
633 %attr(755,root,root) %{_bindir}/2to3
634 #%{_mandir}/man1/*
635
636 %files modules
637 %defattr(644,root,root,755)
638 /etc/shrc.d/python*-modules*
639 #exclude %{py_scriptdir}/UserDict.py[co]
640 %exclude %{py_scriptdir}/codecs.py[co]
641 %exclude %{py_scriptdir}/copyreg.py[co]
642 %exclude %{py_scriptdir}/locale.py[co]
643 %exclude %{py_scriptdir}/posixpath.py[co]
644 %exclude %{py_scriptdir}/pdb.py[co]
645 %exclude %{py_scriptdir}/profile.py[co]
646 %exclude %{py_scriptdir}/pstats.py[co]
647 %exclude %{py_scriptdir}/pydoc.py[co]
648 %exclude %{py_scriptdir}/site.py[co]
649 %exclude %{py_scriptdir}/stat.py[co]
650 %exclude %{py_scriptdir}/timeit.py[co]
651 %exclude %{py_scriptdir}/os.py[co]
652 %exclude %{py_scriptdir}/encodings/*.py[co]
653 %exclude %{py_scriptdir}/types.py[co]
654
655 %{py_scriptdir}/*.py[co]
656
657 %{py_dyndir}/*.egg-info
658
659 #
660 # list .so modules to be sure that all of them are built
661 #
662
663 # three modules below do not work on 64-bit architectures
664 # see Python README file for explanation
665 %ifnarch alpha ia64 ppc64 sparc64 %{x8664}
666 %attr(755,root,root) %{py_dyndir}/audioop.so
667 %attr(755,root,root) %{py_dyndir}/rgbimg.so
668 %attr(755,root,root) %{py_dyndir}/imageop.so
669 # sizeof(long) != sizeof(int), so dl module will not be built on 64-bit
670 # platforms
671 %attr(755,root,root) %{py_dyndir}/dl.so
672 %endif
673
674 %attr(755,root,root) %{py_dyndir}/array.so
675 %attr(755,root,root) %{py_dyndir}/atexit.so
676 %attr(755,root,root) %{py_dyndir}/audioop.so
677 %attr(755,root,root) %{py_dyndir}/binascii.so
678 %attr(755,root,root) %{py_dyndir}/_bisect.so
679 #%attr(755,root,root) %{py_dyndir}/_bsddb.so
680 %attr(755,root,root) %{py_dyndir}/bz2.so
681 %attr(755,root,root) %{py_dyndir}/cmath.so
682 %attr(755,root,root) %{py_dyndir}/_codecs_cn.so
683 %attr(755,root,root) %{py_dyndir}/_codecs_hk.so
684 %attr(755,root,root) %{py_dyndir}/_codecs_iso2022.so
685 %attr(755,root,root) %{py_dyndir}/_codecs_jp.so
686 %attr(755,root,root) %{py_dyndir}/_codecs_kr.so
687 %attr(755,root,root) %{py_dyndir}/_codecs_tw.so
688 %attr(755,root,root) %{py_dyndir}/_collections.so
689 %attr(755,root,root) %{py_dyndir}/crypt.so
690 #%attr(755,root,root) %{py_dyndir}/cStringIO.so
691 %attr(755,root,root) %{py_dyndir}/_csv.so
692 %attr(755,root,root) %{py_dyndir}/_ctypes*.so
693 %attr(755,root,root) %{py_dyndir}/_curses_panel.so
694 %attr(755,root,root) %{py_dyndir}/_curses.so
695 %attr(755,root,root) %{py_dyndir}/datetime.so
696 %attr(755,root,root) %{py_dyndir}/_elementtree.so
697 %attr(755,root,root) %{py_dyndir}/_functools.so
698 %attr(755,root,root) %{py_dyndir}/_hashlib.so
699 %attr(755,root,root) %{py_dyndir}/_heapq.so
700 %attr(755,root,root) %{py_dyndir}/_json.so
701 %attr(755,root,root) %{py_dyndir}/_locale.so
702 %attr(755,root,root) %{py_dyndir}/_lsprof.so
703 %attr(755,root,root) %{py_dyndir}/_multibytecodec.so
704 %attr(755,root,root) %{py_dyndir}/_multiprocessing.so
705 %attr(755,root,root) %{py_dyndir}/_pickle.so
706 %attr(755,root,root) %{py_dyndir}/_random.so
707 %{?with_openssl097:%attr(755,root,root) %{py_dyndir}/_sha*.so}
708 %attr(755,root,root) %{py_dyndir}/_socket.so
709 %attr(755,root,root) %{py_dyndir}/_ssl.so
710 %attr(755,root,root) %{py_dyndir}/_testcapi.so
711 #%attr(755,root,root) %{py_dyndir}/_weakref.so
712 %ifnarch sparc64
713 %attr(755,root,root) %{py_dyndir}/_dbm.so
714 %endif
715 %attr(755,root,root) %{py_dyndir}/fcntl.so
716 %attr(755,root,root) %{py_dyndir}/_gdbm.so
717 %attr(755,root,root) %{py_dyndir}/grp.so
718 %attr(755,root,root) %{py_dyndir}/itertools.so
719 #%attr(755,root,root) %{py_dyndir}/linuxaudiodev.so
720 %attr(755,root,root) %{py_dyndir}/math.so
721 %attr(755,root,root) %{py_dyndir}/mmap.so
722 %attr(755,root,root) %{py_dyndir}/nis.so
723 %attr(755,root,root) %{py_dyndir}/operator.so
724 %attr(755,root,root) %{py_dyndir}/ossaudiodev.so
725 %attr(755,root,root) %{py_dyndir}/parser.so
726 %attr(755,root,root) %{py_dyndir}/pyexpat.so
727 %attr(755,root,root) %{py_dyndir}/readline.so
728 %attr(755,root,root) %{py_dyndir}/resource.so
729 %attr(755,root,root) %{py_dyndir}/select.so
730 #%attr(755,root,root) %{py_dyndir}/strop.so
731 %attr(755,root,root) %{py_dyndir}/syslog.so
732 %attr(755,root,root) %{py_dyndir}/termios.so
733 %attr(755,root,root) %{py_dyndir}/time.so
734 %attr(755,root,root) %{py_dyndir}/spwd.so
735 %attr(755,root,root) %{py_dyndir}/unicodedata.so
736 %attr(755,root,root) %{py_dyndir}/zlib.so
737
738 %dir %{py_scriptdir}/plat-*
739 %{py_scriptdir}/plat-*/*.py[co]
740
741 #%dir %{py_scriptdir}/bsddb
742 #%{py_scriptdir}/bsddb/*.py[co]
743
744 #%dir %{py_scriptdir}/compiler
745 #%{py_scriptdir}/compiler/*.py[co]
746
747 %dir %{py_scriptdir}/ctypes
748 %dir %{py_scriptdir}/ctypes/macholib
749
750 %{py_scriptdir}/ctypes/*.py[co]
751 %{py_scriptdir}/ctypes/macholib/*.py[co]
752 %doc %{py_scriptdir}/ctypes/macholib/README.ctypes
753
754 %dir %{py_scriptdir}/curses
755 %{py_scriptdir}/curses/*.py[co]
756
757 %dir %{py_scriptdir}/dbm
758 %{py_scriptdir}/dbm/*.py[co]
759
760 %dir %{py_scriptdir}/distutils
761 %dir %{py_scriptdir}/distutils/command
762 %doc %{py_scriptdir}/distutils/README
763 %{py_scriptdir}/distutils/*.py[co]
764 %{py_scriptdir}/distutils/command/*.py[co]
765 %{py_scriptdir}/distutils/command/command_template
766
767 %dir %{py_scriptdir}/email
768 %dir %{py_scriptdir}/email/mime
769 %{py_scriptdir}/email/*.py[co]
770 %{py_scriptdir}/email/mime/*.py[co]
771
772 %dir %{py_scriptdir}/html
773 %{py_scriptdir}/html/*.py[co]
774
775 %dir %{py_scriptdir}/http
776 %{py_scriptdir}/http/*.py[co]
777
778 %dir %{py_scriptdir}/json
779 %{py_scriptdir}/json/*.py[co]
780
781 %dir %{py_scriptdir}/lib2to3
782 %{py_scriptdir}/lib2to3/*.txt
783 %{py_scriptdir}/lib2to3/*.pickle
784 %{py_scriptdir}/lib2to3/*.py[co]
785 %dir %{py_scriptdir}/lib2to3/fixes
786 %{py_scriptdir}/lib2to3/fixes/*.py[co]
787 %dir %{py_scriptdir}/lib2to3/pgen2
788 %{py_scriptdir}/lib2to3/pgen2/*.py[co]
789
790 %dir %{py_scriptdir}/logging
791 %{py_scriptdir}/logging/*.py[co]
792
793 %dir %{py_scriptdir}/multiprocessing
794 %{py_scriptdir}/multiprocessing/*.py[co]
795 %dir %{py_scriptdir}/multiprocessing/dummy
796 %{py_scriptdir}/multiprocessing/dummy/*.py[co]
797
798 %dir %{py_scriptdir}/urllib
799 %{py_scriptdir}/urllib/*.py[co]
800
801 %dir %{py_scriptdir}/wsgiref
802 %{py_scriptdir}/wsgiref/*.py[co]
803 %{py_scriptdir}/wsgiref.egg-info
804
805 %dir %{py_scriptdir}/xml
806 %dir %{py_scriptdir}/xml/dom
807 %dir %{py_scriptdir}/xml/etree
808 %dir %{py_scriptdir}/xml/parsers
809 %dir %{py_scriptdir}/xml/sax
810 %{py_scriptdir}/xml/*.py[co]
811 %{py_scriptdir}/xml/dom/*.py[co]
812 %{py_scriptdir}/xml/etree/*.py[co]
813 %{py_scriptdir}/xml/parsers/*.py[co]
814 %{py_scriptdir}/xml/sax/*.py[co]
815
816 %dir %{py_scriptdir}/xmlrpc
817 %{py_scriptdir}/xmlrpc/*.py[co]
818
819 %files modules-sqlite
820 %defattr(644,root,root,755)
821 %attr(755,root,root) %{py_dyndir}/_sqlite3.so
822 %dir %{py_scriptdir}/sqlite3
823 %{py_scriptdir}/sqlite3/*.py[co]
824
825 %files libs
826 %defattr(644,root,root,755)
827 %doc LICENSE
828 %attr(755,root,root) %{_libdir}/libpython*.so.*
829
830 %dir %{py_dyndir}
831 %dir %{py_scriptdir}
832 %dir %{py_libdir}
833 %dir %{py_sitescriptdir}
834 %dir %{py_sitedir}
835
836 # shared modules required by python library
837 %attr(755,root,root) %{py_dyndir}/_struct.so
838
839 # modules required by python library
840 #%{py_scriptdir}/UserDict.py[co]
841 %{py_scriptdir}/codecs.py[co]
842 %{py_scriptdir}/copyreg.py[co]
843 %{py_scriptdir}/locale.py[co]
844 %{py_scriptdir}/posixpath.py[co]
845 %{py_scriptdir}/site.py[co]
846 %{py_scriptdir}/stat.py[co]
847 %{py_scriptdir}/os.py[co]
848 # needed by the dynamic sys.lib patch
849 %{py_scriptdir}/types.py[co]
850
851 # encodings required by python library
852 %dir %{py_scriptdir}/encodings
853 %{py_scriptdir}/encodings/*.py[co]
854
855 %files -n pydoc30
856 %defattr(644,root,root,755)
857 %attr(755,root,root) %{_bindir}/pydoc%{py_ver}
858 %{py_scriptdir}/pydoc.py[co]
859
860 %files -n idle30
861 %defattr(644,root,root,755)
862 %attr(755,root,root) %{_bindir}/idle%{py_ver}
863 %dir %{py_scriptdir}/idlelib
864 %dir %{py_scriptdir}/idlelib/Icons
865 %{py_scriptdir}/idlelib/*.py[co]
866 %doc %{py_scriptdir}/idlelib/*.txt
867 %doc %{py_scriptdir}/idlelib/ChangeLog
868 %{py_scriptdir}/idlelib/Icons/*
869 %{py_scriptdir}/idlelib/*.def
870
871 %files devel
872 %defattr(644,root,root,755)
873 %doc Misc/{ACKS,NEWS,README,README.valgrind,valgrind-python.supp}
874 #%attr(755,root,root) %{_bindir}/python-config
875 %attr(755,root,root) %{_bindir}/python%{py_ver}-config
876 %attr(755,root,root) %{_libdir}/lib*.so
877 %dir %{py_incdir}
878 %{py_incdir}/*.h
879
880 %dir %{py_libdir}/config
881 %attr(755,root,root) %{py_libdir}/config/makesetup
882 %attr(755,root,root) %{py_libdir}/config/install-sh
883 %{py_libdir}/config/Makefile
884 %{py_libdir}/config/Makefile.pre.in
885 %{py_libdir}/config/Setup
886 %{py_libdir}/config/Setup.config
887 %{py_libdir}/config/Setup.local
888 %{py_libdir}/config/config.c
889 %{py_libdir}/config/config.c.in
890 %{py_libdir}/config/python.o
891
892 %files devel-src
893 %defattr(644,root,root,755)
894 %attr(-,root,root) %{py_scriptdir}/*.py
895 %{py_scriptdir}/plat-*/*.py
896 #%{py_scriptdir}/bsddb/*.py
897 %{py_scriptdir}/ctypes/*.py
898 %{py_scriptdir}/ctypes/macholib/*.py
899 #%{py_scriptdir}/compiler/*.py
900 %{py_scriptdir}/curses/*.py
901 %{py_scriptdir}/dbm/*.py
902 %{py_scriptdir}/distutils/*.py
903 %{py_scriptdir}/distutils/command/*.py
904 %{py_scriptdir}/email/*.py
905 %{py_scriptdir}/email/mime/*.py
906 %{py_scriptdir}/html/*.py
907 %{py_scriptdir}/http/*.py
908 %{py_scriptdir}/json/*.py
909 %{py_scriptdir}/lib2to3/*.py
910 %{py_scriptdir}/lib2to3/fixes/*.py
911 %{py_scriptdir}/lib2to3/pgen2/*.py
912 %{py_scriptdir}/logging/*.py
913 %{py_scriptdir}/multiprocessing/*.py
914 %{py_scriptdir}/multiprocessing/dummy/*.py
915 %{py_scriptdir}/sqlite3/*.py
916 %{py_scriptdir}/urllib/*.py
917 %{py_scriptdir}/wsgiref/*.py
918 %{py_scriptdir}/tkinter/*.py
919 %{py_scriptdir}/xml/*.py
920 %{py_scriptdir}/xml/dom/*.py
921 %{py_scriptdir}/xml/etree/*.py
922 %{py_scriptdir}/xml/parsers/*.py
923 %{py_scriptdir}/xml/sax/*.py
924 %{py_scriptdir}/xmlrpc/*.py
925 %{py_scriptdir}/encodings/*.py
926 %{py_scriptdir}/idlelib/*.py
927
928 %files devel-tools
929 %defattr(644,root,root,755)
930 %doc Lib/pdb.doc
931 /etc/shrc.d/python*-devel*
932
933 %attr(755,root,root) %{_bindir}/pygettext%{py_ver}
934
935 #%attr(755,root,root) %{py_dyndir}/_hotshot.so
936 #%dir %{py_scriptdir}/hotshot
937 #%{py_scriptdir}/hotshot/*.py[co]
938 %{py_scriptdir}/pdb.py[co]
939 %{py_scriptdir}/profile.py[co]
940 %{py_scriptdir}/pstats.py[co]
941 %{py_scriptdir}/timeit.py[co]
942
943 %files static
944 %defattr(644,root,root,755)
945 %{_libdir}/lib*.a
946
947 %files examples
948 %defattr(644,root,root,755)
949 %{_examplesdir}/%{name}-%{version}
950
951
952 #%files doc
953 #%defattr(644,root,root,755)
954 #%doc Python-Docs-%{version}%{beta}/*
955
956 %if %{with info}
957 %files doc-info
958 %defattr(644,root,root,755)
959 %{_infodir}/*.info*
960 %endif
961
962 %if %{with tkinter}
963 %files tkinter
964 %defattr(644,root,root,755)
965 %dir %{py_scriptdir}/tkinter
966 %{py_scriptdir}/tkinter/*.py[co]
967 %attr(755,root,root) %{py_dyndir}/_tkinter.so
968 %endif
This page took 0.092255 seconds and 2 git commands to generate.