]> git.pld-linux.org Git - packages/python3.git/blob - python3.spec
- updated lib64 and noarch_to_datadir patches
[packages/python3.git] / python3.spec
1 #
2 # TODO:
3 # - fix tests
4 # - check unpackaged files
5
6 # Conditional build:
7 %bcond_with     info                    # info pages (requires emacs)
8 %bcond_without  tkinter                 # disables tkinter module building
9 %bcond_without  tests                   # disables Python testing
10 %bcond_with     verbose_tests           # runs tests in verbose mode
11 #
12 # tests which will not work on 64-bit platforms
13 %define         no64bit_tests   test_audioop test_rgbimg test_imageop
14 # tests which may fail because of builder environment limitations (no /proc or /dev/pts)
15 %define         nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
16 # tests which fail because of some unknown/unresolved reason (this list should be empty)
17 %define         broken_tests test_httpservers test_distutils test_cmd_line test_pydoc test_telnetlib test_zlib
18
19 %define py_ver          3.2
20 %define py_prefix       %{_prefix}
21 %define py_libdir       %{py_prefix}/%{_lib}/python%{py_ver}
22 %define py_incdir       %{_includedir}/python%{py_ver}
23 %define py_sitedir      %{py_libdir}/site-packages
24 %define py_dyndir       %{py_libdir}/lib-dynload
25
26 Summary:        Very high level scripting language with X interface
27 Summary(es.UTF-8):      Lenguaje script de alto nivel con interfaz X
28 Summary(fr.UTF-8):      Langage de script de très haut niveau avec interface X
29 Summary(pl.UTF-8):      Python - język obiektowy wysokiego poziomu
30 Summary(pt_BR.UTF-8):   Linguagem de programação interpretada de alto nível
31 Summary(ru.UTF-8):      Язык программирования очень высокого уровня с X-интерфейсом
32 Summary(tr.UTF-8):      X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
33 Summary(uk.UTF-8):      Мова програмування дуже високого рівня з X-інтерфейсом
34 Name:           python3
35 Version:        %{py_ver}
36 Release:        0.1
37 Epoch:          1
38 License:        PSF
39 Group:          Applications
40 Source0:        http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
41 # Source0-md5:  563c0b4b8c8596e332cc076c4f013971
42 Patch0:         %{name}-pythonpath.patch
43 Patch1:         %{name}-ac_fixes.patch
44 Patch2:         %{name}-lib64.patch
45 Patch3:         %{name}-noarch_to_datadir.patch
46 URL:            http://www.python.org/
47 BuildRequires:  autoconf
48 BuildRequires:  bluez-libs-devel
49 BuildRequires:  bzip2-devel
50 BuildRequires:  db-devel >= 4
51 %{?with_info:BuildRequires:     emacs >= 21}
52 BuildRequires:  expat-devel >= 1:1.95.7
53 BuildRequires:  file
54 BuildRequires:  gdbm-devel >= 1.8.3
55 BuildRequires:  gmp-devel >= 4.0
56 BuildRequires:  libffi-devel
57 BuildRequires:  libstdc++-devel
58 BuildRequires:  ncurses-ext-devel >= 5.2
59 BuildRequires:  openssl-devel >= 0.9.8
60 BuildRequires:  readline-devel >= 5.0
61 BuildRequires:  rpm-pythonprov
62 BuildRequires:  sed >= 4.0
63 BuildRequires:  sqlite3-devel >= 3.3.5
64 %{?with_info:BuildRequires:     tetex-makeindex}
65 %{?with_tkinter:BuildRequires:  tix-devel >= 1:8.1.4-4}
66 %{?with_tkinter:BuildRequires:  tk-devel >= 8.4.3}
67 BuildRequires:  zlib-devel
68 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %define         specflags_ppc   -D__ppc__=1
72 %define         specflags_ppc64 -D__ppc64__=1
73
74 %if %{with verbose_tests}
75 %define test_flags -v -l -x
76 %else
77 %define test_flags -w -l -x
78 %endif
79
80 %ifarch alpha ia64 ppc64 sparc64 ppc64 %{x8664}
81 %define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
82 %else
83 %define test_list %{nobuilder_tests} %{broken_tests}
84 %endif
85
86 %ifarch sparc
87 %define test_list %{nobuilder_tests} %{broken_tests} test_fcntl test_ioctl
88 %endif
89
90 %description
91 Python is an interpreted, interactive, object-oriented programming
92 language. It incorporates modules, exceptions, dynamic typing, very
93 high level dynamic data types, and classes. Python combines remarkable
94 power with very clear syntax. It has interfaces to many system calls
95 and libraries, as well as to various window systems, and is extensible
96 in C or C++. It is also usable as an extension language for
97 applications that need a programmable interface. Finally, Python is
98 portable: it runs on many brands of UNIX, on the Mac, and on PCs under
99 MS-DOS, Windows, Windows NT, and OS/2.
100
101 This package contains the Python binary.
102
103 %description -l de.UTF-8
104 Python ist eine interpretierte, interaktive, objektorientierte
105 Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
106 Python enthält Module, Klassen, Exceptions, High-Level dynamische
107 Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
108 zu vielen Systemaufrufen und Libraries, sowie verschiedene
109 Fenstersysteme (X11, Motif, Tk, Mac und MFC)
110
111 Programmierer können neue built-in-Module für Python in C oder C++
112 schreiben. Python kann auch als Erweiterungssprache für Applikationen
113 benutzt werden, die ein programmierbares Interface brauchen. Dieses
114 Paket enthält die meisten Standard-Python-Module, und Module zum
115 Ansprechen von Tix (Tk-widget set) und RPM.
116
117 %description -l es.UTF-8
118 Python es un lenguaje de scripts interpretado orientado a objetos.
119 Contiene soporte para carga dinámica de objetos, clases, módulos y
120 excepciones.
121
122 Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
123 través de código C, tornando Python fácil de usar en ambientes
124 particulares/personalizados. Este paquete Python incluye la mayoría de
125 los módulos padrón Python, junto con módulos para crear interfaces
126 para el conjunto de componentes Tix para Tk y RPM.
127
128 %description -l fr.UTF-8
129 Python est un langage de script interprété et orienté objet. Il gère
130 le chargement dynamique des objets, les classes, les modules et les
131 exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
132 avec du code C est simple, ce qui rend Python facile à utiliser dans
133 des configs personnalisées.
134
135 Ce paquetage Python contient la plupart des modules Python standards,
136 ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
137 et RPM.
138
139 %description -l pl.UTF-8
140 Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
141 językiem programowania. Jest modularny, obsługuje wyjątki, dynamiczne
142 typy, zaawansowane dynamiczne struktury danych i klasy. Python łączy w
143 sobie duże możliwości i przejrzystą składnię. Posiada interfejsy do
144 wielu wywołań systemowych i bibliotek, w tym również do różnych
145 bibliotek okienkowych. Możliwości jego można jeszcze rozszerzać
146 poprzez odpowiednie moduły pisane w C lub C++. Python może być również
147 użyty jako element aplikacji, którym potrzebny jest interpreter do
148 skryptów. I wreszcie, Python jest wieloplatformowy, działa na wielu
149 odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
150 OS/2.
151
152 Ten pakiet zawiera binarkę Pythona.
153
154 %description -l pt_BR.UTF-8
155 Python é uma linguagem de scripts interpretada orientada a objetos.
156 Contém suporte para carga dinâmica de objetos, classes, módulos e
157 exceções. Adicionar interfaces para novos sistemas de biblioteca
158 através de código C é simples, tornando Python fácil de usar em
159 ambientes particulares/personalizados.
160
161 Este pacote Python inclui a maioria do módulos padrão Python, junto
162 com módulos para interfaceamento para o conjunto de componentes Tix
163 para Tk e RPM.
164
165 %description -l ru.UTF-8
166 Python - это интерпретируемый, объектно-ориентированный язык
167 программирования. Он поддерживает динамическую загрузку объектов,
168 классы, модули и обработку исключительных ситуаций (exceptions).
169 Простота добавления интерфейсов к новым системным библиотекам через
170 код на языке C делает Python хорошим выбором для использования в
171 специальных конфигурациях.
172
173 %description -l tr.UTF-8
174 Python, nesneye yönelik bir kabuk yorumlayıcıdır. Nesnelerin,
175 sınıfların, modüllerin ve aykırı durumların dinamik yüklenmelerine
176 destek verir. C koduyla birlikte kullanımı son derece kolaydır. Bu
177 paket, standart Python birimlerinin çoğunun yanısıra Tk ve RPM için
178 arayüz birimlerini de içerir.
179
180 %description -l uk.UTF-8
181 Python - це інтерпретована, об'єктно-орієнтована мова програмування.
182 Він підтримує динамічну загрузку об'єктів, класи, модулі та обробку
183 виключних ситуацій (exceptions). Простота додавання інтерфейсів для
184 нових системних бібліотек через код на мові C робить Python добрим
185 вибором для використання в спеціальних конфігураціях.
186
187 %package libs
188 Summary:        Python library
189 Summary(pl.UTF-8):      Biblioteka języka Python
190 Group:          Libraries/Python
191 # broken detection in rpm/pythondeps.sh
192 Provides:       python(abi) = %{py_ver}
193 # for compatibility with existing Ac packages
194 Provides:       python(bytecode) = %{py_ver}
195 %{!?with_info:Obsoletes:        python3-doc-info}
196
197 %description libs
198 Python shared library and very essental modules for Python binary.
199
200 %description libs -l pl.UTF-8
201 Biblioteka współdzielona języka Python oraz bardzo podstawowe moduły
202 dla Pythona.
203
204 %package modules
205 Summary:        Python modules
206 Summary(pl.UTF-8):      Moduły języka Python
207 Group:          Libraries/Python
208 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
209 Obsoletes:      python3-modules-sqlite
210
211 %description modules
212 Python officially distributed modules.
213
214 %description modules -l pl.UTF-8
215 Oficjalnie rozprowadzane moduły języka Python.
216
217 %package -n pydoc3
218 Summary:        Python interactive module documentation access support
219 Summary(pl.UTF-8):      Interaktywne korzystanie z dokumentacji modułów języka Python
220 Group:          Applications
221 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
222
223 %description -n pydoc3
224 Python interactive module documentation access support.
225
226 %description -n pydoc3 -l pl.UTF-8
227 Interaktywne korzystanie z dokumentacji modułów języka Python.
228
229 %package -n idle3
230 Summary:        IDE for Python language
231 Summary(pl.UTF-8):      IDE dla języka Python
232 Group:          Applications
233 Requires:       %{name}-tkinter = %{epoch}:%{version}-%{release}
234
235 %description -n idle3
236 IDE for Python language.
237
238 %description -n idle3 -l pl.UTF-8
239 IDE dla języka Python.
240
241 %package devel
242 Summary:        Libraries and header files for building python code
243 Summary(de.UTF-8):      Libraries und Header-Dateien zum Erstellen von Python-Code
244 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para construir programas en python
245 Summary(fr.UTF-8):      Bibliothèques et en-têtes pour construire du code python
246 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki Pythona
247 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para o Python
248 Summary(ru.UTF-8):      Библиотеки и хедеры для построения кода на языке Python
249 Summary(tr.UTF-8):      Python ile geliştirme yapmak için gerekli dosyalar
250 Summary(uk.UTF-8):      Бібліотеки та хедери для програмування на мові Python
251 Group:          Development/Languages/Python
252 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
253
254 %description devel
255 The Python interpreter is relatively easy to extend with dynamically
256 loaded extensions and to embed in other programs. This package
257 contains the header files and libraries which are needed to do both of
258 these tasks.
259
260 %description devel -l de.UTF-8
261 Der Python-Interpretierer ist relativ einfach anhand von dynamisch
262 ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
263 integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
264 die für beide Aufgaben erforderlich sind.
265
266 %description devel -l es.UTF-8
267 El interpretador Python permite incluir con facilidad extensiones
268 cargadas dinámicamente. Python es también fácil de ser empotrado en
269 otros programas. Este paquete contiene los archivos de inclusión y
270 bibliotecas necesarios para estas dos tareas.
271
272 %description devel -l fr.UTF-8
273 L'interpréteur Python est relativement facile à étendre avec des
274 extensions chargées dynamiquement et à insérer dans d'autres
275 programmes. Ce paquetage contient les en-têtes et les bibliothèques
276 nécessaires à ces deux tâches.
277
278 %description devel -l pl.UTF-8
279 Interpreter Pythona jest w miarę łatwy do rozszerzania przy pomocy
280 dynamicznie ładowanych rozszerzeń napisanych w C lub C++ oraz
281 osadzania w innych programach. Ten pakiet zawiera pliki nagłówkowe i
282 wszystko inne co potrzebne do tych celów.
283
284 %description devel -l pt_BR.UTF-8
285 O interpretador Python permite incluir com facilidade extensões
286 carregadas dinamicamente. Python é também fácil de ser embutido em
287 outros programas. Este pacote contém os arquivos de inclusão e
288 bibliotecas necessários para estas duas tarefas.
289
290 %description devel -l ru.UTF-8
291 Интерпретатор Python относительно легко расширяется при помощи
292 динамически загружаемых расширений и встраивается в другие программы.
293 Этот пакет содержит хедеры и библиотеки, необходимые для обеих этих
294 задач.
295
296 %description devel -l tr.UTF-8
297 Bu paket, Python ile geliştirme yapılabilmesi için gerekli başlık
298 dosyalarını ve kitaplıkları içerir.
299
300 %description devel -l uk.UTF-8
301 Інтерпретатор Python відносно легко розширюється за допомогою
302 розширень з динамічною загрузкою та вбудовується в інші програми. Цей
303 пакет містить хедери та бібліотеки, необхідні для обох цих задач.
304
305 %package devel-src
306 Summary:        Python module sources
307 Summary(pl.UTF-8):      Pliki źródłowe modułów Pythona
308 Group:          Development/Languages/Python
309 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
310
311 %description devel-src
312 Python module sources.
313
314 %description devel-src -l pl.UTF-8
315 Pliki źródłowe modułów Pythona.
316
317 %package devel-tools
318 Summary:        Python development tools
319 Summary(pl.UTF-8):      Narzędzia programistyczne języka Python
320 Group:          Development/Languages/Python
321 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
322
323 %description devel-tools
324 Python development tools such as profilers and debugger.
325
326 %description devel-tools -l pl.UTF-8
327 Narzędzia programistyczne języka Python takie jak profiler oraz
328 debugger.
329
330 %package 2to3
331 Summary:        Automated Python 2 to 3 code translation
332 Summary(pl.UTF-8):      Automatyczne tłumaczenie kodu Pythona 2 do 3
333 Group:          Development/Languages/Pythona
334
335 %description 2to3
336 2to3 is a Python program that reads Python 2.x source code and applies
337 a series of fixers to transform it into valid Python 3.x code. The
338 standard library contains a rich set of fixers that will handle almost
339 all code. 2to3 supporting library lib2to3 is, however, a flexible and
340 generic library, so it is possible to write your own fixers for 2to3.
341 lib2to3 could also be adapted to custom applications in which Python
342 code needs to be edited automatically.
343
344 %description 2to3 -l pl.UTF-8
345 2to3 to program w Pythonie czytający od źródłowy w Pythonie 2.x i
346 aplikujący serię poprawek przekształcających go w poprawny kod w
347 Pythonie 3.x. Biblioteka standardowa zawiera duży zbiór poprawek
348 obsługujących większość kodu. Biblioteka wspierająca 2to3 (lib2to3)
349 jest jednak elastyczną i ogólną biblioteką, więc można pisać własne
350 poprawki dla 2to3. lib2to3 można także zaadaptować na potrzeby
351 własnych zastosowań, w których kod w Pythonie musi być modyfikowany
352 automatycznie.
353
354 %package static
355 Summary:        Static python library
356 Summary(pl.UTF-8):      Statyczna biblioteka Pythona
357 Group:          Development/Languages/Python
358 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
359
360 %description static
361 Static python library.
362
363 %description static -l pl.UTF-8
364 Statyczna biblioteka Pythona.
365
366 %package doc-info
367 Summary:        Documentation on Python in texinfo format
368 Summary(pl.UTF-8):      Dokumentacja do Pythona w formacie texinfo
369 Group:          Documentation
370
371 %description doc-info
372 Documentation on Python in texinfo format.
373
374 %description doc-info -l pl.UTF-8
375 Dokumentacja do Pythona w formacie texinfo.
376
377 %package tkinter
378 Summary:        Standard Python interface to the Tk GUI toolkit
379 Summary(de.UTF-8):      Grafische Tk-Schnittstelle für Python
380 Summary(es.UTF-8):      Interfaz de GUI Tk para Python
381 Summary(fr.UTF-8):      Interface graphique Tk pour Python
382 Summary(pl.UTF-8):      Standardowy interfejs Pythona do biblioteki Tk
383 Summary(pt_BR.UTF-8):   Interface GUI Tk para Phyton
384 Summary(tr.UTF-8):      Python için grafik kullanıcı arayüzü
385 Group:          Libraries/Python
386 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
387 Requires:       tcl >= 8.4.3
388 Requires:       tix >= 1:8.1.4-4
389 Requires:       tk >= 8.4.3
390
391 %description tkinter
392 Standard Python interface to the Tk GUI toolkit.
393
394 %description tkinter -l de.UTF-8
395 Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
396 vielen Konfigurations-Tools genutzt.
397
398 %description tkinter -l es.UTF-8
399 Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por muchas
400 herramientas de configuración.
401
402 %description tkinter -l fr.UTF-8
403 Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
404 beaucoup des outils de configuration.
405
406 %description tkinter -l pl.UTF-8
407 Standardowy interfejs Pythona do biblioteki Tk.
408
409 %description tkinter -l pt_BR.UTF-8
410 Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
411 muitas ferramentas de configuração.
412
413 %description tkinter -l ru.UTF-8
414 Графический интерфейс (GUI) для Python, построенный на Tcl/Tk.
415
416 %description tkinter -l tr.UTF-8
417 Python için Tcl/Tk'ye dayalı ve pek çok ayarlama aracı tarafından
418 kullanılan grafik bir arayüzdür.
419
420 %description tkinter -l uk.UTF-8
421 Графічний інтерфейс (GUI) для Python, побудований на Tcl/Tk.
422
423 %package examples
424 Summary:        Example programs in Python
425 Summary(pl.UTF-8):      Przykładowe programy w Pythonie
426 Group:          Development/Languages/Python
427
428 %description examples
429 Example programs in Python.
430
431 These are for Python 2.3.4, not %{version}.
432
433 %description examples -l pl.UTF-8
434 Przykładowe programy w Pythonie.
435
436 Przykłady te są dla Pythona 2.3.4, nie %{version}.
437
438 %prep
439 %setup -q -n Python-%{version}
440 %patch0 -p1
441 %patch1 -p1
442 %patch2 -p1
443 %patch3 -p1
444
445 %build
446 %{__autoconf}
447 CPPFLAGS="-I/usr/include/ncursesw %{rpmcppflags}"; export CPPFLAGS
448 %configure \
449         --with-cxx-main="%{__cxx}" \
450         --enable-shared \
451         --enable-ipv6 \
452         --with-dbmliborder=gdbm:bdb \
453         --with-wide-unicode \
454         --with-signal-module \
455         --with-tsc \
456         --with-threads \
457         --with-doc-strings \
458         --with-fpectl \
459         --with-system-ffi \
460         --with-computed-gotos \
461         LINKCC='$(PURIFY) $(CXX)' \
462         LDSHARED='$(CC) $(CFLAGS) -shared' \
463         BLDSHARED='$(CC) $(CFLAGS) -shared' \
464         LDFLAGS="%{rpmcflags} %{rpmldflags}"
465
466 %{__make} \
467         OPT="%{rpmcflags} -fno-caller-saves" 2>&1 | awk '
468 BEGIN { fail = 0; logmsg = ""; }
469 {
470         if ($0 ~ /\*\*\* WARNING:/) {
471                 fail = 1;
472                 logmsg = logmsg $0;
473         }
474         print $0;
475 }
476 END { if (fail) { print "\nPROBLEMS FOUND:"; print logmsg; exit(1); } }'
477
478 LC_ALL=C
479 export LC_ALL
480 %if %{with tests}
481 binlibdir=`echo build/lib.*`
482 %{__make} test \
483         TESTOPTS="%{test_flags} %{test_list}" \
484         TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:$binlibdir ./python -tt"
485 %endif
486
487 %install
488 rm -rf $RPM_BUILD_ROOT
489 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
490         $RPM_BUILD_ROOT{%{py_sitedir},%{_mandir}/man1} \
491         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
492         $RPM_BUILD_ROOT%{_infodir} \
493         $RPM_BUILD_ROOT/etc/shrc.d
494
495 %{__make} install \
496         DESTDIR=$RPM_BUILD_ROOT
497
498 %if %{with info}
499 %{__make} -C Doc/info
500 install Doc/info/python*info* $RPM_BUILD_ROOT%{_infodir}
501 %endif
502
503 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
504 cp -a Tools $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
505
506 #
507 # create several useful aliases, such as timeit.py, profile.py, pdb.py, smtpd.py
508 #
509
510 # for python devel tools
511 for script in timeit profile pdb pstats; do
512     echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
513 done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
514
515 echo alias pygettext%{py_ver}.py='"pygettext%{py_ver}"' \
516         >> $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
517
518 sed 's/=/ /' \
519         < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh \
520         > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.csh
521
522 # for python modules
523 for script in smtpd webbrowser; do
524     echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
525 done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh
526
527 sed 's/=/ /' \
528         < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh \
529         > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.csh
530
531 # xgettext specific for Python code
532 #
533 # we will have two commands: pygettext.py (an alias) and pygettext;
534 # this way there are no import (which is impossible now) conflicts and
535 # pygettext.py is provided for compatibility
536 install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext%{py_ver}
537
538 # just to cut the noise, as they are not packaged (now)
539 # first tests
540 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/test
541 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/test
542 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/distutils/tests
543 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/email/test
544 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/importlib/test
545 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/lib2to3/tests
546 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/sqlite3/test
547 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/tkinter/test
548
549 # other files
550 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/plat-*/regen
551 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/macholib/fetch_macholib*
552 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/site-packages/README
553 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/distutils/command/wininst*.exe
554 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.bat
555 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.pyw
556 # already in %%doc
557 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/LICENSE.txt
558
559 %clean
560 rm -rf $RPM_BUILD_ROOT
561
562 %post   libs -p /sbin/ldconfig
563 %postun libs -p /sbin/ldconfig
564
565 %post   doc-info -p /sbin/postshell
566 -/usr/sbin/fix-info-dir -c %{_infodir}
567
568 %postun doc-info -p /sbin/postshell
569 -/usr/sbin/fix-info-dir -c %{_infodir}
570
571 %files
572 %defattr(644,root,root,755)
573 %attr(755,root,root) %{_bindir}/python%{py_ver}
574 %attr(755,root,root) %{_bindir}/python3
575 %{_mandir}/man1/python*.1*
576
577 %files modules
578 %defattr(644,root,root,755)
579 /etc/shrc.d/python*-modules*
580 %exclude %{py_scriptdir}/_abcoll.py[co]
581 %exclude %{py_scriptdir}/_weakrefset.py[co]
582 %exclude %{py_scriptdir}/abc.py[co]
583 %exclude %{py_scriptdir}/codecs.py[co]
584 %exclude %{py_scriptdir}/copyreg.py[co]
585 %exclude %{py_scriptdir}/genericpath.py[co]
586 %exclude %{py_scriptdir}/io.py[co]
587 %exclude %{py_scriptdir}/locale.py[co]
588 %exclude %{py_scriptdir}/posixpath.py[co]
589 %exclude %{py_scriptdir}/pdb.py[co]
590 %exclude %{py_scriptdir}/profile.py[co]
591 %exclude %{py_scriptdir}/pstats.py[co]
592 %exclude %{py_scriptdir}/pydoc.py[co]
593 %exclude %{py_scriptdir}/site.py[co]
594 %exclude %{py_scriptdir}/stat.py[co]
595 %exclude %{py_scriptdir}/timeit.py[co]
596 %exclude %{py_scriptdir}/os.py[co]
597 %exclude %{py_scriptdir}/encodings/*.py[co]
598 %exclude %{py_scriptdir}/types.py[co]
599
600 %{py_scriptdir}/*.py[co]
601
602 %{py_dyndir}/*.egg-info
603
604 #
605 # list .so modules to be sure that all of them are built
606 #
607
608 # modules below do not work on 64-bit architectures
609 # see Python README file for explanation
610 %ifnarch alpha ia64 ppc64 sparc64 %{x8664}
611 %attr(755,root,root) %{py_dyndir}/audioop.so
612 %endif
613
614 %attr(755,root,root) %{py_dyndir}/array.so
615 %attr(755,root,root) %{py_dyndir}/atexit.so
616 %attr(755,root,root) %{py_dyndir}/audioop.so
617 %attr(755,root,root) %{py_dyndir}/binascii.so
618 %attr(755,root,root) %{py_dyndir}/_bisect.so
619 %attr(755,root,root) %{py_dyndir}/bz2.so
620 %attr(755,root,root) %{py_dyndir}/cmath.so
621 %attr(755,root,root) %{py_dyndir}/_codecs_cn.so
622 %attr(755,root,root) %{py_dyndir}/_codecs_hk.so
623 %attr(755,root,root) %{py_dyndir}/_codecs_iso2022.so
624 %attr(755,root,root) %{py_dyndir}/_codecs_jp.so
625 %attr(755,root,root) %{py_dyndir}/_codecs_kr.so
626 %attr(755,root,root) %{py_dyndir}/_codecs_tw.so
627 %attr(755,root,root) %{py_dyndir}/_collections.so
628 %attr(755,root,root) %{py_dyndir}/crypt.so
629 %attr(755,root,root) %{py_dyndir}/_csv.so
630 %attr(755,root,root) %{py_dyndir}/_ctypes*.so
631 %attr(755,root,root) %{py_dyndir}/_curses_panel.so
632 %attr(755,root,root) %{py_dyndir}/_curses.so
633 %attr(755,root,root) %{py_dyndir}/datetime.so
634 %attr(755,root,root) %{py_dyndir}/_elementtree.so
635 #%attr(755,root,root) %{py_dyndir}/_functools.so
636 %attr(755,root,root) %{py_dyndir}/_hashlib.so
637 %attr(755,root,root) %{py_dyndir}/_heapq.so
638 %attr(755,root,root) %{py_dyndir}/_json.so
639 #%attr(755,root,root) %{py_dyndir}/_locale.so
640 %attr(755,root,root) %{py_dyndir}/_lsprof.so
641 %attr(755,root,root) %{py_dyndir}/_multibytecodec.so
642 %attr(755,root,root) %{py_dyndir}/_multiprocessing.so
643 %attr(755,root,root) %{py_dyndir}/_pickle.so
644 %attr(755,root,root) %{py_dyndir}/_random.so
645 %attr(755,root,root) %{py_dyndir}/_socket.so
646 %attr(755,root,root) %{py_dyndir}/_ssl.so
647 %attr(755,root,root) %{py_dyndir}/_testcapi.so
648 %ifnarch sparc64
649 %attr(755,root,root) %{py_dyndir}/_dbm.so
650 %endif
651 %attr(755,root,root) %{py_dyndir}/fcntl.so
652 %attr(755,root,root) %{py_dyndir}/_gdbm.so
653 %attr(755,root,root) %{py_dyndir}/grp.so
654 %attr(755,root,root) %{py_dyndir}/itertools.so
655 %attr(755,root,root) %{py_dyndir}/math.so
656 %attr(755,root,root) %{py_dyndir}/mmap.so
657 %attr(755,root,root) %{py_dyndir}/nis.so
658 %attr(755,root,root) %{py_dyndir}/operator.so
659 %attr(755,root,root) %{py_dyndir}/ossaudiodev.so
660 %attr(755,root,root) %{py_dyndir}/parser.so
661 %attr(755,root,root) %{py_dyndir}/pyexpat.so
662 %attr(755,root,root) %{py_dyndir}/readline.so
663 %attr(755,root,root) %{py_dyndir}/resource.so
664 %attr(755,root,root) %{py_dyndir}/select.so
665 %attr(755,root,root) %{py_dyndir}/syslog.so
666 %attr(755,root,root) %{py_dyndir}/termios.so
667 %attr(755,root,root) %{py_dyndir}/time.so
668 %attr(755,root,root) %{py_dyndir}/spwd.so
669 %attr(755,root,root) %{py_dyndir}/unicodedata.so
670 %attr(755,root,root) %{py_dyndir}/zlib.so
671
672 %dir %{py_scriptdir}/plat-*
673 %{py_scriptdir}/plat-*/*.py[co]
674
675 %dir %{py_scriptdir}/ctypes
676 %dir %{py_scriptdir}/ctypes/macholib
677
678 %{py_scriptdir}/ctypes/*.py[co]
679 %{py_scriptdir}/ctypes/macholib/*.py[co]
680 %doc %{py_scriptdir}/ctypes/macholib/README.ctypes
681
682 %dir %{py_scriptdir}/curses
683 %{py_scriptdir}/curses/*.py[co]
684
685 %dir %{py_scriptdir}/dbm
686 %{py_scriptdir}/dbm/*.py[co]
687
688 %dir %{py_scriptdir}/distutils
689 %dir %{py_scriptdir}/distutils/command
690 %doc %{py_scriptdir}/distutils/README
691 %{py_scriptdir}/distutils/*.py[co]
692 %{py_scriptdir}/distutils/command/*.py[co]
693 %{py_scriptdir}/distutils/command/command_template
694
695 %dir %{py_scriptdir}/email
696 %dir %{py_scriptdir}/email/mime
697 %{py_scriptdir}/email/*.py[co]
698 %{py_scriptdir}/email/mime/*.py[co]
699
700 %dir %{py_scriptdir}/html
701 %{py_scriptdir}/html/*.py[co]
702
703 %dir %{py_scriptdir}/http
704 %{py_scriptdir}/http/*.py[co]
705
706 %dir %{py_scriptdir}/importlib
707 %{py_scriptdir}/importlib/*.py[co]
708
709 %dir %{py_scriptdir}/json
710 %{py_scriptdir}/json/*.py[co]
711
712 %dir %{py_scriptdir}/logging
713 %{py_scriptdir}/logging/*.py[co]
714
715 %dir %{py_scriptdir}/multiprocessing
716 %{py_scriptdir}/multiprocessing/*.py[co]
717 %dir %{py_scriptdir}/multiprocessing/dummy
718 %{py_scriptdir}/multiprocessing/dummy/*.py[co]
719
720 %dir %{py_scriptdir}/urllib
721 %{py_scriptdir}/urllib/*.py[co]
722
723 %dir %{py_scriptdir}/wsgiref
724 %{py_scriptdir}/wsgiref/*.py[co]
725 %{py_scriptdir}/wsgiref.egg-info
726
727 %dir %{py_scriptdir}/xml
728 %dir %{py_scriptdir}/xml/dom
729 %dir %{py_scriptdir}/xml/etree
730 %dir %{py_scriptdir}/xml/parsers
731 %dir %{py_scriptdir}/xml/sax
732 %{py_scriptdir}/xml/*.py[co]
733 %{py_scriptdir}/xml/dom/*.py[co]
734 %{py_scriptdir}/xml/etree/*.py[co]
735 %{py_scriptdir}/xml/parsers/*.py[co]
736 %{py_scriptdir}/xml/sax/*.py[co]
737
738 %dir %{py_scriptdir}/xmlrpc
739 %{py_scriptdir}/xmlrpc/*.py[co]
740
741 %attr(755,root,root) %{py_dyndir}/_sqlite3.so
742 %dir %{py_scriptdir}/sqlite3
743 %{py_scriptdir}/sqlite3/*.py[co]
744
745 %files libs
746 %defattr(644,root,root,755)
747 %doc LICENSE
748 %attr(755,root,root) %{_libdir}/libpython*.so.*
749
750 %dir %{py_dyndir}
751 %dir %{py_scriptdir}
752 %dir %{py_libdir}
753 %dir %{py_sitescriptdir}
754 %dir %{py_sitedir}
755
756 # shared modules required by python library
757 %attr(755,root,root) %{py_dyndir}/_struct.so
758
759 # modules required by python library
760 %{py_scriptdir}/_abcoll.py[co]
761 %{py_scriptdir}/_weakrefset.py[co]
762 %{py_scriptdir}/abc.py[co]
763 %{py_scriptdir}/codecs.py[co]
764 %{py_scriptdir}/copyreg.py[co]
765 %{py_scriptdir}/genericpath.py[co]
766 %{py_scriptdir}/locale.py[co]
767 %{py_scriptdir}/io.py[co]
768 %{py_scriptdir}/posixpath.py[co]
769 %{py_scriptdir}/site.py[co]
770 %{py_scriptdir}/stat.py[co]
771 %{py_scriptdir}/os.py[co]
772 # needed by the dynamic sys.lib patch
773 %{py_scriptdir}/types.py[co]
774
775 # encodings required by python library
776 %dir %{py_scriptdir}/encodings
777 %{py_scriptdir}/encodings/*.py[co]
778
779 %files -n pydoc3
780 %defattr(644,root,root,755)
781 %attr(755,root,root) %{_bindir}/pydoc3
782 %{py_scriptdir}/pydoc.py[co]
783 %dir %{py_scriptdir}/pydoc_data
784 %{py_scriptdir}/pydoc_data/*.py[co]
785
786 %files -n idle3
787 %defattr(644,root,root,755)
788 %attr(755,root,root) %{_bindir}/idle3
789 %dir %{py_scriptdir}/idlelib
790 %dir %{py_scriptdir}/idlelib/Icons
791 %{py_scriptdir}/idlelib/*.py[co]
792 %doc %{py_scriptdir}/idlelib/*.txt
793 %doc %{py_scriptdir}/idlelib/ChangeLog
794 %{py_scriptdir}/idlelib/Icons/*
795 %{py_scriptdir}/idlelib/*.def
796
797 %files devel
798 %defattr(644,root,root,755)
799 %doc Misc/{ACKS,NEWS,README,README.valgrind,valgrind-python.supp}
800 %attr(755,root,root) %{_bindir}/python*-config
801 %attr(755,root,root) %{_libdir}/lib*.so
802 %dir %{py_incdir}
803 %{py_incdir}/*.h
804 %{_pkgconfigdir}/python*.pc
805
806 %dir %{py_libdir}/config
807 %attr(755,root,root) %{py_libdir}/config/makesetup
808 %attr(755,root,root) %{py_libdir}/config/install-sh
809 %{py_libdir}/config/Makefile
810 %{py_libdir}/config/Makefile.pre.in
811 %{py_libdir}/config/Setup
812 %{py_libdir}/config/Setup.config
813 %{py_libdir}/config/Setup.local
814 %{py_libdir}/config/config.c
815 %{py_libdir}/config/config.c.in
816 %{py_libdir}/config/python.o
817
818 %files devel-src
819 %defattr(644,root,root,755)
820 %attr(-,root,root) %{py_scriptdir}/*.py
821 %{py_scriptdir}/plat-*/*.py
822 %{py_scriptdir}/ctypes/*.py
823 %{py_scriptdir}/ctypes/macholib/*.py
824 %{py_scriptdir}/curses/*.py
825 %{py_scriptdir}/dbm/*.py
826 %{py_scriptdir}/distutils/*.py
827 %{py_scriptdir}/distutils/command/*.py
828 %{py_scriptdir}/email/*.py
829 %{py_scriptdir}/email/mime/*.py
830 %{py_scriptdir}/encodings/*.py
831 %{py_scriptdir}/html/*.py
832 %{py_scriptdir}/http/*.py
833 %{py_scriptdir}/idlelib/*.py
834 %{py_scriptdir}/importlib/*.py
835 %{py_scriptdir}/json/*.py
836 %{py_scriptdir}/lib2to3/*.py
837 %{py_scriptdir}/lib2to3/pgen2/*.py
838 %{py_scriptdir}/logging/*.py
839 %{py_scriptdir}/multiprocessing/*.py
840 %{py_scriptdir}/multiprocessing/dummy/*.py
841 %{py_scriptdir}/pydoc_data/*.py
842 %{py_scriptdir}/sqlite3/*.py
843 %{py_scriptdir}/tkinter/*.py
844 %{py_scriptdir}/urllib/*.py
845 %{py_scriptdir}/wsgiref/*.py
846 %{py_scriptdir}/xml/*.py
847 %{py_scriptdir}/xml/dom/*.py
848 %{py_scriptdir}/xml/etree/*.py
849 %{py_scriptdir}/xml/parsers/*.py
850 %{py_scriptdir}/xml/sax/*.py
851 %{py_scriptdir}/xmlrpc/*.py
852
853 %files devel-tools
854 %defattr(644,root,root,755)
855 %doc Lib/pdb.doc
856 /etc/shrc.d/python*-devel*
857
858 %attr(755,root,root) %{_bindir}/pygettext%{py_ver}
859
860 %{py_scriptdir}/pdb.py[co]
861 %{py_scriptdir}/profile.py[co]
862 %{py_scriptdir}/pstats.py[co]
863 %{py_scriptdir}/timeit.py[co]
864
865 %files 2to3
866 %attr(755,root,root) %{_bindir}/2to3-%{py_ver}
867 %dir %{py_scriptdir}/lib2to3
868 %{py_scriptdir}/lib2to3/*.txt
869 %{py_scriptdir}/lib2to3/*.pickle
870 %{py_scriptdir}/lib2to3/*.py[co]
871 %dir %{py_scriptdir}/lib2to3/fixes
872 %{py_scriptdir}/lib2to3/fixes/*.py
873 %{py_scriptdir}/lib2to3/fixes/*.py[co]
874 %dir %{py_scriptdir}/lib2to3/pgen2
875 %{py_scriptdir}/lib2to3/pgen2/*.py[co]
876
877 %files static
878 %defattr(644,root,root,755)
879 %{_libdir}/lib*.a
880
881 %files examples
882 %defattr(644,root,root,755)
883 %{_examplesdir}/%{name}-%{version}
884
885 %if %{with info}
886 %files doc-info
887 %defattr(644,root,root,755)
888 %{_infodir}/*.info*
889 %endif
890
891 %if %{with tkinter}
892 %files tkinter
893 %defattr(644,root,root,755)
894 %dir %{py_scriptdir}/tkinter
895 %{py_scriptdir}/tkinter/*.py[co]
896 %attr(755,root,root) %{py_dyndir}/_tkinter.so
897 %endif
This page took 0.142034 seconds and 3 git commands to generate.