]> git.pld-linux.org Git - packages/python3-setuptools_rust.git/commitdiff
- cleanup, added doc stub
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 8 Mar 2022 21:15:20 +0000 (22:15 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 8 Mar 2022 21:15:20 +0000 (22:15 +0100)
python3-setuptools_rust.spec

index d99dee4ca0fce8ddf91ca129fb16acad8666a651..dbca0af8f97e1ad0822831593b47ac1665cdf263 100644 (file)
@@ -1,42 +1,47 @@
+# TODO: finish docs
 #
 # Conditional build:
+%bcond_with    doc     # Sphinx documentation
 %bcond_with    tests   # unit tests (need rust configured)
-%bcond_with    python2 # CPython 2.x module
-%bcond_without python3 # CPython 3.x module
 
 Summary:       Setuptools plugin to build Rust Python extensions
-Summary(pl.UTF-8):     Wtyczka setuptools do budowania rozszerzeń pythonowych Rust
+Summary(pl.UTF-8):     Wtyczka setuptools do budowania rozszerzeń pythonowych w języku Rust
 Name:          python3-setuptools_rust
 Version:       0.12.1
 Release:       1
-License:       BSD
+License:       MIT
 Group:         Libraries/Python
 #Source0Download: https://pypi.org/simple/setuptools-rust/
 Source0:       https://pypi.debian.net/setuptools_rust/setuptools-rust-%{version}.tar.gz
 # Source0-md5: 33c3fd3bcde2877483ab782353bee54c
 URL:           https://rusthub.com/msabramo/setuptools-rust
-%if %{with python2}
-BuildRequires: python-modules >= 1:2.5
-BuildRequires: python-setuptools
-BuildRequires: python-setuptools_scm
-%endif
-%if %{with python3}
-BuildRequires: python3-modules >= 1:3.2
-BuildRequires: python3-setuptools >= 1:46.0
-BuildRequires: python3-setuptools_scm
-%endif
+BuildRequires: python3-modules >= 1:3.6
+BuildRequires: python3-setuptools >= 1:46.1
+BuildRequires: python3-setuptools_scm >= 3.4.3
+BuildRequires: python3-toml >= 0.9.0
 %if %{with tests}
 BuildRequires: rust-core
 %endif
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.714
+%if %{with doc}
+BuildRequires: python3-m2r2
+BuildRequires: python3-sphinx_autodoc_typehints
+BuildRequires: python3-sphinx_rtd_theme
+BuildRequires: sphinx-pdg-3
+%endif
 Requires:      cargo
-Requires:      python3-modules
+Requires:      python3-modules >= 1:3.6
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Compile and distribute Python extensions written in Rust as easily as if they were written in C.
+Compile and distribute Python extensions written in Rust as easily as
+if they were written in C.
+
+%description -l pl.UTF-8
+Kompilownie i dystrybuowanie napisanych w języku Rust rozszerzeń
+Pythona tak łatwo, jakby były napisane w C.
 
 %prep
 %setup -q -n setuptools-rust-%{version}
@@ -44,6 +49,10 @@ Compile and distribute Python extensions written in Rust as easily as if they we
 %build
 %py3_build %{?with_tests:test}
 
+%if %{with doc}
+%{__make} -C docs html
+%endif
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
@@ -54,6 +63,6 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc CHANGELOG.md README.md
+%doc CHANGELOG.md LICENSE README.md
 %{py3_sitescriptdir}/setuptools_rust
 %{py3_sitescriptdir}/setuptools_rust-%{version}-py*.egg-info
This page took 0.066853 seconds and 4 git commands to generate.