]> git.pld-linux.org Git - packages/python3-requests.git/commitdiff
- updated to 0.13.9
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 30 Aug 2012 17:57:50 +0000 (19:57 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 30 Aug 2012 17:57:50 +0000 (19:57 +0200)
- pl
- build HTML docs

python-requests.spec

index f84b3ae98bd5f25e898aba321086d4d237a9cb8f..e84131931bac377541a6d49f987dd12328dbc29f 100644 (file)
@@ -3,19 +3,27 @@
 #   chardet/
 #   chardet2/
 #   oauthlib/
+#
+# Conditional build:
+%bcond_without doc     # HTML documentation build
+#
 %define        module  requests
 Summary:       HTTP library for Python
+Summary(pl.UTF-8):     Biblioteka HTTP dla Pythona
 Name:          python-%{module}
-Version:       0.13.3
-Release:       2
+Version:       0.13.9
+Release:       1
 License:       ISC
 Group:         Development/Languages/Python
-Source0:       https://github.com/kennethreitz/requests/tarball/v%{version}-11-g52b55cc/%{name}-%{version}.tgz
-# Source0-md5: d4e0de0ecfc14128c3a878d9f82328a0
+Source0:       https://github.com/kennethreitz/requests/tarball/v%{version}#/%{module}-%{version}.tar.gz
+# Source0-md5: a0ecf4d6177183a4bb2f50d92ea54fd6
 URL:           https://github.com/kennethreitz/requests
+BuildRequires: python >= 1:2.6
+BuildRequires: python3 >= 3.2
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.219
 BuildRequires: sed >= 4.0
+%{?with_doc:BuildRequires:     sphinx-pdg >= 1.0}
 Requires:      python-modules
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -26,15 +34,24 @@ beings.
 
 Most existing Python modules for sending HTTP requests are extremely
 verbose and cumbersome. Python's builtin urllib2 module provides most
-of the HTTP capabilities you should need, but the api is thoroughly
+of the HTTP capabilities you should need, but the API is thoroughly
 broken. It requires an enormous amount of work (even method overrides)
-to perform the simplest of tasks.
+to perform the simplest of tasks. Things shouldn't be this way. Not in
+Python.
+
+%description -l pl.UTF-8
+Requests to napisana w Pythonie biblioteka HTTP dla ludzi, wydana na
+licencji ISC.
 
-Things shouldn't be this way. Not in Python.
+Większość istniejących modułów Pythona do wysyłania żądań HTTP jest
+zbyt gadatliwa i nieporęczna. Wbudowany w Pythona moduł urllib2
+zapewnia większość wymaganych możliwości HTTP, ale API jest kiepskie -
+wymaga dużych nakładów pracy (nawet nadpisań metod) do wykonania
+najprostszych zadań. Nie powinno tak być. Nie w Pythonie.
 
 %package -n python3-requests
 Summary:       HTTP library, written in Python, for human beings
-License:       ISC
+Summary(pl.UTF-8):     Biblioteka HTTP library napisana w Pythonie dla ludzi
 Group:         Development/Languages/Python
 
 %description -n python3-requests
@@ -45,20 +62,25 @@ Most existing Python modules for sending HTTP requests are extremely
 verbose and cumbersome. Python's builtin urllib2 module provides most
 of the HTTP capabilities you should need, but the api is thoroughly
 broken. It requires an enormous amount of work (even method overrides)
-to perform the simplest of tasks.
+to perform the simplest of tasks. Things shouldn't be this way. Not in
+Python.
+
+%description -n python3-requests -l pl.UTF-8
+Requests is an ISC Licensed HTTP library, written in Python, for human
+beings.
 
-Things shouldn't be this way. Not in Python.
+Most existing Python modules for sending HTTP requests are extremely
+verbose and cumbersome. Python's builtin urllib2 module provides most
+of the HTTP capabilities you should need, but the API is thoroughly
+broken. It requires an enormous amount of work (even method overrides)
+to perform the simplest of tasks. Things shouldn't be this way. Not in
+Python.
 
 %prep
-%setup -qc
-mv *-%{module}-*/* .
+%setup -q -n kennethreitz-%{module}-1be2a55
 
-# fix version in module
-# tarball for 0.13.3 contains 0.13.2:
-#./HISTORY.rst:0.13.2 (2012-06-28)
-#./requests/__init__.py:__version__ = '0.13.2'
-#./requests/__init__.py:__build__ = 0x001302
-%{__sed} -i -e 's/0\.13\.2/0.13.3/; s/0x001302/0x001302/' requests/__init__.py
+# avoid "distutils.errors.DistutilsByteCompileError: byte-compiling is disabled."
+%{__sed} -i -e '/PYTHONDONTWRITEBYTECODE/d' setup.py
 
 %build
 ver=$(%{__python} -c "import requests; print requests.__version__")
@@ -68,6 +90,9 @@ mkdir py2-egg py3-egg
 %{__python} setup.py build --build-base py2 egg_info --egg-base py2-egg
 %{__python3} setup.py build --build-base py3 egg_info --egg-base py3-egg
 
+%if %{with doc}
+%{__make} -C docs html
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -87,7 +112,6 @@ rm -rf $RPM_BUILD_ROOT
         --optimize=2 \
         --root=$RPM_BUILD_ROOT
 
-
 %py_postclean
 
 %clean
@@ -95,13 +119,12 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS.rst README.rst LICENSE  docs
+%doc AUTHORS.rst LICENSE README.rst %{?with_doc:docs/_build/html}
 %{py_sitescriptdir}/%{module}
-%if "%{py_ver}" > "2.4"
-%{py_sitescriptdir}/%{module}-*.egg-info
-%endif
+%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
 
 %files -n python3-requests
 %defattr(644,root,root,755)
+%doc AUTHORS.rst LICENSE README.rst %{?with_doc:docs/_build/html}
 %{py3_sitescriptdir}/%{module}
-%{py3_sitescriptdir}/%{module}-*.egg-info
+%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
This page took 0.075654 seconds and 4 git commands to generate.