]> git.pld-linux.org Git - packages/python3-requests.git/blob - python-requests.spec
- offline tests
[packages/python3-requests.git] / python-requests.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6 %bcond_without  bundled # Bundle Libraries
7 #
8 %define         module  requests
9 Summary:        HTTP library for Python 2
10 Summary(pl.UTF-8):      Biblioteka HTTP dla Pythona 2
11 Name:           python-%{module}
12 Version:        2.5.0
13 Release:        1
14 License:        Apache2
15 Group:          Development/Languages/Python
16 Source0:        https://pypi.python.org/packages/source/r/requests/%{module}-%{version}.tar.gz
17 # Source0-md5:  b8bf3ddca75e7ecf1b6776da1e6e3385
18 URL:            http://python-requests.org
19 # find . -name '*.py' -exec sed -i -e 's#requests\.packages\.urllib3#urllib3#g' "{}" ";"
20 # find . -name '*.py' -exec sed -i -e 's#\.packages\.urllib3#urllib3#g' "{}" ";"
21 # find . -name '*.py' -exec sed -i -e 's#from \.packages import chardet#import charade as chardet#g' "{}" ";"
22 # + manual removal from setup.py
23 Patch0:         system-charade-and-urllib3.patch
24 Patch1:         system-cert.patch
25 Patch2:         requests-test.patch
26 %if %{with python2}
27 BuildRequires:  python-modules >= 1:2.6
28 %if %{without bundled}
29 BuildRequires:  python-charade
30 BuildRequires:  python-urllib3 >= 1.9.1
31 %endif
32 %{?with_tests:BuildRequires:    python-pytest}
33 %endif
34 %if %{with python3}
35 BuildRequires:  python3-modules >= 1:3.2
36 %if %{without bundled}
37 BuildRequires:  python3-charade
38 BuildRequires:  python3-urllib3 >= 1.9.1
39 %endif
40 %{?with_tests:BuildRequires:    python3-pytest}
41 %endif
42 BuildRequires:  rpm-pythonprov
43 BuildRequires:  rpmbuild(macros) >= 1.219
44 Requires:       ca-certificates
45 Requires:       python-modules >= 1:2.6
46 %if %{without bundled}
47 Requires:       python-charade
48 Requires:       python-urllib3 >= 1.9.1
49 %endif
50 # for python2 only to get SNI working. python3 doesn't need this
51 Requires:       python-ndg-httpsclient
52 Requires:       python-pyasn1
53 Requires:       python-pyOpenSSL
54 BuildArch:      noarch
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 Requests is a HTTP library, written in Python, for human beings.
59
60 Most existing Python modules for sending HTTP requests are extremely
61 verbose and cumbersome. Python's builtin urllib2 module provides most
62 of the HTTP capabilities you should need, but the API is thoroughly
63 broken. It requires an enormous amount of work (even method overrides)
64 to perform the simplest of tasks. Things shouldn't be this way. Not in
65 Python.
66
67 This package contains Python 2.x module.
68
69 %description -l pl.UTF-8
70 Requests to napisana w Pythonie biblioteka HTTP dla ludzi.
71
72 Większość istniejących modułów Pythona do wysyłania żądań HTTP jest
73 zbyt gadatliwa i nieporęczna. Wbudowany w Pythona moduł urllib2
74 zapewnia większość wymaganych możliwości HTTP, ale API jest kiepskie -
75 wymaga dużych nakładów pracy (nawet nadpisań metod) do wykonania
76 najprostszych zadań. Nie powinno tak być. Nie w Pythonie.
77
78 Ten pakiet zawiera moduł dla Pythona 2.x.
79
80 %package -n python3-requests
81 Summary:        HTTP library for Python 3
82 Summary(pl.UTF-8):      Biblioteka HTTP dla Pythona 3
83 Group:          Development/Languages/Python
84 Requires:       ca-certificates
85 Requires:       python3-modules >= 1:3.2
86 %if %{without bundled}
87 Requires:       python3-charade
88 Requires:       python3-urllib3 >= 1.9.1
89 %endif
90
91 %description -n python3-requests
92 Requests is a HTTP library, written in Python, for human beings.
93
94 Most existing Python modules for sending HTTP requests are extremely
95 verbose and cumbersome. Python's builtin urllib2 module provides most
96 of the HTTP capabilities you should need, but the api is thoroughly
97 broken. It requires an enormous amount of work (even method overrides)
98 to perform the simplest of tasks. Things shouldn't be this way. Not in
99 Python.
100
101 This package contains Python 3.x module.
102
103 %description -n python3-requests -l pl.UTF-8
104 Requests to napisana w Pythonie biblioteka HTTP dla ludzi.
105
106 Większość istniejących modułów Pythona do wysyłania żądań HTTP jest
107 zbyt gadatliwa i nieporęczna. Wbudowany w Pythona moduł urllib2
108 zapewnia większość wymaganych możliwości HTTP, ale API jest kiepskie -
109 wymaga dużych nakładów pracy (nawet nadpisań metod) do wykonania
110 najprostszych zadań. Nie powinno tak być. Nie w Pythonie.
111
112 Ten pakiet zawiera moduł dla Pythona 3.x.
113
114 %prep
115 %setup -q -n %{module}-%{version}
116 %{!?with_bundled:%patch0 -p1}
117 %patch1 -p1
118 %patch2 -p1
119
120 %build
121 %if %{with python2}
122 %{__python} setup.py build -b py2 %{?with_tests:test}
123 %{?with_tests:cp requirements.txt test_requests.py py2; cd py2; PYTHONPATH=$(pwd)/lib %{__python} test_requests.py; cd ..}
124 %endif
125
126 %if %{with python3}
127 %{__python3} setup.py build -b py3 %{?with_tests:test}
128 %{?with_tests:cp requirements.txt test_requests.py py3; cd py3; PYTHONPATH=$(pwd)/lib %{__python3} test_requests.py; cd ..}
129 %endif
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %if %{with python2}
135 %{__python} setup.py \
136         build -b py2 \
137         install \
138         --skip-build \
139         --optimize=2 \
140         --root=$RPM_BUILD_ROOT
141 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
142 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
143 %py_postclean
144 %endif
145
146 %if %{with python3}
147 %{__python3} setup.py  \
148         build -b py3 \
149         install \
150         --skip-build \
151         --optimize=2 \
152         --root=$RPM_BUILD_ROOT
153 %endif
154
155 %{__rm} -rf $RPM_BUILD_ROOT{%{py_sitescriptdir},%{py3_sitescriptdir}}/%{module}/cacert.pem
156 %{!?with_bundled:%{__rm} -rf $RPM_BUILD_ROOT{%{py_sitescriptdir},%{py3_sitescriptdir}}/%{module}/packages}
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %if %{with python2}
162 %files
163 %defattr(644,root,root,755)
164 %doc HISTORY.rst README.rst
165 %{py_sitescriptdir}/%{module}
166 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
167 %endif
168
169 %if %{with python3}
170 %files -n python3-requests
171 %defattr(644,root,root,755)
172 %doc HISTORY.rst README.rst
173 %{py3_sitescriptdir}/%{module}
174 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
175 %endif
This page took 0.290828 seconds and 4 git commands to generate.