]> git.pld-linux.org Git - packages/python3-requests.git/blob - python-requests.spec
- up to 2.5.0; bundle libraries for now as requests use newer lib than python provide...
[packages/python3-requests.git] / python-requests.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6 %bcond_without  bundled # Bundle Libraries
7 #
8 %define         module  requests
9 Summary:        HTTP library for Python 2
10 Summary(pl.UTF-8):      Biblioteka HTTP dla Pythona 2
11 Name:           python-%{module}
12 Version:        2.5.0
13 Release:        1
14 License:        Apache2
15 Group:          Development/Languages/Python
16 Source0:        https://pypi.python.org/packages/source/r/requests/%{module}-%{version}.tar.gz
17 # Source0-md5:  b8bf3ddca75e7ecf1b6776da1e6e3385
18 URL:            http://python-requests.org
19 # find . -name '*.py' -exec sed -i -e 's#requests\.packages\.urllib3#urllib3#g' "{}" ";"
20 # find . -name '*.py' -exec sed -i -e 's#\.packages\.urllib3#urllib3#g' "{}" ";"
21 # find . -name '*.py' -exec sed -i -e 's#from \.packages import chardet#import charade as chardet#g' "{}" ";"
22 # + manual removal from setup.py
23 Patch0:         system-charade-and-urllib3.patch
24 Patch1:         system-cert.patch
25 %if %{with python2}
26 BuildRequires:  python-modules >= 1:2.6
27 %if %{without bundled}
28 BuildRequires:  python-charade
29 BuildRequires:  python-urllib3 >= 1.9.1
30 %endif
31 %endif
32 %if %{with python3}
33 BuildRequires:  python3-modules >= 1:3.2
34 %if %{without bundled}
35 BuildRequires:  python3-charade
36 BuildRequires:  python3-urllib3 >= 1.9.1
37 %endif
38 %endif
39 BuildRequires:  rpm-pythonprov
40 BuildRequires:  rpmbuild(macros) >= 1.219
41 Requires:       ca-certificates
42 Requires:       python-modules >= 1:2.6
43 %if %{without bundled}
44 Requires:       python-charade
45 Requires:       python-urllib3 >= 1.9.1
46 %endif
47 # for python2 only to get SNI working. python3 doesn't need this
48 Requires:       python-ndg-httpsclient
49 Requires:       python-pyasn1
50 Requires:       python-pyOpenSSL
51 BuildArch:      noarch
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 Requests is a HTTP library, written in Python, for human beings.
56
57 Most existing Python modules for sending HTTP requests are extremely
58 verbose and cumbersome. Python's builtin urllib2 module provides most
59 of the HTTP capabilities you should need, but the API is thoroughly
60 broken. It requires an enormous amount of work (even method overrides)
61 to perform the simplest of tasks. Things shouldn't be this way. Not in
62 Python.
63
64 This package contains Python 2.x module.
65
66 %description -l pl.UTF-8
67 Requests to napisana w Pythonie biblioteka HTTP dla ludzi.
68
69 Większość istniejących modułów Pythona do wysyłania żądań HTTP jest
70 zbyt gadatliwa i nieporęczna. Wbudowany w Pythona moduł urllib2
71 zapewnia większość wymaganych możliwości HTTP, ale API jest kiepskie -
72 wymaga dużych nakładów pracy (nawet nadpisań metod) do wykonania
73 najprostszych zadań. Nie powinno tak być. Nie w Pythonie.
74
75 Ten pakiet zawiera moduł dla Pythona 2.x.
76
77 %package -n python3-requests
78 Summary:        HTTP library for Python 3
79 Summary(pl.UTF-8):      Biblioteka HTTP dla Pythona 3
80 Group:          Development/Languages/Python
81 Requires:       ca-certificates
82 Requires:       python3-modules >= 1:3.2
83 %if %{without bundled}
84 Requires:       python3-charade
85 Requires:       python3-urllib3 >= 1.9.1
86 %endif
87
88 %description -n python3-requests
89 Requests is a HTTP library, written in Python, for human beings.
90
91 Most existing Python modules for sending HTTP requests are extremely
92 verbose and cumbersome. Python's builtin urllib2 module provides most
93 of the HTTP capabilities you should need, but the api is thoroughly
94 broken. It requires an enormous amount of work (even method overrides)
95 to perform the simplest of tasks. Things shouldn't be this way. Not in
96 Python.
97
98 This package contains Python 3.x module.
99
100 %description -n python3-requests -l pl.UTF-8
101 Requests to napisana w Pythonie biblioteka HTTP dla ludzi.
102
103 Większość istniejących modułów Pythona do wysyłania żądań HTTP jest
104 zbyt gadatliwa i nieporęczna. Wbudowany w Pythona moduł urllib2
105 zapewnia większość wymaganych możliwości HTTP, ale API jest kiepskie -
106 wymaga dużych nakładów pracy (nawet nadpisań metod) do wykonania
107 najprostszych zadań. Nie powinno tak być. Nie w Pythonie.
108
109 Ten pakiet zawiera moduł dla Pythona 3.x.
110
111 %prep
112 %setup -q -n %{module}-%{version}
113 %{!?with_bundled:%patch0 -p1}
114 %patch1 -p1
115
116 %build
117 %if %{with python2}
118 %{__python} setup.py build -b py2 %{?with_tests:test}
119 %endif
120
121 %if %{with python3}
122 %{__python3} setup.py build -b py3 %{?with_tests:test}
123 %endif
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 %if %{with python2}
129 %{__python} setup.py \
130         build -b py2 \
131         install \
132         --skip-build \
133         --optimize=2 \
134         --root=$RPM_BUILD_ROOT
135 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
136 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
137 %py_postclean
138 %endif
139
140 %if %{with python3}
141 %{__python3} setup.py  \
142         build -b py3 \
143         install \
144         --skip-build \
145         --optimize=2 \
146         --root=$RPM_BUILD_ROOT
147 %endif
148
149 %{__rm} -rf $RPM_BUILD_ROOT{%{py_sitescriptdir},%{py3_sitescriptdir}}/%{module}/cacert.pem
150 %{!?with_bundled:%{__rm} -rf $RPM_BUILD_ROOT{%{py_sitescriptdir},%{py3_sitescriptdir}}/%{module}/packages}
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %if %{with python2}
156 %files
157 %defattr(644,root,root,755)
158 %doc HISTORY.rst README.rst
159 %{py_sitescriptdir}/%{module}
160 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
161 %endif
162
163 %if %{with python3}
164 %files -n python3-requests
165 %defattr(644,root,root,755)
166 %doc HISTORY.rst README.rst
167 %{py3_sitescriptdir}/%{module}
168 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
169 %endif
This page took 0.053953 seconds and 4 git commands to generate.