]> git.pld-linux.org Git - packages/python3-cryptography.git/blob - python3-cryptography.spec
891e4ab2a1915319d91c3badc5cf1415f1ae8782
[packages/python3-cryptography.git] / python3-cryptography.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_without  tests   # unit test
5
6 %define         crates_ver      35.0.0
7
8 Summary:        Crypthography library for Python 3
9 Summary(pl.UTF-8):      Biblioteka Cryptography dla Pythona 3
10 Name:           python3-cryptography
11 Version:        35.0.0
12 Release:        1
13 License:        Apache v2.0 or BSD
14 Group:          Libraries/Python
15 #Source0Download: https://pypi.org/simple/cryptography/
16 Source0:        https://files.pythonhosted.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
17 # Source0-md5:  ba34eba3ae36cbf3d2e1ee3239f07732
18 #Source1Download: https://pypi.org/simple/cryptography_vectors/
19 Source1:        https://files.pythonhosted.org/packages/source/c/cryptography-vectors/cryptography_vectors-%{version}.tar.gz
20 # Source1-md5:  8e9d050bd601d1788883fa361c69cf85
21 # cd cryptography-%{version}/src/rust
22 # cargo vendor
23 # tar cJf python3-cryptography-crates-%{version}.tar.xz vendor Cargo.lock
24 Source2:        %{name}-crates-%{crates_ver}.tar.xz
25 # Source2-md5:  c3398eb08b99552f09b8b8f16d0d3910
26 URL:            https://cryptography.io/
27 BuildRequires:  openssl-devel >= 1.1.0
28 BuildRequires:  python3-cffi >= 1.12
29 BuildRequires:  python3-devel >= 1:3.6
30 BuildRequires:  python3-setuptools >= 1:18.5
31 BuildRequires:  python3-setuptools_rust
32 BuildRequires:  python3-six >= 1.4.1
33 BuildRequires:  rpm-pythonprov >= 5.4.15-48
34 BuildRequires:  rpmbuild(macros) >= 2.004
35 BuildRequires:  rust >= 1.41.0
36 %if %{with tests}
37 BuildRequires:  python3-hypothesis >= 1.11.4
38 BuildRequires:  python3-iso8601
39 BuildRequires:  python3-pretend
40 BuildRequires:  python3-pytest >= 3.6.0
41 BuildRequires:  python3-pytz
42 %endif
43 %if %{with doc}
44 BuildRequires:  python3-sphinx_rtd_theme
45 BuildRequires:  sphinx-pdg-3 >= 1.6.5
46 BuildRequires:  tar >= 1:1.22
47 BuildRequires:  xz
48 %endif
49 Requires:       openssl >= 1.1.0
50 ExclusiveArch:  %{rust_arches}
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 cryptography is a package which provides cryptographic recipes and
55 primitives to Python developers. Our goal is for it to be your
56 "cryptographic standard library". It supports Python 3.6+ and
57 PyPy3 7.2+.
58
59 cryptography includes both high level recipes and low level interfaces
60 to common cryptographic algorithms such as symmetric ciphers, message
61 digests, and key derivation functions.
62
63 %description -l pl.UTF-8
64 cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
65 obiektów kryptograficznych programistom Pythona. Celem jest
66 dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
67 Pythona 3.6+ oraz PyPy 7.2+.
68
69 cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
70 niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
71 takich jak szyfry symetryczne, skróty wiadomości czy funkcje
72 wyprowadzające klucze.
73
74 %package apidocs
75 Summary:        API documentation for cryptography module
76 Summary(pl.UTF-8):      Dokumentacja API modułu cryptography
77 Group:          Documentation
78 BuildArch:      noarch
79
80 %description apidocs
81 API documentation for cryptography module.
82
83 %description apidocs -l pl.UTF-8
84 Dokumentacja API modułu cryptography.
85
86 %prep
87 %setup -q -n cryptography-%{version} %{?with_tests:-a1}
88
89 %if %{with tests}
90 %{__mv} cryptography_vectors-%{version}/cryptography_vectors .
91 %endif
92
93 cd src/rust
94 tar xf %{SOURCE2}
95 # use our offline registry
96 export CARGO_HOME="$(pwd)/.cargo"
97
98 mkdir -p "$CARGO_HOME"
99 cat >.cargo/config <<EOF
100 [source.crates-io]
101 registry = 'https://github.com/rust-lang/crates.io-index'
102 replace-with = 'vendored-sources'
103
104 [source.vendored-sources]
105 directory = '$PWD/vendor'
106 EOF
107
108 %build
109 export CARGO_HOME="$(pwd)/src/rust/.cargo"
110 export CARGO_OFFLINE=true
111 export RUSTFLAGS="%{rpmrustflags}"
112 export CARGO_TERM_VERBOSE=true
113 %ifarch x32
114 export CARGO_BUILD_TARGET=x86_64-unknown-linux-gnux32
115 %endif
116
117 export CFLAGS="%{rpmcflags}"
118
119 %py3_build
120
121 %if %{with tests}
122 PYTHONPATH=$(echo $(pwd)/build-3/lib.*) \
123 %{__python3} -m pytest tests
124 %endif
125
126 %if %{with doc}
127 %{__make} -C docs html \
128         SPHINXBUILD=sphinx-build-3
129 %endif
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 export CARGO_HOME="$(pwd)/src/rust/.cargo"
135 export CARGO_OFFLINE=true
136 export RUSTFLAGS="%{rpmrustflags}"
137 export CARGO_TERM_VERBOSE=true
138 %ifarch x32
139 export CARGO_BUILD_TARGET=x86_64-unknown-linux-gnux32
140 %endif
141
142 %py3_install
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %files
148 %defattr(644,root,root,755)
149 %doc CHANGELOG.rst CONTRIBUTING.rst LICENSE LICENSE.APACHE LICENSE.BSD README.rst
150 %dir %{py3_sitedir}/cryptography
151 %{py3_sitedir}/cryptography/*.py
152 %{py3_sitedir}/cryptography/py.typed
153 %{py3_sitedir}/cryptography/__pycache__
154 %dir %{py3_sitedir}/cryptography/hazmat
155 %{py3_sitedir}/cryptography/hazmat/*.py
156 %{py3_sitedir}/cryptography/hazmat/__pycache__
157 %dir %{py3_sitedir}/cryptography/hazmat/backends
158 %{py3_sitedir}/cryptography/hazmat/backends/*.py
159 %{py3_sitedir}/cryptography/hazmat/backends/__pycache__
160 %dir %{py3_sitedir}/cryptography/hazmat/backends/openssl
161 %{py3_sitedir}/cryptography/hazmat/backends/openssl/*.py
162 %{py3_sitedir}/cryptography/hazmat/backends/openssl/__pycache__
163 %dir %{py3_sitedir}/cryptography/hazmat/bindings
164 %{py3_sitedir}/cryptography/hazmat/bindings/*.py
165 %{py3_sitedir}/cryptography/hazmat/bindings/__pycache__
166 %attr(755,root,root) %{py3_sitedir}/cryptography/hazmat/bindings/_*.so
167 %dir %{py3_sitedir}/cryptography/hazmat/bindings/_rust
168 %{py3_sitedir}/cryptography/hazmat/bindings/_rust/*.pyi
169 %dir %{py3_sitedir}/cryptography/hazmat/bindings/openssl
170 %{py3_sitedir}/cryptography/hazmat/bindings/openssl/*.py
171 %{py3_sitedir}/cryptography/hazmat/bindings/openssl/__pycache__
172 %dir %{py3_sitedir}/cryptography/hazmat/primitives
173 %{py3_sitedir}/cryptography/hazmat/primitives/*.py
174 %{py3_sitedir}/cryptography/hazmat/primitives/__pycache__
175 %dir %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric
176 %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py
177 %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/__pycache__
178 %dir %{py3_sitedir}/cryptography/hazmat/primitives/ciphers
179 %{py3_sitedir}/cryptography/hazmat/primitives/ciphers/*.py
180 %{py3_sitedir}/cryptography/hazmat/primitives/ciphers/__pycache__
181 %dir %{py3_sitedir}/cryptography/hazmat/primitives/kdf
182 %{py3_sitedir}/cryptography/hazmat/primitives/kdf/*.py
183 %{py3_sitedir}/cryptography/hazmat/primitives/kdf/__pycache__
184 %dir %{py3_sitedir}/cryptography/hazmat/primitives/serialization
185 %{py3_sitedir}/cryptography/hazmat/primitives/serialization/*.py
186 %{py3_sitedir}/cryptography/hazmat/primitives/serialization/__pycache__
187 %dir %{py3_sitedir}/cryptography/hazmat/primitives/twofactor
188 %{py3_sitedir}/cryptography/hazmat/primitives/twofactor/*.py
189 %{py3_sitedir}/cryptography/hazmat/primitives/twofactor/__pycache__
190 %dir %{py3_sitedir}/cryptography/x509
191 %{py3_sitedir}/cryptography/x509/*.py
192 %{py3_sitedir}/cryptography/x509/__pycache__
193 %{py3_sitedir}/cryptography-%{version}-py*.egg-info
194
195 %if %{with doc}
196 %files apidocs
197 %defattr(644,root,root,755)
198 %doc docs/_build/html/{_downloads,_static,development,hazmat,x509,*.html,*.js}
199 %endif
This page took 0.526153 seconds and 3 git commands to generate.