]> git.pld-linux.org Git - packages/python3-PyQt6-WebEngine.git/blob - python3-PyQtWebEngine.spec
- up to 5.15.6
[packages/python3-PyQt6-WebEngine.git] / python3-PyQtWebEngine.spec
1
2 %define         module  PyQtWebEngine
3 # minimal required sip version
4 %define         sip_ver 6.4
5 # last qt version covered by these bindings (minimal required is currently 5.0.0)
6 # %define               qt_ver  %{version}
7 %define         qt_ver  5.15.0
8
9 Summary:        Python bindings for the Qt5WebEngine module
10 Summary(pl.UTF-8):      Wiązania Pythona do modułu Qt5WebEngine
11 Name:           python3-%{module}
12 Version:        5.15.6
13 Release:        1
14 License:        GPL v3
15 Group:          Libraries/Python
16 Source0:        https://pypi.python.org/packages/source/P/PyQtWebEngine/PyQtWebEngine-%{version}.tar.gz
17 # Source0-md5:  d1e548617de149ba8142a32c1eb9f994
18 URL:            http://www.riverbankcomputing.com/software/pyqtwebengine/
19 BuildRequires:  Qt5WebEngine-devel >= %{qt_ver}
20 BuildRequires:  pkgconfig
21 BuildRequires:  python3-PyQt5
22 BuildRequires:  qt5-build >= %{qt_ver}
23 BuildRequires:  qt5-qmake >= %{qt_ver}
24 BuildRequires:  rpm-pythonprov
25 BuildRequires:  rpmbuild(macros) >= 1.219
26 BuildRequires:  sip-PyQt5 >= 5.15.7
27 BuildRequires:  sip6 >= %{sip_ver}
28 Requires:       python3-libs
29 Obsoletes:      python-PyQtWebEngine < 5.15.6
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Python bindings for the Qt5WebEngine module.
34
35 %description -l pl.UTF-8
36 Wiązania Pythona do modułu Qt5WebEngine.
37
38 %package -n sip-PyQtWebEngine
39 Summary:        SIP files needed to build bindings for Qt5WebEngine
40 Summary(pl.UTF-8):      Pliki SIP potrzebne do budowania wiązań do Qt5WebEngine
41 Group:          Development/Languages/Python
42 Requires:       python3-PyQt5-sip >= 2:12.11.0
43 Requires:       sip >= %{sip_ver}
44
45 %description -n sip-PyQtWebEngine
46 SIP files needed to build bindings for Qt5WebEngine.
47
48 %description -n sip-PyQtWebEngine -l pl.UTF-8
49 Pliki SIP potrzebne do budowania wiązań do Qt5WebEngine.
50
51 %prep
52 %setup -q -n PyQtWebEngine-%{version}
53
54 %build
55 sip-build --build-dir build-py3 \
56         --jobs %{__jobs} \
57         --verbose \
58         --pep484-pyi \
59         --qmake="%{_bindir}/qmake-qt5" \
60         --scripts-dir=%{_bindir}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} -C build-py3 install \
66         INSTALL_ROOT=$RPM_BUILD_ROOT
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %attr(755,root,root) %{py3_sitedir}/PyQt5/QtWebEngine.abi3.so
74 %attr(755,root,root) %{py3_sitedir}/PyQt5/QtWebEngineCore.abi3.so
75 %attr(755,root,root) %{py3_sitedir}/PyQt5/QtWebEngineWidgets.abi3.so
76 %{py3_sitedir}/PyQt5/QtWebEngine.pyi
77 %{py3_sitedir}/PyQt5/QtWebEngineCore.pyi
78 %{py3_sitedir}/PyQt5/QtWebEngineWidgets.pyi
79 %{py3_sitedir}/PyQtWebEngine-%{version}.dist-info
80
81 %files -n sip-PyQtWebEngine
82 %defattr(644,root,root,755)
83 %{py3_sitedir}/PyQt5/bindings/QtWebEngine
84 %{py3_sitedir}/PyQt5/bindings/QtWebEngineCore
85 %{py3_sitedir}/PyQt5/bindings/QtWebEngineWidgets
This page took 0.103651 seconds and 3 git commands to generate.