]> git.pld-linux.org Git - packages/python-wtforms.git/commitdiff
- up to 2.2.1
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 4 Nov 2019 22:25:37 +0000 (23:25 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 4 Nov 2019 22:25:37 +0000 (23:25 +0100)
python-wtforms-tests.patch [deleted file]
python-wtforms.spec

diff --git a/python-wtforms-tests.patch b/python-wtforms-tests.patch
deleted file mode 100644 (file)
index 978784f..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
---- WTForms-2.1/tests/ext_django/tests.py.orig 2015-12-14 22:37:32.000000000 +0100
-+++ WTForms-2.1/tests/ext_django/tests.py      2018-05-26 20:58:32.424304869 +0200
-@@ -33,10 +33,10 @@
-         }
-     },
-     # this fixes warnings in django 1.7
--    MIDDLEWARE_CLASSES = [
--            'django.contrib.sessions.middleware.SessionMiddleware',
--            'django.contrib.auth.middleware.AuthenticationMiddleware',
--            'django.contrib.messages.middleware.MessageMiddleware',
-+    MIDDLEWARE_CLASSES=[
-+        'django.contrib.sessions.middleware.SessionMiddleware',
-+        'django.contrib.auth.middleware.AuthenticationMiddleware',
-+        'django.contrib.messages.middleware.MessageMiddleware',
-     ]
- )
---- WTForms-2.1/wtforms/ext/sqlalchemy/fields.py.orig  2014-12-18 11:55:24.000000000 +0100
-+++ WTForms-2.1/wtforms/ext/sqlalchemy/fields.py       2018-05-26 21:21:58.377622148 +0200
-@@ -186,5 +186,5 @@
- def get_pk_from_identity(obj):
--    cls, key = identity_key(instance=obj)
--    return ':'.join(text_type(x) for x in key)
-+    key_vals = identity_key(instance=obj)
-+    return ':'.join(text_type(x) for x in key_vals[1])
index d53e6fb9d5d6b36a962b37b6d9c5fc65d238719a..587a534296d35cf686edc7e37094696063d3ffc2 100644 (file)
@@ -5,18 +5,17 @@
 %bcond_without python2 # CPython 2.x module
 %bcond_without python3 # CPython 3.x module
 
-%define        module  wtforms
+%define                module  wtforms
 Summary:       A flexible forms validation and rendering library for Python 2 web development
 Summary(pl.UTF-8):     Elastyczna biblioteka do generowania i walidacji formularzy WWW w Pythonie 2
 Name:          python-%{module}
-Version:       2.1
-Release:       3
+Version:       2.2.1
+Release:       1
 License:       BSD
 Group:         Development/Languages/Python
 #Source0Download: https://pypi.org/simple/wtforms/
-Source0:       https://files.pythonhosted.org/packages/source/W/WTForms/WTForms-%{version}.zip
-# Source0-md5: 6938a541fafd1a1ae2f6b9b88588eef2
-Patch0:                %{name}-tests.patch
+Source0:       https://github.com/wtforms/wtforms/archive/%{version}/%{module}-%{version}.tar.gz
+# Source0-md5: b43b08c4fc5c8f9fc1b980e939a71811
 URL:           http://wtforms.simplecodes.com/
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.710
@@ -112,8 +111,7 @@ API documentation for Python WTForms module.
 Dokumentacja API modułu Pythona WTForms.
 
 %prep
-%setup -q -n WTForms-%{version}
-%patch0 -p1
+%setup -q -n %{module}-%{version}
 
 # disable failing test
 %{__sed} -i "/OPTIONAL_TESTS/ s/'ext_django\.tests', //" tests/runtests.py
This page took 0.208538 seconds and 4 git commands to generate.