]> git.pld-linux.org Git - packages/python-wheel.git/commitdiff
- updated to 0.37.1 auto/th/python-wheel-0.37.1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 22 Mar 2022 19:25:39 +0000 (20:25 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 22 Mar 2022 19:25:39 +0000 (20:25 +0100)
python-wheel.spec

index 3372289bf62c9d9211e026ead18e85176c0ab27d..9126ef22b91e4fd5155a89ab5e2c239481debddf 100644 (file)
@@ -1,6 +1,7 @@
 #
 # Conditional build:
-%bcond_with    tests   # unit tests [broken with "--build-base"]
+%bcond_without doc     # Sphinx documentation
+%bcond_without tests   # unit tests
 %bcond_without python2 # CPython 2.x module
 %bcond_without python3 # CPython 3.x module
 
@@ -8,42 +9,35 @@
 Summary:       A built-package format for Python
 Summary(pl.UTF-8):     Format zbudowanych pakietów dla Pythona
 Name:          python-%{module}
-Version:       0.34.2
-Release:       2
+Version:       0.37.1
+Release:       1
 License:       MIT
 Group:         Libraries/Python
 #Source0Download: https://pypi.python.org/simple/wheel/
 Source0:       https://pypi.python.org/packages/source/w/wheel/%{module}-%{version}.tar.gz
-# Source0-md5: ce2a27f99c130a927237b5da1ff5ceaf
+# Source0-md5: f490f1399e5903706cb1d4fbed9ecb28
 URL:           https://bitbucket.org/pypa/wheel
 %if %{with python2}
-BuildRequires: python-devel >= 1:2.6
-BuildRequires: python-setuptools
+BuildRequires: python-devel >= 1:2.7
+BuildRequires: python-setuptools >= 1:40.9.0
 %if %{with tests}
-%if "%{py_ver}" < "2.7"
-BuildRequires: python-argparse
-BuildRequires: python-importlib
-%endif
-BuildRequires: python-coverage
-BuildRequires: python-jsonschema
 BuildRequires: python-keyring
-BuildRequires: python-pytest
+BuildRequires: python-pytest >= 3.0.0
 BuildRequires: python-pytest-cov
-BuildRequires: python-pyxdg
 %endif
 %endif
 %if %{with python3}
-BuildRequires: python3-devel >= 1:3.2
-BuildRequires: python3-setuptools
+BuildRequires: python3-devel >= 1:3.5
+BuildRequires: python3-setuptools >= 1:40.9.0
 %if %{with tests}
-BuildRequires: python3-coverage
-BuildRequires: python3-jsonschema
 BuildRequires: python3-keyring
-BuildRequires: python3-pytest
+BuildRequires: python3-pytest >= 3.0.0
 BuildRequires: python3-pytest-cov
-BuildRequires: python3-pyxdg
 %endif
 %endif
+%if %{with doc}
+BuildRequires: sphinx-pdg
+%endif
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.714
 BuildArch:     noarch
@@ -69,6 +63,8 @@ do formatu na dysku.
 Summary:       A built-package format for Python
 Summary(pl.UTF-8):     Format zbudowanych pakietów dla Pythona
 Group:         Libraries/Python
+# /usr/bin/wheel migration
+Conflicts:     python-wheel < 0.37.1
 
 %description -n python3-%{module}
 A built-package format for Python.
@@ -86,6 +82,17 @@ pliku oraz rozszerzeniem ".whl". Jest zaprojektowane, aby zawierało
 wszystkie pliki instalacji zgodnej z PEP 376 w sposób bardzo zbliżony
 do formatu na dysku.
 
+%package apidocs
+Summary:       API documentation for Python wheel module
+Summary(pl.UTF-8):     Dokumentacja API modułu Pythona wheel
+Group:         Documentation
+
+%description apidocs
+API documentation for Python wheel module.
+
+%description apidocs -l pl.UTF-8
+Dokumentacja API modułu Pythona wheel.
+
 %prep
 %setup -q -n %{module}-%{version}
 
@@ -94,7 +101,10 @@ do formatu na dysku.
 %py_build
 
 %if %{with tests}
-PYTHONPATH=build-2/lib %{__python} -m pytest --ignore build -k 'not test_keygen'
+PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
+PYTEST_PLUGINS="pytest_cov.plugin" \
+PYTHONPATH=$(pwd)/src \
+%{__python} -m pytest tests -k 'not test_macosx_libfile'
 %endif
 %endif
 
@@ -102,33 +112,42 @@ PYTHONPATH=build-2/lib %{__python} -m pytest --ignore build -k 'not test_keygen'
 %py3_build
 
 %if %{with tests}
-PYTHONPATH=build-3/lib %{__python3} -m pytest --ignore build
+PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
+PYTEST_PLUGINS="pytest_cov.plugin" \
+PYTHONPATH=$(pwd)/src \
+%{__python3} -m pytest tests -k 'not test_macosx_libfile'
 %endif
 %endif
 
-%clean
-rm -rf $RPM_BUILD_ROOT
+%if %{with doc}
+%{__make} -C docs html
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%if %{with python3}
-%py3_install
-%{__mv} $RPM_BUILD_ROOT%{_bindir}/wheel{,-3}
-%endif
 
 %if %{with python2}
 %py_install
+
 %{__mv} $RPM_BUILD_ROOT%{_bindir}/wheel{,-2}
-ln -sf wheel-2 $RPM_BUILD_ROOT%{_bindir}/wheel
 
 %py_postclean
 %endif
 
+%if %{with python3}
+%py3_install
+
+%{__mv} $RPM_BUILD_ROOT%{_bindir}/wheel{,-3}
+ln -sf wheel-3 $RPM_BUILD_ROOT%{_bindir}/wheel
+%endif
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
 %doc LICENSE.txt README.rst
-%attr(755,root,root) %{_bindir}/wheel
 %attr(755,root,root) %{_bindir}/wheel-2
 %{py_sitescriptdir}/wheel
 %{py_sitescriptdir}/wheel-%{version}-py*.egg-info
@@ -138,7 +157,14 @@ ln -sf wheel-2 $RPM_BUILD_ROOT%{_bindir}/wheel
 %files -n python3-%{module}
 %defattr(644,root,root,755)
 %doc LICENSE.txt README.rst
+%attr(755,root,root) %{_bindir}/wheel
 %attr(755,root,root) %{_bindir}/wheel-3
 %{py3_sitescriptdir}/wheel
 %{py3_sitescriptdir}/wheel-%{version}-py*.egg-info
 %endif
+
+%if %{with doc}
+%files apidocs
+%defattr(644,root,root,755)
+%doc docs/_build/html/{_static,reference,*.html,*.js}
+%endif
This page took 0.1424 seconds and 4 git commands to generate.