]> git.pld-linux.org Git - packages/python-ttystatus.git/blob - python-ttystatus.spec
87c0effe162c9551f205e17257883e836317b054
[packages/python-ttystatus.git] / python-ttystatus.spec
1 %define         module  ttystatus
2 Summary:        Progress and status updates on terminals for Python
3 Name:           python-%{module}
4 Version:        0.23
5 Release:        1
6 License:        GPL v3+
7 Group:          Libraries/Python
8 Source0:        http://code.liw.fi/debian/pool/main/p/python-%{module}/%{name}_%{version}.orig.tar.gz
9 # Source0-md5:  bfc43748b5a569a0d5e283b2e78814a8
10 URL:            http://liw.fi/ttystatus/
11 BuildRequires:  python-Sphinx
12 BuildRequires:  python-coverage-test-runner
13 BuildRequires:  rpm-pythonprov
14 BuildRequires:  rpmbuild(macros) >= 1.219
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 ttystatus is a Python library for showing progress reporting and
20 status updates on terminals, for (Unix) command line programs. Output
21 is automatically adapted to the width of the terminal: truncated if it
22 does not fit, and re-sized if the terminal size changes.
23
24 Output is provided via widgets. Each widgets formats some data into a
25 suitable form for output. It gets the data either via its initializer,
26 or from key/value pairs maintained by the master object. The values
27 are set by the user. Every time a value is updated, widgets get
28 updated (although the terminal is only updated every so often to give
29 user time to actually read the output).
30
31 %package doc
32 Summary:        Documentation for %{module}
33 Requires:       %{name} = %{version}-%{release}
34
35 %description doc
36 This package contains the documentation for %{module}, a Python
37 library providing progress and status updates on terminals.
38
39 %prep
40 %setup -q -n %{module}-%{version}
41
42 %build
43 %if %{with tests}
44 # CoverageTestRunner trips up on build directory;
45 # remove it first
46 rm -rf build
47 %{__make} check
48 %endif
49
50 %py_build
51
52 # Build documentation
53 %{__make}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 %py_install
58
59 # drop internal tests
60 %{__rm} $RPM_BUILD_ROOT%{py_sitescriptdir}/ttystatus/*_tests.py*
61
62 %py_postclean
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc NEWS README
70 %{py_sitescriptdir}/ttystatus-%{version}-py*.egg-info
71 %dir %{py_sitescriptdir}/ttystatus
72 %{py_sitescriptdir}/ttystatus/*.py[co]
73
74 %files doc
75 %defattr(644,root,root,755)
76 %doc doc/_build/html/*
This page took 0.045621 seconds and 2 git commands to generate.