]> git.pld-linux.org Git - packages/python-stevedore.git/blob - python-stevedore.spec
0c13bcb56d82a8db0d5aeeb9abc50092936e12b0
[packages/python-stevedore.git] / python-stevedore.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_with     python3 # CPython 3.x module
6
7 %define         module  stevedore
8 Summary:        Manage dynamic plugins for Python applications
9 Name:           python-%{module}
10 Version:        1.1.0
11 Release:        1
12 License:        Apache v2.0
13 Group:          Development/Languages
14 Source0:        http://pypi.python.org/packages/source/s/stevedore/stevedore-%{version}.tar.gz
15 # Source0-md5:  b7f30055c32410f8f9b6cf1b55bdc68a
16 URL:            https://github.com/dreamhost/stevedore
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.219
19 %if %{with python2}
20 BuildRequires:  python-setuptools
21 %if %{with tests}
22 #BuildRequires:  python-discover
23 BuildRequires:  python-mock
24 #BuildRequires:  python-oslotest
25 BuildRequires:  python-pbr
26 BuildRequires:  python-six
27 BuildRequires:  python-testrepository
28 %endif
29 %endif
30 %if %{with python3}
31 BuildRequires:  python3-devel
32 #BuildRequires:  python3-discover
33 BuildRequires:  python3-mock
34 #BuildRequires:  python3-oslotest
35 BuildRequires:  python3-pbr
36 BuildRequires:  python3-setuptools
37 BuildRequires:  python3-six
38 #BuildRequires:  python3-testrepository
39 %endif
40 Requires:       python-setuptools
41 Requires:       python-six
42 BuildArch:      noarch
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Manage dynamic plugins for Python applications
47
48 %package -n python3-stevedore
49 Summary:        Manage dynamic plugins for Python applications
50 Group:          Development/Libraries
51 Requires:       python3-setuptools
52 Requires:       python3-six
53
54 %description -n python3-stevedore
55 Manage dynamic plugins for Python applications
56
57 %prep
58 %setup -q -n stevedore-%{version}
59
60 %build
61 %if %{with python2}
62 %py_build
63
64 %if %{with tests}
65 PYTHONPATH=. nosetests-%{py_ver}
66 %endif
67 %endif
68
69 %if %{with python3}
70 %py3_build %{?with_tests:test}
71
72 %if %{with tests}
73 PYTHONPATH=. nosetests-%{py3_ver}
74 %endif
75 %endif
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %if %{with python2}
81 %py_install
82
83 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/stevedore/tests
84 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/stevedore/example
85
86 %py_postclean
87 %endif
88
89 %if %{with python3}
90 %py3_install
91
92 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/stevedore/tests
93 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/stevedore/example
94 %endif
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %if %{with python2}
100 %files
101 %defattr(644,root,root,755)
102 %doc README.rst LICENSE
103 %{py_sitescriptdir}/stevedore
104 %{py_sitescriptdir}/stevedore-%{version}-py*.egg-info
105 %endif
106
107 %if %{with python3}
108 %files -n python3-stevedore
109 %defattr(644,root,root,755)
110 %doc README.rst LICENSE
111 %{py3_sitescriptdir}/stevedore
112 %{py3_sitescriptdir}/stevedore-%{version}-py*.egg-info
113 %endif
This page took 0.109671 seconds and 2 git commands to generate.