]> git.pld-linux.org Git - packages/python-setuptools_scm.git/blob - python-setuptools_scm.spec
R: python-toml for complete functionality; rel 2
[packages/python-setuptools_scm.git] / python-setuptools_scm.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # py.test tests
4 %bcond_with     tests_scm       # py.test tests using SCM programs (git, hg)
5 %bcond_without  python2         # CPython 2.x module
6 %bcond_without  python3         # CPython 3.x module
7
8 Summary:        Python 2 package to manager versions by scm tags
9 Summary(pl.UTF-8):      Pakiet Pythona 2 do zarządzania wersjami poprzez etykiety systemu kontroli wersji
10 Name:           python-setuptools_scm
11 Version:        5.0.1
12 Release:        2
13 License:        MIT
14 Group:          Libraries/Python
15 #Source0Download: https://pypi.org/simple/setuptools_scm/
16 Source0:        https://files.pythonhosted.org/packages/source/s/setuptools_scm/setuptools_scm-%{version}.tar.gz
17 # Source0-md5:  c11bf23d80224691a46ee5deb84c42db
18 URL:            https://github.com/pypa/setuptools_scm
19 %if %{with python2}
20 BuildRequires:  python-modules >= 1:2.7
21 BuildRequires:  python-setuptools
22 %if %{with tests}
23 BuildRequires:  python-py >= 1.4.26
24 BuildRequires:  python-pytest >= 3.1.0
25 %endif
26 %endif
27 %if %{with python3}
28 BuildRequires:  python3-setuptools
29 BuildRequires:  python3-modules >= 1:3.5
30 %if %{with tests}
31 BuildRequires:  python3-py >= 1.4.26
32 BuildRequires:  python3-pytest >= 3.1.0
33 %endif
34 %endif
35 BuildRequires:  rpm-pythonprov
36 BuildRequires:  rpmbuild(macros) >= 1.714
37 %if %{with tests_scm}
38 BuildRequires:  git-core
39 BuildRequires:  mercurial
40 %endif
41 Requires:       python-setuptools
42 Requires:       python-toml
43 BuildArch:      noarch
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 setuptools_scm is a simple utility for the setup_requires feature of
48 setuptools for use in Mercurial and Git based projects.
49
50 %description -l pl.UTF-8
51 setuptools_scm to proste narzędzie dla funkcji setup_requires modułu
52 setuptools przeznaczone do stosowania w projektach opatych na
53 systemach kontroli wersji Mercurial i Git.
54
55 %package -n python3-setuptools_scm
56 Summary:        Python 3 package to manager versions by scm tags
57 Summary(pl.UTF-8):      Pakiet Pythona 3 do zarządzania wersjami poprzez etykiety systemu kontroli wersji
58 Group:          Libraries/Python
59 Requires:       python3-setuptools
60 Requires:       python3-toml
61
62 %description -n python3-setuptools_scm
63 setuptools_scm is a simple utility for the setup_requires feature of
64 setuptools for use in Mercurial and Git based projects.
65
66 %description -n python3-setuptools_scm -l pl.UTF-8
67 setuptools_scm to proste narzędzie dla funkcji setup_requires modułu
68 setuptools przeznaczone do stosowania w projektach opatych na
69 systemach kontroli wersji Mercurial i Git.
70
71 %prep
72 %setup -q -n setuptools_scm-%{version}
73
74 %if %{without tests_scm}
75 %{__rm} testing/test_{file_finder,git,mercurial,regressions}.py
76 %endif
77
78 # tries to install using pip
79 %{__rm} testing/test_setuptools_support.py
80
81 # fails due to unknown reason
82 %{__sed} -i -e '/test_fallback/ i@pytest.mark.skip("fails")' testing/test_basic_api.py
83
84 %build
85 %if %{with python2}
86 %py_build
87
88 %if %{with tests}
89 PYTHONPATH=$(pwd)/build-2/lib \
90 %{__python} -m pytest testing
91 %endif
92 %endif
93
94 %if %{with python3}
95 %py3_build
96
97 %if %{with tests}
98 PYTHONPATH=$(pwd)/build-3/lib \
99 %{__python3} -m pytest testing
100 %endif
101 %endif
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %if %{with python2}
107 %py_install
108
109 %py_postclean
110 %endif
111
112 %if %{with python3}
113 %py3_install
114 %endif
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %if %{with python2}
120 %files
121 %defattr(644,root,root,755)
122 %doc CHANGELOG.rst LICENSE README.rst
123 %{py_sitescriptdir}/setuptools_scm
124 %{py_sitescriptdir}/setuptools_scm-%{version}-py*.egg-info
125 %endif
126
127 %if %{with python3}
128 %files -n python3-setuptools_scm
129 %defattr(644,root,root,755)
130 %doc CHANGELOG.rst LICENSE README.rst
131 %{py3_sitescriptdir}/setuptools_scm
132 %{py3_sitescriptdir}/setuptools_scm-%{version}-py*.egg-info
133 %endif
This page took 0.046029 seconds and 3 git commands to generate.