]> git.pld-linux.org Git - packages/python-setuptools_scm.git/blame - python-setuptools_scm.spec
R: python-toml for complete functionality; rel 2
[packages/python-setuptools_scm.git] / python-setuptools_scm.spec
CommitLineData
a7eeda10
JB
1#
2# Conditional build:
f4fbde57 3%bcond_with tests # py.test tests
9c37af6f
JB
4%bcond_with tests_scm # py.test tests using SCM programs (git, hg)
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
a7eeda10
JB
7
8Summary: Python 2 package to manager versions by scm tags
9Summary(pl.UTF-8): Pakiet Pythona 2 do zarządzania wersjami poprzez etykiety systemu kontroli wersji
10Name: python-setuptools_scm
f4fbde57 11Version: 5.0.1
a813f03b 12Release: 2
a7eeda10
JB
13License: MIT
14Group: Libraries/Python
3b805f38
JB
15#Source0Download: https://pypi.org/simple/setuptools_scm/
16Source0: https://files.pythonhosted.org/packages/source/s/setuptools_scm/setuptools_scm-%{version}.tar.gz
f4fbde57 17# Source0-md5: c11bf23d80224691a46ee5deb84c42db
cdd8c19a 18URL: https://github.com/pypa/setuptools_scm
a7eeda10 19%if %{with python2}
3b805f38 20BuildRequires: python-modules >= 1:2.7
a7eeda10 21BuildRequires: python-setuptools
20ee71fd
JB
22%if %{with tests}
23BuildRequires: python-py >= 1.4.26
3b805f38 24BuildRequires: python-pytest >= 3.1.0
20ee71fd 25%endif
a7eeda10
JB
26%endif
27%if %{with python3}
28BuildRequires: python3-setuptools
f4fbde57 29BuildRequires: python3-modules >= 1:3.5
20ee71fd
JB
30%if %{with tests}
31BuildRequires: python3-py >= 1.4.26
3b805f38 32BuildRequires: python3-pytest >= 3.1.0
20ee71fd 33%endif
a7eeda10 34%endif
20ee71fd
JB
35BuildRequires: rpm-pythonprov
36BuildRequires: rpmbuild(macros) >= 1.714
9c37af6f
JB
37%if %{with tests_scm}
38BuildRequires: git-core
39BuildRequires: mercurial
40%endif
a7eeda10 41Requires: python-setuptools
a813f03b 42Requires: python-toml
a7eeda10
JB
43BuildArch: noarch
44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46%description
47setuptools_scm is a simple utility for the setup_requires feature of
48setuptools for use in Mercurial and Git based projects.
49
50%description -l pl.UTF-8
51setuptools_scm to proste narzędzie dla funkcji setup_requires modułu
52setuptools przeznaczone do stosowania w projektach opatych na
53systemach kontroli wersji Mercurial i Git.
54
55%package -n python3-setuptools_scm
56Summary: Python 3 package to manager versions by scm tags
57Summary(pl.UTF-8): Pakiet Pythona 3 do zarządzania wersjami poprzez etykiety systemu kontroli wersji
58Group: Libraries/Python
59Requires: python3-setuptools
a813f03b 60Requires: python3-toml
a7eeda10
JB
61
62%description -n python3-setuptools_scm
63setuptools_scm is a simple utility for the setup_requires feature of
64setuptools for use in Mercurial and Git based projects.
65
66%description -n python3-setuptools_scm -l pl.UTF-8
67setuptools_scm to proste narzędzie dla funkcji setup_requires modułu
68setuptools przeznaczone do stosowania w projektach opatych na
69systemach kontroli wersji Mercurial i Git.
70
71%prep
050f3a26 72%setup -q -n setuptools_scm-%{version}
a7eeda10 73
9c37af6f 74%if %{without tests_scm}
3b805f38 75%{__rm} testing/test_{file_finder,git,mercurial,regressions}.py
9c37af6f
JB
76%endif
77
3b805f38
JB
78# tries to install using pip
79%{__rm} testing/test_setuptools_support.py
80
e46cf47f
JB
81# fails due to unknown reason
82%{__sed} -i -e '/test_fallback/ i@pytest.mark.skip("fails")' testing/test_basic_api.py
83
a7eeda10
JB
84%build
85%if %{with python2}
20ee71fd
JB
86%py_build
87
3b805f38 88%if %{with tests}
6764ee4e 89PYTHONPATH=$(pwd)/build-2/lib \
e46cf47f 90%{__python} -m pytest testing
3b805f38 91%endif
a7eeda10
JB
92%endif
93
94%if %{with python3}
20ee71fd
JB
95%py3_build
96
3b805f38 97%if %{with tests}
6764ee4e 98PYTHONPATH=$(pwd)/build-3/lib \
e46cf47f 99%{__python3} -m pytest testing
3b805f38 100%endif
a7eeda10
JB
101%endif
102
103%install
104rm -rf $RPM_BUILD_ROOT
105
106%if %{with python2}
decb9fc9 107%py_install
a7eeda10
JB
108
109%py_postclean
110%endif
111
112%if %{with python3}
decb9fc9 113%py3_install
a7eeda10
JB
114%endif
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%if %{with python2}
120%files
121%defattr(644,root,root,755)
122%doc CHANGELOG.rst LICENSE README.rst
123%{py_sitescriptdir}/setuptools_scm
124%{py_sitescriptdir}/setuptools_scm-%{version}-py*.egg-info
125%endif
126
127%if %{with python3}
128%files -n python3-setuptools_scm
129%defattr(644,root,root,755)
130%doc CHANGELOG.rst LICENSE README.rst
131%{py3_sitescriptdir}/setuptools_scm
132%{py3_sitescriptdir}/setuptools_scm-%{version}-py*.egg-info
133%endif
This page took 0.098309 seconds and 4 git commands to generate.