]> git.pld-linux.org Git - packages/python-setuptools_scm.git/blame - python-setuptools_scm.spec
- python3.5 rebuild
[packages/python-setuptools_scm.git] / python-setuptools_scm.spec
CommitLineData
a7eeda10
JB
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6
7Summary: Python 2 package to manager versions by scm tags
8Summary(pl.UTF-8): Pakiet Pythona 2 do zarządzania wersjami poprzez etykiety systemu kontroli wersji
9Name: python-setuptools_scm
10Version: 1.2.0
d79aa1a9 11Release: 2
a7eeda10
JB
12License: MIT
13Group: Libraries/Python
14#Source0Download: https://pypi.python.org/pypi/setuptools_scm
15Source0: https://pypi.python.org/packages/source/s/setuptools_scm/setuptools-scm-%{version}.tar.gz
16# Source0-md5: 251730e2ca3ff05e6e1fcd4ba368e6a8
17URL: https://bitbucket.org/pypa/setuptools_scm/
18BuildRequires: rpm-pythonprov
19BuildRequires: rpmbuild(macros) >= 1.612
20%if %{with python2}
21BuildRequires: python-modules >= 1:2.6
22BuildRequires: python-setuptools
23%endif
24%if %{with python3}
25BuildRequires: python3-setuptools
26BuildRequires: python3-modules >= 1:3.2
27%endif
28Requires: python-setuptools
29BuildArch: noarch
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33setuptools_scm is a simple utility for the setup_requires feature of
34setuptools for use in Mercurial and Git based projects.
35
36%description -l pl.UTF-8
37setuptools_scm to proste narzędzie dla funkcji setup_requires modułu
38setuptools przeznaczone do stosowania w projektach opatych na
39systemach kontroli wersji Mercurial i Git.
40
41%package -n python3-setuptools_scm
42Summary: Python 3 package to manager versions by scm tags
43Summary(pl.UTF-8): Pakiet Pythona 3 do zarządzania wersjami poprzez etykiety systemu kontroli wersji
44Group: Libraries/Python
45Requires: python3-setuptools
46
47%description -n python3-setuptools_scm
48setuptools_scm is a simple utility for the setup_requires feature of
49setuptools for use in Mercurial and Git based projects.
50
51%description -n python3-setuptools_scm -l pl.UTF-8
52setuptools_scm to proste narzędzie dla funkcji setup_requires modułu
53setuptools przeznaczone do stosowania w projektach opatych na
54systemach kontroli wersji Mercurial i Git.
55
56%prep
57%setup -q -n setuptools-scm-%{version}
58
59%build
60%if %{with python2}
61%{__python} setup.py \
62 build --build-base build-2 %{?with_tests:test}
63%endif
64
65%if %{with python3}
66%{__python3} setup.py \
67 build --build-base build-3 %{?with_tests:test}
68%endif
69
70%install
71rm -rf $RPM_BUILD_ROOT
72
73%if %{with python2}
74%{__python} setup.py \
75 build --build-base build-2 \
76 install --skip-build \
77 --optimize=2 \
78 --root=$RPM_BUILD_ROOT
79
80%py_postclean
81%endif
82
83%if %{with python3}
84%{__python3} setup.py \
85 build --build-base build-3 \
86 install --skip-build \
87 --optimize=2 \
88 --root=$RPM_BUILD_ROOT
89%endif
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%if %{with python2}
95%files
96%defattr(644,root,root,755)
97%doc CHANGELOG.rst LICENSE README.rst
98%{py_sitescriptdir}/setuptools_scm
99%{py_sitescriptdir}/setuptools_scm-%{version}-py*.egg-info
100%endif
101
102%if %{with python3}
103%files -n python3-setuptools_scm
104%defattr(644,root,root,755)
105%doc CHANGELOG.rst LICENSE README.rst
106%{py3_sitescriptdir}/setuptools_scm
107%{py3_sitescriptdir}/setuptools_scm-%{version}-py*.egg-info
108%endif
This page took 0.156483 seconds and 4 git commands to generate.