]> git.pld-linux.org Git - packages/python-setuptools.git/blob - python-setuptools.spec
- tab
[packages/python-setuptools.git] / python-setuptools.spec
1
2 %define module  setuptools
3 %define sub     c3
4
5 Summary:        A collection of enhancements to the Python distutils
6 Summary(pl):    Zestaw rozszerzeñ dla pythonowych distutils
7 Name:           python-setuptools
8 Version:        0.6
9 Release:        0.%{sub}.2
10 Epoch:          1
11 License:        GPL
12 Group:          Development/Languages/Python
13 Source0:        http://cheeseshop.python.org/packages/source/s/setuptools/setuptools-%{version}%{sub}.tar.gz
14 # Source0-md5:  76cb98b779d356c64323125490f88d17
15 URL:            http://peak.telecommunity.com/DevCenter/setuptools
16 BuildRequires:  findutils
17 %pyrequires_eq  python
18 BuildRequires:  python-devel
19 Requires:       python-devel
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 setuptools is a collection of enhancements to the Python distutils
25 (for Python 2.3.5 and up on most platforms; 64-bit platforms require a
26 minimum of Python 2.4) that allow you to more easily build and
27 distribute Python packages, especially ones that have dependencies on
28 other packages.
29
30 %description -l pl
31 setuptools to zestaw rozszerzeñ do pythonowych distutils (dla Pythona
32 2.3.5 i nowszego na wiêkszo¶ci platform; platformy 64-bitowe wymagaj±
33 co najmniej Pythona 2.4) umo¿liwiaj±cy ³atwiejsze budowanie i
34 rozprowadzanie pakietów Pythona, szczególnie tych maj±cych zale¿no¶ci
35 od innych pakietów.
36
37 %prep
38 %setup -q -n %{module}-%{version}%{sub}
39
40 %build
41 python ./setup.py build
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 python ./setup.py install \
47         --single-version-externally-managed \
48         --optimize 2 \
49         --root=$RPM_BUILD_ROOT
50
51 rm -f $RPM_BUILD_ROOT%{py_sitescriptdir}/*/*.exe
52
53 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
54 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
55 %py_postclean
56 install site.py $RPM_BUILD_ROOT%{py_sitescriptdir}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc *.txt
64 %attr(755,root,root) %{_bindir}/*
65 %{py_sitescriptdir}/%{module}*
66 %{py_sitescriptdir}/*.py[co]
67 %{py_sitescriptdir}/site.py
This page took 0.108928 seconds and 3 git commands to generate.