]> git.pld-linux.org Git - packages/python-ruamel.yaml.clib.git/blob - python-ruamel.yaml.clib.spec
6233e7a699780c0236df7cda3c83ad460abde80c
[packages/python-ruamel.yaml.clib.git] / python-ruamel.yaml.clib.spec
1 # Conditional build:
2 %bcond_with     tests   # unit tests
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         module          ruamel.yaml.clib
7 Summary:        C version of reader, parser and emitter for ruamel.yaml derived from libyaml
8 Name:           python-%{module}
9 Version:        0.2.0
10 Release:        2
11 License:        MIT
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/ruamel.yaml.clib/
14 Source0:        https://files.pythonhosted.org/packages/source/r/ruamel.yaml.clib/%{module}-%{version}.tar.gz
15 # Source0-md5:  d188d050399426dd3ce4dd91a5f06518
16 URL:            https://pypi.org/project/ruamel.yaml.clib/
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.714
19 %if %{with python2}
20 BuildRequires:  python-modules
21 BuildRequires:  python-setuptools
22 %endif
23 %if %{with python3}
24 BuildRequires:  python3-modules
25 BuildRequires:  python3-setuptools
26 %endif
27 Requires:       python-modules
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 C version of reader, parser and emitter for ruamel.yaml derived from
32 libyaml.
33
34 %package -n python3-%{module}
35 Summary:        C version of reader, parser and emitter for ruamel.yaml derived from libyaml
36 Group:          Libraries/Python
37 Requires:       python3-modules
38
39 %description -n python3-%{module}
40 C version of reader, parser and emitter for ruamel.yaml derived from
41 libyaml.
42
43 %prep
44 %setup -q -n %{module}-%{version}
45
46 %build
47 %if %{with python2}
48 %py_build %{?with_tests:test}
49 %endif
50
51 %if %{with python3}
52 %py3_build %{?with_tests:test}
53 %endif
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %if %{with python2}
59 %py_install
60
61 %py_postclean
62 %endif
63
64 %if %{with python3}
65 %py3_install
66 %endif
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %if %{with python2}
72 %files
73 %defattr(644,root,root,755)
74 %doc README.rst
75 %attr(755,root,root) %{py_sitedir}/_ruamel_yaml.so
76 %{py_sitedir}/ruamel/yaml/clib
77 %{py_sitedir}/%{module}-%{version}-py*.egg-info
78 %endif
79
80 %if %{with python3}
81 %files -n python3-%{module}
82 %defattr(644,root,root,755)
83 %doc README.rst
84 %attr(755,root,root) %{py3_sitedir}/_ruamel_yaml.cpython-*.so
85 %{py3_sitedir}/ruamel/yaml/clib
86 %{py3_sitedir}/%{module}-%{version}-py*.egg-info
87 %endif
This page took 0.032702 seconds and 2 git commands to generate.