]> git.pld-linux.org Git - packages/python-requests.git/commitdiff
fix py_build/py_install usage
authorJacek Konieczny <jajcus@jajcus.net>
Thu, 3 Dec 2015 17:02:05 +0000 (18:02 +0100)
committerJacek Konieczny <jajcus@jajcus.net>
Thu, 3 Dec 2015 17:02:05 +0000 (18:02 +0100)
python-requests.spec

index 438c3e21ac4b2a1d49e79581e94580fb082f9cba..452608ce5d4e2c978a3747906944293136fd0dd2 100644 (file)
@@ -40,7 +40,7 @@ BuildRequires:        python3-urllib3 >= %{urllib3ver}
 %{?with_tests:BuildRequires:   python3-pytest >= 2.3.4}
 %endif
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.710
+BuildRequires: rpmbuild(macros) >= 1.713
 Requires:      ca-certificates
 Requires:      python-modules >= 1:2.6
 %if %{without bundled}
@@ -118,37 +118,27 @@ Ten pakiet zawiera moduĊ‚ dla Pythona 3.x.
 
 %build
 %if %{with python2}
-%py_build -b py2 %{?with_tests:test}
-%{?with_tests:cp requirements.txt test_requests.py py2; cd py2; PYTHONPATH=$(pwd)/lib %{__python} test_requests.py; cd ..}
+%py_build %{?with_tests:test}
+%{?with_tests:cp requirements.txt test_requests.py build-2; cd build-2; PYTHONPATH=$(pwd)/lib %{__python} test_requests.py; cd ..}
 %endif
 
 %if %{with python3}
-%py3_build -b py3 %{?with_tests:test}
-%{?with_tests:cp requirements.txt test_requests.py py3; cd py3; PYTHONPATH=$(pwd)/lib %{__python3} test_requests.py; cd ..}
+%py3_build %{?with_tests:test}
+%{?with_tests:cp requirements.txt test_requests.py build-3; cd build-3; PYTHONPATH=$(pwd)/lib %{__python3} test_requests.py; cd ..}
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
-%{__python} setup.py \
-       build -b py2 \
-       install \
-       --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py_install
 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
 %py_postclean
 %endif
 
 %if %{with python3}
-%{__python3} setup.py  \
-       build -b py3 \
-       install \
-       --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py3_install
 %endif
 
 %{__rm} $RPM_BUILD_ROOT{%{py_sitescriptdir},%{py3_sitescriptdir}}/%{module}/cacert.pem
This page took 0.035058 seconds and 4 git commands to generate.