]> git.pld-linux.org Git - packages/python-recommonmark.git/commitdiff
- added docutils patch (try to fix docutils 0.18 compatibility)
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 30 Oct 2022 08:11:32 +0000 (09:11 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 30 Oct 2022 08:11:32 +0000 (09:11 +0100)
python-recommonmark-docutils.patch [new file with mode: 0644]
python-recommonmark.spec

diff --git a/python-recommonmark-docutils.patch b/python-recommonmark-docutils.patch
new file mode 100644 (file)
index 0000000..aaaeb81
--- /dev/null
@@ -0,0 +1,18 @@
+--- recommonmark-0.7.1/recommonmark/parser.py.orig     2022-10-30 07:54:15.297435288 +0100
++++ recommonmark-0.7.1/recommonmark/parser.py  2022-10-30 07:54:17.270757930 +0100
+@@ -3,6 +3,7 @@
+ import sys
+ from os.path import splitext
++import docutils.parsers.rst
+ from docutils import parsers, nodes
+ from sphinx import addnodes
+@@ -23,6 +24,7 @@ class CommonMarkParser(parsers.Parser):
+     """Docutils parser for CommonMark"""
+     supported = ('md', 'markdown')
++    settings_spec = parsers.rst.Parser.settings_spec
+     translate_section_name = None
+     default_config = {
index 27f20c6cfa521ac55e1d5b820b504e13498370af..0991f5e791c88a971c89ea9b5bca0367d3cf34db 100644 (file)
@@ -18,6 +18,7 @@ Source0:      https://files.pythonhosted.org/packages/source/r/recommonmark/recommonm
 # from https://github.com/readthedocs/recommonmark/pull/124
 # https://github.com/readthedocs/recommonmark/commit/917e0359fa93acd9b22d7122e2c03d994d9fda44.patch
 Patch0:                %{name}-math.patch
+Patch1:                %{name}-docutils.patch
 URL:           https://recommonmark.readthedocs.io/en/latest/
 %if %{with python2}
 BuildRequires: python-modules >= 1:2.7
@@ -85,6 +86,7 @@ Dokumentacja moduĊ‚u Pythona recommonmark.
 %prep
 %setup -q -n recommonmark-%{version}
 %patch0 -p1
+%patch1 -p1
 
 %build
 %if %{with python2}
This page took 0.109806 seconds and 4 git commands to generate.