]> git.pld-linux.org Git - packages/python-pyvorbis.git/blob - python-pyvorbis.spec
- based on python-pyogg and alt linux,
[packages/python-pyvorbis.git] / python-pyvorbis.spec
1 %include        /usr/lib/rpm/macros.python
2 %define         module pyvorbis
3 Name:           python-%{module}
4 Version:        1.2
5 Release:        1
6 Summary:        A Python module for the the Ogg/Vorbis library
7 Summary(pl):    Modu³ pythona do biblioteki Ogg/Vorbis
8 Group:          Libraries/Python
9 License:        GPL
10 URL:            http://www.andrewchatham.com/pyogg/
11 Source0:        http://www.andrewchatham.com/pyogg/download/%{module}-%{version}.tar.gz
12 Requires:       python-modules
13 Requires:       libvorbis
14 Requires:       python-pyogg
15 BuildRequires:  python-devel
16 BuildRequires:  libvorbis-devel
17 BuildRequires:  python-pyogg-devel
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 pyvorbis is a wrapper for libvorbis, a compressed audio format library.
22
23 %description -l pl
24 pyvorbis jest wrapperem dla biblioteki libvorbis, formatu skompresowanego.
25
26 %package devel
27 Summary:        pyogg header and example programs
28 Group:          Development/Languages/Python
29 Requires:       %{name} = %{version}
30
31 %description devel
32 pyvorbis is a wrapper for libvorbis, a compressed audio format library.
33
34 Install python-pyvorbis-devel if you need the API documentation and example
35 programs.
36
37 %description devel -l pl
38 pyvorbis jest wrapperem dla biblioteki libvorbis, formatu skompresowanego.
39
40 Zainstaluj tê paczkê je¶li potrzebujesz dokumentacjê API oraz przyk³adowe
41 programy.
42
43 %prep
44 %setup -q -n %{module}-%{version}
45
46 %build
47 python config_unix.py --prefix %{_prefix}
48 python setup.py config
49 python setup.py build
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT%{py_incdir}/%{module}
54 python setup.py install --root $RPM_BUILD_ROOT
55
56 install -m644 src/*.h $RPM_BUILD_ROOT%{py_incdir}/%{module} 
57 chmod -x test/*
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %{py_sitedir}/ogg
65 %doc AUTHORS ChangeLog README NEWS
66
67 %files devel
68 %defattr(644,root,root,755)
69 %{py_incdir}/%{module}
70 %doc test/*
This page took 0.095093 seconds and 3 git commands to generate.