]> git.pld-linux.org Git - packages/python-pytest.git/commitdiff
- updated to 2.9.2 auto/th/python-pytest-2.9.2-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 5 Mar 2017 06:41:51 +0000 (07:41 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 5 Mar 2017 06:41:51 +0000 (07:41 +0100)
- separated -apidocs instead of including over 4MB of docs in both python packages

python-pytest.spec

index b8ca4687d00c0272f4d696085c69b6d99c32fdca..f161b238b2c4ec889639a9f450c5dd5a132c9f84 100644 (file)
@@ -8,13 +8,13 @@
 Summary:       Simple and popular testing tool for Python
 Summary(pl.UTF-8):     Proste i popularne narzędzie testujące dla Pythona
 Name:          python-%{module}
-Version:       2.9.1
-Release:       2
+Version:       2.9.2
+Release:       1
 License:       MIT
 Group:         Development/Languages/Python
-#Source0Download: https://pypi.python.org/pypi/pytest
-Source0:       https://pypi.python.org/packages/source/p/pytest/pytest-%{version}.tar.gz
-# Source0-md5: 05165740ea50928e4e971378630163ec
+#Source0Download: https://pypi.python.org/simple/pytest
+Source0:       https://files.pythonhosted.org/packages/source/p/pytest/pytest-%{version}.tar.gz
+# Source0-md5: b65c2944dfaa0efb62c0239afb424f5b
 URL:           http://pytest.org/
 BuildRequires: python-devel >= 1:2.6
 BuildRequires: python-py >= %{pylib_version}
@@ -55,6 +55,17 @@ py.test provides simple, yet powerful testing for Python.
 py.test to proste, ale bardzo funkcjonalne narzędzie testujące dla
 Pythona.
 
+%package apidocs
+Summary:       Documentation for py.test Pythona package
+Summary(pl.UTF-8):     Dokumentacja pakietu Pythona py.test
+Group:         Documentation
+
+%description apidocs
+Documentation for py.test Pythona package.
+
+%description apidocs -l pl.UTF-8
+Dokumentacja pakietu Pythona py.test.
+
 %prep
 %setup -q -n %{module}-%{version}
 
@@ -71,8 +82,8 @@ for l in doc/*; do
        PYTHONPATH=$(pwd) \
        %{__make} -C $l html
        # remove hidden file
-       rm $l/_build/html/.buildinfo
-       mv $l/_build/html _htmldocs/html/${l##doc/}
+       %{__rm} $l/_build/html/.buildinfo
+       %{__mv} $l/_build/html _htmldocs/html/${l##doc/}
 done
 %endif
 
@@ -92,7 +103,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS CHANGELOG.rst LICENSE README.rst %{?with_doc:_htmldocs/html}
+%doc AUTHORS CHANGELOG.rst LICENSE README.rst
 %attr(755,root,root) %{_bindir}/py.test
 %attr(755,root,root) %{_bindir}/py.test-%{py_ver}
 %{py_sitescriptdir}/pytest.py[co]
@@ -102,10 +113,16 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python3}
 %files -n python3-pytest
 %defattr(644,root,root,755)
-%doc AUTHORS CHANGELOG.rst LICENSE README.rst %{?with_doc:_htmldocs/html}
+%doc AUTHORS CHANGELOG.rst LICENSE README.rst
 %attr(755,root,root) %{_bindir}/py.test-%{py3_ver}
 %{py3_sitescriptdir}/pytest.py
 %{py3_sitescriptdir}/_pytest
 %{py3_sitescriptdir}/__pycache__/pytest.*.py[co]
 %{py3_sitescriptdir}/pytest-%{version}-py*.egg-info
 %endif
+
+%if %{with doc}
+%files apidocs
+%defattr(644,root,root,755)
+%doc _htmldocs/html
+%endif
This page took 0.125347 seconds and 4 git commands to generate.