]> git.pld-linux.org Git - packages/python-pycairo.git/blob - python-pycairo.spec
- pygtk bcond for bootstrapping
[packages/python-pycairo.git] / python-pycairo.spec
1 # Conditional build
2 %bcond_without  pygtk   # for bootstrap without pygtk
3 #
4 %define         pname pycairo
5 Summary:        Python Cairo bindings
6 Summary:        Dowi±zania Pythona dla Cairo
7 Name:           python-%{pname}
8 Version:        0.9.0
9 Release:        1
10 License:        LGPL v2.1 or MPL v1.1
11 Group:          Libraries
12 Source0:        http://cairographics.org/snapshots/%{pname}-%{version}.tar.gz
13 # Source0-md5:  a01c9c34bcb15e89fcea03c324158422
14 URL:            http://cairographics.org/
15 BuildRequires:  autoconf >= 2.54
16 BuildRequires:  automake
17 BuildRequires:  cairo-devel >= 0.9.0
18 BuildRequires:  gtk+2-devel >= 2.0.0
19 BuildRequires:  libsvg-cairo-devel >= 0.1.6
20 BuildRequires:  libtool
21 BuildRequires:  python >= 2.3
22 BuildRequires:  python-numpy-devel
23 %{?with_pygtk:BuildRequires:    python-pygtk-devel >= 1.99.16}
24 %pyrequires_eq  python-libs
25 Requires:       cairo >= 0.9.0
26 Requires:       libsvg-cairo >= 0.1.6
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Python Cairo bindings.
31
32 %description -l pl
33 Dowi±zania Pythona dla Cairo.
34
35 %package devel
36 Summary:        Development files for pycairo
37 Summary(pl):    Pliki programistyczne pycairo
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 Development files for pycairo.
43
44 %description -l pl devel
45 Pliki programistyczne pycairo.
46
47 %package examples
48 Summary:        Example programs using Python Cairo bindings
49 Summary(pl):    Przyk³adowe programy w Pythonie u¿ywaj±ce Cairo
50 Group:          Libraries/Python
51 Requires:       %{name} = %{version}-%{release}
52
53 %description examples
54 Example programs using Python Cairo bindings.
55
56 %description -l pl examples
57 Przyk³adowe programy w Pythonie u¿ywaj±ce Cairo.
58
59 %prep
60 %setup -q -n %{pname}-%{version}
61
62 %build
63 %{__libtoolize}
64 %{__aclocal}
65 %{__autoconf}
66 %{__autoheader}
67 %{__automake}
68 %configure
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 install -d $RPM_BUILD_ROOT%{_examplesdir}
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 cp -ar examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
79
80 rm $RPM_BUILD_ROOT%{py_sitedir}/cairo/*.{la,py}
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %post   -p /sbin/ldconfig
86 %postun -p /sbin/ldconfig
87
88 %files
89 %defattr(644,root,root,755)
90 %doc AUTHORS COPYING ChangeLog NEWS NOTES README
91 %dir %{py_sitedir}/cairo
92 %attr(755,root,root) %{py_sitedir}/cairo/*.so
93 %{py_sitedir}/cairo/*.py[oc]
94
95 %files devel
96 %defattr(644,root,root,755)
97 %{_includedir}/pycairo
98 %{_pkgconfigdir}/pycairo.pc
99
100 %files examples
101 %defattr(644,root,root,755)
102 %{_examplesdir}/%{name}-%{version}
This page took 0.081189 seconds and 4 git commands to generate.